]> git.pld-linux.org Git - packages/gstreamer.git/blobdiff - gstreamer.spec
- updated gtk-doc BR
[packages/gstreamer.git] / gstreamer.spec
index bb36ced7724060d5fdc96d02e0aeb278f11b3783..f5735bc9dedb7e2abf49de8a3ef98008832b01d5 100644 (file)
@@ -1,18 +1,42 @@
+
+%define                _vmajor         0.10
+%define                _vminor         1
+
 Summary:       GStreamer Streaming-media framework runtime
 Summary(pl):   GStreamer - biblioteki ¶rodowiska do obróbki strumieni
 Name:          gstreamer
-Version:       0.3.2
-Release:       1
+Version:       %{_vmajor}.%{_vminor}
+Release:       0.1
 License:       LGPL
 Group:         Libraries
-Source0:       http://prdownloads.sourceforge.net/gstreamer/%{name}-%{version}.tar.bz2
+Source0:       http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
+# Source0-md5: 2a56154a6636a404ab9107524d4b7a89
+Patch0:                %{name}-without_ps_pdf.patch
+Patch1:                %{name}-eps.patch
 URL:           http://gstreamer.net/
-BuildRequires: glib2-devel
-BuildRequires: libxml2-devel
+BuildRequires: autoconf >= 2.52
+BuildRequires: automake >= 1.6
+BuildRequires: bison >= 1.35
+BuildRequires: docbook-utils >= 0.6.10
+BuildRequires: flex
+BuildRequires: glib2-devel >= 1:2.8.0
+BuildRequires: gtk-doc >= 1.3
+BuildRequires: libtool >= 1.4
+BuildRequires: libxml2-devel >= 2.4.17
 BuildRequires: nasm
-BuildRequires: pkgconfig
+BuildRequires: perl-base
+BuildRequires: pkgconfig >= 1:0.9.0
+BuildRequires: popt-devel >= 1.6.3
+BuildRequires: transfig
+BuildRequires: xmlto
+Requires:      glib2 >= 1:2.8.0
+Requires(post):        /sbin/ldconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
+%define                _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
+%define                _gstcachedir    %{_var}/cache/gstreamer
+
 %description
 GStreamer is a streaming-media framework, based on graphs of filters
 which operate on media data. Applications using this library can do
@@ -25,7 +49,7 @@ installing new plugins.
 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
-rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
+rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
 nowych typów danych lub mo¿liwo¶ci obróbki.
 
@@ -33,7 +57,10 @@ nowych typ
 Summary:       Include files for GStreamer streaming-media framework
 Summary(pl):   Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      glib2-devel >= 1:2.8.0
+Requires:      libxml2-devel >= 2.4.17
+Requires:      popt-devel >= 1.6.3
 
 %description devel
 This package contains the includes files necessary to develop
@@ -47,7 +74,7 @@ i wtyczek do GStreamera.
 Summary:       GStreamer static libraries
 Summary(pl):   Biblioteki statyczne GStreamer
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static versions of GStreamer libraries.
@@ -57,44 +84,73 @@ Statyczne wersje bibliotek GStreamer.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
-%configure \
-       --enable-glib2 \
-       --enable-libmmx \
-       --enable-atomic
+%{__libtoolize}
+%{__aclocal} -I common/m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 
+%configure \
+       --disable-examples \
+       --disable-tests \
+       --enable-docbook \
+       --enable-gtk-doc \
+       --with-html-dir=%{_gtkdocdir} \
+       --with-cachedir=%{_gstcachedir}
+       
 %{__make}
 
-%install  
+%install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
 
-%{__make} DESTDIR=$RPM_BUILD_ROOT install
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+#touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
+
+mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
+mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
+       $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
+
+%find_lang %{name} --all-name --with-gnome
+
+# no static modules and *.la for them - shut up check files
+rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
-%{_bindir}/gst-register --gst-mask=0
 
 %postun        -p /sbin/ldconfig
-  
-%files
+
+%files -f %{name}.lang
 %defattr(644,root,root,755)
+%doc AUTHORS ChangeLog NEWS README TODO
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so.*
-%attr(755,root,root) %{_libdir}/gst/*.so*
-%attr(755,root,root) %{_libdir}/gst/*.la
+%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%dir %{_gstlibdir}
+%attr(755,root,root) %{_gstlibdir}/*.so
+%dir %{_gstcachedir}
+#%ghost %{_gstcachedir}/registry.xml
 %{_mandir}/man1/*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/lib*.so
-%{_includedir}/gst
+%{_libdir}/lib*.la
+%{_docdir}/%{name}-devel-%{version}
+%{_gstincludedir}
+%{_gtkdocdir}/*
 %{_pkgconfigdir}/*
+%{_aclocaldir}/*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
-%{_libdir}/gst/lib*.a
This page took 0.067761 seconds and 4 git commands to generate.