]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- updated without_ps_pdf patch (now configurable - but not disabled by default (yet?)
[packages/gstreamer.git] / gstreamer.spec
1
2 %define         _vmajor         0.10
3 %define         _vminor         1
4
5 Summary:        GStreamer Streaming-media framework runtime
6 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
7 Name:           gstreamer
8 Version:        %{_vmajor}.%{_vminor}
9 Release:        0.1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
13 # Source0-md5:  2a56154a6636a404ab9107524d4b7a89
14 Patch0:         %{name}-without_ps_pdf.patch
15 Patch1:         %{name}-eps.patch
16 URL:            http://gstreamer.net/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  bison >= 1.35
20 BuildRequires:  docbook-utils >= 0.6.10
21 BuildRequires:  flex
22 BuildRequires:  glib2-devel >= 1:2.6.0
23 BuildRequires:  gtk-doc >= 1.0
24 BuildRequires:  libtool >= 1.4
25 BuildRequires:  libxml2-devel >= 2.4.17
26 BuildRequires:  nasm
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 BuildRequires:  popt-devel >= 1.6.3
30 BuildRequires:  transfig
31 BuildRequires:  xmlto
32 Requires:       glib2 >= 1:2.6.0
33 Requires(post): /sbin/ldconfig
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
37 %define         _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
38 %define         _gstcachedir    %{_var}/cache/gstreamer
39
40 %description
41 GStreamer is a streaming-media framework, based on graphs of filters
42 which operate on media data. Applications using this library can do
43 anything from real-time sound processing to playing videos, and just
44 about anything else media-related. Its plugin-based architecture means
45 that new data types or processing capabilities can be added simply by
46 installing new plugins.
47
48 %description -l pl
49 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
50 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
51 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
52 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
53 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
54 nowych typów danych lub mo¿liwo¶ci obróbki.
55
56 %package devel
57 Summary:        Include files for GStreamer streaming-media framework
58 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       glib2-devel >= 1:2.4.4
62 Requires:       libxml2-devel >= 2.4.17
63 Requires:       popt-devel >= 1.6.3
64
65 %description devel
66 This package contains the includes files necessary to develop
67 applications and plugins for GStreamer.
68
69 %description devel -l pl
70 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
71 i wtyczek do GStreamera.
72
73 %package static
74 Summary:        GStreamer static libraries
75 Summary(pl):    Biblioteki statyczne GStreamer
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static versions of GStreamer libraries.
81
82 %description static -l pl
83 Statyczne wersje bibliotek GStreamer.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal} -I common/m4
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96
97 %configure \
98         --disable-examples \
99         --disable-tests \
100         --enable-docbook \
101         --enable-gtk-doc \
102         --with-html-dir=%{_gtkdocdir} \
103         --with-cachedir=%{_gstcachedir}
104         
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 #touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
115
116 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
117 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
118         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
119
120 %find_lang %{name} --all-name --with-gnome
121
122 # no static modules and *.la for them - shut up check files
123 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 /sbin/ldconfig
130
131 %postun -p /sbin/ldconfig
132
133 %files -f %{name}.lang
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README TODO
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
138 %dir %{_gstlibdir}
139 %attr(755,root,root) %{_gstlibdir}/*.so
140 %dir %{_gstcachedir}
141 #%ghost %{_gstcachedir}/registry.xml
142 %{_mandir}/man1/*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %{_libdir}/lib*.la
148 %{_docdir}/%{name}-devel-%{version}
149 %{_gstincludedir}
150 %{_gtkdocdir}/*
151 %{_pkgconfigdir}/*
152 %{_aclocaldir}/*
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/lib*.a
This page took 0.066398 seconds and 4 git commands to generate.