]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- 0.10.6
[packages/gstreamer.git] / gstreamer.spec
1
2 %define         _vmajor         0.10
3 %define         _vminor         6
4
5 Summary:        GStreamer Streaming-media framework runtime
6 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
7 Name:           gstreamer
8 Version:        %{_vmajor}.%{_vminor}
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
13 # Source0-md5:  3b0ba3698bfdb0a59918563ca285cefd
14 Patch0:         %{name}-without_ps_pdf.patch
15 Patch1:         %{name}-eps.patch
16 URL:            http://gstreamer.net/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  bison >= 1.35
20 BuildRequires:  check >= 0.9.3-2
21 BuildRequires:  docbook-utils >= 0.6.10
22 BuildRequires:  flex
23 BuildRequires:  glib2-devel >= 1:2.8.0
24 BuildRequires:  gtk-doc >= 1.3
25 BuildRequires:  libtool >= 1.4
26 BuildRequires:  libxml2-devel >= 2.4.17
27 BuildRequires:  nasm
28 BuildRequires:  perl-base
29 BuildRequires:  pkgconfig >= 1:0.9.0
30 BuildRequires:  popt-devel >= 1.6.3
31 # not sure it is a right place for this BR
32 BuildRequires:  python-PyXML
33 BuildRequires:  transfig
34 BuildRequires:  xmlto
35 Requires:       glib2 >= 1:2.8.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
39 %define         _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
40
41 %description
42 GStreamer is a streaming-media framework, based on graphs of filters
43 which operate on media data. Applications using this library can do
44 anything from real-time sound processing to playing videos, and just
45 about anything else media-related. Its plugin-based architecture means
46 that new data types or processing capabilities can be added simply by
47 installing new plugins.
48
49 %description -l pl
50 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
51 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
52 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
53 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
54 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
55 nowych typów danych lub mo¿liwo¶ci obróbki.
56
57 %package devel
58 Summary:        Include files for GStreamer streaming-media framework
59 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       glib2-devel >= 1:2.8.0
63 Requires:       libxml2-devel >= 2.4.17
64 Requires:       popt-devel >= 1.6.3
65
66 %description devel
67 This package contains the includes files necessary to develop
68 applications and plugins for GStreamer.
69
70 %description devel -l pl
71 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
72 i wtyczek do GStreamera.
73
74 %package static
75 Summary:        GStreamer static libraries
76 Summary(pl):    Biblioteki statyczne GStreamer
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static versions of GStreamer libraries.
82
83 %description static -l pl
84 Statyczne wersje bibliotek GStreamer.
85
86 %package apidocs
87 Summary:        GStreamer API documentation
88 Summary(pl):    Dokumentacja API Gstreamera
89 Group:          Documentation
90 Requires:       gtk-doc-common
91
92 %description apidocs
93 GStreamer API documentation.
94
95 %description apidocs -l pl
96 Dokumentacja API Gstreamera.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I common/m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109
110 %configure \
111         --disable-examples \
112         --disable-pspdf \
113         --disable-tests \
114         --enable-docbook \
115         --enable-gtk-doc \
116         --with-html-dir=%{_gtkdocdir}
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
128 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
129         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
130
131 %find_lang %{name} --all-name --with-gnome
132
133 # no static modules and *.la for them - shut up check files
134 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog NEWS README TODO
145 %attr(755,root,root) %{_bindir}/*
146 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
147 %dir %{_gstlibdir}
148 %attr(755,root,root) %{_gstlibdir}/*.so
149 %{_mandir}/man1/*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_docdir}/%{name}-devel-%{version}
156 %{_gstincludedir}
157 %{_pkgconfigdir}/*
158 %{_aclocaldir}/*
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
163
164 %files apidocs
165 %defattr(644,root,root,755)
166 %{_gtkdocdir}/*
This page took 0.082987 seconds and 4 git commands to generate.