]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- added gstreamer-rpmdeps.sh and gstreamer-rpmmacros. These files are
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl.UTF-8):      GStreamer - biblioteki środowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.10.21
5 Release:        4
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  7bad90af3fd81a1535363cf85359125c
10 Source1:        %{name}-rpmdeps.sh
11 Source2:        %{name}-rpmmacros
12 Patch0:         %{name}-without_ps_pdf.patch
13 Patch1:         %{name}-eps.patch
14 Patch2:         %{name}-inspect-rpm-format.patch
15 URL:            http://gstreamer.net/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  bison >= 1.35
19 BuildRequires:  check >= 0.9.3-2
20 BuildRequires:  docbook-utils >= 0.6.10
21 BuildRequires:  flex
22 BuildRequires:  gettext-devel >= 0.11.5
23 BuildRequires:  glib2-devel >= 1:2.12.0
24 BuildRequires:  gtk-doc >= 1.6
25 BuildRequires:  libtool >= 1.4
26 BuildRequires:  libxml2-devel >= 1:2.6.26
27 BuildRequires:  nasm
28 BuildRequires:  perl-base
29 BuildRequires:  pkgconfig >= 1:0.9.0
30 BuildRequires:  popt-devel >= 1.6.3
31 # not sure it is a right place for this BR
32 BuildRequires:  python-PyXML
33 BuildRequires:  transfig
34 BuildRequires:  xmlto
35 Requires:       glib2 >= 1:2.12.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         vmajor          %(echo %{version} | cut -d. -f1,2)
39 %define         _gstlibdir      %{_libdir}/gstreamer-%{vmajor}
40 %define         _gstincludedir  %{_includedir}/gstreamer-%{vmajor}
41
42 %define         rpmlibdir       /usr/lib/rpm
43
44 %description
45 GStreamer is a streaming-media framework, based on graphs of filters
46 which operate on media data. Applications using this library can do
47 anything from real-time sound processing to playing videos, and just
48 about anything else media-related. Its plugin-based architecture means
49 that new data types or processing capabilities can be added simply by
50 installing new plugins.
51
52 %description -l pl.UTF-8
53 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
54 grafie filtrów operujących na danych medialnych. Aplikacje używające
55 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
56 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
57 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
58 nowych typów danych lub możliwości obróbki.
59
60 %package devel
61 Summary:        Include files for GStreamer streaming-media framework
62 Summary(pl.UTF-8):      Pliki nagłówkowe do środowiska obróbki strumieni GStreamer
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       glib2-devel >= 1:2.12.0
66 Requires:       libxml2-devel >= 1:2.6.26
67 Requires:       popt-devel >= 1.6.3
68
69 %description devel
70 This package contains the includes files necessary to develop
71 applications and plugins for GStreamer.
72
73 %description devel -l pl.UTF-8
74 Ten pakiet zawiera pliki nagłówkowe potrzebne do rozwijania aplikacji
75 i wtyczek do GStreamera.
76
77 %package static
78 Summary:        GStreamer static libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne GStreamer
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static versions of GStreamer libraries.
85
86 %description static -l pl.UTF-8
87 Statyczne wersje bibliotek GStreamer.
88
89 %package apidocs
90 Summary:        GStreamer API documentation
91 Summary(pl.UTF-8):      Dokumentacja API Gstreamera
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 GStreamer API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API Gstreamera.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p0
106
107 %build
108 # po/Makefile.in.in is modified
109 #{__gettextize}
110 %{__libtoolize}
111 %{__aclocal} -I common/m4
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         --disable-examples \
117         --disable-pspdf \
118         --disable-tests \
119         --enable-docbook \
120         --enable-gtk-doc \
121         --with-html-dir=%{_gtkdocdir}
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_docdir}/%{name}-devel-%{version},%{rpmlibdir}}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{rpmlibdir}/gstreamerdeps.sh
133 install %{SOURCE2} $RPM_BUILD_ROOT%{rpmlibdir}/macros.gstreamer
134
135 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{vmajor},%{version}}
136 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
137         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
138
139 %find_lang %{name} --all-name --with-gnome
140
141 # no static modules and *.la for them - shut up check files
142 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README TODO
153 %attr(755,root,root) %{_bindir}/gst-*
154 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libgstbase-0.10.so.0
156 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libgstcheck-0.10.so.0
158 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgstcontroller-0.10.so.0
160 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libgstdataprotocol-0.10.so.0
162 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libgstnet-0.10.so.0
164 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libgstreamer-0.10.so.0
166 %dir %{_gstlibdir}
167 %attr(755,root,root) %{_gstlibdir}/libgstcoreelements.so
168 %attr(755,root,root) %{_gstlibdir}/libgstcoreindexers.so
169 %{_mandir}/man1/gst-*.1*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so
174 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so
175 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so
176 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so
177 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so
178 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so
179 %{_libdir}/libgstbase-0.10.la
180 %{_libdir}/libgstcheck-0.10.la
181 %{_libdir}/libgstcontroller-0.10.la
182 %{_libdir}/libgstdataprotocol-0.10.la
183 %{_libdir}/libgstnet-0.10.la
184 %{_libdir}/libgstreamer-0.10.la
185 %{_docdir}/%{name}-devel-%{version}
186 %{_gstincludedir}
187 %{_pkgconfigdir}/gstreamer-0.10.pc
188 %{_pkgconfigdir}/gstreamer-base-0.10.pc
189 %{_pkgconfigdir}/gstreamer-check-0.10.pc
190 %{_pkgconfigdir}/gstreamer-controller-0.10.pc
191 %{_pkgconfigdir}/gstreamer-dataprotocol-0.10.pc
192 %{_pkgconfigdir}/gstreamer-net-0.10.pc
193 %{_aclocaldir}/gst-element-check-0.10.m4
194 %attr(755,root,root) %{rpmlibdir}/gstreamerdeps.sh
195 %{rpmlibdir}/macros.gstreamer
196
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/libgstbase-0.10.a
200 %{_libdir}/libgstcheck-0.10.a
201 %{_libdir}/libgstcontroller-0.10.a
202 %{_libdir}/libgstdataprotocol-0.10.a
203 %{_libdir}/libgstnet-0.10.a
204 %{_libdir}/libgstreamer-0.10.a
205
206 %files apidocs
207 %defattr(644,root,root,755)
208 %{_gtkdocdir}/gstreamer-0.10
209 %{_gtkdocdir}/gstreamer-libs-0.10
210 %{_gtkdocdir}/gstreamer-plugins-0.10
This page took 0.04428 seconds and 4 git commands to generate.