]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- updated to 0.8.4
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.8.4
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
9 # Source0-md5:  5bf02f686f3bbd787f9dca4331ce8ee2
10 Patch0:         %{name}-without_ps_pdf.patch
11 URL:            http://gstreamer.net/
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake >= 1.6
14 BuildRequires:  bison >= 1.35
15 BuildRequires:  flex
16 BuildRequires:  gettext-devel >= 0.14.1
17 BuildRequires:  glib2-devel >= 1:2.4.4
18 BuildRequires:  gtk-doc >= 1.0
19 BuildRequires:  intltool
20 BuildRequires:  libtool >= 1.4
21 BuildRequires:  libxml2-devel >= 2.4.17
22 BuildRequires:  nasm
23 BuildRequires:  perl-base
24 BuildRequires:  pkgconfig >= 0.9.0
25 BuildRequires:  popt-devel >= 1.6.3
26 BuildRequires:  transfig
27 BuildRequires:  xmlto
28 Requires(post): /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _gstlibdir      %{_libdir}/gstreamer-0.8
32 %define         _gstincludedir  %{_includedir}/gstreamer-0.8
33 %define         _gstcachedir    %{_var}/cache/gstreamer
34
35 %description
36 GStreamer is a streaming-media framework, based on graphs of filters
37 which operate on media data. Applications using this library can do
38 anything from real-time sound processing to playing videos, and just
39 about anything else media-related. Its plugin-based architecture means
40 that new data types or processing capabilities can be added simply by
41 installing new plugins.
42
43 %description -l pl
44 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
45 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
46 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
47 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
48 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
49 nowych typów danych lub mo¿liwo¶ci obróbki.
50
51 %package devel
52 Summary:        Include files for GStreamer streaming-media framework
53 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       glib2-devel >= 1:2.4.4
57 Requires:       libxml2-devel >= 2.4.17
58 Requires:       popt-devel >= 1.6.3
59
60 %description devel
61 This package contains the includes files necessary to develop
62 applications and plugins for GStreamer.
63
64 %description devel -l pl
65 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
66 i wtyczek do GStreamera.
67
68 %package static
69 Summary:        GStreamer static libraries
70 Summary(pl):    Biblioteki statyczne GStreamer
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static versions of GStreamer libraries.
76
77 %description static -l pl
78 Statyczne wersje bibliotek GStreamer.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 intltoolize --copy --force
86 %{__gettextize}
87 %{__libtoolize}
88 %{__aclocal} -I common/m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92
93 %configure \
94         --program-suffix="" \
95 %ifarch i586 i686 athlon
96         --enable-fast-stack-trash \
97 %else
98         --disable-fast-stack-trash \
99 %endif
100         --enable-libmmx \
101         --enable-atomic \
102         --disable-examples \
103         --disable-tests \
104         --disable-debug \
105         --disable-debug-color \
106         --enable-docs-build \
107         --with-html-dir=%{_gtkdocdir} \
108         --with-cachedir=%{_gstcachedir}
109         
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
120
121 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
122         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
123
124 %find_lang %{name} --all-name --with-gnome
125
126 # no static modules and *.la for them - shut up check files
127 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 /sbin/ldconfig
134 %{_bindir}/gst-register --gst-registry=%{_gstcachedir}/registry.xml > /dev/null 2> /dev/null
135
136 %postun -p /sbin/ldconfig
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README TODO
141 %attr(755,root,root) %{_bindir}/*
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
143 %dir %{_gstlibdir}
144 %attr(755,root,root) %{_gstlibdir}/*.so
145 %dir %{_gstcachedir}
146 %ghost %{_gstcachedir}/registry.xml
147 %{_mandir}/man1/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc DEVEL
152 %attr(755,root,root) %{_libdir}/lib*.so
153 %{_libdir}/lib*.la
154 %{_gstincludedir}
155 %{_gtkdocdir}/*
156 %{_pkgconfigdir}/*
157 %{_aclocaldir}/*
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/lib*.a
This page took 0.063006 seconds and 4 git commands to generate.