]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- BR: gettext; ghostscript is required by transfig
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.8.3
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
9 # Source0-md5:  090bdbd35c9b831746694d020356d5b6
10 Patch0:         %{name}-without_ps_pdf.patch
11 URL:            http://gstreamer.net/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  gettext-devel >= 0.14.1
17 BuildRequires:  glib2-devel >= 1:2.4.2
18 BuildRequires:  gtk-doc >= 1.0
19 BuildRequires:  intltool
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel >= 2.4.17
22 BuildRequires:  nasm
23 BuildRequires:  perl-base
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel >= 1.6.3
26 BuildRequires:  transfig
27 BuildRequires:  xmlto
28 Requires(post): /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _gstlibdir      %{_libdir}/gstreamer-0.8
32 %define         _gstincludedir  %{_includedir}/gstreamer-0.8
33 %define         _gstcachedir    %{_var}/cache/gstreamer
34
35 %description
36 GStreamer is a streaming-media framework, based on graphs of filters
37 which operate on media data. Applications using this library can do
38 anything from real-time sound processing to playing videos, and just
39 about anything else media-related. Its plugin-based architecture means
40 that new data types or processing capabilities can be added simply by
41 installing new plugins.
42
43 %description -l pl
44 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
45 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
46 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
47 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
48 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
49 nowych typów danych lub mo¿liwo¶ci obróbki.
50
51 %package devel
52 Summary:        Include files for GStreamer streaming-media framework
53 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       glib2-devel >= 1:2.4.2
57 Requires:       libxml2-devel >= 2.4.17
58 Requires:       popt-devel >= 1.6.3
59
60 %description devel
61 This package contains the includes files necessary to develop
62 applications and plugins for GStreamer.
63
64 %description devel -l pl
65 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
66 i wtyczek do GStreamera.
67
68 %package static
69 Summary:        GStreamer static libraries
70 Summary(pl):    Biblioteki statyczne GStreamer
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static versions of GStreamer libraries.
76
77 %description static -l pl
78 Statyczne wersje bibliotek GStreamer.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 intltoolize --copy --force
86 %{__gettextize}
87 %{__libtoolize}
88 %{__aclocal} -I common/m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92
93 %configure \
94         --program-suffix="" \
95 %ifarch i586 i686 athlon
96         --enable-fast-stack-trash \
97 %else
98         --disable-fast-stack-trash \
99 %endif
100         --enable-glib2 \
101         --enable-libmmx \
102         --enable-atomic \
103         --disable-examples \
104         --disable-tests \
105         --disable-debug \
106         --disable-debug-color \
107         --enable-docs-build \
108         --with-html-dir=%{_gtkdocdir} \
109         --with-cachedir=%{_gstcachedir}
110         
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
121
122 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
123         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
124
125 %find_lang %{name} --all-name --with-gnome
126
127 # no static modules and *.la for them - shut up check files
128 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 /sbin/ldconfig
135 %{_bindir}/gst-register --gst-registry=%{_gstcachedir}/registry.xml > /dev/null 2> /dev/null
136
137 %postun -p /sbin/ldconfig
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README TODO
142 %attr(755,root,root) %{_bindir}/*
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
144 %dir %{_gstlibdir}
145 %attr(755,root,root) %{_gstlibdir}/*.so
146 %dir %{_gstcachedir}
147 %ghost %{_gstcachedir}/registry.xml
148 %{_mandir}/man1/*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %doc DEVEL
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_gstincludedir}
156 %{_gtkdocdir}/*
157 %{_pkgconfigdir}/*
158 %{_aclocaldir}/*
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
This page took 0.074111 seconds and 4 git commands to generate.