]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- rel 3
[packages/gstreamer.git] / gstreamer.spec
1
2 %define         _vmajor         0.10
3 %define         _vminor         11
4
5 Summary:        GStreamer Streaming-media framework runtime
6 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
7 Name:           gstreamer
8 Version:        %{_vmajor}.%{_vminor}
9 Release:        3
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
13 # Source0-md5:  67240094e08c845b7bbcfba755c95695
14 Patch0:         %{name}-without_ps_pdf.patch
15 Patch1:         %{name}-eps.patch
16 URL:            http://gstreamer.net/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  bison >= 1.35
20 BuildRequires:  check >= 0.9.3-2
21 BuildRequires:  docbook-utils >= 0.6.10
22 BuildRequires:  flex
23 BuildRequires:  gettext-devel >= 0.11.5
24 BuildRequires:  glib2-devel >= 1:2.12.0
25 BuildRequires:  gtk-doc >= 1.6
26 BuildRequires:  libtool >= 1.4
27 BuildRequires:  libxml2-devel >= 1:2.6.26
28 BuildRequires:  nasm
29 BuildRequires:  perl-base
30 BuildRequires:  pkgconfig >= 1:0.9.0
31 BuildRequires:  popt-devel >= 1.6.3
32 # not sure it is a right place for this BR
33 BuildRequires:  python-PyXML
34 BuildRequires:  transfig
35 BuildRequires:  xmlto
36 Requires:       glib2 >= 1:2.12.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
40 %define         _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
41
42 %description
43 GStreamer is a streaming-media framework, based on graphs of filters
44 which operate on media data. Applications using this library can do
45 anything from real-time sound processing to playing videos, and just
46 about anything else media-related. Its plugin-based architecture means
47 that new data types or processing capabilities can be added simply by
48 installing new plugins.
49
50 %description -l pl
51 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
52 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
53 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
54 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
55 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
56 nowych typów danych lub mo¿liwo¶ci obróbki.
57
58 %package devel
59 Summary:        Include files for GStreamer streaming-media framework
60 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       glib2-devel >= 1:2.12.0
64 Requires:       libxml2-devel >= 1:2.6.26
65 Requires:       popt-devel >= 1.6.3
66
67 %description devel
68 This package contains the includes files necessary to develop
69 applications and plugins for GStreamer.
70
71 %description devel -l pl
72 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
73 i wtyczek do GStreamera.
74
75 %package static
76 Summary:        GStreamer static libraries
77 Summary(pl):    Biblioteki statyczne GStreamer
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static versions of GStreamer libraries.
83
84 %description static -l pl
85 Statyczne wersje bibliotek GStreamer.
86
87 %package apidocs
88 Summary:        GStreamer API documentation
89 Summary(pl):    Dokumentacja API Gstreamera
90 Group:          Documentation
91 Requires:       gtk-doc-common
92
93 %description apidocs
94 GStreamer API documentation.
95
96 %description apidocs -l pl
97 Dokumentacja API Gstreamera.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 %{__gettextize}
106 %{__libtoolize}
107 %{__aclocal} -I common/m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --disable-examples \
113         --disable-pspdf \
114         --disable-tests \
115         --enable-docbook \
116         --enable-gtk-doc \
117         --with-html-dir=%{_gtkdocdir}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
129 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
130         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
131
132 %find_lang %{name} --all-name --with-gnome
133
134 # no static modules and *.la for them - shut up check files
135 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README TODO
146 %attr(755,root,root) %{_bindir}/*
147 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
148 %dir %{_gstlibdir}
149 %attr(755,root,root) %{_gstlibdir}/*.so
150 %{_mandir}/man1/*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/lib*.la
156 %{_docdir}/%{name}-devel-%{version}
157 %{_gstincludedir}
158 %{_pkgconfigdir}/*
159 %{_aclocaldir}/*
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/lib*.a
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/*
This page took 0.073202 seconds and 4 git commands to generate.