]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- first try to stable 0.10.1
[packages/gstreamer.git] / gstreamer.spec
1
2 %define         _vmajor         0.10
3 %define         _vminor         1
4
5 Summary:        GStreamer Streaming-media framework runtime
6 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
7 Name:           gstreamer
8 Version:        %{_vmajor}.%{_vminor}
9 Release:        0.1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
13 # Source0-md5:  2a56154a6636a404ab9107524d4b7a89
14 #Patch0:                %{name}-without_ps_pdf.patch
15 URL:            http://gstreamer.net/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.6
18 BuildRequires:  bison >= 1.35
19 BuildRequires:  flex
20 BuildRequires:  glib2-devel >= 1:2.6.0
21 BuildRequires:  gtk-doc >= 1.0
22 BuildRequires:  libtool >= 1.4
23 BuildRequires:  libxml2-devel >= 2.4.17
24 BuildRequires:  nasm
25 BuildRequires:  perl-base
26 BuildRequires:  pkgconfig >= 1:0.9.0
27 BuildRequires:  popt-devel >= 1.6.3
28 BuildRequires:  transfig
29 BuildRequires:  xmlto
30 Requires:       glib2 >= 1:2.6.0
31 Requires(post): /sbin/ldconfig
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
35 %define         _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
36 %define         _gstcachedir    %{_var}/cache/gstreamer
37
38 %description
39 GStreamer is a streaming-media framework, based on graphs of filters
40 which operate on media data. Applications using this library can do
41 anything from real-time sound processing to playing videos, and just
42 about anything else media-related. Its plugin-based architecture means
43 that new data types or processing capabilities can be added simply by
44 installing new plugins.
45
46 %description -l pl
47 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
48 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
49 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
50 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
51 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
52 nowych typów danych lub mo¿liwo¶ci obróbki.
53
54 %package devel
55 Summary:        Include files for GStreamer streaming-media framework
56 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.4.4
60 Requires:       libxml2-devel >= 2.4.17
61 Requires:       popt-devel >= 1.6.3
62
63 %description devel
64 This package contains the includes files necessary to develop
65 applications and plugins for GStreamer.
66
67 %description devel -l pl
68 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
69 i wtyczek do GStreamera.
70
71 %package static
72 Summary:        GStreamer static libraries
73 Summary(pl):    Biblioteki statyczne GStreamer
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static versions of GStreamer libraries.
79
80 %description static -l pl
81 Statyczne wersje bibliotek GStreamer.
82
83 %prep
84 %setup -q
85 #%patch0 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I common/m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93
94 %configure \
95         --disable-examples \
96         --disable-tests \
97         --enable-docbook \
98         --enable-gtk-doc \
99         --with-html-dir=%{_gtkdocdir} \
100         --with-cachedir=%{_gstcachedir}
101         
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 #touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
112
113 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
114 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
115         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
116
117 %find_lang %{name} --all-name --with-gnome
118
119 # no static modules and *.la for them - shut up check files
120 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 /sbin/ldconfig
127
128 %postun -p /sbin/ldconfig
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README TODO
133 %attr(755,root,root) %{_bindir}/*
134 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
135 %dir %{_gstlibdir}
136 %attr(755,root,root) %{_gstlibdir}/*.so
137 %dir %{_gstcachedir}
138 #%ghost %{_gstcachedir}/registry.xml
139 %{_mandir}/man1/*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/lib*.so
144 %{_libdir}/lib*.la
145 %{_docdir}/%{name}-devel-%{version}
146 %{_gstincludedir}
147 %{_gtkdocdir}/*
148 %{_pkgconfigdir}/*
149 %{_aclocaldir}/*
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
This page took 0.081915 seconds and 4 git commands to generate.