]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- add rpm provides output format to gst-inspect
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl.UTF-8):      GStreamer - biblioteki środowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.10.21
5 Release:        3
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  7bad90af3fd81a1535363cf85359125c
10 Patch0:         %{name}-without_ps_pdf.patch
11 Patch1:         %{name}-eps.patch
12 Patch2:         %{name}-inspect-rpm-format.patch
13 URL:            http://gstreamer.net/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake >= 1.6
16 BuildRequires:  bison >= 1.35
17 BuildRequires:  check >= 0.9.3-2
18 BuildRequires:  docbook-utils >= 0.6.10
19 BuildRequires:  flex
20 BuildRequires:  gettext-devel >= 0.11.5
21 BuildRequires:  glib2-devel >= 1:2.12.0
22 BuildRequires:  gtk-doc >= 1.6
23 BuildRequires:  libtool >= 1.4
24 BuildRequires:  libxml2-devel >= 1:2.6.26
25 BuildRequires:  nasm
26 BuildRequires:  perl-base
27 BuildRequires:  pkgconfig >= 1:0.9.0
28 BuildRequires:  popt-devel >= 1.6.3
29 # not sure it is a right place for this BR
30 BuildRequires:  python-PyXML
31 BuildRequires:  transfig
32 BuildRequires:  xmlto
33 Requires:       glib2 >= 1:2.12.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         vmajor          %(echo %{version} | cut -d. -f1,2)
37 %define         _gstlibdir      %{_libdir}/gstreamer-%{vmajor}
38 %define         _gstincludedir  %{_includedir}/gstreamer-%{vmajor}
39
40 %description
41 GStreamer is a streaming-media framework, based on graphs of filters
42 which operate on media data. Applications using this library can do
43 anything from real-time sound processing to playing videos, and just
44 about anything else media-related. Its plugin-based architecture means
45 that new data types or processing capabilities can be added simply by
46 installing new plugins.
47
48 %description -l pl.UTF-8
49 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
50 grafie filtrów operujących na danych medialnych. Aplikacje używające
51 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
52 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
53 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
54 nowych typów danych lub możliwości obróbki.
55
56 %package devel
57 Summary:        Include files for GStreamer streaming-media framework
58 Summary(pl.UTF-8):      Pliki nagłówkowe do środowiska obróbki strumieni GStreamer
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       glib2-devel >= 1:2.12.0
62 Requires:       libxml2-devel >= 1:2.6.26
63 Requires:       popt-devel >= 1.6.3
64
65 %description devel
66 This package contains the includes files necessary to develop
67 applications and plugins for GStreamer.
68
69 %description devel -l pl.UTF-8
70 Ten pakiet zawiera pliki nagłówkowe potrzebne do rozwijania aplikacji
71 i wtyczek do GStreamera.
72
73 %package static
74 Summary:        GStreamer static libraries
75 Summary(pl.UTF-8):      Biblioteki statyczne GStreamer
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static versions of GStreamer libraries.
81
82 %description static -l pl.UTF-8
83 Statyczne wersje bibliotek GStreamer.
84
85 %package apidocs
86 Summary:        GStreamer API documentation
87 Summary(pl.UTF-8):      Dokumentacja API Gstreamera
88 Group:          Documentation
89 Requires:       gtk-doc-common
90
91 %description apidocs
92 GStreamer API documentation.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API Gstreamera.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p0
102
103 %build
104 # po/Makefile.in.in is modified
105 #{__gettextize}
106 %{__libtoolize}
107 %{__aclocal} -I common/m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --disable-examples \
113         --disable-pspdf \
114         --disable-tests \
115         --enable-docbook \
116         --enable-gtk-doc \
117         --with-html-dir=%{_gtkdocdir}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{vmajor},%{version}}
129 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
130         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
131
132 %find_lang %{name} --all-name --with-gnome
133
134 # no static modules and *.la for them - shut up check files
135 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README TODO
146 %attr(755,root,root) %{_bindir}/gst-*
147 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libgstbase-0.10.so.0
149 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libgstcheck-0.10.so.0
151 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libgstcontroller-0.10.so.0
153 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libgstdataprotocol-0.10.so.0
155 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libgstnet-0.10.so.0
157 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libgstreamer-0.10.so.0
159 %dir %{_gstlibdir}
160 %attr(755,root,root) %{_gstlibdir}/libgstcoreelements.so
161 %attr(755,root,root) %{_gstlibdir}/libgstcoreindexers.so
162 %{_mandir}/man1/gst-*.1*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so
167 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so
168 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so
169 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so
170 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so
171 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so
172 %{_libdir}/libgstbase-0.10.la
173 %{_libdir}/libgstcheck-0.10.la
174 %{_libdir}/libgstcontroller-0.10.la
175 %{_libdir}/libgstdataprotocol-0.10.la
176 %{_libdir}/libgstnet-0.10.la
177 %{_libdir}/libgstreamer-0.10.la
178 %{_docdir}/%{name}-devel-%{version}
179 %{_gstincludedir}
180 %{_pkgconfigdir}/gstreamer-0.10.pc
181 %{_pkgconfigdir}/gstreamer-base-0.10.pc
182 %{_pkgconfigdir}/gstreamer-check-0.10.pc
183 %{_pkgconfigdir}/gstreamer-controller-0.10.pc
184 %{_pkgconfigdir}/gstreamer-dataprotocol-0.10.pc
185 %{_pkgconfigdir}/gstreamer-net-0.10.pc
186 %{_aclocaldir}/gst-element-check-0.10.m4
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libgstbase-0.10.a
191 %{_libdir}/libgstcheck-0.10.a
192 %{_libdir}/libgstcontroller-0.10.a
193 %{_libdir}/libgstdataprotocol-0.10.a
194 %{_libdir}/libgstnet-0.10.a
195 %{_libdir}/libgstreamer-0.10.a
196
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/gstreamer-0.10
200 %{_gtkdocdir}/gstreamer-libs-0.10
201 %{_gtkdocdir}/gstreamer-plugins-0.10
This page took 0.060489 seconds and 4 git commands to generate.