]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- release 2
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl.UTF-8):      GStreamer - biblioteki środowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.10.23
5 Release:        2
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  f7b2e300d2d85756407ec529424ab237
10 Source1:        %{name}-rpmdeps.sh
11 Patch0:         %{name}-without_ps_pdf.patch
12 Patch1:         %{name}-eps.patch
13 Patch2:         %{name}-inspect-rpm-format.patch
14 URL:            http://gstreamer.net/
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  bison >= 1.35
18 BuildRequires:  check >= 0.9.3-2
19 BuildRequires:  docbook-utils >= 0.6.10
20 BuildRequires:  flex
21 BuildRequires:  gettext-devel >= 0.11.5
22 BuildRequires:  glib2-devel >= 1:2.12.0
23 BuildRequires:  gtk-doc >= 1.6
24 BuildRequires:  libtool >= 1.4
25 BuildRequires:  libxml2-devel >= 1:2.6.26
26 BuildRequires:  nasm
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 BuildRequires:  popt-devel >= 1.6.3
30 # not sure it is a right place for this BR
31 BuildRequires:  python-PyXML
32 BuildRequires:  transfig
33 BuildRequires:  xmlto
34 Requires:       glib2 >= 1:2.12.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         vmajor          %(echo %{version} | cut -d. -f1,2)
38 %define         _gstlibdir      %{_libdir}/gstreamer-%{vmajor}
39 %define         _gstincludedir  %{_includedir}/gstreamer-%{vmajor}
40
41 %define         rpmlibdir       /usr/lib/rpm
42
43 %description
44 GStreamer is a streaming-media framework, based on graphs of filters
45 which operate on media data. Applications using this library can do
46 anything from real-time sound processing to playing videos, and just
47 about anything else media-related. Its plugin-based architecture means
48 that new data types or processing capabilities can be added simply by
49 installing new plugins.
50
51 %description -l pl.UTF-8
52 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
53 grafie filtrów operujących na danych medialnych. Aplikacje używające
54 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
55 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
56 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
57 nowych typów danych lub możliwości obróbki.
58
59 %package devel
60 Summary:        Include files for GStreamer streaming-media framework
61 Summary(pl.UTF-8):      Pliki nagłówkowe do środowiska obróbki strumieni GStreamer
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 1:2.12.0
65 Requires:       libxml2-devel >= 1:2.6.26
66 Requires:       popt-devel >= 1.6.3
67 Obsoletes:      gstreamer-plugins-bad-devel < 0.10.10
68
69 %description devel
70 This package contains the includes files necessary to develop
71 applications and plugins for GStreamer.
72
73 %description devel -l pl.UTF-8
74 Ten pakiet zawiera pliki nagłówkowe potrzebne do rozwijania aplikacji
75 i wtyczek do GStreamera.
76
77 %package static
78 Summary:        GStreamer static libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne GStreamer
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static versions of GStreamer libraries.
85
86 %description static -l pl.UTF-8
87 Statyczne wersje bibliotek GStreamer.
88
89 %package apidocs
90 Summary:        GStreamer API documentation
91 Summary(pl.UTF-8):      Dokumentacja API Gstreamera
92 Group:          Documentation
93 Requires:       gtk-doc-common
94
95 %description apidocs
96 GStreamer API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API Gstreamera.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106
107 %build
108 # po/Makefile.in.in is modified
109 #{__gettextize}
110 %{__libtoolize}
111 %{__aclocal} -I common/m4
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 %configure \
116         --disable-examples \
117         --disable-pspdf \
118         --disable-tests \
119         --enable-docbook \
120         --enable-gtk-doc \
121         --with-html-dir=%{_gtkdocdir}
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_docdir}/%{name}-devel-%{version},%{rpmlibdir}}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{rpmlibdir}/gstreamerdeps.sh
133
134 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{vmajor},%{version}}
135 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
136         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
137
138 %find_lang %{name} --all-name --with-gnome
139
140 # no static modules and *.la for them - shut up check files
141 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS README TODO
152 %attr(755,root,root) %{_bindir}/gst-*
153 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libgstbase-0.10.so.0
155 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libgstcheck-0.10.so.0
157 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libgstcontroller-0.10.so.0
159 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgstdataprotocol-0.10.so.0
161 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libgstnet-0.10.so.0
163 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libgstreamer-0.10.so.0
165 %dir %{_gstlibdir}
166 %attr(755,root,root) %{_gstlibdir}/libgstcoreelements.so
167 %attr(755,root,root) %{_gstlibdir}/libgstcoreindexers.so
168 %{_mandir}/man1/gst-*.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so
173 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so
174 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so
175 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so
176 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so
177 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so
178 %{_libdir}/libgstbase-0.10.la
179 %{_libdir}/libgstcheck-0.10.la
180 %{_libdir}/libgstcontroller-0.10.la
181 %{_libdir}/libgstdataprotocol-0.10.la
182 %{_libdir}/libgstnet-0.10.la
183 %{_libdir}/libgstreamer-0.10.la
184 %{_docdir}/%{name}-devel-%{version}
185 %{_gstincludedir}
186 %{_pkgconfigdir}/gstreamer-0.10.pc
187 %{_pkgconfigdir}/gstreamer-base-0.10.pc
188 %{_pkgconfigdir}/gstreamer-check-0.10.pc
189 %{_pkgconfigdir}/gstreamer-controller-0.10.pc
190 %{_pkgconfigdir}/gstreamer-dataprotocol-0.10.pc
191 %{_pkgconfigdir}/gstreamer-net-0.10.pc
192 %{_aclocaldir}/gst-element-check-0.10.m4
193 %attr(755,root,root) %{rpmlibdir}/gstreamerdeps.sh
194
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/libgstbase-0.10.a
198 %{_libdir}/libgstcheck-0.10.a
199 %{_libdir}/libgstcontroller-0.10.a
200 %{_libdir}/libgstdataprotocol-0.10.a
201 %{_libdir}/libgstnet-0.10.a
202 %{_libdir}/libgstreamer-0.10.a
203
204 %files apidocs
205 %defattr(644,root,root,755)
206 %{_gtkdocdir}/gstreamer-0.10
207 %{_gtkdocdir}/gstreamer-libs-0.10
208 %{_gtkdocdir}/gstreamer-plugins-0.10
This page took 0.062548 seconds and 4 git commands to generate.