]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- 0.8.8, STBR
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.8.8
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  31a796592433eb250486bfae0d51238d
10 Patch0:         %{name}-without_ps_pdf.patch
11 URL:            http://gstreamer.net/
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake >= 1.6
14 BuildRequires:  bison >= 1.35
15 BuildRequires:  flex
16 BuildRequires:  glib2-devel >= 1:2.4.4
17 BuildRequires:  gtk-doc >= 1.0
18 BuildRequires:  libtool >= 1.4
19 BuildRequires:  libxml2-devel >= 2.4.17
20 BuildRequires:  nasm
21 BuildRequires:  perl-base
22 BuildRequires:  pkgconfig >= 1:0.9.0
23 BuildRequires:  popt-devel >= 1.6.3
24 BuildRequires:  transfig
25 BuildRequires:  xmlto
26 Requires(post): /sbin/ldconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _gstlibdir      %{_libdir}/gstreamer-0.8
30 %define         _gstincludedir  %{_includedir}/gstreamer-0.8
31 %define         _gstcachedir    %{_var}/cache/gstreamer
32
33 %description
34 GStreamer is a streaming-media framework, based on graphs of filters
35 which operate on media data. Applications using this library can do
36 anything from real-time sound processing to playing videos, and just
37 about anything else media-related. Its plugin-based architecture means
38 that new data types or processing capabilities can be added simply by
39 installing new plugins.
40
41 %description -l pl
42 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
43 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
44 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
45 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
46 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
47 nowych typów danych lub mo¿liwo¶ci obróbki.
48
49 %package devel
50 Summary:        Include files for GStreamer streaming-media framework
51 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       glib2-devel >= 1:2.4.4
55 Requires:       libxml2-devel >= 2.4.17
56 Requires:       popt-devel >= 1.6.3
57
58 %description devel
59 This package contains the includes files necessary to develop
60 applications and plugins for GStreamer.
61
62 %description devel -l pl
63 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
64 i wtyczek do GStreamera.
65
66 %package static
67 Summary:        GStreamer static libraries
68 Summary(pl):    Biblioteki statyczne GStreamer
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static versions of GStreamer libraries.
74
75 %description static -l pl
76 Statyczne wersje bibliotek GStreamer.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I common/m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88
89 %configure \
90         --program-suffix="" \
91 %ifarch i586 i686 athlon
92         --enable-fast-stack-trash \
93 %else
94         --disable-fast-stack-trash \
95 %endif
96         --enable-libmmx \
97         --enable-atomic \
98         --disable-examples \
99         --disable-tests \
100         --disable-debug \
101         --disable-debug-color \
102         --enable-docs-build \
103         --with-html-dir=%{_gtkdocdir} \
104         --with-cachedir=%{_gstcachedir}
105         
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
116
117 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
118         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
119
120 %find_lang %{name} --all-name --with-gnome
121
122 # no static modules and *.la for them - shut up check files
123 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 /sbin/ldconfig
130 %{_bindir}/gst-register --gst-registry=%{_gstcachedir}/registry.xml > /dev/null 2> /dev/null
131
132 %postun -p /sbin/ldconfig
133
134 %files -f %{name}.lang
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog NEWS README TODO
137 %attr(755,root,root) %{_bindir}/*
138 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
139 %dir %{_gstlibdir}
140 %attr(755,root,root) %{_gstlibdir}/*.so
141 %dir %{_gstcachedir}
142 %ghost %{_gstcachedir}/registry.xml
143 %{_mandir}/man1/*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %doc DEVEL
148 %attr(755,root,root) %{_libdir}/lib*.so
149 %{_libdir}/lib*.la
150 %{_gstincludedir}
151 %{_gtkdocdir}/*
152 %{_pkgconfigdir}/*
153 %{_aclocaldir}/*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
This page took 0.042357 seconds and 4 git commands to generate.