- generalized EGL/OpenGL/OpenGLES dependencies
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 21 May 2021 18:09:40 +0000 (20:09 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 21 May 2021 18:09:40 +0000 (20:09 +0200)
gstreamer-vaapi.spec

index a6867a0e1dd7d297c26f99a3564d450cf87c710a..4f473583369c8caa3b76bdb7d68524d5c5784a57 100644 (file)
@@ -17,9 +17,11 @@ Group:               Libraries
 Source0:       https://gstreamer.freedesktop.org/src/gstreamer-vaapi/%{name}-%{version}.tar.xz
 # Source0-md5: 8c9b5a4d20afc04bc5e1536e81511f27
 URL:           https://gstreamer.freedesktop.org/
-BuildRequires: Mesa-libEGL-devel
-BuildRequires: Mesa-libGL-devel
-BuildRequires: Mesa-libGLES-devel
+BuildRequires: EGL-devel
+BuildRequires: OpenGL-devel
+BuildRequires: OpenGL-GLX-devel
+BuildRequires: OpenGLESv2-devel
+BuildRequires: OpenGLESv3-devel
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.14
 BuildRequires: glib2-devel >= 1:2.40.0
@@ -36,6 +38,10 @@ BuildRequires:       libva-drm-devel >= 1.1.0
 BuildRequires: libva-wayland-devel >= 1.1.0
 BuildRequires: libva-x11-devel >= 1.0.3
 BuildRequires: pkgconfig
+BuildRequires: pkgconfig(egl)
+BuildRequires: pkgconfig(gl)
+BuildRequires: pkgconfig(glesv2)
+BuildRequires: pkgconfig(glesv3)
 # libva API versions
 BuildRequires: pkgconfig(libva) >= 0.39.0
 BuildRequires: pkgconfig(libva-drm) >= 0.39.0
This page took 0.297584 seconds and 4 git commands to generate.