]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- ldconfig not needed
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  gconf           # don't build GConf plugin
7 %bcond_without  ladspa          # don't build ladspa plugin
8 %bcond_without  speex           # don't build speex plugin
9 #
10 %define         gstname         gst-plugins-good
11 %define         gst_major_ver   0.10
12 %define         gst_req_ver     0.10.1
13 #
14 Summary:        Good GStreamer Streaming-media framework plugins
15 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
16 Name:           gstreamer-plugins-good
17 Version:        0.10.1
18 Release:        0.1
19 License:        LGPL
20 Group:          Libraries
21 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
22 # Source0-md5:  be5ba72454a1df6e4e6d5deeeec88e59
23 Patch0:         %{name}-bashish.patch
24 Patch1:         %{name}-libcaca.patch
25 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.0}
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake >= 1.5
28 BuildRequires:  glib2-devel >= 1:2.6.0
29 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
30 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
31 BuildRequires:  gtk-doc >= 1.3
32 BuildRequires:  gtk+2-devel >= 2:2.2.0
33 BuildRequires:  liboil-devel >= 0.3.2
34 BuildRequires:  libtool >= 1.4
35 BuildRequires:  pkgconfig >= 1:0.9.0
36 ##
37 ## plugins
38 ##
39 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
40 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0.0}
41 BuildRequires:  esound-devel >= 0.2.12
42 BuildRequires:  flac-devel >= 1.1.2
43 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
44 BuildRequires:  libavc1394-devel
45 %{?with_caca:BuildRequires:     libcaca-devel}
46 BuildRequires:  libdv-devel >= 0.104
47 BuildRequires:  libjpeg-devel
48 BuildRequires:  libpng-devel >= 1.2.0
49 BuildRequires:  libraw1394-devel
50 BuildRequires:  libshout-devel >= 2.0
51 BuildRequires:  rpmbuild(macros) >= 1.198
52 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
53 BuildRequires:  zlib-devel
54 Requires:       gstreamer >= %{gst_req_ver}
55 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
56 Obsoletes:      gstreamer-avi
57 Obsoletes:      gstreamer-flx
58 Obsoletes:      gstreamer-matroska
59 Obsoletes:      gstreamer-mixer
60 Obsoletes:      gstreamer-navigation
61 Obsoletes:      gstreamer-rtp
62 Obsoletes:      gstreamer-udp
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
66 %define         gstincludedir   %{_includedir}/gstreamer-%{gst_major_ver}
67
68 %description
69 GStreamer is a streaming-media framework, based on graphs of filters
70 which operate on media data. Applications using this library can do
71 anything from real-time sound processing to playing videos, and just
72 about anything else media-related. Its plugin-based architecture means
73 that new data types or processing capabilities can be added simply by
74 installing new plugins.
75
76 %description -l pl
77 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
78 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
79 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
80 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
81 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
82 nowych typów danych lub mo¿liwo¶ci obróbki.
83
84 %package -n gstreamer-GConf
85 Summary:        GStreamer GConf schemas
86 Summary(pl):    Schematy GConf GStreamera
87 Group:          Libraries
88 Requires(post,preun):   GConf2
89 Requires:       gstreamer >= %{gst_req_ver}
90 Obsoletes:      gstreamer-GConf-devel
91
92 %description -n gstreamer-GConf
93 Installation of GStreamer GConf schemas. These set usable defaults
94 used by all GStreamer-enabled GNOME applications.
95
96 %description -n gstreamer-GConf -l pl
97 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
98 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
99
100 ##
101 ## Plugins
102 ##
103
104 %package -n gstreamer-videosink-aa
105 Summary:        GStreamer plugin for Ascii-art output
106 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
107 Group:          Libraries
108 Requires:       gstreamer >= %{gst_req_ver}
109 Provides:       gstreamer-videosink = %{version}
110 Obsoletes:      gstreamer-aalib
111
112 %description -n gstreamer-videosink-aa
113 Plugin for viewing movies in Ascii-art using aalib library.
114
115 %description -n gstreamer-videosink-aa -l pl
116 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
117
118 %package -n gstreamer-audio-effects-good
119 Summary:        Good GStreamer audio effects plugins
120 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
121 Group:          Libraries
122 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
123 Obsoletes:      gstreamer-audio-effects
124
125 %description -n gstreamer-audio-effects-good
126 Good GStreamer audio effects plugins.
127
128 %description -n gstreamer-audio-effects-good -l pl
129 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
130
131 %package -n gstreamer-audio-formats
132 Summary:        GStreamer audio format plugins
133 Summary(pl):    Wtyczki formatów d¼wiêku
134 Group:          Libraries
135 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
136 # for locales in wavparse module
137 Requires:       %{name} = %{version}-%{release}
138
139 %description -n gstreamer-audio-formats
140 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
141
142 %description -n gstreamer-audio-formats -l pl
143 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
144
145 %package -n gstreamer-cairo
146 Summary:        GStreamer cairo plugin
147 Summary(pl):    Wtyczka cairo do GStreamera
148 Group:          Libraries
149 Requires:       gstreamer >= %{gst_req_ver}
150
151 %description -n gstreamer-cairo
152 GStreamer cairo plugin.
153
154 %description -n gstreamer-cairo -l pl
155 Wtyczka cairo do GStreamera.
156
157 %package -n gstreamer-dv
158 Summary:        GStreamer dv plugin
159 Summary(pl):    Wtyczka dv do GStreamera
160 Group:          Libraries
161 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
162
163 %description -n gstreamer-dv
164 Plugin for digital video support.
165
166 %description -n gstreamer-dv -l pl
167 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
168
169 %package -n gstreamer-audiosink-esd
170 Summary:        GStreamer plugin for ESD sound output
171 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
172 Group:          Libraries
173 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
174 Provides:       gstreamer-audiosink = %{version}
175 Obsoletes:      gstreamer-esound
176
177 %description -n gstreamer-audiosink-esd
178 Output plugin for GStreamer for use with the esound package.
179
180 %description -n gstreamer-audiosink-esd -l pl
181 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
182
183 %package -n gstreamer-flac
184 Summary:        GStreamer plugin for FLAC lossless audio format
185 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
186 Group:          Libraries
187 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
188
189 %description -n gstreamer-flac
190 Plugin for the free FLAC lossless audio format.
191
192 %description -n gstreamer-flac -l pl
193 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
194
195 %package -n gstreamer-ladspa
196 Summary:        GStreamer wrapper for LADSPA plugins
197 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
198 Group:          Libraries
199 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
200
201 %description -n gstreamer-ladspa
202 Plugin which wraps LADSPA plugins for use by GStreamer applications.
203
204 %description -n gstreamer-ladspa -l pl
205 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
206 GStreamera.
207
208 %package -n gstreamer-videosink-libcaca
209 Summary:        GStreamer plugin for libcaca Ascii-art output
210 Summary(pl):    Wtyczka libcaca do GStreamera
211 Group:          Libraries
212 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
213 Provides:       gstreamer-videosink = %{version}
214
215 %description -n gstreamer-videosink-libcaca
216 GStreamer plug-in for libcaca Ascii-art output.
217
218 %description -n gstreamer-videosink-libcaca -l pl
219 Wtyczka libcaca do GStreamera.
220
221 %package -n gstreamer-libpng
222 Summary:        GStreamer plugin to encode png images
223 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
224 Group:          Libraries
225 #Requires:      gstreamer >= %{gst_req_ver}
226 # for locales
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       libpng >= 1.2.0
229
230 %description -n gstreamer-libpng
231 Plugin for encoding png images.
232
233 %description -n gstreamer-libpng -l pl
234 Wtyczka koduj±ca pliki png.
235
236 %package -n gstreamer-audiosink-oss
237 Summary:        GStreamer plugins for input and output using OSS
238 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
239 Group:          Libraries
240 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
241 # for locales
242 Requires:       %{name} = %{version}-%{release}
243 Provides:       gstreamer-audiosink = %{version}
244 Obsoletes:      gstreamer-oss
245
246 %description -n gstreamer-audiosink-oss
247 Plugins for output and input to the OpenSoundSystem audio drivers
248 found in the Linux kernels or commercially available from OpenSound.
249
250 %description -n gstreamer-audiosink-oss -l pl
251 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
252 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
253 od OpenSound.
254
255 %package -n gstreamer-raw1394
256 Summary:        GStreamer raw1394 Firewire plugin
257 Summary(pl):    Wtyczka FireWire dla GStreamera
258 Group:          Libraries
259 Requires:       gstreamer >= %{gst_req_ver}
260
261 %description -n gstreamer-raw1394
262 Plugin for digital video support using raw1394.
263
264 %description -n gstreamer-raw1394 -l pl
265 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
266
267 %package -n gstreamer-shout2
268 Summary:        GStreamer plugin for communicating with Shoutcast servers
269 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
270 Group:          Libraries
271 Requires:       gstreamer >= %{gst_req_ver}
272
273 %description -n gstreamer-shout2
274 GStreamer plugin for communicating with Shoutcast servers.
275
276 %description -n gstreamer-shout2 -l pl
277 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
278
279 %package -n gstreamer-speex
280 Summary:        GStreamer speex codec decoder/encoder plugin
281 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
282 Group:          Libraries
283 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
284 Requires:       speex >= 1:1.1.6
285
286 %description -n gstreamer-speex
287 GStreamer speex codec decoder/encoder plugin.
288
289 %description -n gstreamer-speex -l pl
290 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
291
292 %package -n gstreamer-video-effects
293 Summary:        GStreamer video effects plugins
294 Summary(pl):    Wtyczki efektów wideo do GStreamera
295 Group:          Libraries
296 # for locales in jpeg module
297 Requires:       %{name} = %{version}-%{release}
298
299 %description -n gstreamer-video-effects
300 GStreamer video effects plugins.
301
302 %description -n gstreamer-video-effects -l pl
303 Wtyczki efektów wideo do GStreamera.
304
305 %package -n gstreamer-visualisation
306 Summary:        GStreamer visualisations plugins
307 Summary(pl):    Wtyczki wizualizacji do GStreamera
308 Group:          Libraries
309 Requires:       gstreamer >= %{gst_req_ver}
310
311 %description -n gstreamer-visualisation
312 Various plugins for visual effects to use with audio. Included are
313 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
314
315 %description -n gstreamer-visualisation -l pl
316 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
317 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
318
319 %prep
320 %setup -q -n %{gstname}-%{version}
321 %patch0 -p1
322 %patch1 -p1
323
324 %build
325 %{__libtoolize}
326 %{__aclocal} -I m4 -I common/m4
327 %{__autoconf}
328 %{__autoheader}
329 %{__automake}
330 %configure \
331         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
332         %{!?with_aalib:--disable-aalib} \
333         %{!?with_caca:--disable-libcaca} \
334         %{!?with_cairo:--disable-cairo} \
335         %{!?with_ladspa:--disable-ladspa} \
336         %{!?with_speex:--disable-speex} \
337         --disable-static \
338         --enable-gtk-doc \
339         --with-html-dir=%{_gtkdocdir}
340
341 %{__make}
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345
346 %{__make} install \
347         DESTDIR=$RPM_BUILD_ROOT
348
349 # We don't need plugins' *.la files
350 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
351
352 %find_lang %{gstname}-%{gst_major_ver}
353
354 %clean
355 rm -rf $RPM_BUILD_ROOT
356
357 %post   -n gstreamer-GConf
358 %gconf_schema_install gstreamer-0.10.schemas
359
360 %preun  -n gstreamer-GConf
361 %gconf_schema_uninstall gstreamer-0.10.schemas
362
363 %files -f %{gstname}-%{gst_major_ver}.lang
364 %defattr(644,root,root,755)
365 %doc AUTHORS ChangeLog NEWS README RELEASE 
366 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
367 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
368 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
369 %attr(755,root,root) %{gstlibdir}/libgstavi.so
370 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
371 %attr(755,root,root) %{gstlibdir}/libgstefence.so
372 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
373 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
374 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
375 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
376 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
377 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
378 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
379 %attr(755,root,root) %{gstlibdir}/libgstudp.so
380 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
381 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
382 %{_gtkdocdir}/gst-plugins-good-plugins-*
383
384 %if %{with gconf}
385 %files -n gstreamer-GConf
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
388 %{_sysconfdir}/gconf/schemas/*
389 %endif
390
391 ##
392 ## Plugins
393 ##
394
395 %if %{with aalib}
396 %files -n gstreamer-videosink-aa
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
399 %endif
400
401 %files -n gstreamer-audio-effects-good
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
404 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
405 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
406 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
407
408 %files -n gstreamer-audio-formats
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
411 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
412 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
413
414 %if %{with cairo}
415 %files -n gstreamer-cairo
416 %defattr(644,root,root,755)
417 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
418 %endif
419
420 %files -n gstreamer-dv
421 %defattr(644,root,root,755)
422 %attr(755,root,root) %{gstlibdir}/libgstdv.so
423
424 %files -n gstreamer-audiosink-esd
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{gstlibdir}/libgstesd.so
427
428 %files -n gstreamer-flac
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{gstlibdir}/libgstflac.so
431
432 #%if %{with ladspa}
433 #%files -n gstreamer-ladspa
434 #%defattr(644,root,root,755)
435 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
436 #%endif
437
438 %if %{with caca}
439 %files -n gstreamer-videosink-libcaca
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
442 %endif
443
444 %files -n gstreamer-libpng
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{gstlibdir}/libgstpng.so
447
448 %files -n gstreamer-audiosink-oss
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
451
452 %files -n gstreamer-raw1394
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{gstlibdir}/libgst1394.so
455
456 %files -n gstreamer-shout2
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
459
460 %if %{with speex}
461 %files -n gstreamer-speex
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
464 %endif
465
466 %files -n gstreamer-video-effects
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
469 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
470 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
471 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
472
473 %files -n gstreamer-visualisation
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
This page took 0.05721 seconds and 4 git commands to generate.