]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
rebuild with separate debuginfo build-ids
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  aalib           # aa videosink plugin
5 %bcond_without  caca            # caca videosink plugin
6 %bcond_without  cairo           # cairo plugin
7 %bcond_without  gtk             # GTK+ (3.x) elements (video sink plugin)
8 %bcond_without  jack            # JACK audio plugin
9 %bcond_with     jack1           # JACK 1 (0.12x) instead of JACK 2 (1.9.x)
10 %bcond_without  lame            # LAME MP2/MP3 encoding plugin
11 %bcond_without  mpg123          # MPG123-based MP3 plugin
12 %bcond_without  qt              # Qt (5.x) elements (video sink plugin)
13 %bcond_without  soup            # libsoup (2.4 API) http source plugin
14 %bcond_without  speex           # speex plugin
15 %bcond_without  wavpack         # wavpack plugin
16
17 %define         gstname         gst-plugins-good
18 %define         gstmver         1.0
19 %define         gst_ver         1.16.3
20 %define         gstpb_ver       1.16.3
21
22 Summary:        Good GStreamer Streaming-media framework plugins
23 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
24 Name:           gstreamer-plugins-good
25 Version:        1.16.3
26 Release:        2
27 License:        LGPL v2+
28 Group:          Libraries
29 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.xz
30 # Source0-md5:  c79b6c2f8eaadb2bb66615b694db399e
31 URL:            https://gstreamer.freedesktop.org/
32 BuildRequires:  autoconf >= 2.69
33 BuildRequires:  automake >= 1:1.14
34 BuildRequires:  docbook-dtd412-xml
35 BuildRequires:  gettext-tools >= 0.17
36 BuildRequires:  glib2-devel >= 1:2.40
37 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
38 BuildRequires:  glibc-localedb-all
39 %endif
40 BuildRequires:  gstreamer-devel >= %{gst_ver}
41 BuildRequires:  gstreamer-gl-devel >= %{gstpb_ver}
42 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
43 BuildRequires:  gtk+3-devel >= 3.0.0
44 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.12}
45 BuildRequires:  libtool >= 2:2.2.6
46 BuildRequires:  orc-devel >= 0.4.17
47 BuildRequires:  pkgconfig >= 1:0.9.0
48 BuildRequires:  python >= 2.1
49 BuildRequires:  rpm-build >= 4.6
50 BuildRequires:  rpmbuild(macros) >= 1.198
51 BuildRequires:  tar >= 1:1.22
52 BuildRequires:  xz
53 ##
54 ## plugins
55 ##
56 %{?with_qt:BuildRequires:       Qt5Core-devel >= 5.4.0}
57 %{?with_qt:BuildRequires:       Qt5Gui-devel >= 5.4.0}
58 %{?with_qt:BuildRequires:       Qt5Quick-devel >= 5.4.0}
59 %{?with_qt:BuildRequires:       Qt5Qml-devel >= 5.4.0}
60 %{?with_qt:BuildRequires:       Qt5X11Extras-devel >= 5.4.0}
61 %{?with_qt:BuildRequires:       Qt5WaylandClient-devel >= 5.4.0}
62 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
63 BuildRequires:  bzip2-devel
64 %{?with_cairo:BuildRequires:    cairo-devel >= 1.10.0}
65 %{?with_cairo:BuildRequires:    cairo-gobject-devel >= 1.10.0}
66 BuildRequires:  dbus-devel >= 0.91
67 BuildRequires:  flac-devel >= 1.1.4
68 BuildRequires:  gdk-pixbuf2-devel >= 2.8.0
69 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.15.0}
70 %if %{with jack}
71 %{?with_jack1:BuildRequires:    jack-audio-connection-kit-devel >= 0.120.1}
72 %{!?with_jack1:BuildRequires:   jack-audio-connection-kit-devel >= 1.9.7}
73 %endif
74 %{?with_lame:BuildRequires:     lame-libs-devel}
75 BuildRequires:  libavc1394-devel
76 %{?with_caca:BuildRequires:     libcaca-devel}
77 BuildRequires:  libdv-devel >= 0.104
78 BuildRequires:  libiec61883-devel >= 1.0.0
79 BuildRequires:  libjpeg-devel
80 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
81 BuildRequires:  libpng-devel >= 2:1.5.1
82 BuildRequires:  libraw1394-devel >= 2.0.0
83 BuildRequires:  libshout-devel >= 2.0
84 %{?with_soup:BuildRequires:     libsoup-devel >= 2.48}
85 BuildRequires:  libstdc++-devel
86 BuildRequires:  libv4l-devel
87 BuildRequires:  libvpx-devel >= 1.8.0
88 BuildRequires:  pulseaudio-devel >= 2.0
89 %{?with_qt:BuildRequires:       qt5-build >= 5.4.0}
90 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
91 BuildRequires:  taglib-devel >= 1.5
92 %{?with_lame:BuildRequires:     twolame-devel >= 0.3.10}
93 BuildRequires:  udev-glib-devel >= 1:147
94 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.60.0}
95 BuildRequires:  xorg-lib-libX11-devel
96 BuildRequires:  xorg-lib-libXdamage-devel
97 BuildRequires:  xorg-lib-libXext-devel
98 BuildRequires:  xorg-lib-libXfixes-devel
99 BuildRequires:  zlib-devel
100 Requires:       glib2 >= 1:2.40
101 Requires:       gstreamer >= %{gst_ver}
102 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
103 Requires:       orc >= 0.4.17
104 Obsoletes:      gstreamer-avi < 0.10
105 Obsoletes:      gstreamer-flx < 0.10
106 Obsoletes:      gstreamer-matroska < 0.10
107 Obsoletes:      gstreamer-mixer < 0.10
108 Obsoletes:      gstreamer-navigation < 0.10
109 Obsoletes:      gstreamer-oss4 < 0.10
110 Obsoletes:      gstreamer-rtp < 0.10
111 Obsoletes:      gstreamer-udp < 0.10
112 Conflicts:      gstreamer-plugins-bad < 0.10.19
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         gstlibdir       %{_libdir}/gstreamer-%{gstmver}
116
117 %description
118 GStreamer is a streaming-media framework, based on graphs of filters
119 which operate on media data. Applications using this library can do
120 anything from real-time sound processing to playing videos, and just
121 about anything else media-related. Its plugin-based architecture means
122 that new data types or processing capabilities can be added simply by
123 installing new plugins.
124
125 %description -l pl.UTF-8
126 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
127 grafie filtrów operujących na danych medialnych. Aplikacje używające
128 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
129 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
130 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
131 nowych typów danych lub możliwości obróbki.
132
133 %package apidocs
134 Summary:        Good GStreamer streaming-media framework plugins API documentation
135 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
136 Group:          Documentation
137 Requires:       gtk-doc-common
138 BuildArch:      noarch
139
140 %description apidocs
141 Good GStreamer streaming-media framework plugins API documentation.
142
143 %description apidocs -l pl.UTF-8
144 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
145 GStreamer.
146
147 ## ## Plugins ##
148
149 %package -n gstreamer-videosink-aa
150 Summary:        GStreamer plugin for Ascii-art output
151 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
152 Group:          Libraries
153 Requires:       gstreamer >= %{gst_ver}
154 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
155 Provides:       gstreamer-videosink = %{version}
156 Obsoletes:      gstreamer-aalib < 0.10
157
158 %description -n gstreamer-videosink-aa
159 Plugin for viewing movies in Ascii-art using aalib library.
160
161 %description -n gstreamer-videosink-aa -l pl.UTF-8
162 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
163
164 %package -n gstreamer-audio-effects-good
165 Summary:        Good GStreamer audio effects plugins
166 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
167 Group:          Libraries
168 Requires:       gstreamer >= %{gst_ver}
169 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
170 Obsoletes:      gstreamer-audio-effects < 0.10
171
172 %description -n gstreamer-audio-effects-good
173 Good GStreamer audio effects plugins.
174
175 %description -n gstreamer-audio-effects-good -l pl.UTF-8
176 Dobre wtyczki efektów dźwiękowych do GStreamera.
177
178 %package -n gstreamer-audio-formats
179 Summary:        GStreamer audio format plugins
180 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
181 Group:          Libraries
182 Requires:       gstreamer >= %{gst_ver}
183 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
184 # for locales in wavparse module
185 Requires:       %{name} = %{version}-%{release}
186
187 %description -n gstreamer-audio-formats
188 Plugin for playback of WAV, au and mod audio files as well as MP3
189 type.
190
191 %description -n gstreamer-audio-formats -l pl.UTF-8
192 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
193
194 %package -n gstreamer-cairo
195 Summary:        GStreamer cairo plugin
196 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
197 Group:          Libraries
198 Requires:       cairo >= 1.10.0
199 Requires:       cairo-gobject >= 1.10.0
200 Requires:       gstreamer >= %{gst_ver}
201 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
202
203 %description -n gstreamer-cairo
204 GStreamer cairo plugin.
205
206 %description -n gstreamer-cairo -l pl.UTF-8
207 Wtyczka cairo do GStreamera.
208
209 %package -n gstreamer-dv
210 Summary:        GStreamer dv plugin
211 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
212 Group:          Libraries
213 Requires:       gstreamer >= %{gst_ver}
214 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
215 Requires:       libdv >= 0.104
216
217 %description -n gstreamer-dv
218 Plugin for digital video support.
219
220 %description -n gstreamer-dv -l pl.UTF-8
221 Wtyczka do GStreamera obsługująca cyfrowy obraz.
222
223 %package -n gstreamer-flac
224 Summary:        GStreamer plugin for FLAC lossless audio format
225 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
226 Group:          Libraries
227 Requires:       flac >= 1.1.4
228 Requires:       gstreamer >= %{gst_ver}
229 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
230
231 %description -n gstreamer-flac
232 Plugin for the free FLAC lossless audio format.
233
234 %description -n gstreamer-flac -l pl.UTF-8
235 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
236
237 %package -n gstreamer-gdkpixbuf
238 Summary:        GStreamer images input plugin
239 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
240 Group:          Libraries
241 Requires:       gdk-pixbuf2 >= 2.8.0
242 Requires:       gstreamer >= %{gst_ver}
243 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
244
245 %description -n gstreamer-gdkpixbuf
246 This GStreamer plugin load images via gdkpixbuf library.
247
248 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
249 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
250 gdkpixbuf.
251
252 %package -n gstreamer-videosink-gtk
253 Summary:        GStreamer GTK+ (3.x) output plugin
254 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera
255 Group:          Libraries
256 Requires:       gstreamer >= %{gst_ver}
257 Requires:       gstreamer-gl-libs >= %{gstpb_ver}
258 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
259 Requires:       gtk+3 >= 3.15.0
260 Provides:       gstreamer-videosink = %{version}
261
262 %description -n gstreamer-videosink-gtk
263 GStreamer GTK+ (3.x) output plugin.
264
265 %description -n gstreamer-videosink-gtk -l pl.UTF-8
266 Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera.
267
268 %package -n gstreamer-jack
269 Summary:        GStreamer plugin for the JACK Sound Server
270 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
271 Group:          Libraries
272 Requires:       gstreamer >= %{gst_ver}
273 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
274 %{?with_jack1:Requires: jack-audio-connection-kit-libs >= 0.120.1}
275 %{!?with_jack1:Requires:        jack-audio-connection-kit-libs >= 1.9.7}
276 # for locales
277 Requires:       %{name} = %{version}-%{release}
278 Provides:       gstreamer-audiosink = %{version}
279
280 %description -n gstreamer-jack
281 Plugin for the JACK professional sound server.
282
283 %description -n gstreamer-jack -l pl.UTF-8
284 Wtyczka dla profesjonalnego serwera dźwięku JACK.
285
286 %package -n gstreamer-videosink-libcaca
287 Summary:        GStreamer plugin for libcaca Ascii-art output
288 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
289 Group:          Libraries
290 Requires:       gstreamer >= %{gst_ver}
291 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
292 Provides:       gstreamer-videosink = %{version}
293
294 %description -n gstreamer-videosink-libcaca
295 GStreamer plug-in for libcaca Ascii-art output.
296
297 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
298 Wtyczka libcaca do GStreamera.
299
300 %package -n gstreamer-lame
301 Summary:        GStreamer plugin encoding MP3 songs
302 Summary(pl.UTF-8):      Wtyczka do GStreamera kodująca pliki MP3
303 Group:          Libraries
304 # for NLS
305 Requires:       %{name} = %{version}-%{release}
306 Requires:       gstreamer >= %{gst_ver}
307 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
308 Requires:       twolame-libs >= 0.3.10
309
310 %description -n gstreamer-lame
311 Plugin for encoding MP3 with lame.
312
313 %description -n gstreamer-lame -l pl.UTF-8
314 Wtyczka do GStreamera kodująca pliki MP3 przy użyciu lame.
315
316 %package -n gstreamer-mpg123
317 Summary:        GStreamer mpg123 plugin
318 Summary(pl.UTF-8):      Wtyczka mpg123 do GStreamera
319 Group:          Libraries
320 Requires:       gstreamer >= %{gst_ver}
321 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
322 Requires:       libmpg123 >= 1.14
323 # plugin obsoleted in 1.12.0, functionality in mpg123 plugin (or libav)
324 Obsoletes:      gstreamer-mad < 1.12.0
325
326 %description -n gstreamer-mpg123
327 GStreamer mpg123 plugin for MP3 playback.
328
329 %description -n gstreamer-mpg123 -l pl.UTF-8
330 Wtyczka mpg123 do GStreamera, odtwarzająca MP3.
331
332 %package -n gstreamer-libpng
333 Summary:        GStreamer plugin to encode png images
334 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
335 Group:          Libraries
336 Requires:       gstreamer >= %{gst_ver}
337 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
338 # for locales
339 Requires:       %{name} = %{version}-%{release}
340 Requires:       libpng >= 2:1.5.1
341
342 %description -n gstreamer-libpng
343 Plugin for encoding png images.
344
345 %description -n gstreamer-libpng -l pl.UTF-8
346 Wtyczka kodująca pliki png.
347
348 %package -n gstreamer-audiosink-oss
349 Summary:        GStreamer plugins for input and output using OSS
350 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
351 Group:          Libraries
352 Requires:       gstreamer >= %{gst_ver}
353 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
354 # for locales
355 Requires:       %{name} = %{version}-%{release}
356 Provides:       gstreamer-audiosink = %{version}
357 Obsoletes:      gstreamer-oss < 0.10
358
359 %description -n gstreamer-audiosink-oss
360 Plugins for output and input to the OpenSoundSystem audio drivers
361 found in the Linux kernels or commercially available from OpenSound.
362
363 %description -n gstreamer-audiosink-oss -l pl.UTF-8
364 Wtyczki wyjścia i wejścia dźwięku używające sterowników
365 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
366 od OpenSound.
367
368 %package -n gstreamer-pulseaudio
369 Summary:        GStreamer plugin for PulseAudio sound server
370 Summary(pl.UTF-8):      Wtyczka GStreamera dla serwera dźwięku PulseAudio
371 Group:          Libraries
372 Requires:       gstreamer >= %{gst_ver}
373 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
374 Requires:       pulseaudio >= 2.0
375 # for locales
376 Requires:       %{name} = %{version}-%{release}
377 Provides:       gstreamer-audiosink = %{version}
378 Obsoletes:      gstreamer-audiosink-polypaudio < 0.10
379 Obsoletes:      gstreamer-polypaudio < 0.10
380
381 %description -n gstreamer-pulseaudio
382 GStreamer plugin for PulseAudio sound server.
383
384 %description -n gstreamer-pulseaudio -l pl.UTF-8
385 Wtyczka GStreamera dla serwera dźwięku PulseAudio.
386
387 %package -n gstreamer-videosink-qt
388 Summary:        GStreamer Qt (5.x) output plugin
389 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera
390 Group:          Libraries
391 Requires:       Qt5Core >= 5.4.0
392 Requires:       Qt5Gui >= 5.4.0
393 Requires:       Qt5Quick >= 5.4.0
394 Requires:       gstreamer >= %{gst_ver}
395 Requires:       gstreamer-gl-libs >= %{gstpb_ver}
396 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
397 Provides:       gstreamer-videosink = %{version}
398
399 %description -n gstreamer-videosink-qt
400 GStreamer Qt (5.x) output plugin.
401
402 %description -n gstreamer-videosink-qt -l pl.UTF-8
403 Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera.
404
405 %package -n gstreamer-raw1394
406 Summary:        GStreamer raw1394 Firewire plugin
407 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
408 Group:          Libraries
409 Requires:       gstreamer >= %{gst_ver}
410
411 %description -n gstreamer-raw1394
412 Plugin for digital video support using raw1394.
413
414 %description -n gstreamer-raw1394 -l pl.UTF-8
415 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
416
417 %package -n gstreamer-shout2
418 Summary:        GStreamer plugin for communicating with Shoutcast servers
419 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
420 Group:          Libraries
421 Requires:       gstreamer >= %{gst_ver}
422 # for locales
423 Requires:       %{name} = %{version}-%{release}
424
425 %description -n gstreamer-shout2
426 GStreamer plugin for communicating with Shoutcast servers.
427
428 %description -n gstreamer-shout2 -l pl.UTF-8
429 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
430
431 %package -n gstreamer-soup
432 Summary:        GStreamer Soup plugin
433 Summary(pl.UTF-8):      Wtyczka biblioteki Soup dla GStreamera
434 Group:          Libraries
435 Requires:       gstreamer >= %{gst_ver}
436 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
437 Requires:       libsoup >= 2.48
438 # for locales
439 Requires:       %{name} = %{version}-%{release}
440
441 %description -n gstreamer-soup
442 GStreamer Plugin for downloading files with Soup library.
443
444 %description -n gstreamer-soup -l pl.UTF-8
445 Wtyczka GStreamera umożliwiająca ściąganie plików za pomocą biblioteki
446 Soup.
447
448 %package -n gstreamer-speex
449 Summary:        GStreamer speex codec decoder/encoder plugin
450 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
451 Group:          Libraries
452 Requires:       gstreamer >= %{gst_ver}
453 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
454 Requires:       speex >= 1:1.1.6
455
456 %description -n gstreamer-speex
457 GStreamer speex codec decoder/encoder plugin.
458
459 %description -n gstreamer-speex -l pl.UTF-8
460 Wtyczka do GStreamera obsługująca kodek Speex.
461
462 %package -n gstreamer-taglib
463 Summary:        GStreamer tag writing plugin based on taglib
464 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
465 Group:          Libraries
466 Requires:       gstreamer >= %{gst_ver}
467 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
468 Requires:       taglib >= 1.5
469
470 %description -n gstreamer-taglib
471 GStreamer tag writing plugin based on taglib.
472
473 %description -n gstreamer-taglib -l pl.UTF-8
474 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
475
476 %package -n gstreamer-v4l2
477 Summary:        GStreamer Video4Linux2 input plugin
478 Summary(pl.UTF-8):      Wtyczka wejścia Video4Linux2 dla GStreamera
479 Group:          Libraries
480 Requires:       %{name} = %{version}-%{release}
481 Requires:       gstreamer >= %{gst_ver}
482 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
483 Requires:       udev-glib >= 1:147
484
485 %description -n gstreamer-v4l2
486 GStreamer plugin for accessing Video4Linux2 devices.
487
488 %description -n gstreamer-v4l2 -l pl.UTF-8
489 Wtyczka GStreamera pozwalająca na dostęp do urządzeń Video4Linux2.
490
491 %package -n gstreamer-video-effects
492 Summary:        GStreamer video effects plugins
493 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
494 Group:          Libraries
495 Requires:       gstreamer >= %{gst_ver}
496 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
497 # for locales in jpeg module
498 Requires:       %{name} = %{version}-%{release}
499
500 %description -n gstreamer-video-effects
501 GStreamer video effects plugins.
502
503 %description -n gstreamer-video-effects -l pl.UTF-8
504 Wtyczki efektów wideo do GStreamera.
505
506 %package -n gstreamer-visualisation
507 Summary:        GStreamer visualisations plugins
508 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
509 Group:          Libraries
510 Requires:       gstreamer >= %{gst_ver}
511 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
512
513 %description -n gstreamer-visualisation
514 Various plugins for visual effects to use with audio. Included are
515 monoscope, spectrum, goom (2k4) and goom2k1.
516
517 %description -n gstreamer-visualisation -l pl.UTF-8
518 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
519 monoscope, spectrum, goom (2k4) i goom2k1.
520
521 %package -n gstreamer-vpx
522 Summary:        GStreamer plugin for VP8/VP9 video format
523 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca format obrazu VP8/VP9
524 Group:          Libraries
525 Requires:       gstreamer >= %{gst_ver}
526 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
527 Requires:       libvpx >= 1.8.0
528 Obsoletes:      gstreamer-vp8 < 1.0
529
530 %description -n gstreamer-vpx
531 GStreamer plugin for VP8/VP9 video format using libvpx library.
532
533 %description -n gstreamer-vpx -l pl.UTF-8
534 Wtyczka do GStreamera obsługująca format obrazu VP8/VP9 przy użyciu
535 biblioteki libvpx.
536
537 %package -n gstreamer-wavpack
538 Summary:        GStreamer plugin for Wavpack lossless audio format
539 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
540 Group:          Libraries
541 Requires:       gstreamer >= %{gst_ver}
542 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
543 Requires:       wavpack-libs >= 4.60.0
544
545 %description -n gstreamer-wavpack
546 Plugin for lossless Wavpack audio format.
547
548 %description -n gstreamer-wavpack -l pl.UTF-8
549 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
550
551 %package -n gstreamer-ximagesrc
552 Summary:        GStreamer X11 video input plugin using standard Xlib calls
553 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
554 Group:          Libraries
555 Requires:       %{name} = %{version}-%{release}
556 Requires:       gstreamer >= %{gst_ver}
557 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
558
559 %description -n gstreamer-ximagesrc
560 GStreamer X11 video input plugin using standard Xlib calls.
561
562 %description -n gstreamer-ximagesrc -l pl.UTF-8
563 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
564 Xlib.
565
566 %prep
567 %setup -q -n %{gstname}-%{version}
568
569 %build
570 %{__libtoolize}
571 %{__aclocal} -I m4 -I common/m4
572 %{__autoconf}
573 %{__autoheader}
574 %{__automake}
575 %configure \
576         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
577         --disable-silent-rules \
578         --disable-static \
579         --enable-experimental \
580         %{!?with_aalib:--disable-aalib} \
581         %{!?with_cairo:--disable-cairo} \
582         %{!?with_gtk:--disable-gtk} \
583         %{!?with_jack:--disable-jack} \
584         %{!?with_lame:--disable-lame --disable-twolame} \
585         %{!?with_caca:--disable-libcaca} \
586         %{!?with_mpg123:--disable-mpg123} \
587         %{!?with_qt:--disable-qt} \
588         %{!?with_soup:--disable-soup} \
589         %{!?with_speex:--disable-speex} \
590         %{!?with_wavpack:--disable-wavpack} \
591         --enable-gtk-doc%{!?with_apidocs:=no} \
592         --enable-orc \
593         --with-html-dir=%{_gtkdocdir}
594
595 LC_ALL=C.UTF-8 \
596 %{__make}
597
598 %install
599 rm -rf $RPM_BUILD_ROOT
600
601 %{__make} install \
602         DESTDIR=$RPM_BUILD_ROOT
603
604 # We don't need plugins' *.la files
605 %{__rm} $RPM_BUILD_ROOT%{gstlibdir}/*.la
606
607 %find_lang %{gstname}-%{gstmver}
608
609 %clean
610 rm -rf $RPM_BUILD_ROOT
611
612 %files -f %{gstname}-%{gstmver}.lang
613 %defattr(644,root,root,755)
614 %doc AUTHORS ChangeLog NEWS README RELEASE
615 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
616 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
617 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
618 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
619 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
620 %attr(755,root,root) %{gstlibdir}/libgstavi.so
621 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
622 %attr(755,root,root) %{gstlibdir}/libgstdtmf.so
623 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
624 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
625 %attr(755,root,root) %{gstlibdir}/libgstflv.so
626 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
627 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
628 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
629 %attr(755,root,root) %{gstlibdir}/libgstimagefreeze.so
630 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
631 %attr(755,root,root) %{gstlibdir}/libgstisomp4.so
632 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
633 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
634 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
635 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
636 %attr(755,root,root) %{gstlibdir}/libgstoss4.so
637 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
638 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
639 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
640 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
641 %attr(755,root,root) %{gstlibdir}/libgstshapewipe.so
642 %attr(755,root,root) %{gstlibdir}/libgstudp.so
643 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
644 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
645 %attr(755,root,root) %{gstlibdir}/libgstvideofilter.so
646 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
647 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
648 %dir %{_datadir}/gstreamer-%{gstmver}
649 %{_datadir}/gstreamer-%{gstmver}/presets
650
651 %if %{with apidocs}
652 %files apidocs
653 %defattr(644,root,root,755)
654 %{_gtkdocdir}/gst-plugins-good-plugins-%{gstmver}
655 %endif
656
657 ##
658 ## Plugins
659 ##
660
661 %if %{with aalib}
662 %files -n gstreamer-videosink-aa
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
665 %endif
666
667 %files -n gstreamer-audio-effects-good
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
670 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
671 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
672 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
673
674 %files -n gstreamer-audio-formats
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
677 %attr(755,root,root) %{gstlibdir}/libgstaudioparsers.so
678 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
679 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
680
681 %if %{with cairo}
682 %files -n gstreamer-cairo
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
685 %endif
686
687 %files -n gstreamer-dv
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{gstlibdir}/libgstdv.so
690
691 %files -n gstreamer-flac
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{gstlibdir}/libgstflac.so
694
695 %files -n gstreamer-gdkpixbuf
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
698
699 %if %{with gtk}
700 %files -n gstreamer-videosink-gtk
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{gstlibdir}/libgstgtk.so
703 %endif
704
705 %if %{with jack}
706 %files -n gstreamer-jack
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{gstlibdir}/libgstjack.so
709 %endif
710
711 %if %{with caca}
712 %files -n gstreamer-videosink-libcaca
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
715 %endif
716
717 %files -n gstreamer-lame
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{gstlibdir}/libgstlame.so
720 %attr(755,root,root) %{gstlibdir}/libgsttwolame.so
721
722 %if %{with mpg123}
723 %files -n gstreamer-mpg123
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{gstlibdir}/libgstmpg123.so
726 %endif
727
728 %files -n gstreamer-libpng
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{gstlibdir}/libgstpng.so
731
732 %files -n gstreamer-audiosink-oss
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
735
736 %files -n gstreamer-pulseaudio
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{gstlibdir}/libgstpulseaudio.so
739
740 %if %{with qt}
741 %files -n gstreamer-videosink-qt
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{gstlibdir}/libgstqmlgl.so
744 %endif
745
746 %files -n gstreamer-raw1394
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{gstlibdir}/libgst1394.so
749
750 %files -n gstreamer-shout2
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
753
754 %if %{with soup}
755 %files -n gstreamer-soup
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{gstlibdir}/libgstsoup.so
758 %endif
759
760 %if %{with speex}
761 %files -n gstreamer-speex
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
764 %endif
765
766 %files -n gstreamer-taglib
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
769
770 %files -n gstreamer-v4l2
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
773
774 %files -n gstreamer-video-effects
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
777 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
778 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
779
780 %files -n gstreamer-visualisation
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
783 %attr(755,root,root) %{gstlibdir}/libgstgoom2k1.so
784 %attr(755,root,root) %{gstlibdir}/libgstmonoscope.so
785 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
786
787 %files -n gstreamer-vpx
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{gstlibdir}/libgstvpx.so
790
791 %if %{with wavpack}
792 %files -n gstreamer-wavpack
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
795 %endif
796
797 %files -n gstreamer-ximagesrc
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.623533 seconds and 4 git commands to generate.