]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- rel.2
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  cdio            # don't build cdio plugin
7 %bcond_without  gconf           # don't build GConf plugin
8 %bcond_without  ladspa          # don't build ladspa plugin
9 %bcond_without  speex           # don't build speex plugin
10 #
11 %define         gstname         gst-plugins-good
12 %define         gst_major_ver   0.10
13 %define         gst_req_ver     0.10.2.2
14 #
15 Summary:        Good GStreamer Streaming-media framework plugins
16 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
17 Name:           gstreamer-plugins-good
18 Version:        0.10.2
19 Release:        2
20 License:        LGPL
21 Group:          Libraries
22 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
23 # Source0-md5:  03d3d0b5f19014fe0065234a3ea65ee6
24 Patch0:         %{name}-bashish.patch
25 Patch1:         %{name}-libcaca.patch
26 URL:            http://gstreamer.freedesktop.org/
27 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.0}
28 BuildRequires:  autoconf >= 2.52
29 BuildRequires:  automake >= 1.5
30 BuildRequires:  glib2-devel >= 1:2.6.0
31 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
32 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
33 BuildRequires:  gtk-doc >= 1.3
34 BuildRequires:  gtk+2-devel >= 2:2.2.0
35 BuildRequires:  liboil-devel >= 0.3.2
36 BuildRequires:  libtool >= 1.4
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 ##
39 ## plugins
40 ##
41 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
42 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0.0}
43 BuildRequires:  esound-devel >= 0.2.12
44 BuildRequires:  flac-devel >= 1.1.2
45 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
46 BuildRequires:  libavc1394-devel
47 %{?with_caca:BuildRequires:     libcaca-devel}
48 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
49 BuildRequires:  libdv-devel >= 0.104
50 BuildRequires:  libjpeg-devel
51 BuildRequires:  libpng-devel >= 1.2.0
52 BuildRequires:  libraw1394-devel
53 BuildRequires:  libshout-devel >= 2.0
54 BuildRequires:  rpmbuild(macros) >= 1.198
55 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
56 BuildRequires:  zlib-devel
57 Requires:       gstreamer >= %{gst_req_ver}
58 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
59 Obsoletes:      gstreamer-avi
60 Obsoletes:      gstreamer-flx
61 Obsoletes:      gstreamer-matroska
62 Obsoletes:      gstreamer-mixer
63 Obsoletes:      gstreamer-navigation
64 Obsoletes:      gstreamer-rtp
65 Obsoletes:      gstreamer-udp
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
69
70 %description
71 GStreamer is a streaming-media framework, based on graphs of filters
72 which operate on media data. Applications using this library can do
73 anything from real-time sound processing to playing videos, and just
74 about anything else media-related. Its plugin-based architecture means
75 that new data types or processing capabilities can be added simply by
76 installing new plugins.
77
78 %description -l pl
79 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
80 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
81 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
82 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
83 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
84 nowych typów danych lub mo¿liwo¶ci obróbki.
85
86 %package -n gstreamer-GConf
87 Summary:        GStreamer GConf schemas
88 Summary(pl):    Schematy GConf GStreamera
89 Group:          Libraries
90 Requires(post,preun):   GConf2
91 Requires:       gstreamer >= %{gst_req_ver}
92 Obsoletes:      gstreamer-GConf-devel
93
94 %description -n gstreamer-GConf
95 Installation of GStreamer GConf schemas. These set usable defaults
96 used by all GStreamer-enabled GNOME applications.
97
98 %description -n gstreamer-GConf -l pl
99 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
100 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
101
102 ##
103 ## Plugins
104 ##
105
106 %package -n gstreamer-videosink-aa
107 Summary:        GStreamer plugin for Ascii-art output
108 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
109 Group:          Libraries
110 Requires:       gstreamer >= %{gst_req_ver}
111 Provides:       gstreamer-videosink = %{version}
112 Obsoletes:      gstreamer-aalib
113
114 %description -n gstreamer-videosink-aa
115 Plugin for viewing movies in Ascii-art using aalib library.
116
117 %description -n gstreamer-videosink-aa -l pl
118 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
119
120 %package -n gstreamer-audio-effects-good
121 Summary:        Good GStreamer audio effects plugins
122 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
123 Group:          Libraries
124 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
125 Obsoletes:      gstreamer-audio-effects
126
127 %description -n gstreamer-audio-effects-good
128 Good GStreamer audio effects plugins.
129
130 %description -n gstreamer-audio-effects-good -l pl
131 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
132
133 %package -n gstreamer-audio-formats
134 Summary:        GStreamer audio format plugins
135 Summary(pl):    Wtyczki formatów d¼wiêku
136 Group:          Libraries
137 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
138 # for locales in wavparse module
139 Requires:       %{name} = %{version}-%{release}
140
141 %description -n gstreamer-audio-formats
142 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
143
144 %description -n gstreamer-audio-formats -l pl
145 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
146
147 %package -n gstreamer-cairo
148 Summary:        GStreamer cairo plugin
149 Summary(pl):    Wtyczka cairo do GStreamera
150 Group:          Libraries
151 Requires:       gstreamer >= %{gst_req_ver}
152
153 %description -n gstreamer-cairo
154 GStreamer cairo plugin.
155
156 %description -n gstreamer-cairo -l pl
157 Wtyczka cairo do GStreamera.
158
159 %package -n gstreamer-cdio
160 Summary:        GStreamer plugin for CD audio input using libcdio
161 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdio
162 Group:          Libraries
163 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
164 Requires:       libcdio >= 0.71
165
166 %description -n gstreamer-cdio
167 Plugin for playing audio tracks using libcdio under GStreamer.
168
169 %description -n gstreamer-cdio -l pl
170 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
171 libcdio.
172
173 %package -n gstreamer-dv
174 Summary:        GStreamer dv plugin
175 Summary(pl):    Wtyczka dv do GStreamera
176 Group:          Libraries
177 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
178
179 %description -n gstreamer-dv
180 Plugin for digital video support.
181
182 %description -n gstreamer-dv -l pl
183 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
184
185 %package -n gstreamer-audiosink-esd
186 Summary:        GStreamer plugin for ESD sound output
187 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
188 Group:          Libraries
189 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
190 Provides:       gstreamer-audiosink = %{version}
191 Obsoletes:      gstreamer-esound
192
193 %description -n gstreamer-audiosink-esd
194 Output plugin for GStreamer for use with the esound package.
195
196 %description -n gstreamer-audiosink-esd -l pl
197 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
198
199 %package -n gstreamer-flac
200 Summary:        GStreamer plugin for FLAC lossless audio format
201 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
202 Group:          Libraries
203 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
204
205 %description -n gstreamer-flac
206 Plugin for the free FLAC lossless audio format.
207
208 %description -n gstreamer-flac -l pl
209 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
210
211 %package -n gstreamer-ladspa
212 Summary:        GStreamer wrapper for LADSPA plugins
213 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
214 Group:          Libraries
215 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
216
217 %description -n gstreamer-ladspa
218 Plugin which wraps LADSPA plugins for use by GStreamer applications.
219
220 %description -n gstreamer-ladspa -l pl
221 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
222 GStreamera.
223
224 %package -n gstreamer-videosink-libcaca
225 Summary:        GStreamer plugin for libcaca Ascii-art output
226 Summary(pl):    Wtyczka libcaca do GStreamera
227 Group:          Libraries
228 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
229 Provides:       gstreamer-videosink = %{version}
230
231 %description -n gstreamer-videosink-libcaca
232 GStreamer plug-in for libcaca Ascii-art output.
233
234 %description -n gstreamer-videosink-libcaca -l pl
235 Wtyczka libcaca do GStreamera.
236
237 %package -n gstreamer-libpng
238 Summary:        GStreamer plugin to encode png images
239 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
240 Group:          Libraries
241 #Requires:      gstreamer >= %{gst_req_ver}
242 # for locales
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       libpng >= 1.2.0
245
246 %description -n gstreamer-libpng
247 Plugin for encoding png images.
248
249 %description -n gstreamer-libpng -l pl
250 Wtyczka koduj±ca pliki png.
251
252 %package -n gstreamer-audiosink-oss
253 Summary:        GStreamer plugins for input and output using OSS
254 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
255 Group:          Libraries
256 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
257 # for locales
258 Requires:       %{name} = %{version}-%{release}
259 Provides:       gstreamer-audiosink = %{version}
260 Obsoletes:      gstreamer-oss
261
262 %description -n gstreamer-audiosink-oss
263 Plugins for output and input to the OpenSoundSystem audio drivers
264 found in the Linux kernels or commercially available from OpenSound.
265
266 %description -n gstreamer-audiosink-oss -l pl
267 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
268 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
269 od OpenSound.
270
271 %package -n gstreamer-raw1394
272 Summary:        GStreamer raw1394 Firewire plugin
273 Summary(pl):    Wtyczka FireWire dla GStreamera
274 Group:          Libraries
275 Requires:       gstreamer >= %{gst_req_ver}
276
277 %description -n gstreamer-raw1394
278 Plugin for digital video support using raw1394.
279
280 %description -n gstreamer-raw1394 -l pl
281 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
282
283 %package -n gstreamer-shout2
284 Summary:        GStreamer plugin for communicating with Shoutcast servers
285 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
286 Group:          Libraries
287 Requires:       gstreamer >= %{gst_req_ver}
288
289 %description -n gstreamer-shout2
290 GStreamer plugin for communicating with Shoutcast servers.
291
292 %description -n gstreamer-shout2 -l pl
293 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
294
295 %package -n gstreamer-speex
296 Summary:        GStreamer speex codec decoder/encoder plugin
297 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
298 Group:          Libraries
299 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
300 Requires:       speex >= 1:1.1.6
301
302 %description -n gstreamer-speex
303 GStreamer speex codec decoder/encoder plugin.
304
305 %description -n gstreamer-speex -l pl
306 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
307
308 %package -n gstreamer-video-effects
309 Summary:        GStreamer video effects plugins
310 Summary(pl):    Wtyczki efektów wideo do GStreamera
311 Group:          Libraries
312 # for locales in jpeg module
313 Requires:       %{name} = %{version}-%{release}
314
315 %description -n gstreamer-video-effects
316 GStreamer video effects plugins.
317
318 %description -n gstreamer-video-effects -l pl
319 Wtyczki efektów wideo do GStreamera.
320
321 %package -n gstreamer-visualisation
322 Summary:        GStreamer visualisations plugins
323 Summary(pl):    Wtyczki wizualizacji do GStreamera
324 Group:          Libraries
325 Requires:       gstreamer >= %{gst_req_ver}
326
327 %description -n gstreamer-visualisation
328 Various plugins for visual effects to use with audio. Included are
329 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
330
331 %description -n gstreamer-visualisation -l pl
332 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
333 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
334
335 %prep
336 %setup -q -n %{gstname}-%{version}
337 %patch0 -p1
338 %patch1 -p1
339
340 %build
341 %{__libtoolize}
342 %{__aclocal} -I m4 -I common/m4
343 %{__autoconf}
344 %{__autoheader}
345 %{__automake}
346 %configure \
347         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
348         %{!?with_aalib:--disable-aalib} \
349         %{!?with_caca:--disable-libcaca} \
350         %{!?with_cairo:--disable-cairo} \
351         %{!?with_cdio:--disable-cdio} \
352         %{!?with_ladspa:--disable-ladspa} \
353         %{!?with_speex:--disable-speex} \
354         --disable-static \
355         --enable-gtk-doc \
356         --with-html-dir=%{_gtkdocdir}
357
358 %{__make}
359
360 %install
361 rm -rf $RPM_BUILD_ROOT
362
363 %{__make} install \
364         DESTDIR=$RPM_BUILD_ROOT
365
366 # We don't need plugins' *.la files
367 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
368
369 %find_lang %{gstname}-%{gst_major_ver}
370
371 %clean
372 rm -rf $RPM_BUILD_ROOT
373
374 %post   -n gstreamer-GConf
375 %gconf_schema_install gstreamer-0.10.schemas
376
377 %preun  -n gstreamer-GConf
378 %gconf_schema_uninstall gstreamer-0.10.schemas
379
380 %files -f %{gstname}-%{gst_major_ver}.lang
381 %defattr(644,root,root,755)
382 %doc AUTHORS ChangeLog NEWS README RELEASE 
383 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
384 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
385 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
386 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
387 %attr(755,root,root) %{gstlibdir}/libgstavi.so
388 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
389 %attr(755,root,root) %{gstlibdir}/libgstefence.so
390 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
391 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
392 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
393 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
394 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
395 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
396 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
397 %attr(755,root,root) %{gstlibdir}/libgstudp.so
398 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
399 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
400 %{_gtkdocdir}/gst-plugins-good-plugins-*
401
402 %if %{with gconf}
403 %files -n gstreamer-GConf
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
406 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
407 %endif
408
409 ##
410 ## Plugins
411 ##
412
413 %if %{with aalib}
414 %files -n gstreamer-videosink-aa
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
417 %endif
418
419 %files -n gstreamer-audio-effects-good
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
422 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
423 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
424 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
425
426 %files -n gstreamer-audio-formats
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
429 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
430 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
431
432 %if %{with cairo}
433 %files -n gstreamer-cairo
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
436 %endif
437
438 %if %{with cdio}
439 %files -n gstreamer-cdio
440 %defattr(644,root,root,755)
441 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
442 %endif
443
444 %files -n gstreamer-dv
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{gstlibdir}/libgstdv.so
447
448 %files -n gstreamer-audiosink-esd
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{gstlibdir}/libgstesd.so
451
452 %files -n gstreamer-flac
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{gstlibdir}/libgstflac.so
455
456 #%if %{with ladspa}
457 #%files -n gstreamer-ladspa
458 #%defattr(644,root,root,755)
459 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
460 #%endif
461
462 %if %{with caca}
463 %files -n gstreamer-videosink-libcaca
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
466 %endif
467
468 %files -n gstreamer-libpng
469 %defattr(644,root,root,755)
470 %attr(755,root,root) %{gstlibdir}/libgstpng.so
471
472 %files -n gstreamer-audiosink-oss
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
475
476 %files -n gstreamer-raw1394
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{gstlibdir}/libgst1394.so
479
480 %files -n gstreamer-shout2
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
483
484 %if %{with speex}
485 %files -n gstreamer-speex
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
488 %endif
489
490 %files -n gstreamer-video-effects
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
493 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
494 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
495 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
496
497 %files -n gstreamer-visualisation
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
This page took 0.117736 seconds and 4 git commands to generate.