]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- updated to 0.10.3
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  cdio            # don't build cdio plugin
7 %bcond_without  gconf           # don't build GConf plugin
8 %bcond_without  ladspa          # don't build ladspa plugin
9 %bcond_without  speex           # don't build speex plugin
10 #
11 %define         gstname         gst-plugins-good
12 %define         gst_major_ver   0.10
13 %define         gst_req_ver     0.10.4.1
14 %define         gstpb_req_ver   0.10.5.1
15 #
16 Summary:        Good GStreamer Streaming-media framework plugins
17 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
18 Name:           gstreamer-plugins-good
19 Version:        0.10.3
20 Release:        1
21 License:        LGPL
22 Group:          Libraries
23 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
24 # Source0-md5:  a58bb825bd4b22412764f2a8d2f98b1c
25 Patch0:         %{name}-bashish.patch
26 Patch1:         %{name}-libcaca.patch
27 URL:            http://gstreamer.freedesktop.org/
28 BuildRequires:  autoconf >= 2.59-9
29 BuildRequires:  automake >= 1.5
30 BuildRequires:  glib2-devel >= 1:2.6.0
31 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
32 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
33 BuildRequires:  gtk-doc >= 1.3
34 BuildRequires:  gtk+2-devel >= 2:2.2.0
35 BuildRequires:  liboil-devel >= 0.3.2
36 BuildRequires:  libtool >= 1.4
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 ##
39 ## plugins
40 ##
41 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.0}
42 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
43 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0.0}
44 BuildRequires:  dbus-devel >= 0.32
45 BuildRequires:  esound-devel >= 0.2.12
46 BuildRequires:  flac-devel >= 1.1.2
47 BuildRequires:  hal-devel >= 0.5.6
48 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
49 BuildRequires:  libavc1394-devel
50 %{?with_caca:BuildRequires:     libcaca-devel}
51 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
52 BuildRequires:  libdv-devel >= 0.104
53 BuildRequires:  libjpeg-devel
54 BuildRequires:  libpng-devel >= 1.2.0
55 BuildRequires:  libraw1394-devel
56 BuildRequires:  libshout-devel >= 2.0
57 # for taglib
58 BuildRequires:  libstdc++-devel
59 BuildRequires:  libxml2-devel >= 2.4.9
60 BuildRequires:  rpmbuild(macros) >= 1.198
61 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
62 BuildRequires:  taglib-devel >= 1.4
63 BuildRequires:  xorg-lib-libX11-devel
64 BuildRequires:  xorg-lib-libXdamage-devel
65 BuildRequires:  xorg-lib-libXext-devel
66 BuildRequires:  xorg-lib-libXfixes-devel
67 BuildRequires:  zlib-devel
68 Requires:       gstreamer >= %{gst_req_ver}
69 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
70 Obsoletes:      gstreamer-avi
71 Obsoletes:      gstreamer-flx
72 Obsoletes:      gstreamer-matroska
73 Obsoletes:      gstreamer-mixer
74 Obsoletes:      gstreamer-navigation
75 Obsoletes:      gstreamer-rtp
76 Obsoletes:      gstreamer-udp
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
80
81 %description
82 GStreamer is a streaming-media framework, based on graphs of filters
83 which operate on media data. Applications using this library can do
84 anything from real-time sound processing to playing videos, and just
85 about anything else media-related. Its plugin-based architecture means
86 that new data types or processing capabilities can be added simply by
87 installing new plugins.
88
89 %description -l pl
90 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
91 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
92 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
93 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
94 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
95 nowych typów danych lub mo¿liwo¶ci obróbki.
96
97 %package -n gstreamer-GConf
98 Summary:        GStreamer GConf schemas
99 Summary(pl):    Schematy GConf GStreamera
100 Group:          Libraries
101 Requires(post,preun):   GConf2
102 Requires:       gstreamer >= %{gst_req_ver}
103 Obsoletes:      gstreamer-GConf-devel
104
105 %description -n gstreamer-GConf
106 Installation of GStreamer GConf schemas. These set usable defaults
107 used by all GStreamer-enabled GNOME applications.
108
109 %description -n gstreamer-GConf -l pl
110 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
111 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
112
113 ##
114 ## Plugins
115 ##
116
117 %package -n gstreamer-videosink-aa
118 Summary:        GStreamer plugin for Ascii-art output
119 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
120 Group:          Libraries
121 Requires:       gstreamer >= %{gst_req_ver}
122 Provides:       gstreamer-videosink = %{version}
123 Obsoletes:      gstreamer-aalib
124
125 %description -n gstreamer-videosink-aa
126 Plugin for viewing movies in Ascii-art using aalib library.
127
128 %description -n gstreamer-videosink-aa -l pl
129 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
130
131 %package -n gstreamer-audio-effects-good
132 Summary:        Good GStreamer audio effects plugins
133 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
134 Group:          Libraries
135 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
136 Obsoletes:      gstreamer-audio-effects
137
138 %description -n gstreamer-audio-effects-good
139 Good GStreamer audio effects plugins.
140
141 %description -n gstreamer-audio-effects-good -l pl
142 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
143
144 %package -n gstreamer-audio-formats
145 Summary:        GStreamer audio format plugins
146 Summary(pl):    Wtyczki formatów d¼wiêku
147 Group:          Libraries
148 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
149 # for locales in wavparse module
150 Requires:       %{name} = %{version}-%{release}
151
152 %description -n gstreamer-audio-formats
153 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
154
155 %description -n gstreamer-audio-formats -l pl
156 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
157
158 %package -n gstreamer-cairo
159 Summary:        GStreamer cairo plugin
160 Summary(pl):    Wtyczka cairo do GStreamera
161 Group:          Libraries
162 Requires:       gstreamer >= %{gst_req_ver}
163
164 %description -n gstreamer-cairo
165 GStreamer cairo plugin.
166
167 %description -n gstreamer-cairo -l pl
168 Wtyczka cairo do GStreamera.
169
170 %package -n gstreamer-cdio
171 Summary:        GStreamer plugin for CD audio input using libcdio
172 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdio
173 Group:          Libraries
174 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
175 Requires:       libcdio >= 0.71
176
177 %description -n gstreamer-cdio
178 Plugin for playing audio tracks using libcdio under GStreamer.
179
180 %description -n gstreamer-cdio -l pl
181 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
182 libcdio.
183
184 %package -n gstreamer-dv
185 Summary:        GStreamer dv plugin
186 Summary(pl):    Wtyczka dv do GStreamera
187 Group:          Libraries
188 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
189
190 %description -n gstreamer-dv
191 Plugin for digital video support.
192
193 %description -n gstreamer-dv -l pl
194 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
195
196 %package -n gstreamer-audiosink-esd
197 Summary:        GStreamer plugin for ESD sound output
198 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
199 Group:          Libraries
200 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
201 Provides:       gstreamer-audiosink = %{version}
202 Obsoletes:      gstreamer-esound
203
204 %description -n gstreamer-audiosink-esd
205 Output plugin for GStreamer for use with the esound package.
206
207 %description -n gstreamer-audiosink-esd -l pl
208 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
209
210 %package -n gstreamer-flac
211 Summary:        GStreamer plugin for FLAC lossless audio format
212 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
213 Group:          Libraries
214 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
215
216 %description -n gstreamer-flac
217 Plugin for the free FLAC lossless audio format.
218
219 %description -n gstreamer-flac -l pl
220 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
221
222 %package -n gstreamer-gdkpixbuf
223 Summary:        GStreamer images input plugin
224 Summary(pl):    Wtyczka do GStreamera wczytuj±ca obrazki
225 Group:          Libraries
226 Requires:       gstreamer >= %{gst_req_ver}
227
228 %description -n gstreamer-gdkpixbuf
229 This GStreamer plugin load images via gdkpixbuf library.
230
231 %description -n gstreamer-gdkpixbuf -l pl
232 Ta wtyczka GStreamera wczytuje obrazki za po¶rednictwem biblioteki
233 gdkpixbuf.
234
235 %package -n gstreamer-hal
236 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
237 Summary(pl):    Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku z HAL-em
238 Group:          Libraries
239 Requires:       gstreamer >= %{gst_req_ver}
240
241 %description -n gstreamer-hal
242 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
243
244 %description -n gstreamer-hal -l pl
245 Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku miêdzy
246 GStreamerem a HAL-em.
247
248 %package -n gstreamer-ladspa
249 Summary:        GStreamer wrapper for LADSPA plugins
250 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
251 Group:          Libraries
252 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
253
254 %description -n gstreamer-ladspa
255 Plugin which wraps LADSPA plugins for use by GStreamer applications.
256
257 %description -n gstreamer-ladspa -l pl
258 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
259 GStreamera.
260
261 %package -n gstreamer-videosink-libcaca
262 Summary:        GStreamer plugin for libcaca Ascii-art output
263 Summary(pl):    Wtyczka libcaca do GStreamera
264 Group:          Libraries
265 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
266 Provides:       gstreamer-videosink = %{version}
267
268 %description -n gstreamer-videosink-libcaca
269 GStreamer plug-in for libcaca Ascii-art output.
270
271 %description -n gstreamer-videosink-libcaca -l pl
272 Wtyczka libcaca do GStreamera.
273
274 %package -n gstreamer-libpng
275 Summary:        GStreamer plugin to encode png images
276 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
277 Group:          Libraries
278 #Requires:      gstreamer >= %{gst_req_ver}
279 # for locales
280 Requires:       %{name} = %{version}-%{release}
281 Requires:       libpng >= 1.2.0
282
283 %description -n gstreamer-libpng
284 Plugin for encoding png images.
285
286 %description -n gstreamer-libpng -l pl
287 Wtyczka koduj±ca pliki png.
288
289 %package -n gstreamer-audiosink-oss
290 Summary:        GStreamer plugins for input and output using OSS
291 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
292 Group:          Libraries
293 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
294 # for locales
295 Requires:       %{name} = %{version}-%{release}
296 Provides:       gstreamer-audiosink = %{version}
297 Obsoletes:      gstreamer-oss
298
299 %description -n gstreamer-audiosink-oss
300 Plugins for output and input to the OpenSoundSystem audio drivers
301 found in the Linux kernels or commercially available from OpenSound.
302
303 %description -n gstreamer-audiosink-oss -l pl
304 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
305 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
306 od OpenSound.
307
308 %package -n gstreamer-raw1394
309 Summary:        GStreamer raw1394 Firewire plugin
310 Summary(pl):    Wtyczka FireWire dla GStreamera
311 Group:          Libraries
312 Requires:       gstreamer >= %{gst_req_ver}
313
314 %description -n gstreamer-raw1394
315 Plugin for digital video support using raw1394.
316
317 %description -n gstreamer-raw1394 -l pl
318 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
319
320 %package -n gstreamer-shout2
321 Summary:        GStreamer plugin for communicating with Shoutcast servers
322 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
323 Group:          Libraries
324 Requires:       gstreamer >= %{gst_req_ver}
325
326 %description -n gstreamer-shout2
327 GStreamer plugin for communicating with Shoutcast servers.
328
329 %description -n gstreamer-shout2 -l pl
330 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
331
332 %package -n gstreamer-speex
333 Summary:        GStreamer speex codec decoder/encoder plugin
334 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
335 Group:          Libraries
336 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
337 Requires:       speex >= 1:1.1.6
338
339 %description -n gstreamer-speex
340 GStreamer speex codec decoder/encoder plugin.
341
342 %description -n gstreamer-speex -l pl
343 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
344
345 %package -n gstreamer-taglib
346 Summary:        GStreamer tag writing plugin based on taglib
347 Summary(pl):    Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib
348 Group:          Libraries
349 Requires:       gstreamer >= %{gst_req_ver}
350
351 %description -n gstreamer-taglib
352 GStreamer tag writing plugin based on taglib.
353
354 %description -n gstreamer-taglib -l pl
355 Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib.
356
357 %package -n gstreamer-video-effects
358 Summary:        GStreamer video effects plugins
359 Summary(pl):    Wtyczki efektów wideo do GStreamera
360 Group:          Libraries
361 # for locales in jpeg module
362 Requires:       %{name} = %{version}-%{release}
363
364 %description -n gstreamer-video-effects
365 GStreamer video effects plugins.
366
367 %description -n gstreamer-video-effects -l pl
368 Wtyczki efektów wideo do GStreamera.
369
370 %package -n gstreamer-visualisation
371 Summary:        GStreamer visualisations plugins
372 Summary(pl):    Wtyczki wizualizacji do GStreamera
373 Group:          Libraries
374 Requires:       gstreamer >= %{gst_req_ver}
375
376 %description -n gstreamer-visualisation
377 Various plugins for visual effects to use with audio. Included are
378 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
379
380 %description -n gstreamer-visualisation -l pl
381 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
382 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
383
384 %package -n gstreamer-ximagesrc
385 Summary:        GStreamer X11 video input plugin using standard Xlib calls
386 Summary(pl):    Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ Xlib
387 Group:          Libraries
388 Requires:       %{name} = %{version}-%{release}
389
390 %description -n gstreamer-ximagesrc
391 GStreamer X11 video input plugin using standard Xlib calls.
392
393 %description -n gstreamer-ximagesrc -l pl
394 Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ
395 Xlib.
396
397 %prep
398 %setup -q -n %{gstname}-%{version}
399 %patch0 -p1
400 %patch1 -p1
401
402 %build
403 %{__libtoolize}
404 %{__aclocal} -I m4 -I common/m4
405 %{__autoconf}
406 %{__autoheader}
407 %{__automake}
408 %configure \
409         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
410         %{!?with_aalib:--disable-aalib} \
411         %{!?with_caca:--disable-libcaca} \
412         %{!?with_cairo:--disable-cairo} \
413         %{!?with_cdio:--disable-cdio} \
414         %{!?with_ladspa:--disable-ladspa} \
415         %{!?with_speex:--disable-speex} \
416         --disable-static \
417         --enable-gtk-doc \
418         --with-html-dir=%{_gtkdocdir}
419
420 %{__make}
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424
425 %{__make} install \
426         DESTDIR=$RPM_BUILD_ROOT
427
428 # We don't need plugins' *.la files
429 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
430
431 %find_lang %{gstname}-%{gst_major_ver}
432
433 %clean
434 rm -rf $RPM_BUILD_ROOT
435
436 %post   -n gstreamer-GConf
437 %gconf_schema_install gstreamer-0.10.schemas
438
439 %preun  -n gstreamer-GConf
440 %gconf_schema_uninstall gstreamer-0.10.schemas
441
442 %files -f %{gstname}-%{gst_major_ver}.lang
443 %defattr(644,root,root,755)
444 %doc AUTHORS ChangeLog NEWS README RELEASE 
445 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
446 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
447 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
448 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
449 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
450 %attr(755,root,root) %{gstlibdir}/libgstavi.so
451 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
452 %attr(755,root,root) %{gstlibdir}/libgstefence.so
453 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
454 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
455 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
456 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
457 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
458 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
459 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
460 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
461 %attr(755,root,root) %{gstlibdir}/libgstudp.so
462 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
463 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
464 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
465 %{_gtkdocdir}/gst-plugins-good-plugins-*
466
467 %if %{with gconf}
468 %files -n gstreamer-GConf
469 %defattr(644,root,root,755)
470 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
471 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
472 %endif
473
474 ##
475 ## Plugins
476 ##
477
478 %if %{with aalib}
479 %files -n gstreamer-videosink-aa
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
482 %endif
483
484 %files -n gstreamer-audio-effects-good
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
487 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
488 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
489 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
490
491 %files -n gstreamer-audio-formats
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
494 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
495 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
496
497 %if %{with cairo}
498 %files -n gstreamer-cairo
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
501 %endif
502
503 %if %{with cdio}
504 %files -n gstreamer-cdio
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
507 %endif
508
509 %files -n gstreamer-dv
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{gstlibdir}/libgstdv.so
512
513 %files -n gstreamer-audiosink-esd
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{gstlibdir}/libgstesd.so
516
517 %files -n gstreamer-flac
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{gstlibdir}/libgstflac.so
520
521 %files -n gstreamer-gdkpixbuf
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
524
525 %files -n gstreamer-hal
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
528
529 #%if %{with ladspa}
530 #%files -n gstreamer-ladspa
531 #%defattr(644,root,root,755)
532 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
533 #%endif
534
535 %if %{with caca}
536 %files -n gstreamer-videosink-libcaca
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
539 %endif
540
541 %files -n gstreamer-libpng
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{gstlibdir}/libgstpng.so
544
545 %files -n gstreamer-audiosink-oss
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
548
549 %files -n gstreamer-raw1394
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{gstlibdir}/libgst1394.so
552
553 %files -n gstreamer-shout2
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
556
557 %if %{with speex}
558 %files -n gstreamer-speex
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
561 %endif
562
563 %files -n gstreamer-taglib
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
566
567 %files -n gstreamer-video-effects
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
570 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
571 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
572 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
573
574 %files -n gstreamer-visualisation
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
577
578 %files -n gstreamer-ximagesrc
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.102703 seconds and 4 git commands to generate.