]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- unconditional noarch subpackages
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  aalib           # aa videosink plugin
5 %bcond_without  caca            # caca videosink plugin
6 %bcond_without  cairo           # cairo plugin
7 %bcond_without  gtk             # GTK+ (3.x) elements (video sink plugin)
8 %bcond_without  jack            # JACK audio plugin
9 %bcond_with     jack1           # JACK 1 (0.12x) instead of JACK 2 (1.9.x)
10 %bcond_without  lame            # LAME MP2/MP3 encoding plugin
11 %bcond_without  mpg123          # MPG123-based MP3 plugin
12 %bcond_without  qt              # Qt (5.x) elements (video sink plugin)
13 %bcond_without  soup            # libsoup (2.4 API) http source plugin
14 %bcond_without  speex           # speex plugin
15 %bcond_without  wavpack         # wavpack plugin
16
17 %define         gstname         gst-plugins-good
18 %define         gstmver         1.0
19 %define         gst_ver         1.16.2
20 %define         gstpb_ver       1.16.2
21
22 Summary:        Good GStreamer Streaming-media framework plugins
23 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
24 Name:           gstreamer-plugins-good
25 Version:        1.16.2
26 Release:        1
27 License:        LGPL v2+
28 Group:          Libraries
29 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.xz
30 # Source0-md5:  bd025f8f14974f94b75ac69a9d1b9c93
31 URL:            https://gstreamer.freedesktop.org/
32 BuildRequires:  autoconf >= 2.69
33 BuildRequires:  automake >= 1:1.14
34 BuildRequires:  docbook-dtd412-xml
35 BuildRequires:  gettext-tools >= 0.17
36 BuildRequires:  glib2-devel >= 1:2.40
37 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
38 BuildRequires:  glibc-localedb-all
39 %endif
40 BuildRequires:  gstreamer-devel >= %{gst_ver}
41 BuildRequires:  gstreamer-gl-devel >= %{gstpb_ver}
42 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
43 BuildRequires:  gtk+3-devel >= 3.0.0
44 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.12}
45 BuildRequires:  libtool >= 2:2.2.6
46 BuildRequires:  orc-devel >= 0.4.17
47 BuildRequires:  pkgconfig >= 1:0.9.0
48 BuildRequires:  python >= 2.1
49 BuildRequires:  rpmbuild(macros) >= 1.198
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 ##
53 ## plugins
54 ##
55 %{?with_qt:BuildRequires:       Qt5Core-devel >= 5.4.0}
56 %{?with_qt:BuildRequires:       Qt5Gui-devel >= 5.4.0}
57 %{?with_qt:BuildRequires:       Qt5Quick-devel >= 5.4.0}
58 %{?with_qt:BuildRequires:       Qt5Qml-devel >= 5.4.0}
59 %{?with_qt:BuildRequires:       Qt5X11Extras-devel >= 5.4.0}
60 %{?with_qt:BuildRequires:       Qt5WaylandClient-devel >= 5.4.0}
61 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
62 BuildRequires:  bzip2-devel
63 %{?with_cairo:BuildRequires:    cairo-devel >= 1.10.0}
64 %{?with_cairo:BuildRequires:    cairo-gobject-devel >= 1.10.0}
65 BuildRequires:  dbus-devel >= 0.91
66 BuildRequires:  flac-devel >= 1.1.4
67 BuildRequires:  gdk-pixbuf2-devel >= 2.8.0
68 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.15.0}
69 %if %{with jack}
70 %{?with_jack1:BuildRequires:    jack-audio-connection-kit-devel >= 0.120.1}
71 %{!?with_jack1:BuildRequires:   jack-audio-connection-kit-devel >= 1.9.7}
72 %endif
73 %{?with_lame:BuildRequires:     lame-libs-devel}
74 BuildRequires:  libavc1394-devel
75 %{?with_caca:BuildRequires:     libcaca-devel}
76 BuildRequires:  libdv-devel >= 0.104
77 BuildRequires:  libiec61883-devel >= 1.0.0
78 BuildRequires:  libjpeg-devel
79 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
80 BuildRequires:  libpng-devel >= 2:1.5.1
81 BuildRequires:  libraw1394-devel >= 2.0.0
82 BuildRequires:  libshout-devel >= 2.0
83 %{?with_soup:BuildRequires:     libsoup-devel >= 2.48}
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  libv4l-devel
86 BuildRequires:  libvpx-devel >= 1.8.0
87 BuildRequires:  pulseaudio-devel >= 2.0
88 %{?with_qt:BuildRequires:       qt5-build >= 5.4.0}
89 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
90 BuildRequires:  taglib-devel >= 1.5
91 %{?with_lame:BuildRequires:     twolame-devel >= 0.3.10}
92 BuildRequires:  udev-glib-devel >= 1:147
93 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.60.0}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xorg-lib-libXdamage-devel
96 BuildRequires:  xorg-lib-libXext-devel
97 BuildRequires:  xorg-lib-libXfixes-devel
98 BuildRequires:  zlib-devel
99 Requires:       glib2 >= 1:2.40
100 Requires:       gstreamer >= %{gst_ver}
101 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
102 Requires:       orc >= 0.4.17
103 Obsoletes:      gstreamer-avi
104 Obsoletes:      gstreamer-flx
105 Obsoletes:      gstreamer-matroska
106 Obsoletes:      gstreamer-mixer
107 Obsoletes:      gstreamer-navigation
108 Obsoletes:      gstreamer-oss4
109 Obsoletes:      gstreamer-rtp
110 Obsoletes:      gstreamer-udp
111 Conflicts:      gstreamer-plugins-bad < 0.10.19
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         gstlibdir       %{_libdir}/gstreamer-%{gstmver}
115
116 %description
117 GStreamer is a streaming-media framework, based on graphs of filters
118 which operate on media data. Applications using this library can do
119 anything from real-time sound processing to playing videos, and just
120 about anything else media-related. Its plugin-based architecture means
121 that new data types or processing capabilities can be added simply by
122 installing new plugins.
123
124 %description -l pl.UTF-8
125 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
126 grafie filtrów operujących na danych medialnych. Aplikacje używające
127 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
128 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
129 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
130 nowych typów danych lub możliwości obróbki.
131
132 %package apidocs
133 Summary:        Good GStreamer streaming-media framework plugins API documentation
134 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
135 Group:          Documentation
136 Requires:       gtk-doc-common
137 BuildArch:      noarch
138
139 %description apidocs
140 Good GStreamer streaming-media framework plugins API documentation.
141
142 %description apidocs -l pl.UTF-8
143 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
144 GStreamer.
145
146 ## ## Plugins ##
147
148 %package -n gstreamer-videosink-aa
149 Summary:        GStreamer plugin for Ascii-art output
150 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
151 Group:          Libraries
152 Requires:       gstreamer >= %{gst_ver}
153 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
154 Provides:       gstreamer-videosink = %{version}
155 Obsoletes:      gstreamer-aalib
156
157 %description -n gstreamer-videosink-aa
158 Plugin for viewing movies in Ascii-art using aalib library.
159
160 %description -n gstreamer-videosink-aa -l pl.UTF-8
161 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
162
163 %package -n gstreamer-audio-effects-good
164 Summary:        Good GStreamer audio effects plugins
165 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
166 Group:          Libraries
167 Requires:       gstreamer >= %{gst_ver}
168 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
169 Obsoletes:      gstreamer-audio-effects
170
171 %description -n gstreamer-audio-effects-good
172 Good GStreamer audio effects plugins.
173
174 %description -n gstreamer-audio-effects-good -l pl.UTF-8
175 Dobre wtyczki efektów dźwiękowych do GStreamera.
176
177 %package -n gstreamer-audio-formats
178 Summary:        GStreamer audio format plugins
179 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
180 Group:          Libraries
181 Requires:       gstreamer >= %{gst_ver}
182 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
183 # for locales in wavparse module
184 Requires:       %{name} = %{version}-%{release}
185
186 %description -n gstreamer-audio-formats
187 Plugin for playback of WAV, au and mod audio files as well as MP3
188 type.
189
190 %description -n gstreamer-audio-formats -l pl.UTF-8
191 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
192
193 %package -n gstreamer-cairo
194 Summary:        GStreamer cairo plugin
195 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
196 Group:          Libraries
197 Requires:       cairo >= 1.10.0
198 Requires:       cairo-gobject >= 1.10.0
199 Requires:       gstreamer >= %{gst_ver}
200 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
201
202 %description -n gstreamer-cairo
203 GStreamer cairo plugin.
204
205 %description -n gstreamer-cairo -l pl.UTF-8
206 Wtyczka cairo do GStreamera.
207
208 %package -n gstreamer-dv
209 Summary:        GStreamer dv plugin
210 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
211 Group:          Libraries
212 Requires:       gstreamer >= %{gst_ver}
213 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
214 Requires:       libdv >= 0.104
215
216 %description -n gstreamer-dv
217 Plugin for digital video support.
218
219 %description -n gstreamer-dv -l pl.UTF-8
220 Wtyczka do GStreamera obsługująca cyfrowy obraz.
221
222 %package -n gstreamer-flac
223 Summary:        GStreamer plugin for FLAC lossless audio format
224 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
225 Group:          Libraries
226 Requires:       flac >= 1.1.4
227 Requires:       gstreamer >= %{gst_ver}
228 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
229
230 %description -n gstreamer-flac
231 Plugin for the free FLAC lossless audio format.
232
233 %description -n gstreamer-flac -l pl.UTF-8
234 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
235
236 %package -n gstreamer-gdkpixbuf
237 Summary:        GStreamer images input plugin
238 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
239 Group:          Libraries
240 Requires:       gdk-pixbuf2 >= 2.8.0
241 Requires:       gstreamer >= %{gst_ver}
242 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
243
244 %description -n gstreamer-gdkpixbuf
245 This GStreamer plugin load images via gdkpixbuf library.
246
247 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
248 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
249 gdkpixbuf.
250
251 %package -n gstreamer-videosink-gtk
252 Summary:        GStreamer GTK+ (3.x) output plugin
253 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera
254 Group:          Libraries
255 Requires:       gstreamer >= %{gst_ver}
256 Requires:       gstreamer-gl-libs >= %{gstpb_ver}
257 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
258 Requires:       gtk+3 >= 3.15.0
259 Provides:       gstreamer-videosink = %{version}
260
261 %description -n gstreamer-videosink-gtk
262 GStreamer GTK+ (3.x) output plugin.
263
264 %description -n gstreamer-videosink-gtk -l pl.UTF-8
265 Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera.
266
267 %package -n gstreamer-jack
268 Summary:        GStreamer plugin for the JACK Sound Server
269 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
270 Group:          Libraries
271 Requires:       gstreamer >= %{gst_ver}
272 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
273 %{?with_jack1:Requires: jack-audio-connection-kit-libs >= 0.120.1}
274 %{!?with_jack1:Requires:        jack-audio-connection-kit-libs >= 1.9.7}
275 # for locales
276 Requires:       %{name} = %{version}-%{release}
277 Provides:       gstreamer-audiosink = %{version}
278
279 %description -n gstreamer-jack
280 Plugin for the JACK professional sound server.
281
282 %description -n gstreamer-jack -l pl.UTF-8
283 Wtyczka dla profesjonalnego serwera dźwięku JACK.
284
285 %package -n gstreamer-videosink-libcaca
286 Summary:        GStreamer plugin for libcaca Ascii-art output
287 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
288 Group:          Libraries
289 Requires:       gstreamer >= %{gst_ver}
290 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
291 Provides:       gstreamer-videosink = %{version}
292
293 %description -n gstreamer-videosink-libcaca
294 GStreamer plug-in for libcaca Ascii-art output.
295
296 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
297 Wtyczka libcaca do GStreamera.
298
299 %package -n gstreamer-lame
300 Summary:        GStreamer plugin encoding MP3 songs
301 Summary(pl.UTF-8):      Wtyczka do GStreamera kodująca pliki MP3
302 Group:          Libraries
303 # for NLS
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       gstreamer >= %{gst_ver}
306 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
307 Requires:       twolame-libs >= 0.3.10
308
309 %description -n gstreamer-lame
310 Plugin for encoding MP3 with lame.
311
312 %description -n gstreamer-lame -l pl.UTF-8
313 Wtyczka do GStreamera kodująca pliki MP3 przy użyciu lame.
314
315 %package -n gstreamer-mpg123
316 Summary:        GStreamer mpg123 plugin
317 Summary(pl.UTF-8):      Wtyczka mpg123 do GStreamera
318 Group:          Libraries
319 Requires:       gstreamer >= %{gst_ver}
320 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
321 Requires:       libmpg123 >= 1.14
322 # plugin obsoleted in 1.12.0, functionality in mpg123 plugin (or libav)
323 Obsoletes:      gstreamer-mad < 1.12.0
324
325 %description -n gstreamer-mpg123
326 GStreamer mpg123 plugin for MP3 playback.
327
328 %description -n gstreamer-mpg123 -l pl.UTF-8
329 Wtyczka mpg123 do GStreamera, odtwarzająca MP3.
330
331 %package -n gstreamer-libpng
332 Summary:        GStreamer plugin to encode png images
333 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
334 Group:          Libraries
335 Requires:       gstreamer >= %{gst_ver}
336 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
337 # for locales
338 Requires:       %{name} = %{version}-%{release}
339 Requires:       libpng >= 2:1.5.1
340
341 %description -n gstreamer-libpng
342 Plugin for encoding png images.
343
344 %description -n gstreamer-libpng -l pl.UTF-8
345 Wtyczka kodująca pliki png.
346
347 %package -n gstreamer-audiosink-oss
348 Summary:        GStreamer plugins for input and output using OSS
349 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
350 Group:          Libraries
351 Requires:       gstreamer >= %{gst_ver}
352 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
353 # for locales
354 Requires:       %{name} = %{version}-%{release}
355 Provides:       gstreamer-audiosink = %{version}
356 Obsoletes:      gstreamer-oss
357
358 %description -n gstreamer-audiosink-oss
359 Plugins for output and input to the OpenSoundSystem audio drivers
360 found in the Linux kernels or commercially available from OpenSound.
361
362 %description -n gstreamer-audiosink-oss -l pl.UTF-8
363 Wtyczki wyjścia i wejścia dźwięku używające sterowników
364 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
365 od OpenSound.
366
367 %package -n gstreamer-pulseaudio
368 Summary:        GStreamer plugin for PulseAudio sound server
369 Summary(pl.UTF-8):      Wtyczka GStreamera dla serwera dźwięku PulseAudio
370 Group:          Libraries
371 Requires:       gstreamer >= %{gst_ver}
372 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
373 Requires:       pulseaudio >= 2.0
374 # for locales
375 Requires:       %{name} = %{version}-%{release}
376 Provides:       gstreamer-audiosink = %{version}
377 Obsoletes:      gstreamer-audiosink-polypaudio
378 Obsoletes:      gstreamer-polypaudio
379
380 %description -n gstreamer-pulseaudio
381 GStreamer plugin for PulseAudio sound server.
382
383 %description -n gstreamer-pulseaudio -l pl.UTF-8
384 Wtyczka GStreamera dla serwera dźwięku PulseAudio.
385
386 %package -n gstreamer-videosink-qt
387 Summary:        GStreamer Qt (5.x) output plugin
388 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera
389 Group:          Libraries
390 Requires:       Qt5Core >= 5.4.0
391 Requires:       Qt5Gui >= 5.4.0
392 Requires:       Qt5Quick >= 5.4.0
393 Requires:       gstreamer >= %{gst_ver}
394 Requires:       gstreamer-gl-libs >= %{gstpb_ver}
395 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
396 Provides:       gstreamer-videosink = %{version}
397
398 %description -n gstreamer-videosink-qt
399 GStreamer Qt (5.x) output plugin.
400
401 %description -n gstreamer-videosink-qt -l pl.UTF-8
402 Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera.
403
404 %package -n gstreamer-raw1394
405 Summary:        GStreamer raw1394 Firewire plugin
406 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
407 Group:          Libraries
408 Requires:       gstreamer >= %{gst_ver}
409
410 %description -n gstreamer-raw1394
411 Plugin for digital video support using raw1394.
412
413 %description -n gstreamer-raw1394 -l pl.UTF-8
414 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
415
416 %package -n gstreamer-shout2
417 Summary:        GStreamer plugin for communicating with Shoutcast servers
418 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
419 Group:          Libraries
420 Requires:       gstreamer >= %{gst_ver}
421 # for locales
422 Requires:       %{name} = %{version}-%{release}
423
424 %description -n gstreamer-shout2
425 GStreamer plugin for communicating with Shoutcast servers.
426
427 %description -n gstreamer-shout2 -l pl.UTF-8
428 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
429
430 %package -n gstreamer-soup
431 Summary:        GStreamer Soup plugin
432 Summary(pl.UTF-8):      Wtyczka biblioteki Soup dla GStreamera
433 Group:          Libraries
434 Requires:       gstreamer >= %{gst_ver}
435 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
436 Requires:       libsoup >= 2.48
437 # for locales
438 Requires:       %{name} = %{version}-%{release}
439
440 %description -n gstreamer-soup
441 GStreamer Plugin for downloading files with Soup library.
442
443 %description -n gstreamer-soup -l pl.UTF-8
444 Wtyczka GStreamera umożliwiająca ściąganie plików za pomocą biblioteki
445 Soup.
446
447 %package -n gstreamer-speex
448 Summary:        GStreamer speex codec decoder/encoder plugin
449 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
450 Group:          Libraries
451 Requires:       gstreamer >= %{gst_ver}
452 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
453 Requires:       speex >= 1:1.1.6
454
455 %description -n gstreamer-speex
456 GStreamer speex codec decoder/encoder plugin.
457
458 %description -n gstreamer-speex -l pl.UTF-8
459 Wtyczka do GStreamera obsługująca kodek Speex.
460
461 %package -n gstreamer-taglib
462 Summary:        GStreamer tag writing plugin based on taglib
463 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
464 Group:          Libraries
465 Requires:       gstreamer >= %{gst_ver}
466 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
467 Requires:       taglib >= 1.5
468
469 %description -n gstreamer-taglib
470 GStreamer tag writing plugin based on taglib.
471
472 %description -n gstreamer-taglib -l pl.UTF-8
473 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
474
475 %package -n gstreamer-v4l2
476 Summary:        GStreamer Video4Linux2 input plugin
477 Summary(pl.UTF-8):      Wtyczka wejścia Video4Linux2 dla GStreamera
478 Group:          Libraries
479 Requires:       %{name} = %{version}-%{release}
480 Requires:       gstreamer >= %{gst_ver}
481 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
482 Requires:       udev-glib >= 1:147
483
484 %description -n gstreamer-v4l2
485 GStreamer plugin for accessing Video4Linux2 devices.
486
487 %description -n gstreamer-v4l2 -l pl.UTF-8
488 Wtyczka GStreamera pozwalająca na dostęp do urządzeń Video4Linux2.
489
490 %package -n gstreamer-video-effects
491 Summary:        GStreamer video effects plugins
492 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
493 Group:          Libraries
494 Requires:       gstreamer >= %{gst_ver}
495 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
496 # for locales in jpeg module
497 Requires:       %{name} = %{version}-%{release}
498
499 %description -n gstreamer-video-effects
500 GStreamer video effects plugins.
501
502 %description -n gstreamer-video-effects -l pl.UTF-8
503 Wtyczki efektów wideo do GStreamera.
504
505 %package -n gstreamer-visualisation
506 Summary:        GStreamer visualisations plugins
507 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
508 Group:          Libraries
509 Requires:       gstreamer >= %{gst_ver}
510 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
511
512 %description -n gstreamer-visualisation
513 Various plugins for visual effects to use with audio. Included are
514 monoscope, spectrum, goom (2k4) and goom2k1.
515
516 %description -n gstreamer-visualisation -l pl.UTF-8
517 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
518 monoscope, spectrum, goom (2k4) i goom2k1.
519
520 %package -n gstreamer-vpx
521 Summary:        GStreamer plugin for VP8/VP9 video format
522 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca format obrazu VP8/VP9
523 Group:          Libraries
524 Requires:       gstreamer >= %{gst_ver}
525 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
526 Requires:       libvpx >= 1.8.0
527 Obsoletes:      gstreamer-vp8
528
529 %description -n gstreamer-vpx
530 GStreamer plugin for VP8/VP9 video format using libvpx library.
531
532 %description -n gstreamer-vpx -l pl.UTF-8
533 Wtyczka do GStreamera obsługująca format obrazu VP8/VP9 przy użyciu
534 biblioteki libvpx.
535
536 %package -n gstreamer-wavpack
537 Summary:        GStreamer plugin for Wavpack lossless audio format
538 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
539 Group:          Libraries
540 Requires:       gstreamer >= %{gst_ver}
541 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
542 Requires:       wavpack-libs >= 4.60.0
543
544 %description -n gstreamer-wavpack
545 Plugin for lossless Wavpack audio format.
546
547 %description -n gstreamer-wavpack -l pl.UTF-8
548 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
549
550 %package -n gstreamer-ximagesrc
551 Summary:        GStreamer X11 video input plugin using standard Xlib calls
552 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
553 Group:          Libraries
554 Requires:       %{name} = %{version}-%{release}
555 Requires:       gstreamer >= %{gst_ver}
556 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
557
558 %description -n gstreamer-ximagesrc
559 GStreamer X11 video input plugin using standard Xlib calls.
560
561 %description -n gstreamer-ximagesrc -l pl.UTF-8
562 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
563 Xlib.
564
565 %prep
566 %setup -q -n %{gstname}-%{version}
567
568 %build
569 %{__libtoolize}
570 %{__aclocal} -I m4 -I common/m4
571 %{__autoconf}
572 %{__autoheader}
573 %{__automake}
574 %configure \
575         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
576         --disable-silent-rules \
577         --disable-static \
578         --enable-experimental \
579         %{!?with_aalib:--disable-aalib} \
580         %{!?with_cairo:--disable-cairo} \
581         %{!?with_gtk:--disable-gtk} \
582         %{!?with_jack:--disable-jack} \
583         %{!?with_lame:--disable-lame --disable-twolame} \
584         %{!?with_caca:--disable-libcaca} \
585         %{!?with_mpg123:--disable-mpg123} \
586         %{!?with_qt:--disable-qt} \
587         %{!?with_soup:--disable-soup} \
588         %{!?with_speex:--disable-speex} \
589         %{!?with_wavpack:--disable-wavpack} \
590         --enable-gtk-doc%{!?with_apidocs:=no} \
591         --enable-orc \
592         --with-html-dir=%{_gtkdocdir}
593
594 LC_ALL=C.UTF-8 \
595 %{__make}
596
597 %install
598 rm -rf $RPM_BUILD_ROOT
599
600 %{__make} install \
601         DESTDIR=$RPM_BUILD_ROOT
602
603 # We don't need plugins' *.la files
604 %{__rm} $RPM_BUILD_ROOT%{gstlibdir}/*.la
605
606 %find_lang %{gstname}-%{gstmver}
607
608 %clean
609 rm -rf $RPM_BUILD_ROOT
610
611 %files -f %{gstname}-%{gstmver}.lang
612 %defattr(644,root,root,755)
613 %doc AUTHORS ChangeLog NEWS README RELEASE
614 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
615 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
616 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
617 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
618 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
619 %attr(755,root,root) %{gstlibdir}/libgstavi.so
620 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
621 %attr(755,root,root) %{gstlibdir}/libgstdtmf.so
622 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
623 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
624 %attr(755,root,root) %{gstlibdir}/libgstflv.so
625 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
626 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
627 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
628 %attr(755,root,root) %{gstlibdir}/libgstimagefreeze.so
629 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
630 %attr(755,root,root) %{gstlibdir}/libgstisomp4.so
631 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
632 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
633 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
634 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
635 %attr(755,root,root) %{gstlibdir}/libgstoss4.so
636 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
637 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
638 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
639 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
640 %attr(755,root,root) %{gstlibdir}/libgstshapewipe.so
641 %attr(755,root,root) %{gstlibdir}/libgstudp.so
642 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
643 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
644 %attr(755,root,root) %{gstlibdir}/libgstvideofilter.so
645 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
646 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
647 %dir %{_datadir}/gstreamer-%{gstmver}
648 %{_datadir}/gstreamer-%{gstmver}/presets
649
650 %if %{with apidocs}
651 %files apidocs
652 %defattr(644,root,root,755)
653 %{_gtkdocdir}/gst-plugins-good-plugins-%{gstmver}
654 %endif
655
656 ##
657 ## Plugins
658 ##
659
660 %if %{with aalib}
661 %files -n gstreamer-videosink-aa
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
664 %endif
665
666 %files -n gstreamer-audio-effects-good
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
669 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
670 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
671 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
672
673 %files -n gstreamer-audio-formats
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
676 %attr(755,root,root) %{gstlibdir}/libgstaudioparsers.so
677 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
678 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
679
680 %if %{with cairo}
681 %files -n gstreamer-cairo
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
684 %endif
685
686 %files -n gstreamer-dv
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{gstlibdir}/libgstdv.so
689
690 %files -n gstreamer-flac
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{gstlibdir}/libgstflac.so
693
694 %files -n gstreamer-gdkpixbuf
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
697
698 %if %{with gtk}
699 %files -n gstreamer-videosink-gtk
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{gstlibdir}/libgstgtk.so
702 %endif
703
704 %if %{with jack}
705 %files -n gstreamer-jack
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{gstlibdir}/libgstjack.so
708 %endif
709
710 %if %{with caca}
711 %files -n gstreamer-videosink-libcaca
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
714 %endif
715
716 %files -n gstreamer-lame
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{gstlibdir}/libgstlame.so
719 %attr(755,root,root) %{gstlibdir}/libgsttwolame.so
720
721 %if %{with mpg123}
722 %files -n gstreamer-mpg123
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{gstlibdir}/libgstmpg123.so
725 %endif
726
727 %files -n gstreamer-libpng
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{gstlibdir}/libgstpng.so
730
731 %files -n gstreamer-audiosink-oss
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
734
735 %files -n gstreamer-pulseaudio
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{gstlibdir}/libgstpulseaudio.so
738
739 %if %{with qt}
740 %files -n gstreamer-videosink-qt
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{gstlibdir}/libgstqmlgl.so
743 %endif
744
745 %files -n gstreamer-raw1394
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{gstlibdir}/libgst1394.so
748
749 %files -n gstreamer-shout2
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
752
753 %if %{with soup}
754 %files -n gstreamer-soup
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{gstlibdir}/libgstsoup.so
757 %endif
758
759 %if %{with speex}
760 %files -n gstreamer-speex
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
763 %endif
764
765 %files -n gstreamer-taglib
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
768
769 %files -n gstreamer-v4l2
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
772
773 %files -n gstreamer-video-effects
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
776 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
777 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
778
779 %files -n gstreamer-visualisation
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
782 %attr(755,root,root) %{gstlibdir}/libgstgoom2k1.so
783 %attr(755,root,root) %{gstlibdir}/libgstmonoscope.so
784 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
785
786 %files -n gstreamer-vpx
787 %defattr(644,root,root,755)
788 %attr(755,root,root) %{gstlibdir}/libgstvpx.so
789
790 %if %{with wavpack}
791 %files -n gstreamer-wavpack
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
794 %endif
795
796 %files -n gstreamer-ximagesrc
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.114807 seconds and 4 git commands to generate.