]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- package goom2k1 plugin (in gstreamer-visualisation)
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  apidocs         # disable gtk-doc
5 %bcond_without  caca            # don't build caca videosink plugin
6 %bcond_without  cairo           # don't build cairo plugin
7 %bcond_without  cdio            # don't build cdio plugin
8 %bcond_without  gconf           # don't build GConf plugin
9 %bcond_with     ladspa          # build ladspa plugin [currently built in plugins-bad]
10 %bcond_without  soup            # don't build libsoup 2.4 http source plugin
11 %bcond_without  speex           # don't build speex plugin
12 %bcond_without  wavpack         # don't build wavpack plugin
13 #
14 %define         gstname         gst-plugins-good
15 %define         gst_major_ver   0.10
16 %define         gst_req_ver     0.10.14
17 %define         gstpb_req_ver   0.10.14
18 #
19 Summary:        Good GStreamer Streaming-media framework plugins
20 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
21 Name:           gstreamer-plugins-good
22 Version:        0.10.8
23 Release:        1
24 License:        LGPL
25 Group:          Libraries
26 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
27 # Source0-md5:  32414def093652d8281f3708ccaf086b
28 Patch0:         %{name}-bashish.patch
29 Patch1:         %{name}-libcaca.patch
30 URL:            http://gstreamer.freedesktop.org/
31 BuildRequires:  autoconf >= 2.59-9
32 BuildRequires:  automake >= 1.5
33 BuildRequires:  glib2-devel >= 1:2.12.1
34 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
35 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
36 BuildRequires:  gtk+2-devel >= 2:2.10.1
37 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
38 BuildRequires:  liboil-devel >= 0.3.6
39 BuildRequires:  libtool >= 1.4
40 BuildRequires:  pkgconfig >= 1:0.9.0
41 BuildRequires:  python >= 2.1
42 BuildRequires:  python-PyXML
43 BuildRequires:  rpmbuild(macros) >= 1.198
44 ##
45 ## plugins
46 ##
47 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.14.0}
48 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
49 %{?with_cairo:BuildRequires:    cairo-devel >= 1.2.0}
50 BuildRequires:  dbus-devel >= 0.91
51 BuildRequires:  esound-devel >= 0.2.12
52 BuildRequires:  flac-devel >= 1.1.3
53 BuildRequires:  hal-devel >= 0.5.7.1
54 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
55 BuildRequires:  libavc1394-devel
56 %{?with_caca:BuildRequires:     libcaca-devel}
57 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
58 BuildRequires:  libdv-devel >= 0.104
59 BuildRequires:  libiec61883-devel >= 1.0.0
60 BuildRequires:  libjpeg-devel
61 BuildRequires:  libpng-devel >= 1.2.0
62 BuildRequires:  libraw1394-devel >= 1.2.1
63 BuildRequires:  libshout-devel >= 2.0
64 %{?with_soup:BuildRequires:     libsoup-devel >= 2.4.0}
65 # for taglib
66 BuildRequires:  libstdc++-devel
67 BuildRequires:  libxml2-devel >= 1:2.6.26
68 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
69 BuildRequires:  taglib-devel >= 1.4
70 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.40.0}
71 BuildRequires:  xorg-lib-libX11-devel
72 BuildRequires:  xorg-lib-libXdamage-devel
73 BuildRequires:  xorg-lib-libXext-devel
74 BuildRequires:  xorg-lib-libXfixes-devel
75 BuildRequires:  zlib-devel
76 Requires:       gstreamer >= %{gst_req_ver}
77 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
78 Obsoletes:      gstreamer-avi
79 Obsoletes:      gstreamer-flx
80 Obsoletes:      gstreamer-matroska
81 Obsoletes:      gstreamer-mixer
82 Obsoletes:      gstreamer-navigation
83 Obsoletes:      gstreamer-rtp
84 Obsoletes:      gstreamer-udp
85 Obsoletes:      gstreamer-v4l2
86 Conflicts:      gstreamer-plugins-bad < 0.10.4
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
90
91 %description
92 GStreamer is a streaming-media framework, based on graphs of filters
93 which operate on media data. Applications using this library can do
94 anything from real-time sound processing to playing videos, and just
95 about anything else media-related. Its plugin-based architecture means
96 that new data types or processing capabilities can be added simply by
97 installing new plugins.
98
99 %description -l pl.UTF-8
100 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
101 grafie filtrów operujących na danych medialnych. Aplikacje używające
102 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
103 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
104 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
105 nowych typów danych lub możliwości obróbki.
106
107 %package apidocs
108 Summary:        Good GStreamer streaming-media framework plugins API documentation
109 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
110 Group:          Documentation
111 Requires:       gtk-doc-common
112
113 %description apidocs
114 Good GStreamer streaming-media framework plugins API documentation.
115
116 %description apidocs -l pl.UTF-8
117 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
118 GStreamer.
119
120 %package -n gstreamer-GConf
121 Summary:        GStreamer GConf schemas
122 Summary(pl.UTF-8):      Schematy GConf GStreamera
123 Group:          Libraries
124 Requires(post,preun):   GConf2
125 Requires:       gstreamer >= %{gst_req_ver}
126 Obsoletes:      gstreamer-GConf-devel
127
128 %description -n gstreamer-GConf
129 Installation of GStreamer GConf schemas. These set usable defaults
130 used by all GStreamer-enabled GNOME applications.
131
132 %description -n gstreamer-GConf -l pl.UTF-8
133 Schematy GConf dla GStreamera. Zestaw ten ustawia wartości domyślne
134 dla wszystkich aplikacji GNOME korzystających z GStreamera
135
136 ## ## Plugins ##
137
138 %package -n gstreamer-videosink-aa
139 Summary:        GStreamer plugin for Ascii-art output
140 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
141 Group:          Libraries
142 Requires:       gstreamer >= %{gst_req_ver}
143 Provides:       gstreamer-videosink = %{version}
144 Obsoletes:      gstreamer-aalib
145
146 %description -n gstreamer-videosink-aa
147 Plugin for viewing movies in Ascii-art using aalib library.
148
149 %description -n gstreamer-videosink-aa -l pl.UTF-8
150 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
151
152 %package -n gstreamer-audio-effects-good
153 Summary:        Good GStreamer audio effects plugins
154 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
155 Group:          Libraries
156 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
157 Obsoletes:      gstreamer-audio-effects
158
159 %description -n gstreamer-audio-effects-good
160 Good GStreamer audio effects plugins.
161
162 %description -n gstreamer-audio-effects-good -l pl.UTF-8
163 Dobre wtyczki efektów dźwiękowych do GStreamera.
164
165 %package -n gstreamer-audio-formats
166 Summary:        GStreamer audio format plugins
167 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
168 Group:          Libraries
169 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
170 # for locales in wavparse module
171 Requires:       %{name} = %{version}-%{release}
172
173 %description -n gstreamer-audio-formats
174 Plugin for playback of WAV, au and mod audio files as well as MP3
175 type.
176
177 %description -n gstreamer-audio-formats -l pl.UTF-8
178 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
179
180 %package -n gstreamer-cairo
181 Summary:        GStreamer cairo plugin
182 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
183 Group:          Libraries
184 Requires:       gstreamer >= %{gst_req_ver}
185
186 %description -n gstreamer-cairo
187 GStreamer cairo plugin.
188
189 %description -n gstreamer-cairo -l pl.UTF-8
190 Wtyczka cairo do GStreamera.
191
192 %package -n gstreamer-cdio
193 Summary:        GStreamer plugin for CD audio input using libcdio
194 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdio
195 Group:          Libraries
196 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
197 Requires:       libcdio >= 0.71
198
199 %description -n gstreamer-cdio
200 Plugin for playing audio tracks using libcdio under GStreamer.
201
202 %description -n gstreamer-cdio -l pl.UTF-8
203 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
204 libcdio.
205
206 %package -n gstreamer-dv
207 Summary:        GStreamer dv plugin
208 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
209 Group:          Libraries
210 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
211
212 %description -n gstreamer-dv
213 Plugin for digital video support.
214
215 %description -n gstreamer-dv -l pl.UTF-8
216 Wtyczka do GStreamera obsługująca cyfrowy obraz.
217
218 %package -n gstreamer-audiosink-esd
219 Summary:        GStreamer plugin for ESD sound output
220 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku ESD do GStreamera
221 Group:          Libraries
222 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
223 Provides:       gstreamer-audiosink = %{version}
224 Obsoletes:      gstreamer-esound
225
226 %description -n gstreamer-audiosink-esd
227 Output plugin for GStreamer for use with the esound package.
228
229 %description -n gstreamer-audiosink-esd -l pl.UTF-8
230 Wtyczka wyjścia dźwięku ESD (esound) dla GStreamera.
231
232 %package -n gstreamer-flac
233 Summary:        GStreamer plugin for FLAC lossless audio format
234 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
235 Group:          Libraries
236 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
237
238 %description -n gstreamer-flac
239 Plugin for the free FLAC lossless audio format.
240
241 %description -n gstreamer-flac -l pl.UTF-8
242 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
243
244 %package -n gstreamer-gdkpixbuf
245 Summary:        GStreamer images input plugin
246 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
247 Group:          Libraries
248 Requires:       gstreamer >= %{gst_req_ver}
249
250 %description -n gstreamer-gdkpixbuf
251 This GStreamer plugin load images via gdkpixbuf library.
252
253 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
254 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
255 gdkpixbuf.
256
257 %package -n gstreamer-hal
258 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
259 Summary(pl.UTF-8):      Wtyczka GStreamera spinająca urządzenia wejścia/wyjścia dźwięku z HAL-em
260 Group:          Libraries
261 Requires:       gstreamer >= %{gst_req_ver}
262
263 %description -n gstreamer-hal
264 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
265
266 %description -n gstreamer-hal -l pl.UTF-8
267 Wtyczka GStreamera spinająca urządzenia wejścia/wyjścia dźwięku między
268 GStreamerem a HAL-em.
269
270 %package -n gstreamer-ladspa
271 Summary:        GStreamer wrapper for LADSPA plugins
272 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
273 Group:          Libraries
274 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
275
276 %description -n gstreamer-ladspa
277 Plugin which wraps LADSPA plugins for use by GStreamer applications.
278
279 %description -n gstreamer-ladspa -l pl.UTF-8
280 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
281 GStreamera.
282
283 %package -n gstreamer-videosink-libcaca
284 Summary:        GStreamer plugin for libcaca Ascii-art output
285 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
286 Group:          Libraries
287 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
288 Provides:       gstreamer-videosink = %{version}
289
290 %description -n gstreamer-videosink-libcaca
291 GStreamer plug-in for libcaca Ascii-art output.
292
293 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
294 Wtyczka libcaca do GStreamera.
295
296 %package -n gstreamer-libpng
297 Summary:        GStreamer plugin to encode png images
298 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
299 Group:          Libraries
300 #Requires:      gstreamer >= %{gst_req_ver}
301 # for locales
302 Requires:       %{name} = %{version}-%{release}
303 Requires:       libpng >= 1.2.0
304
305 %description -n gstreamer-libpng
306 Plugin for encoding png images.
307
308 %description -n gstreamer-libpng -l pl.UTF-8
309 Wtyczka kodująca pliki png.
310
311 %package -n gstreamer-audiosink-oss
312 Summary:        GStreamer plugins for input and output using OSS
313 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
314 Group:          Libraries
315 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
316 # for locales
317 Requires:       %{name} = %{version}-%{release}
318 Provides:       gstreamer-audiosink = %{version}
319 Obsoletes:      gstreamer-oss
320
321 %description -n gstreamer-audiosink-oss
322 Plugins for output and input to the OpenSoundSystem audio drivers
323 found in the Linux kernels or commercially available from OpenSound.
324
325 %description -n gstreamer-audiosink-oss -l pl.UTF-8
326 Wtyczki wyjścia i wejścia dźwięku używające sterowników
327 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
328 od OpenSound.
329
330 %package -n gstreamer-raw1394
331 Summary:        GStreamer raw1394 Firewire plugin
332 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
333 Group:          Libraries
334 Requires:       gstreamer >= %{gst_req_ver}
335
336 %description -n gstreamer-raw1394
337 Plugin for digital video support using raw1394.
338
339 %description -n gstreamer-raw1394 -l pl.UTF-8
340 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
341
342 %package -n gstreamer-shout2
343 Summary:        GStreamer plugin for communicating with Shoutcast servers
344 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
345 Group:          Libraries
346 Requires:       gstreamer >= %{gst_req_ver}
347
348 %description -n gstreamer-shout2
349 GStreamer plugin for communicating with Shoutcast servers.
350
351 %description -n gstreamer-shout2 -l pl.UTF-8
352 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
353
354 %package -n gstreamer-soup
355 Summary:        GStreamer Soup plugin
356 Summary(pl.UTF-8):      Wtyczka biblioteki Soup dla GStreamera
357 Group:          Libraries
358 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
359
360 %description -n gstreamer-soup
361 GStreamer Plugin for downloading files with Soup library.
362
363 %description -n gstreamer-soup -l pl.UTF-8
364 Wtyczka GStreamera umożliwiająca ściąganie plików za pomocą biblioteki
365 Soup.
366
367 %package -n gstreamer-speex
368 Summary:        GStreamer speex codec decoder/encoder plugin
369 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
370 Group:          Libraries
371 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
372 Requires:       speex >= 1:1.1.6
373
374 %description -n gstreamer-speex
375 GStreamer speex codec decoder/encoder plugin.
376
377 %description -n gstreamer-speex -l pl.UTF-8
378 Wtyczka do GStreamera obsługująca kodek Speex.
379
380 %package -n gstreamer-taglib
381 Summary:        GStreamer tag writing plugin based on taglib
382 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
383 Group:          Libraries
384 Requires:       gstreamer >= %{gst_req_ver}
385
386 %description -n gstreamer-taglib
387 GStreamer tag writing plugin based on taglib.
388
389 %description -n gstreamer-taglib -l pl.UTF-8
390 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
391
392 %package -n gstreamer-video-effects
393 Summary:        GStreamer video effects plugins
394 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
395 Group:          Libraries
396 # for locales in jpeg module
397 Requires:       %{name} = %{version}-%{release}
398
399 %description -n gstreamer-video-effects
400 GStreamer video effects plugins.
401
402 %description -n gstreamer-video-effects -l pl.UTF-8
403 Wtyczki efektów wideo do GStreamera.
404
405 %package -n gstreamer-visualisation
406 Summary:        GStreamer visualisations plugins
407 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
408 Group:          Libraries
409 Requires:       gstreamer >= %{gst_req_ver}
410
411 %description -n gstreamer-visualisation
412 Various plugins for visual effects to use with audio. Included are
413 monoscope, spectrum, goom (2k4) and goom2k1.
414
415 %description -n gstreamer-visualisation -l pl.UTF-8
416 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
417 monoscope, spectrum, goom (2k4) i goom2k1.
418
419 %package -n gstreamer-ximagesrc
420 Summary:        GStreamer X11 video input plugin using standard Xlib calls
421 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
422 Group:          Libraries
423 Requires:       %{name} = %{version}-%{release}
424
425 %description -n gstreamer-ximagesrc
426 GStreamer X11 video input plugin using standard Xlib calls.
427
428 %description -n gstreamer-ximagesrc -l pl.UTF-8
429 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
430 Xlib.
431
432 %package -n gstreamer-wavpack
433 Summary:        GStreamer plugin for Wavpack lossless audio format
434 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
435 Group:          Libraries
436 Requires:       gstreamer >= %{gst_req_ver}
437
438 %description -n gstreamer-wavpack
439 Plugin for lossless Wavpack audio format.
440
441 %description -n gstreamer-wavpack -l pl.UTF-8
442 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
443
444 %prep
445 %setup -q -n %{gstname}-%{version}
446 %patch0 -p1
447 %patch1 -p1
448
449 %build
450 %{__libtoolize}
451 %{__aclocal} -I m4 -I common/m4
452 %{__autoconf}
453 %{__autoheader}
454 %{__automake}
455 %configure \
456         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
457         %{!?with_aalib:--disable-aalib} \
458         %{!?with_caca:--disable-libcaca} \
459         %{!?with_cairo:--disable-cairo} \
460         %{!?with_cdio:--disable-cdio} \
461         --enable-experimental \
462         %{?with_ladspa:--enable-ladspa} \
463         %{!?with_soup:--disable-soup} \
464         %{!?with_speex:--disable-speex} \
465         %{!?with_wavpack:--disable-wavpack} \
466         --disable-static \
467         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
468         --with-html-dir=%{_gtkdocdir}
469
470 %{__make}
471
472 %install
473 rm -rf $RPM_BUILD_ROOT
474
475 %{__make} install \
476         DESTDIR=$RPM_BUILD_ROOT
477
478 # We don't need plugins' *.la files
479 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
480
481 %find_lang %{gstname}-%{gst_major_ver}
482
483 %clean
484 rm -rf $RPM_BUILD_ROOT
485
486 %post   -n gstreamer-GConf
487 %gconf_schema_install gstreamer-0.10.schemas
488
489 %preun  -n gstreamer-GConf
490 %gconf_schema_uninstall gstreamer-0.10.schemas
491
492 %files -f %{gstname}-%{gst_major_ver}.lang
493 %defattr(644,root,root,755)
494 %doc AUTHORS ChangeLog NEWS README RELEASE
495 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
496 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
497 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
498 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
499 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
500 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
501 %attr(755,root,root) %{gstlibdir}/libgstavi.so
502 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
503 %attr(755,root,root) %{gstlibdir}/libgstefence.so
504 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
505 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
506 %attr(755,root,root) %{gstlibdir}/libgstgamma.so
507 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
508 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
509 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
510 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
511 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
512 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
513 %attr(755,root,root) %{gstlibdir}/libgstqtdemux.so
514 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
515 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
516 %attr(755,root,root) %{gstlibdir}/libgstudp.so
517 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
518 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
519 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
520 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
521 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
522
523 %if %{with apidocs}
524 %files apidocs
525 %defattr(644,root,root,755)
526 %{_gtkdocdir}/gst-plugins-good-plugins-*
527 %endif
528
529 %if %{with gconf}
530 %files -n gstreamer-GConf
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
533 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
534 %endif
535
536 ##
537 ## Plugins
538 ##
539
540 %if %{with aalib}
541 %files -n gstreamer-videosink-aa
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
544 %endif
545
546 %files -n gstreamer-audio-effects-good
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
549 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
550 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
551 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
552
553 %files -n gstreamer-audio-formats
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
556 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
557 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
558
559 %if %{with cairo}
560 %files -n gstreamer-cairo
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
563 %endif
564
565 %if %{with cdio}
566 %files -n gstreamer-cdio
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
569 %endif
570
571 %files -n gstreamer-dv
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{gstlibdir}/libgstdv.so
574
575 %files -n gstreamer-audiosink-esd
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{gstlibdir}/libgstesd.so
578
579 %files -n gstreamer-flac
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{gstlibdir}/libgstflac.so
582
583 %files -n gstreamer-gdkpixbuf
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
586
587 %files -n gstreamer-hal
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
590
591 # disabled in ext/Makefile.am, currently built in plugins-bad
592 #%if %{with ladspa}
593 #%files -n gstreamer-ladspa
594 #%defattr(644,root,root,755)
595 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
596 #%endif
597
598 %if %{with caca}
599 %files -n gstreamer-videosink-libcaca
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
602 %endif
603
604 %files -n gstreamer-libpng
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{gstlibdir}/libgstpng.so
607
608 %files -n gstreamer-audiosink-oss
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
611
612 %files -n gstreamer-raw1394
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{gstlibdir}/libgst1394.so
615
616 %files -n gstreamer-shout2
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
619
620 %if %{with soup}
621 %files -n gstreamer-soup
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{gstlibdir}/libgstsouphttpsrc.so
624 %endif
625
626 %if %{with speex}
627 %files -n gstreamer-speex
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
630 %endif
631
632 %files -n gstreamer-taglib
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
635
636 %files -n gstreamer-video-effects
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
639 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
640 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
641 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
642
643 %files -n gstreamer-visualisation
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
646 %attr(755,root,root) %{gstlibdir}/libgstgoom2k1.so
647 %attr(755,root,root) %{gstlibdir}/libgstmonoscope.so
648 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
649
650 %if %{with wavpack}
651 %files -n gstreamer-wavpack
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
654 %endif
655
656 %files -n gstreamer-ximagesrc
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.076028 seconds and 4 git commands to generate.