]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- added apidocs bcond and subpackage
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  apidocs         # disable gtk-doc
5 %bcond_without  caca            # don't build caca videosink plugin
6 %bcond_without  cairo           # don't build cairo plugin
7 %bcond_without  cdio            # don't build cdio plugin
8 %bcond_without  gconf           # don't build GConf plugin
9 %bcond_with     ladspa          # build ladspa plugin [currently built in plugins-bad]
10 %bcond_without  speex           # don't build speex plugin
11 #
12 %define         gstname         gst-plugins-good
13 %define         gst_major_ver   0.10
14 %define         gst_req_ver     0.10.10.1
15 %define         gstpb_req_ver   0.10.10.1
16 #
17 Summary:        Good GStreamer Streaming-media framework plugins
18 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
19 Name:           gstreamer-plugins-good
20 Version:        0.10.5
21 Release:        2
22 License:        LGPL
23 Group:          Libraries
24 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
25 # Source0-md5:  c45fc9ace9feb4d3df32da0a6d262d84
26 Patch0:         %{name}-bashish.patch
27 Patch1:         %{name}-libcaca.patch
28 Patch2:         %{name}-flac.patch
29 URL:            http://gstreamer.freedesktop.org/
30 BuildRequires:  autoconf >= 2.59-9
31 BuildRequires:  automake >= 1.5
32 BuildRequires:  glib2-devel >= 1:2.12.1
33 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
34 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
35 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
36 BuildRequires:  gtk+2-devel >= 2:2.10.1
37 BuildRequires:  liboil-devel >= 0.3.6
38 BuildRequires:  libtool >= 1.4
39 BuildRequires:  pkgconfig >= 1:0.9.0
40 BuildRequires:  python >= 2.1
41 BuildRequires:  python-PyXML
42 BuildRequires:  rpmbuild(macros) >= 1.198
43 ##
44 ## plugins
45 ##
46 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.14.0}
47 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
48 %{?with_cairo:BuildRequires:    cairo-devel >= 1.2.0}
49 BuildRequires:  dbus-devel >= 0.91
50 BuildRequires:  esound-devel >= 0.2.12
51 BuildRequires:  flac-devel >= 1.1.3
52 BuildRequires:  hal-devel >= 0.5.7.1
53 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
54 BuildRequires:  libavc1394-devel
55 %{?with_caca:BuildRequires:     libcaca-devel}
56 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
57 BuildRequires:  libdv-devel >= 0.104
58 BuildRequires:  libiec61883-devel >= 1.0.0
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libpng-devel >= 1.2.0
61 BuildRequires:  libraw1394-devel >= 1.2.1
62 BuildRequires:  libshout-devel >= 2.0
63 # for taglib
64 BuildRequires:  libstdc++-devel
65 BuildRequires:  libxml2-devel >= 1:2.6.26
66 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
67 BuildRequires:  taglib-devel >= 1.4
68 BuildRequires:  xorg-lib-libX11-devel
69 BuildRequires:  xorg-lib-libXdamage-devel
70 BuildRequires:  xorg-lib-libXext-devel
71 BuildRequires:  xorg-lib-libXfixes-devel
72 BuildRequires:  zlib-devel
73 Requires:       gstreamer >= %{gst_req_ver}
74 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
75 Obsoletes:      gstreamer-avi
76 Obsoletes:      gstreamer-flx
77 Obsoletes:      gstreamer-matroska
78 Obsoletes:      gstreamer-mixer
79 Obsoletes:      gstreamer-navigation
80 Obsoletes:      gstreamer-rtp
81 Obsoletes:      gstreamer-udp
82 Obsoletes:      gstreamer-v4l2
83 Conflicts:      gstreamer-plugins-bad < 0.10.4
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
87
88 %description
89 GStreamer is a streaming-media framework, based on graphs of filters
90 which operate on media data. Applications using this library can do
91 anything from real-time sound processing to playing videos, and just
92 about anything else media-related. Its plugin-based architecture means
93 that new data types or processing capabilities can be added simply by
94 installing new plugins.
95
96 %description -l pl.UTF-8
97 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
98 grafie filtrów operujących na danych medialnych. Aplikacje używające
99 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
100 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
101 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
102 nowych typów danych lub możliwości obróbki.
103
104 %package apidocs
105 Summary:        Good GStreamer streaming-media framework plugins API documentation
106 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
107 Group:          Documentation
108 Requires:       gtk-doc-common
109
110 %description apidocs
111 Good GStreamer streaming-media framework plugins API documentation.
112
113 %description apidocs -l pl.UTF-8
114 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
115 GStreamer.
116
117 %package -n gstreamer-GConf
118 Summary:        GStreamer GConf schemas
119 Summary(pl.UTF-8):      Schematy GConf GStreamera
120 Group:          Libraries
121 Requires(post,preun):   GConf2
122 Requires:       gstreamer >= %{gst_req_ver}
123 Obsoletes:      gstreamer-GConf-devel
124
125 %description -n gstreamer-GConf
126 Installation of GStreamer GConf schemas. These set usable defaults
127 used by all GStreamer-enabled GNOME applications.
128
129 %description -n gstreamer-GConf -l pl.UTF-8
130 Schematy GConf dla GStreamera. Zestaw ten ustawia wartości domyślne
131 dla wszystkich aplikacji GNOME korzystających z GStreamera
132
133 ##
134 ## Plugins
135 ##
136
137 %package -n gstreamer-videosink-aa
138 Summary:        GStreamer plugin for Ascii-art output
139 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
140 Group:          Libraries
141 Requires:       gstreamer >= %{gst_req_ver}
142 Provides:       gstreamer-videosink = %{version}
143 Obsoletes:      gstreamer-aalib
144
145 %description -n gstreamer-videosink-aa
146 Plugin for viewing movies in Ascii-art using aalib library.
147
148 %description -n gstreamer-videosink-aa -l pl.UTF-8
149 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
150
151 %package -n gstreamer-audio-effects-good
152 Summary:        Good GStreamer audio effects plugins
153 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
154 Group:          Libraries
155 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
156 Obsoletes:      gstreamer-audio-effects
157
158 %description -n gstreamer-audio-effects-good
159 Good GStreamer audio effects plugins.
160
161 %description -n gstreamer-audio-effects-good -l pl.UTF-8
162 Dobre wtyczki efektów dźwiękowych do GStreamera.
163
164 %package -n gstreamer-audio-formats
165 Summary:        GStreamer audio format plugins
166 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
167 Group:          Libraries
168 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
169 # for locales in wavparse module
170 Requires:       %{name} = %{version}-%{release}
171
172 %description -n gstreamer-audio-formats
173 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
174
175 %description -n gstreamer-audio-formats -l pl.UTF-8
176 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
177
178 %package -n gstreamer-cairo
179 Summary:        GStreamer cairo plugin
180 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
181 Group:          Libraries
182 Requires:       gstreamer >= %{gst_req_ver}
183
184 %description -n gstreamer-cairo
185 GStreamer cairo plugin.
186
187 %description -n gstreamer-cairo -l pl.UTF-8
188 Wtyczka cairo do GStreamera.
189
190 %package -n gstreamer-cdio
191 Summary:        GStreamer plugin for CD audio input using libcdio
192 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdio
193 Group:          Libraries
194 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
195 Requires:       libcdio >= 0.71
196
197 %description -n gstreamer-cdio
198 Plugin for playing audio tracks using libcdio under GStreamer.
199
200 %description -n gstreamer-cdio -l pl.UTF-8
201 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
202 libcdio.
203
204 %package -n gstreamer-dv
205 Summary:        GStreamer dv plugin
206 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
207 Group:          Libraries
208 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
209
210 %description -n gstreamer-dv
211 Plugin for digital video support.
212
213 %description -n gstreamer-dv -l pl.UTF-8
214 Wtyczka do GStreamera obsługująca cyfrowy obraz.
215
216 %package -n gstreamer-audiosink-esd
217 Summary:        GStreamer plugin for ESD sound output
218 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku ESD do GStreamera
219 Group:          Libraries
220 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
221 Provides:       gstreamer-audiosink = %{version}
222 Obsoletes:      gstreamer-esound
223
224 %description -n gstreamer-audiosink-esd
225 Output plugin for GStreamer for use with the esound package.
226
227 %description -n gstreamer-audiosink-esd -l pl.UTF-8
228 Wtyczka wyjścia dźwięku ESD (esound) dla GStreamera.
229
230 %package -n gstreamer-flac
231 Summary:        GStreamer plugin for FLAC lossless audio format
232 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
233 Group:          Libraries
234 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
235
236 %description -n gstreamer-flac
237 Plugin for the free FLAC lossless audio format.
238
239 %description -n gstreamer-flac -l pl.UTF-8
240 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
241
242 %package -n gstreamer-gdkpixbuf
243 Summary:        GStreamer images input plugin
244 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
245 Group:          Libraries
246 Requires:       gstreamer >= %{gst_req_ver}
247
248 %description -n gstreamer-gdkpixbuf
249 This GStreamer plugin load images via gdkpixbuf library.
250
251 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
252 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
253 gdkpixbuf.
254
255 %package -n gstreamer-hal
256 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
257 Summary(pl.UTF-8):      Wtyczka GStreamera spinająca urządzenia wejścia/wyjścia dźwięku z HAL-em
258 Group:          Libraries
259 Requires:       gstreamer >= %{gst_req_ver}
260
261 %description -n gstreamer-hal
262 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
263
264 %description -n gstreamer-hal -l pl.UTF-8
265 Wtyczka GStreamera spinająca urządzenia wejścia/wyjścia dźwięku między
266 GStreamerem a HAL-em.
267
268 %package -n gstreamer-ladspa
269 Summary:        GStreamer wrapper for LADSPA plugins
270 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
271 Group:          Libraries
272 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
273
274 %description -n gstreamer-ladspa
275 Plugin which wraps LADSPA plugins for use by GStreamer applications.
276
277 %description -n gstreamer-ladspa -l pl.UTF-8
278 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
279 GStreamera.
280
281 %package -n gstreamer-videosink-libcaca
282 Summary:        GStreamer plugin for libcaca Ascii-art output
283 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
284 Group:          Libraries
285 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
286 Provides:       gstreamer-videosink = %{version}
287
288 %description -n gstreamer-videosink-libcaca
289 GStreamer plug-in for libcaca Ascii-art output.
290
291 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
292 Wtyczka libcaca do GStreamera.
293
294 %package -n gstreamer-libpng
295 Summary:        GStreamer plugin to encode png images
296 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
297 Group:          Libraries
298 #Requires:      gstreamer >= %{gst_req_ver}
299 # for locales
300 Requires:       %{name} = %{version}-%{release}
301 Requires:       libpng >= 1.2.0
302
303 %description -n gstreamer-libpng
304 Plugin for encoding png images.
305
306 %description -n gstreamer-libpng -l pl.UTF-8
307 Wtyczka kodująca pliki png.
308
309 %package -n gstreamer-audiosink-oss
310 Summary:        GStreamer plugins for input and output using OSS
311 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
312 Group:          Libraries
313 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
314 # for locales
315 Requires:       %{name} = %{version}-%{release}
316 Provides:       gstreamer-audiosink = %{version}
317 Obsoletes:      gstreamer-oss
318
319 %description -n gstreamer-audiosink-oss
320 Plugins for output and input to the OpenSoundSystem audio drivers
321 found in the Linux kernels or commercially available from OpenSound.
322
323 %description -n gstreamer-audiosink-oss -l pl.UTF-8
324 Wtyczki wyjścia i wejścia dźwięku używające sterowników
325 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
326 od OpenSound.
327
328 %package -n gstreamer-raw1394
329 Summary:        GStreamer raw1394 Firewire plugin
330 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
331 Group:          Libraries
332 Requires:       gstreamer >= %{gst_req_ver}
333
334 %description -n gstreamer-raw1394
335 Plugin for digital video support using raw1394.
336
337 %description -n gstreamer-raw1394 -l pl.UTF-8
338 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
339
340 %package -n gstreamer-shout2
341 Summary:        GStreamer plugin for communicating with Shoutcast servers
342 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
343 Group:          Libraries
344 Requires:       gstreamer >= %{gst_req_ver}
345
346 %description -n gstreamer-shout2
347 GStreamer plugin for communicating with Shoutcast servers.
348
349 %description -n gstreamer-shout2 -l pl.UTF-8
350 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
351
352 %package -n gstreamer-speex
353 Summary:        GStreamer speex codec decoder/encoder plugin
354 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
355 Group:          Libraries
356 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
357 Requires:       speex >= 1:1.1.6
358
359 %description -n gstreamer-speex
360 GStreamer speex codec decoder/encoder plugin.
361
362 %description -n gstreamer-speex -l pl.UTF-8
363 Wtyczka do GStreamera obsługująca kodek Speex.
364
365 %package -n gstreamer-taglib
366 Summary:        GStreamer tag writing plugin based on taglib
367 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
368 Group:          Libraries
369 Requires:       gstreamer >= %{gst_req_ver}
370
371 %description -n gstreamer-taglib
372 GStreamer tag writing plugin based on taglib.
373
374 %description -n gstreamer-taglib -l pl.UTF-8
375 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
376
377 %package -n gstreamer-video-effects
378 Summary:        GStreamer video effects plugins
379 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
380 Group:          Libraries
381 # for locales in jpeg module
382 Requires:       %{name} = %{version}-%{release}
383
384 %description -n gstreamer-video-effects
385 GStreamer video effects plugins.
386
387 %description -n gstreamer-video-effects -l pl.UTF-8
388 Wtyczki efektów wideo do GStreamera.
389
390 %package -n gstreamer-visualisation
391 Summary:        GStreamer visualisations plugins
392 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
393 Group:          Libraries
394 Requires:       gstreamer >= %{gst_req_ver}
395
396 %description -n gstreamer-visualisation
397 Various plugins for visual effects to use with audio. Included are
398 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
399
400 %description -n gstreamer-visualisation -l pl.UTF-8
401 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
402 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
403
404 %package -n gstreamer-ximagesrc
405 Summary:        GStreamer X11 video input plugin using standard Xlib calls
406 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
407 Group:          Libraries
408 Requires:       %{name} = %{version}-%{release}
409
410 %description -n gstreamer-ximagesrc
411 GStreamer X11 video input plugin using standard Xlib calls.
412
413 %description -n gstreamer-ximagesrc -l pl.UTF-8
414 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
415 Xlib.
416
417 %prep
418 %setup -q -n %{gstname}-%{version}
419 %patch0 -p1
420 %patch1 -p1
421 %patch2 -p1
422
423 %build
424 %{__libtoolize}
425 %{__aclocal} -I m4 -I common/m4
426 %{__autoconf}
427 %{__autoheader}
428 %{__automake}
429 %configure \
430         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
431         %{!?with_aalib:--disable-aalib} \
432         %{!?with_caca:--disable-libcaca} \
433         %{!?with_cairo:--disable-cairo} \
434         %{!?with_cdio:--disable-cdio} \
435         --enable-experimental \
436         %{?with_ladspa:--enable-ladspa} \
437         %{!?with_speex:--disable-speex} \
438         --disable-static \
439         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
440         --with-html-dir=%{_gtkdocdir}
441
442 %{__make}
443
444 %install
445 rm -rf $RPM_BUILD_ROOT
446
447 %{__make} install \
448         DESTDIR=$RPM_BUILD_ROOT
449
450 # We don't need plugins' *.la files
451 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
452
453 %find_lang %{gstname}-%{gst_major_ver}
454
455 %clean
456 rm -rf $RPM_BUILD_ROOT
457
458 %post   -n gstreamer-GConf
459 %gconf_schema_install gstreamer-0.10.schemas
460
461 %preun  -n gstreamer-GConf
462 %gconf_schema_uninstall gstreamer-0.10.schemas
463
464 %files -f %{gstname}-%{gst_major_ver}.lang
465 %defattr(644,root,root,755)
466 %doc AUTHORS ChangeLog NEWS README RELEASE 
467 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
468 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
469 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
470 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
471 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
472 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
473 %attr(755,root,root) %{gstlibdir}/libgstavi.so
474 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
475 %attr(755,root,root) %{gstlibdir}/libgstefence.so
476 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
477 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
478 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
479 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
480 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
481 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
482 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
483 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
484 %attr(755,root,root) %{gstlibdir}/libgstudp.so
485 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
486 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
487 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
488 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
489
490 %if %{with apidocs}
491 %files apidocs
492 %defattr(644,root,root,755)
493 %{_gtkdocdir}/gst-plugins-good-plugins-*
494 %endif
495
496 %if %{with gconf}
497 %files -n gstreamer-GConf
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
500 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
501 %endif
502
503 ##
504 ## Plugins
505 ##
506
507 %if %{with aalib}
508 %files -n gstreamer-videosink-aa
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
511 %endif
512
513 %files -n gstreamer-audio-effects-good
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
516 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
517 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
518 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
519
520 %files -n gstreamer-audio-formats
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
523 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
524 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
525
526 %if %{with cairo}
527 %files -n gstreamer-cairo
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
530 %endif
531
532 %if %{with cdio}
533 %files -n gstreamer-cdio
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
536 %endif
537
538 %files -n gstreamer-dv
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{gstlibdir}/libgstdv.so
541
542 %files -n gstreamer-audiosink-esd
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{gstlibdir}/libgstesd.so
545
546 %files -n gstreamer-flac
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{gstlibdir}/libgstflac.so
549
550 %files -n gstreamer-gdkpixbuf
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
553
554 %files -n gstreamer-hal
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
557
558 # disabled in ext/Makefile.am, currently built in plugins-bad
559 #%if %{with ladspa}
560 #%files -n gstreamer-ladspa
561 #%defattr(644,root,root,755)
562 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
563 #%endif
564
565 %if %{with caca}
566 %files -n gstreamer-videosink-libcaca
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
569 %endif
570
571 %files -n gstreamer-libpng
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{gstlibdir}/libgstpng.so
574
575 %files -n gstreamer-audiosink-oss
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
578
579 %files -n gstreamer-raw1394
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{gstlibdir}/libgst1394.so
582
583 %files -n gstreamer-shout2
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
586
587 %if %{with speex}
588 %files -n gstreamer-speex
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
591 %endif
592
593 %files -n gstreamer-taglib
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
596
597 %files -n gstreamer-video-effects
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
600 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
601 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
602 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
603
604 %files -n gstreamer-visualisation
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
607
608 %files -n gstreamer-ximagesrc
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.076863 seconds and 4 git commands to generate.