]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- removed unused gstincludedir macro
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  gconf           # don't build GConf plugin
7 %bcond_without  ladspa          # don't build ladspa plugin
8 %bcond_without  speex           # don't build speex plugin
9 #
10 %define         gstname         gst-plugins-good
11 %define         gst_major_ver   0.10
12 %define         gst_req_ver     0.10.1
13 #
14 Summary:        Good GStreamer Streaming-media framework plugins
15 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
16 Name:           gstreamer-plugins-good
17 Version:        0.10.1
18 Release:        0.1
19 License:        LGPL
20 Group:          Libraries
21 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
22 # Source0-md5:  be5ba72454a1df6e4e6d5deeeec88e59
23 Patch0:         %{name}-bashish.patch
24 Patch1:         %{name}-libcaca.patch
25 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.0}
26 BuildRequires:  autoconf >= 2.52
27 BuildRequires:  automake >= 1.5
28 BuildRequires:  glib2-devel >= 1:2.6.0
29 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
30 BuildRequires:  gstreamer-plugins-base-devel >= %{gst_req_ver}
31 BuildRequires:  gtk-doc >= 1.3
32 BuildRequires:  gtk+2-devel >= 2:2.2.0
33 BuildRequires:  liboil-devel >= 0.3.2
34 BuildRequires:  libtool >= 1.4
35 BuildRequires:  pkgconfig >= 1:0.9.0
36 ##
37 ## plugins
38 ##
39 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
40 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0.0}
41 BuildRequires:  esound-devel >= 0.2.12
42 BuildRequires:  flac-devel >= 1.1.2
43 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
44 BuildRequires:  libavc1394-devel
45 %{?with_caca:BuildRequires:     libcaca-devel}
46 BuildRequires:  libdv-devel >= 0.104
47 BuildRequires:  libjpeg-devel
48 BuildRequires:  libpng-devel >= 1.2.0
49 BuildRequires:  libraw1394-devel
50 BuildRequires:  libshout-devel >= 2.0
51 BuildRequires:  rpmbuild(macros) >= 1.198
52 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
53 BuildRequires:  zlib-devel
54 Requires:       gstreamer >= %{gst_req_ver}
55 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
56 Obsoletes:      gstreamer-avi
57 Obsoletes:      gstreamer-flx
58 Obsoletes:      gstreamer-matroska
59 Obsoletes:      gstreamer-mixer
60 Obsoletes:      gstreamer-navigation
61 Obsoletes:      gstreamer-rtp
62 Obsoletes:      gstreamer-udp
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
66
67 %description
68 GStreamer is a streaming-media framework, based on graphs of filters
69 which operate on media data. Applications using this library can do
70 anything from real-time sound processing to playing videos, and just
71 about anything else media-related. Its plugin-based architecture means
72 that new data types or processing capabilities can be added simply by
73 installing new plugins.
74
75 %description -l pl
76 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
77 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
78 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
79 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
80 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
81 nowych typów danych lub mo¿liwo¶ci obróbki.
82
83 %package -n gstreamer-GConf
84 Summary:        GStreamer GConf schemas
85 Summary(pl):    Schematy GConf GStreamera
86 Group:          Libraries
87 Requires(post,preun):   GConf2
88 Requires:       gstreamer >= %{gst_req_ver}
89 Obsoletes:      gstreamer-GConf-devel
90
91 %description -n gstreamer-GConf
92 Installation of GStreamer GConf schemas. These set usable defaults
93 used by all GStreamer-enabled GNOME applications.
94
95 %description -n gstreamer-GConf -l pl
96 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
97 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
98
99 ##
100 ## Plugins
101 ##
102
103 %package -n gstreamer-videosink-aa
104 Summary:        GStreamer plugin for Ascii-art output
105 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
106 Group:          Libraries
107 Requires:       gstreamer >= %{gst_req_ver}
108 Provides:       gstreamer-videosink = %{version}
109 Obsoletes:      gstreamer-aalib
110
111 %description -n gstreamer-videosink-aa
112 Plugin for viewing movies in Ascii-art using aalib library.
113
114 %description -n gstreamer-videosink-aa -l pl
115 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
116
117 %package -n gstreamer-audio-effects-good
118 Summary:        Good GStreamer audio effects plugins
119 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
120 Group:          Libraries
121 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
122 Obsoletes:      gstreamer-audio-effects
123
124 %description -n gstreamer-audio-effects-good
125 Good GStreamer audio effects plugins.
126
127 %description -n gstreamer-audio-effects-good -l pl
128 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
129
130 %package -n gstreamer-audio-formats
131 Summary:        GStreamer audio format plugins
132 Summary(pl):    Wtyczki formatów d¼wiêku
133 Group:          Libraries
134 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
135 # for locales in wavparse module
136 Requires:       %{name} = %{version}-%{release}
137
138 %description -n gstreamer-audio-formats
139 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
140
141 %description -n gstreamer-audio-formats -l pl
142 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
143
144 %package -n gstreamer-cairo
145 Summary:        GStreamer cairo plugin
146 Summary(pl):    Wtyczka cairo do GStreamera
147 Group:          Libraries
148 Requires:       gstreamer >= %{gst_req_ver}
149
150 %description -n gstreamer-cairo
151 GStreamer cairo plugin.
152
153 %description -n gstreamer-cairo -l pl
154 Wtyczka cairo do GStreamera.
155
156 %package -n gstreamer-dv
157 Summary:        GStreamer dv plugin
158 Summary(pl):    Wtyczka dv do GStreamera
159 Group:          Libraries
160 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
161
162 %description -n gstreamer-dv
163 Plugin for digital video support.
164
165 %description -n gstreamer-dv -l pl
166 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
167
168 %package -n gstreamer-audiosink-esd
169 Summary:        GStreamer plugin for ESD sound output
170 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
171 Group:          Libraries
172 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
173 Provides:       gstreamer-audiosink = %{version}
174 Obsoletes:      gstreamer-esound
175
176 %description -n gstreamer-audiosink-esd
177 Output plugin for GStreamer for use with the esound package.
178
179 %description -n gstreamer-audiosink-esd -l pl
180 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
181
182 %package -n gstreamer-flac
183 Summary:        GStreamer plugin for FLAC lossless audio format
184 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
185 Group:          Libraries
186 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
187
188 %description -n gstreamer-flac
189 Plugin for the free FLAC lossless audio format.
190
191 %description -n gstreamer-flac -l pl
192 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
193
194 %package -n gstreamer-ladspa
195 Summary:        GStreamer wrapper for LADSPA plugins
196 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
197 Group:          Libraries
198 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
199
200 %description -n gstreamer-ladspa
201 Plugin which wraps LADSPA plugins for use by GStreamer applications.
202
203 %description -n gstreamer-ladspa -l pl
204 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
205 GStreamera.
206
207 %package -n gstreamer-videosink-libcaca
208 Summary:        GStreamer plugin for libcaca Ascii-art output
209 Summary(pl):    Wtyczka libcaca do GStreamera
210 Group:          Libraries
211 Requires:       gstreamer-plugins-base >= %{gst_req_ver}
212 Provides:       gstreamer-videosink = %{version}
213
214 %description -n gstreamer-videosink-libcaca
215 GStreamer plug-in for libcaca Ascii-art output.
216
217 %description -n gstreamer-videosink-libcaca -l pl
218 Wtyczka libcaca do GStreamera.
219
220 %package -n gstreamer-libpng
221 Summary:        GStreamer plugin to encode png images
222 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
223 Group:          Libraries
224 #Requires:      gstreamer >= %{gst_req_ver}
225 # for locales
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       libpng >= 1.2.0
228
229 %description -n gstreamer-libpng
230 Plugin for encoding png images.
231
232 %description -n gstreamer-libpng -l pl
233 Wtyczka koduj±ca pliki png.
234
235 %package -n gstreamer-audiosink-oss
236 Summary:        GStreamer plugins for input and output using OSS
237 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
238 Group:          Libraries
239 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
240 # for locales
241 Requires:       %{name} = %{version}-%{release}
242 Provides:       gstreamer-audiosink = %{version}
243 Obsoletes:      gstreamer-oss
244
245 %description -n gstreamer-audiosink-oss
246 Plugins for output and input to the OpenSoundSystem audio drivers
247 found in the Linux kernels or commercially available from OpenSound.
248
249 %description -n gstreamer-audiosink-oss -l pl
250 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
251 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
252 od OpenSound.
253
254 %package -n gstreamer-raw1394
255 Summary:        GStreamer raw1394 Firewire plugin
256 Summary(pl):    Wtyczka FireWire dla GStreamera
257 Group:          Libraries
258 Requires:       gstreamer >= %{gst_req_ver}
259
260 %description -n gstreamer-raw1394
261 Plugin for digital video support using raw1394.
262
263 %description -n gstreamer-raw1394 -l pl
264 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
265
266 %package -n gstreamer-shout2
267 Summary:        GStreamer plugin for communicating with Shoutcast servers
268 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
269 Group:          Libraries
270 Requires:       gstreamer >= %{gst_req_ver}
271
272 %description -n gstreamer-shout2
273 GStreamer plugin for communicating with Shoutcast servers.
274
275 %description -n gstreamer-shout2 -l pl
276 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
277
278 %package -n gstreamer-speex
279 Summary:        GStreamer speex codec decoder/encoder plugin
280 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
281 Group:          Libraries
282 #Requires:      gstreamer-plugins-base >= %{gst_req_ver}
283 Requires:       speex >= 1:1.1.6
284
285 %description -n gstreamer-speex
286 GStreamer speex codec decoder/encoder plugin.
287
288 %description -n gstreamer-speex -l pl
289 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
290
291 %package -n gstreamer-video-effects
292 Summary:        GStreamer video effects plugins
293 Summary(pl):    Wtyczki efektów wideo do GStreamera
294 Group:          Libraries
295 # for locales in jpeg module
296 Requires:       %{name} = %{version}-%{release}
297
298 %description -n gstreamer-video-effects
299 GStreamer video effects plugins.
300
301 %description -n gstreamer-video-effects -l pl
302 Wtyczki efektów wideo do GStreamera.
303
304 %package -n gstreamer-visualisation
305 Summary:        GStreamer visualisations plugins
306 Summary(pl):    Wtyczki wizualizacji do GStreamera
307 Group:          Libraries
308 Requires:       gstreamer >= %{gst_req_ver}
309
310 %description -n gstreamer-visualisation
311 Various plugins for visual effects to use with audio. Included are
312 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
313
314 %description -n gstreamer-visualisation -l pl
315 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
316 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
317
318 %prep
319 %setup -q -n %{gstname}-%{version}
320 %patch0 -p1
321 %patch1 -p1
322
323 %build
324 %{__libtoolize}
325 %{__aclocal} -I m4 -I common/m4
326 %{__autoconf}
327 %{__autoheader}
328 %{__automake}
329 %configure \
330         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
331         %{!?with_aalib:--disable-aalib} \
332         %{!?with_caca:--disable-libcaca} \
333         %{!?with_cairo:--disable-cairo} \
334         %{!?with_ladspa:--disable-ladspa} \
335         %{!?with_speex:--disable-speex} \
336         --disable-static \
337         --enable-gtk-doc \
338         --with-html-dir=%{_gtkdocdir}
339
340 %{__make}
341
342 %install
343 rm -rf $RPM_BUILD_ROOT
344
345 %{__make} install \
346         DESTDIR=$RPM_BUILD_ROOT
347
348 # We don't need plugins' *.la files
349 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
350
351 %find_lang %{gstname}-%{gst_major_ver}
352
353 %clean
354 rm -rf $RPM_BUILD_ROOT
355
356 %post   -n gstreamer-GConf
357 %gconf_schema_install gstreamer-0.10.schemas
358
359 %preun  -n gstreamer-GConf
360 %gconf_schema_uninstall gstreamer-0.10.schemas
361
362 %files -f %{gstname}-%{gst_major_ver}.lang
363 %defattr(644,root,root,755)
364 %doc AUTHORS ChangeLog NEWS README RELEASE 
365 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
366 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
367 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
368 %attr(755,root,root) %{gstlibdir}/libgstavi.so
369 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
370 %attr(755,root,root) %{gstlibdir}/libgstefence.so
371 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
372 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
373 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
374 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
375 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
376 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
377 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
378 %attr(755,root,root) %{gstlibdir}/libgstudp.so
379 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
380 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
381 %{_gtkdocdir}/gst-plugins-good-plugins-*
382
383 %if %{with gconf}
384 %files -n gstreamer-GConf
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
387 %{_sysconfdir}/gconf/schemas/*
388 %endif
389
390 ##
391 ## Plugins
392 ##
393
394 %if %{with aalib}
395 %files -n gstreamer-videosink-aa
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
398 %endif
399
400 %files -n gstreamer-audio-effects-good
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
403 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
404 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
405 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
406
407 %files -n gstreamer-audio-formats
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
410 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
411 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
412
413 %if %{with cairo}
414 %files -n gstreamer-cairo
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
417 %endif
418
419 %files -n gstreamer-dv
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{gstlibdir}/libgstdv.so
422
423 %files -n gstreamer-audiosink-esd
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{gstlibdir}/libgstesd.so
426
427 %files -n gstreamer-flac
428 %defattr(644,root,root,755)
429 %attr(755,root,root) %{gstlibdir}/libgstflac.so
430
431 #%if %{with ladspa}
432 #%files -n gstreamer-ladspa
433 #%defattr(644,root,root,755)
434 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
435 #%endif
436
437 %if %{with caca}
438 %files -n gstreamer-videosink-libcaca
439 %defattr(644,root,root,755)
440 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
441 %endif
442
443 %files -n gstreamer-libpng
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{gstlibdir}/libgstpng.so
446
447 %files -n gstreamer-audiosink-oss
448 %defattr(644,root,root,755)
449 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
450
451 %files -n gstreamer-raw1394
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{gstlibdir}/libgst1394.so
454
455 %files -n gstreamer-shout2
456 %defattr(644,root,root,755)
457 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
458
459 %if %{with speex}
460 %files -n gstreamer-speex
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
463 %endif
464
465 %files -n gstreamer-video-effects
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
468 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
469 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
470 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
471
472 %files -n gstreamer-visualisation
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
This page took 0.102109 seconds and 4 git commands to generate.