]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- updated to 1.16.2
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  aalib           # aa videosink plugin
5 %bcond_without  caca            # caca videosink plugin
6 %bcond_without  cairo           # cairo plugin
7 %bcond_without  gtk             # GTK+ (3.x) elements (video sink plugin)
8 %bcond_without  jack            # JACK audio plugin
9 %bcond_with     jack1           # JACK 1 (0.12x) instead of JACK 2 (1.9.x)
10 %bcond_without  lame            # LAME MP2/MP3 encoding plugin
11 %bcond_without  mpg123          # MPG123-based MP3 plugin
12 %bcond_without  qt              # Qt (5.x) elements (video sink plugin)
13 %bcond_without  soup            # libsoup (2.4 API) http source plugin
14 %bcond_without  speex           # speex plugin
15 %bcond_without  wavpack         # wavpack plugin
16
17 %define         gstname         gst-plugins-good
18 %define         gstmver         1.0
19 %define         gst_ver         1.16.2
20 %define         gstpb_ver       1.16.2
21
22 Summary:        Good GStreamer Streaming-media framework plugins
23 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
24 Name:           gstreamer-plugins-good
25 Version:        1.16.2
26 Release:        1
27 License:        LGPL v2+
28 Group:          Libraries
29 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.xz
30 # Source0-md5:  bd025f8f14974f94b75ac69a9d1b9c93
31 URL:            https://gstreamer.freedesktop.org/
32 BuildRequires:  autoconf >= 2.69
33 BuildRequires:  automake >= 1:1.14
34 BuildRequires:  docbook-dtd412-xml
35 BuildRequires:  gettext-tools >= 0.17
36 BuildRequires:  glib2-devel >= 1:2.40
37 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
38 BuildRequires:  glibc-localedb-all
39 %endif
40 BuildRequires:  gstreamer-devel >= %{gst_ver}
41 BuildRequires:  gstreamer-gl-devel >= %{gstpb_ver}
42 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
43 BuildRequires:  gtk+3-devel >= 3.0.0
44 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.12}
45 BuildRequires:  libtool >= 2:2.2.6
46 BuildRequires:  orc-devel >= 0.4.17
47 BuildRequires:  pkgconfig >= 1:0.9.0
48 BuildRequires:  python >= 2.1
49 BuildRequires:  rpmbuild(macros) >= 1.198
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 ##
53 ## plugins
54 ##
55 %{?with_qt:BuildRequires:       Qt5Core-devel >= 5.4.0}
56 %{?with_qt:BuildRequires:       Qt5Gui-devel >= 5.4.0}
57 %{?with_qt:BuildRequires:       Qt5Quick-devel >= 5.4.0}
58 %{?with_qt:BuildRequires:       Qt5Qml-devel >= 5.4.0}
59 %{?with_qt:BuildRequires:       Qt5X11Extras-devel >= 5.4.0}
60 %{?with_qt:BuildRequires:       Qt5WaylandClient-devel >= 5.4.0}
61 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
62 BuildRequires:  bzip2-devel
63 %{?with_cairo:BuildRequires:    cairo-devel >= 1.10.0}
64 %{?with_cairo:BuildRequires:    cairo-gobject-devel >= 1.10.0}
65 BuildRequires:  dbus-devel >= 0.91
66 BuildRequires:  flac-devel >= 1.1.4
67 BuildRequires:  gdk-pixbuf2-devel >= 2.8.0
68 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.15.0}
69 %if %{with jack}
70 %{?with_jack1:BuildRequires:    jack-audio-connection-kit-devel >= 0.120.1}
71 %{!?with_jack1:BuildRequires:   jack-audio-connection-kit-devel >= 1.9.7}
72 %endif
73 %{?with_lame:BuildRequires:     lame-libs-devel}
74 BuildRequires:  libavc1394-devel
75 %{?with_caca:BuildRequires:     libcaca-devel}
76 BuildRequires:  libdv-devel >= 0.104
77 BuildRequires:  libiec61883-devel >= 1.0.0
78 BuildRequires:  libjpeg-devel
79 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
80 BuildRequires:  libpng-devel >= 2:1.5.1
81 BuildRequires:  libraw1394-devel >= 2.0.0
82 BuildRequires:  libshout-devel >= 2.0
83 %{?with_soup:BuildRequires:     libsoup-devel >= 2.48}
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  libv4l-devel
86 BuildRequires:  libvpx-devel >= 1.8.0
87 BuildRequires:  pulseaudio-devel >= 2.0
88 %{?with_qt:BuildRequires:       qt5-build >= 5.4.0}
89 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
90 BuildRequires:  taglib-devel >= 1.5
91 %{?with_lame:BuildRequires:     twolame-devel >= 0.3.10}
92 BuildRequires:  udev-glib-devel >= 1:147
93 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.60.0}
94 BuildRequires:  xorg-lib-libX11-devel
95 BuildRequires:  xorg-lib-libXdamage-devel
96 BuildRequires:  xorg-lib-libXext-devel
97 BuildRequires:  xorg-lib-libXfixes-devel
98 BuildRequires:  zlib-devel
99 Requires:       glib2 >= 1:2.40
100 Requires:       gstreamer >= %{gst_ver}
101 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
102 Requires:       orc >= 0.4.17
103 Obsoletes:      gstreamer-avi
104 Obsoletes:      gstreamer-flx
105 Obsoletes:      gstreamer-matroska
106 Obsoletes:      gstreamer-mixer
107 Obsoletes:      gstreamer-navigation
108 Obsoletes:      gstreamer-oss4
109 Obsoletes:      gstreamer-rtp
110 Obsoletes:      gstreamer-udp
111 Conflicts:      gstreamer-plugins-bad < 0.10.19
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         gstlibdir       %{_libdir}/gstreamer-%{gstmver}
115
116 %description
117 GStreamer is a streaming-media framework, based on graphs of filters
118 which operate on media data. Applications using this library can do
119 anything from real-time sound processing to playing videos, and just
120 about anything else media-related. Its plugin-based architecture means
121 that new data types or processing capabilities can be added simply by
122 installing new plugins.
123
124 %description -l pl.UTF-8
125 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
126 grafie filtrów operujących na danych medialnych. Aplikacje używające
127 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
128 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
129 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
130 nowych typów danych lub możliwości obróbki.
131
132 %package apidocs
133 Summary:        Good GStreamer streaming-media framework plugins API documentation
134 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
135 Group:          Documentation
136 Requires:       gtk-doc-common
137 %if "%{_rpmversion}" >= "5"
138 BuildArch:      noarch
139 %endif
140
141 %description apidocs
142 Good GStreamer streaming-media framework plugins API documentation.
143
144 %description apidocs -l pl.UTF-8
145 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
146 GStreamer.
147
148 ## ## Plugins ##
149
150 %package -n gstreamer-videosink-aa
151 Summary:        GStreamer plugin for Ascii-art output
152 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
153 Group:          Libraries
154 Requires:       gstreamer >= %{gst_ver}
155 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
156 Provides:       gstreamer-videosink = %{version}
157 Obsoletes:      gstreamer-aalib
158
159 %description -n gstreamer-videosink-aa
160 Plugin for viewing movies in Ascii-art using aalib library.
161
162 %description -n gstreamer-videosink-aa -l pl.UTF-8
163 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
164
165 %package -n gstreamer-audio-effects-good
166 Summary:        Good GStreamer audio effects plugins
167 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
168 Group:          Libraries
169 Requires:       gstreamer >= %{gst_ver}
170 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
171 Obsoletes:      gstreamer-audio-effects
172
173 %description -n gstreamer-audio-effects-good
174 Good GStreamer audio effects plugins.
175
176 %description -n gstreamer-audio-effects-good -l pl.UTF-8
177 Dobre wtyczki efektów dźwiękowych do GStreamera.
178
179 %package -n gstreamer-audio-formats
180 Summary:        GStreamer audio format plugins
181 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
182 Group:          Libraries
183 Requires:       gstreamer >= %{gst_ver}
184 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
185 # for locales in wavparse module
186 Requires:       %{name} = %{version}-%{release}
187
188 %description -n gstreamer-audio-formats
189 Plugin for playback of WAV, au and mod audio files as well as MP3
190 type.
191
192 %description -n gstreamer-audio-formats -l pl.UTF-8
193 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
194
195 %package -n gstreamer-cairo
196 Summary:        GStreamer cairo plugin
197 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
198 Group:          Libraries
199 Requires:       cairo >= 1.10.0
200 Requires:       cairo-gobject >= 1.10.0
201 Requires:       gstreamer >= %{gst_ver}
202 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
203
204 %description -n gstreamer-cairo
205 GStreamer cairo plugin.
206
207 %description -n gstreamer-cairo -l pl.UTF-8
208 Wtyczka cairo do GStreamera.
209
210 %package -n gstreamer-dv
211 Summary:        GStreamer dv plugin
212 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
213 Group:          Libraries
214 Requires:       gstreamer >= %{gst_ver}
215 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
216 Requires:       libdv >= 0.104
217
218 %description -n gstreamer-dv
219 Plugin for digital video support.
220
221 %description -n gstreamer-dv -l pl.UTF-8
222 Wtyczka do GStreamera obsługująca cyfrowy obraz.
223
224 %package -n gstreamer-flac
225 Summary:        GStreamer plugin for FLAC lossless audio format
226 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
227 Group:          Libraries
228 Requires:       flac >= 1.1.4
229 Requires:       gstreamer >= %{gst_ver}
230 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
231
232 %description -n gstreamer-flac
233 Plugin for the free FLAC lossless audio format.
234
235 %description -n gstreamer-flac -l pl.UTF-8
236 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
237
238 %package -n gstreamer-gdkpixbuf
239 Summary:        GStreamer images input plugin
240 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
241 Group:          Libraries
242 Requires:       gdk-pixbuf2 >= 2.8.0
243 Requires:       gstreamer >= %{gst_ver}
244 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
245
246 %description -n gstreamer-gdkpixbuf
247 This GStreamer plugin load images via gdkpixbuf library.
248
249 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
250 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
251 gdkpixbuf.
252
253 %package -n gstreamer-videosink-gtk
254 Summary:        GStreamer GTK+ (3.x) output plugin
255 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera
256 Group:          Libraries
257 Requires:       gstreamer >= %{gst_ver}
258 Requires:       gstreamer-gl-libs >= %{gstpb_ver}
259 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
260 Requires:       gtk+3 >= 3.15.0
261 Provides:       gstreamer-videosink = %{version}
262
263 %description -n gstreamer-videosink-gtk
264 GStreamer GTK+ (3.x) output plugin.
265
266 %description -n gstreamer-videosink-gtk -l pl.UTF-8
267 Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera.
268
269 %package -n gstreamer-jack
270 Summary:        GStreamer plugin for the JACK Sound Server
271 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
272 Group:          Libraries
273 Requires:       gstreamer >= %{gst_ver}
274 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
275 %{?with_jack1:Requires: jack-audio-connection-kit-libs >= 0.120.1}
276 %{!?with_jack1:Requires:        jack-audio-connection-kit-libs >= 1.9.7}
277 # for locales
278 Requires:       %{name} = %{version}-%{release}
279 Provides:       gstreamer-audiosink = %{version}
280
281 %description -n gstreamer-jack
282 Plugin for the JACK professional sound server.
283
284 %description -n gstreamer-jack -l pl.UTF-8
285 Wtyczka dla profesjonalnego serwera dźwięku JACK.
286
287 %package -n gstreamer-videosink-libcaca
288 Summary:        GStreamer plugin for libcaca Ascii-art output
289 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
290 Group:          Libraries
291 Requires:       gstreamer >= %{gst_ver}
292 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
293 Provides:       gstreamer-videosink = %{version}
294
295 %description -n gstreamer-videosink-libcaca
296 GStreamer plug-in for libcaca Ascii-art output.
297
298 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
299 Wtyczka libcaca do GStreamera.
300
301 %package -n gstreamer-lame
302 Summary:        GStreamer plugin encoding MP3 songs
303 Summary(pl.UTF-8):      Wtyczka do GStreamera kodująca pliki MP3
304 Group:          Libraries
305 # for NLS
306 Requires:       %{name} = %{version}-%{release}
307 Requires:       gstreamer >= %{gst_ver}
308 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
309 Requires:       twolame-libs >= 0.3.10
310
311 %description -n gstreamer-lame
312 Plugin for encoding MP3 with lame.
313
314 %description -n gstreamer-lame -l pl.UTF-8
315 Wtyczka do GStreamera kodująca pliki MP3 przy użyciu lame.
316
317 %package -n gstreamer-mpg123
318 Summary:        GStreamer mpg123 plugin
319 Summary(pl.UTF-8):      Wtyczka mpg123 do GStreamera
320 Group:          Libraries
321 Requires:       gstreamer >= %{gst_ver}
322 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
323 Requires:       libmpg123 >= 1.14
324 # plugin obsoleted in 1.12.0, functionality in mpg123 plugin (or libav)
325 Obsoletes:      gstreamer-mad < 1.12.0
326
327 %description -n gstreamer-mpg123
328 GStreamer mpg123 plugin for MP3 playback.
329
330 %description -n gstreamer-mpg123 -l pl.UTF-8
331 Wtyczka mpg123 do GStreamera, odtwarzająca MP3.
332
333 %package -n gstreamer-libpng
334 Summary:        GStreamer plugin to encode png images
335 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
336 Group:          Libraries
337 Requires:       gstreamer >= %{gst_ver}
338 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
339 # for locales
340 Requires:       %{name} = %{version}-%{release}
341 Requires:       libpng >= 2:1.5.1
342
343 %description -n gstreamer-libpng
344 Plugin for encoding png images.
345
346 %description -n gstreamer-libpng -l pl.UTF-8
347 Wtyczka kodująca pliki png.
348
349 %package -n gstreamer-audiosink-oss
350 Summary:        GStreamer plugins for input and output using OSS
351 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
352 Group:          Libraries
353 Requires:       gstreamer >= %{gst_ver}
354 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
355 # for locales
356 Requires:       %{name} = %{version}-%{release}
357 Provides:       gstreamer-audiosink = %{version}
358 Obsoletes:      gstreamer-oss
359
360 %description -n gstreamer-audiosink-oss
361 Plugins for output and input to the OpenSoundSystem audio drivers
362 found in the Linux kernels or commercially available from OpenSound.
363
364 %description -n gstreamer-audiosink-oss -l pl.UTF-8
365 Wtyczki wyjścia i wejścia dźwięku używające sterowników
366 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
367 od OpenSound.
368
369 %package -n gstreamer-pulseaudio
370 Summary:        GStreamer plugin for PulseAudio sound server
371 Summary(pl.UTF-8):      Wtyczka GStreamera dla serwera dźwięku PulseAudio
372 Group:          Libraries
373 Requires:       gstreamer >= %{gst_ver}
374 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
375 Requires:       pulseaudio >= 2.0
376 # for locales
377 Requires:       %{name} = %{version}-%{release}
378 Provides:       gstreamer-audiosink = %{version}
379 Obsoletes:      gstreamer-audiosink-polypaudio
380 Obsoletes:      gstreamer-polypaudio
381
382 %description -n gstreamer-pulseaudio
383 GStreamer plugin for PulseAudio sound server.
384
385 %description -n gstreamer-pulseaudio -l pl.UTF-8
386 Wtyczka GStreamera dla serwera dźwięku PulseAudio.
387
388 %package -n gstreamer-videosink-qt
389 Summary:        GStreamer Qt (5.x) output plugin
390 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera
391 Group:          Libraries
392 Requires:       Qt5Core >= 5.4.0
393 Requires:       Qt5Gui >= 5.4.0
394 Requires:       Qt5Quick >= 5.4.0
395 Requires:       gstreamer >= %{gst_ver}
396 Requires:       gstreamer-gl-libs >= %{gstpb_ver}
397 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
398 Provides:       gstreamer-videosink = %{version}
399
400 %description -n gstreamer-videosink-qt
401 GStreamer Qt (5.x) output plugin.
402
403 %description -n gstreamer-videosink-qt -l pl.UTF-8
404 Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera.
405
406 %package -n gstreamer-raw1394
407 Summary:        GStreamer raw1394 Firewire plugin
408 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
409 Group:          Libraries
410 Requires:       gstreamer >= %{gst_ver}
411
412 %description -n gstreamer-raw1394
413 Plugin for digital video support using raw1394.
414
415 %description -n gstreamer-raw1394 -l pl.UTF-8
416 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
417
418 %package -n gstreamer-shout2
419 Summary:        GStreamer plugin for communicating with Shoutcast servers
420 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
421 Group:          Libraries
422 Requires:       gstreamer >= %{gst_ver}
423 # for locales
424 Requires:       %{name} = %{version}-%{release}
425
426 %description -n gstreamer-shout2
427 GStreamer plugin for communicating with Shoutcast servers.
428
429 %description -n gstreamer-shout2 -l pl.UTF-8
430 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
431
432 %package -n gstreamer-soup
433 Summary:        GStreamer Soup plugin
434 Summary(pl.UTF-8):      Wtyczka biblioteki Soup dla GStreamera
435 Group:          Libraries
436 Requires:       gstreamer >= %{gst_ver}
437 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
438 Requires:       libsoup >= 2.48
439 # for locales
440 Requires:       %{name} = %{version}-%{release}
441
442 %description -n gstreamer-soup
443 GStreamer Plugin for downloading files with Soup library.
444
445 %description -n gstreamer-soup -l pl.UTF-8
446 Wtyczka GStreamera umożliwiająca ściąganie plików za pomocą biblioteki
447 Soup.
448
449 %package -n gstreamer-speex
450 Summary:        GStreamer speex codec decoder/encoder plugin
451 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
452 Group:          Libraries
453 Requires:       gstreamer >= %{gst_ver}
454 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
455 Requires:       speex >= 1:1.1.6
456
457 %description -n gstreamer-speex
458 GStreamer speex codec decoder/encoder plugin.
459
460 %description -n gstreamer-speex -l pl.UTF-8
461 Wtyczka do GStreamera obsługująca kodek Speex.
462
463 %package -n gstreamer-taglib
464 Summary:        GStreamer tag writing plugin based on taglib
465 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
466 Group:          Libraries
467 Requires:       gstreamer >= %{gst_ver}
468 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
469 Requires:       taglib >= 1.5
470
471 %description -n gstreamer-taglib
472 GStreamer tag writing plugin based on taglib.
473
474 %description -n gstreamer-taglib -l pl.UTF-8
475 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
476
477 %package -n gstreamer-v4l2
478 Summary:        GStreamer Video4Linux2 input plugin
479 Summary(pl.UTF-8):      Wtyczka wejścia Video4Linux2 dla GStreamera
480 Group:          Libraries
481 Requires:       %{name} = %{version}-%{release}
482 Requires:       gstreamer >= %{gst_ver}
483 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
484 Requires:       udev-glib >= 1:147
485
486 %description -n gstreamer-v4l2
487 GStreamer plugin for accessing Video4Linux2 devices.
488
489 %description -n gstreamer-v4l2 -l pl.UTF-8
490 Wtyczka GStreamera pozwalająca na dostęp do urządzeń Video4Linux2.
491
492 %package -n gstreamer-video-effects
493 Summary:        GStreamer video effects plugins
494 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
495 Group:          Libraries
496 Requires:       gstreamer >= %{gst_ver}
497 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
498 # for locales in jpeg module
499 Requires:       %{name} = %{version}-%{release}
500
501 %description -n gstreamer-video-effects
502 GStreamer video effects plugins.
503
504 %description -n gstreamer-video-effects -l pl.UTF-8
505 Wtyczki efektów wideo do GStreamera.
506
507 %package -n gstreamer-visualisation
508 Summary:        GStreamer visualisations plugins
509 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
510 Group:          Libraries
511 Requires:       gstreamer >= %{gst_ver}
512 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
513
514 %description -n gstreamer-visualisation
515 Various plugins for visual effects to use with audio. Included are
516 monoscope, spectrum, goom (2k4) and goom2k1.
517
518 %description -n gstreamer-visualisation -l pl.UTF-8
519 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
520 monoscope, spectrum, goom (2k4) i goom2k1.
521
522 %package -n gstreamer-vpx
523 Summary:        GStreamer plugin for VP8/VP9 video format
524 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca format obrazu VP8/VP9
525 Group:          Libraries
526 Requires:       gstreamer >= %{gst_ver}
527 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
528 Requires:       libvpx >= 1.8.0
529 Obsoletes:      gstreamer-vp8
530
531 %description -n gstreamer-vpx
532 GStreamer plugin for VP8/VP9 video format using libvpx library.
533
534 %description -n gstreamer-vpx -l pl.UTF-8
535 Wtyczka do GStreamera obsługująca format obrazu VP8/VP9 przy użyciu
536 biblioteki libvpx.
537
538 %package -n gstreamer-wavpack
539 Summary:        GStreamer plugin for Wavpack lossless audio format
540 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
541 Group:          Libraries
542 Requires:       gstreamer >= %{gst_ver}
543 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
544 Requires:       wavpack-libs >= 4.60.0
545
546 %description -n gstreamer-wavpack
547 Plugin for lossless Wavpack audio format.
548
549 %description -n gstreamer-wavpack -l pl.UTF-8
550 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
551
552 %package -n gstreamer-ximagesrc
553 Summary:        GStreamer X11 video input plugin using standard Xlib calls
554 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
555 Group:          Libraries
556 Requires:       %{name} = %{version}-%{release}
557 Requires:       gstreamer >= %{gst_ver}
558 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
559
560 %description -n gstreamer-ximagesrc
561 GStreamer X11 video input plugin using standard Xlib calls.
562
563 %description -n gstreamer-ximagesrc -l pl.UTF-8
564 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
565 Xlib.
566
567 %prep
568 %setup -q -n %{gstname}-%{version}
569
570 %build
571 %{__libtoolize}
572 %{__aclocal} -I m4 -I common/m4
573 %{__autoconf}
574 %{__autoheader}
575 %{__automake}
576 %configure \
577         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
578         --disable-silent-rules \
579         --disable-static \
580         --enable-experimental \
581         %{!?with_aalib:--disable-aalib} \
582         %{!?with_cairo:--disable-cairo} \
583         %{!?with_gtk:--disable-gtk} \
584         %{!?with_jack:--disable-jack} \
585         %{!?with_lame:--disable-lame --disable-twolame} \
586         %{!?with_caca:--disable-libcaca} \
587         %{!?with_mpg123:--disable-mpg123} \
588         %{!?with_qt:--disable-qt} \
589         %{!?with_soup:--disable-soup} \
590         %{!?with_speex:--disable-speex} \
591         %{!?with_wavpack:--disable-wavpack} \
592         --enable-gtk-doc%{!?with_apidocs:=no} \
593         --enable-orc \
594         --with-html-dir=%{_gtkdocdir}
595
596 LC_ALL=C.UTF-8 \
597 %{__make}
598
599 %install
600 rm -rf $RPM_BUILD_ROOT
601
602 %{__make} install \
603         DESTDIR=$RPM_BUILD_ROOT
604
605 # We don't need plugins' *.la files
606 %{__rm} $RPM_BUILD_ROOT%{gstlibdir}/*.la
607
608 %find_lang %{gstname}-%{gstmver}
609
610 %clean
611 rm -rf $RPM_BUILD_ROOT
612
613 %files -f %{gstname}-%{gstmver}.lang
614 %defattr(644,root,root,755)
615 %doc AUTHORS ChangeLog NEWS README RELEASE
616 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
617 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
618 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
619 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
620 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
621 %attr(755,root,root) %{gstlibdir}/libgstavi.so
622 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
623 %attr(755,root,root) %{gstlibdir}/libgstdtmf.so
624 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
625 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
626 %attr(755,root,root) %{gstlibdir}/libgstflv.so
627 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
628 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
629 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
630 %attr(755,root,root) %{gstlibdir}/libgstimagefreeze.so
631 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
632 %attr(755,root,root) %{gstlibdir}/libgstisomp4.so
633 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
634 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
635 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
636 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
637 %attr(755,root,root) %{gstlibdir}/libgstoss4.so
638 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
639 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
640 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
641 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
642 %attr(755,root,root) %{gstlibdir}/libgstshapewipe.so
643 %attr(755,root,root) %{gstlibdir}/libgstudp.so
644 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
645 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
646 %attr(755,root,root) %{gstlibdir}/libgstvideofilter.so
647 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
648 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
649 %dir %{_datadir}/gstreamer-%{gstmver}
650 %{_datadir}/gstreamer-%{gstmver}/presets
651
652 %if %{with apidocs}
653 %files apidocs
654 %defattr(644,root,root,755)
655 %{_gtkdocdir}/gst-plugins-good-plugins-%{gstmver}
656 %endif
657
658 ##
659 ## Plugins
660 ##
661
662 %if %{with aalib}
663 %files -n gstreamer-videosink-aa
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
666 %endif
667
668 %files -n gstreamer-audio-effects-good
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
671 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
672 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
673 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
674
675 %files -n gstreamer-audio-formats
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
678 %attr(755,root,root) %{gstlibdir}/libgstaudioparsers.so
679 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
680 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
681
682 %if %{with cairo}
683 %files -n gstreamer-cairo
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
686 %endif
687
688 %files -n gstreamer-dv
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{gstlibdir}/libgstdv.so
691
692 %files -n gstreamer-flac
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{gstlibdir}/libgstflac.so
695
696 %files -n gstreamer-gdkpixbuf
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
699
700 %if %{with gtk}
701 %files -n gstreamer-videosink-gtk
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{gstlibdir}/libgstgtk.so
704 %endif
705
706 %if %{with jack}
707 %files -n gstreamer-jack
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{gstlibdir}/libgstjack.so
710 %endif
711
712 %if %{with caca}
713 %files -n gstreamer-videosink-libcaca
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
716 %endif
717
718 %files -n gstreamer-lame
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{gstlibdir}/libgstlame.so
721 %attr(755,root,root) %{gstlibdir}/libgsttwolame.so
722
723 %if %{with mpg123}
724 %files -n gstreamer-mpg123
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{gstlibdir}/libgstmpg123.so
727 %endif
728
729 %files -n gstreamer-libpng
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{gstlibdir}/libgstpng.so
732
733 %files -n gstreamer-audiosink-oss
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
736
737 %files -n gstreamer-pulseaudio
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{gstlibdir}/libgstpulseaudio.so
740
741 %if %{with qt}
742 %files -n gstreamer-videosink-qt
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{gstlibdir}/libgstqmlgl.so
745 %endif
746
747 %files -n gstreamer-raw1394
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{gstlibdir}/libgst1394.so
750
751 %files -n gstreamer-shout2
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
754
755 %if %{with soup}
756 %files -n gstreamer-soup
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{gstlibdir}/libgstsoup.so
759 %endif
760
761 %if %{with speex}
762 %files -n gstreamer-speex
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
765 %endif
766
767 %files -n gstreamer-taglib
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
770
771 %files -n gstreamer-v4l2
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
774
775 %files -n gstreamer-video-effects
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
778 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
779 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
780
781 %files -n gstreamer-visualisation
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
784 %attr(755,root,root) %{gstlibdir}/libgstgoom2k1.so
785 %attr(755,root,root) %{gstlibdir}/libgstmonoscope.so
786 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
787
788 %files -n gstreamer-vpx
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{gstlibdir}/libgstvpx.so
791
792 %if %{with wavpack}
793 %files -n gstreamer-wavpack
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
796 %endif
797
798 %files -n gstreamer-ximagesrc
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.094668 seconds and 4 git commands to generate.