]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
ae684fe2164c82308318f2ed75c5dcdb6f20a8e8
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  cdio            # don't build cdio plugin
7 %bcond_without  gconf           # don't build GConf plugin
8 %bcond_with     ladspa          # build ladspa plugin [currently built in plugins-bad]
9 %bcond_without  speex           # don't build speex plugin
10 #
11 %define         gstname         gst-plugins-good
12 %define         gst_major_ver   0.10
13 %define         gst_req_ver     0.10.10.1
14 %define         gstpb_req_ver   0.10.10.1
15 #
16 Summary:        Good GStreamer Streaming-media framework plugins
17 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
18 Name:           gstreamer-plugins-good
19 Version:        0.10.5
20 Release:        1
21 License:        LGPL
22 Group:          Libraries
23 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
24 # Source0-md5:  c45fc9ace9feb4d3df32da0a6d262d84
25 Patch0:         %{name}-bashish.patch
26 Patch1:         %{name}-libcaca.patch
27 Patch2:         %{name}-flac.patch
28 URL:            http://gstreamer.freedesktop.org/
29 BuildRequires:  autoconf >= 2.59-9
30 BuildRequires:  automake >= 1.5
31 BuildRequires:  glib2-devel >= 1:2.12.1
32 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
33 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
34 BuildRequires:  gtk-doc >= 1.7
35 BuildRequires:  gtk+2-devel >= 2:2.10.1
36 BuildRequires:  liboil-devel >= 0.3.6
37 BuildRequires:  libtool >= 1.4
38 BuildRequires:  pkgconfig >= 1:0.9.0
39 BuildRequires:  python >= 2.1
40 BuildRequires:  python-PyXML
41 BuildRequires:  rpmbuild(macros) >= 1.198
42 ##
43 ## plugins
44 ##
45 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.14.0}
46 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
47 %{?with_cairo:BuildRequires:    cairo-devel >= 1.2.0}
48 BuildRequires:  dbus-devel >= 0.91
49 BuildRequires:  esound-devel >= 0.2.12
50 BuildRequires:  flac-devel >= 1.1.3
51 BuildRequires:  hal-devel >= 0.5.7.1
52 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
53 BuildRequires:  libavc1394-devel
54 %{?with_caca:BuildRequires:     libcaca-devel}
55 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
56 BuildRequires:  libdv-devel >= 0.104
57 BuildRequires:  libiec61883-devel >= 1.0.0
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libpng-devel >= 1.2.0
60 BuildRequires:  libraw1394-devel >= 1.2.1
61 BuildRequires:  libshout-devel >= 2.0
62 # for taglib
63 BuildRequires:  libstdc++-devel
64 BuildRequires:  libxml2-devel >= 1:2.6.26
65 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
66 BuildRequires:  taglib-devel >= 1.4
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXdamage-devel
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXfixes-devel
71 BuildRequires:  zlib-devel
72 Requires:       gstreamer >= %{gst_req_ver}
73 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
74 Obsoletes:      gstreamer-avi
75 Obsoletes:      gstreamer-flx
76 Obsoletes:      gstreamer-matroska
77 Obsoletes:      gstreamer-mixer
78 Obsoletes:      gstreamer-navigation
79 Obsoletes:      gstreamer-rtp
80 Obsoletes:      gstreamer-udp
81 Obsoletes:      gstreamer-v4l2
82 Conflicts:      gstreamer-plugins-bad < 0.10.4
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
86
87 %description
88 GStreamer is a streaming-media framework, based on graphs of filters
89 which operate on media data. Applications using this library can do
90 anything from real-time sound processing to playing videos, and just
91 about anything else media-related. Its plugin-based architecture means
92 that new data types or processing capabilities can be added simply by
93 installing new plugins.
94
95 %description -l pl
96 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
97 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
98 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
99 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
100 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
101 nowych typów danych lub mo¿liwo¶ci obróbki.
102
103 %package -n gstreamer-GConf
104 Summary:        GStreamer GConf schemas
105 Summary(pl):    Schematy GConf GStreamera
106 Group:          Libraries
107 Requires(post,preun):   GConf2
108 Requires:       gstreamer >= %{gst_req_ver}
109 Obsoletes:      gstreamer-GConf-devel
110
111 %description -n gstreamer-GConf
112 Installation of GStreamer GConf schemas. These set usable defaults
113 used by all GStreamer-enabled GNOME applications.
114
115 %description -n gstreamer-GConf -l pl
116 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
117 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
118
119 ##
120 ## Plugins
121 ##
122
123 %package -n gstreamer-videosink-aa
124 Summary:        GStreamer plugin for Ascii-art output
125 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
126 Group:          Libraries
127 Requires:       gstreamer >= %{gst_req_ver}
128 Provides:       gstreamer-videosink = %{version}
129 Obsoletes:      gstreamer-aalib
130
131 %description -n gstreamer-videosink-aa
132 Plugin for viewing movies in Ascii-art using aalib library.
133
134 %description -n gstreamer-videosink-aa -l pl
135 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
136
137 %package -n gstreamer-audio-effects-good
138 Summary:        Good GStreamer audio effects plugins
139 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
140 Group:          Libraries
141 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
142 Obsoletes:      gstreamer-audio-effects
143
144 %description -n gstreamer-audio-effects-good
145 Good GStreamer audio effects plugins.
146
147 %description -n gstreamer-audio-effects-good -l pl
148 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
149
150 %package -n gstreamer-audio-formats
151 Summary:        GStreamer audio format plugins
152 Summary(pl):    Wtyczki formatów d¼wiêku
153 Group:          Libraries
154 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
155 # for locales in wavparse module
156 Requires:       %{name} = %{version}-%{release}
157
158 %description -n gstreamer-audio-formats
159 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
160
161 %description -n gstreamer-audio-formats -l pl
162 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
163
164 %package -n gstreamer-cairo
165 Summary:        GStreamer cairo plugin
166 Summary(pl):    Wtyczka cairo do GStreamera
167 Group:          Libraries
168 Requires:       gstreamer >= %{gst_req_ver}
169
170 %description -n gstreamer-cairo
171 GStreamer cairo plugin.
172
173 %description -n gstreamer-cairo -l pl
174 Wtyczka cairo do GStreamera.
175
176 %package -n gstreamer-cdio
177 Summary:        GStreamer plugin for CD audio input using libcdio
178 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdio
179 Group:          Libraries
180 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
181 Requires:       libcdio >= 0.71
182
183 %description -n gstreamer-cdio
184 Plugin for playing audio tracks using libcdio under GStreamer.
185
186 %description -n gstreamer-cdio -l pl
187 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
188 libcdio.
189
190 %package -n gstreamer-dv
191 Summary:        GStreamer dv plugin
192 Summary(pl):    Wtyczka dv do GStreamera
193 Group:          Libraries
194 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
195
196 %description -n gstreamer-dv
197 Plugin for digital video support.
198
199 %description -n gstreamer-dv -l pl
200 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
201
202 %package -n gstreamer-audiosink-esd
203 Summary:        GStreamer plugin for ESD sound output
204 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
205 Group:          Libraries
206 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
207 Provides:       gstreamer-audiosink = %{version}
208 Obsoletes:      gstreamer-esound
209
210 %description -n gstreamer-audiosink-esd
211 Output plugin for GStreamer for use with the esound package.
212
213 %description -n gstreamer-audiosink-esd -l pl
214 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
215
216 %package -n gstreamer-flac
217 Summary:        GStreamer plugin for FLAC lossless audio format
218 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
219 Group:          Libraries
220 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
221
222 %description -n gstreamer-flac
223 Plugin for the free FLAC lossless audio format.
224
225 %description -n gstreamer-flac -l pl
226 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
227
228 %package -n gstreamer-gdkpixbuf
229 Summary:        GStreamer images input plugin
230 Summary(pl):    Wtyczka do GStreamera wczytuj±ca obrazki
231 Group:          Libraries
232 Requires:       gstreamer >= %{gst_req_ver}
233
234 %description -n gstreamer-gdkpixbuf
235 This GStreamer plugin load images via gdkpixbuf library.
236
237 %description -n gstreamer-gdkpixbuf -l pl
238 Ta wtyczka GStreamera wczytuje obrazki za po¶rednictwem biblioteki
239 gdkpixbuf.
240
241 %package -n gstreamer-hal
242 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
243 Summary(pl):    Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku z HAL-em
244 Group:          Libraries
245 Requires:       gstreamer >= %{gst_req_ver}
246
247 %description -n gstreamer-hal
248 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
249
250 %description -n gstreamer-hal -l pl
251 Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku miêdzy
252 GStreamerem a HAL-em.
253
254 %package -n gstreamer-ladspa
255 Summary:        GStreamer wrapper for LADSPA plugins
256 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
257 Group:          Libraries
258 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
259
260 %description -n gstreamer-ladspa
261 Plugin which wraps LADSPA plugins for use by GStreamer applications.
262
263 %description -n gstreamer-ladspa -l pl
264 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
265 GStreamera.
266
267 %package -n gstreamer-videosink-libcaca
268 Summary:        GStreamer plugin for libcaca Ascii-art output
269 Summary(pl):    Wtyczka libcaca do GStreamera
270 Group:          Libraries
271 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
272 Provides:       gstreamer-videosink = %{version}
273
274 %description -n gstreamer-videosink-libcaca
275 GStreamer plug-in for libcaca Ascii-art output.
276
277 %description -n gstreamer-videosink-libcaca -l pl
278 Wtyczka libcaca do GStreamera.
279
280 %package -n gstreamer-libpng
281 Summary:        GStreamer plugin to encode png images
282 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
283 Group:          Libraries
284 #Requires:      gstreamer >= %{gst_req_ver}
285 # for locales
286 Requires:       %{name} = %{version}-%{release}
287 Requires:       libpng >= 1.2.0
288
289 %description -n gstreamer-libpng
290 Plugin for encoding png images.
291
292 %description -n gstreamer-libpng -l pl
293 Wtyczka koduj±ca pliki png.
294
295 %package -n gstreamer-audiosink-oss
296 Summary:        GStreamer plugins for input and output using OSS
297 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
298 Group:          Libraries
299 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
300 # for locales
301 Requires:       %{name} = %{version}-%{release}
302 Provides:       gstreamer-audiosink = %{version}
303 Obsoletes:      gstreamer-oss
304
305 %description -n gstreamer-audiosink-oss
306 Plugins for output and input to the OpenSoundSystem audio drivers
307 found in the Linux kernels or commercially available from OpenSound.
308
309 %description -n gstreamer-audiosink-oss -l pl
310 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
311 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
312 od OpenSound.
313
314 %package -n gstreamer-raw1394
315 Summary:        GStreamer raw1394 Firewire plugin
316 Summary(pl):    Wtyczka FireWire dla GStreamera
317 Group:          Libraries
318 Requires:       gstreamer >= %{gst_req_ver}
319
320 %description -n gstreamer-raw1394
321 Plugin for digital video support using raw1394.
322
323 %description -n gstreamer-raw1394 -l pl
324 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
325
326 %package -n gstreamer-shout2
327 Summary:        GStreamer plugin for communicating with Shoutcast servers
328 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
329 Group:          Libraries
330 Requires:       gstreamer >= %{gst_req_ver}
331
332 %description -n gstreamer-shout2
333 GStreamer plugin for communicating with Shoutcast servers.
334
335 %description -n gstreamer-shout2 -l pl
336 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
337
338 %package -n gstreamer-speex
339 Summary:        GStreamer speex codec decoder/encoder plugin
340 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
341 Group:          Libraries
342 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
343 Requires:       speex >= 1:1.1.6
344
345 %description -n gstreamer-speex
346 GStreamer speex codec decoder/encoder plugin.
347
348 %description -n gstreamer-speex -l pl
349 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
350
351 %package -n gstreamer-taglib
352 Summary:        GStreamer tag writing plugin based on taglib
353 Summary(pl):    Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib
354 Group:          Libraries
355 Requires:       gstreamer >= %{gst_req_ver}
356
357 %description -n gstreamer-taglib
358 GStreamer tag writing plugin based on taglib.
359
360 %description -n gstreamer-taglib -l pl
361 Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib.
362
363 %package -n gstreamer-video-effects
364 Summary:        GStreamer video effects plugins
365 Summary(pl):    Wtyczki efektów wideo do GStreamera
366 Group:          Libraries
367 # for locales in jpeg module
368 Requires:       %{name} = %{version}-%{release}
369
370 %description -n gstreamer-video-effects
371 GStreamer video effects plugins.
372
373 %description -n gstreamer-video-effects -l pl
374 Wtyczki efektów wideo do GStreamera.
375
376 %package -n gstreamer-visualisation
377 Summary:        GStreamer visualisations plugins
378 Summary(pl):    Wtyczki wizualizacji do GStreamera
379 Group:          Libraries
380 Requires:       gstreamer >= %{gst_req_ver}
381
382 %description -n gstreamer-visualisation
383 Various plugins for visual effects to use with audio. Included are
384 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
385
386 %description -n gstreamer-visualisation -l pl
387 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
388 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
389
390 %package -n gstreamer-ximagesrc
391 Summary:        GStreamer X11 video input plugin using standard Xlib calls
392 Summary(pl):    Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ Xlib
393 Group:          Libraries
394 Requires:       %{name} = %{version}-%{release}
395
396 %description -n gstreamer-ximagesrc
397 GStreamer X11 video input plugin using standard Xlib calls.
398
399 %description -n gstreamer-ximagesrc -l pl
400 Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ
401 Xlib.
402
403 %prep
404 %setup -q -n %{gstname}-%{version}
405 %patch0 -p1
406 %patch1 -p1
407 %patch2 -p1
408
409 %build
410 %{__libtoolize}
411 %{__aclocal} -I m4 -I common/m4
412 %{__autoconf}
413 %{__autoheader}
414 %{__automake}
415 %configure \
416         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
417         %{!?with_aalib:--disable-aalib} \
418         %{!?with_caca:--disable-libcaca} \
419         %{!?with_cairo:--disable-cairo} \
420         %{!?with_cdio:--disable-cdio} \
421         --enable-experimental \
422         %{?with_ladspa:--enable-ladspa} \
423         %{!?with_speex:--disable-speex} \
424         --disable-static \
425         --enable-gtk-doc \
426         --with-html-dir=%{_gtkdocdir}
427
428 %{__make}
429
430 %install
431 rm -rf $RPM_BUILD_ROOT
432
433 %{__make} install \
434         DESTDIR=$RPM_BUILD_ROOT
435
436 # We don't need plugins' *.la files
437 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
438
439 %find_lang %{gstname}-%{gst_major_ver}
440
441 %clean
442 rm -rf $RPM_BUILD_ROOT
443
444 %post   -n gstreamer-GConf
445 %gconf_schema_install gstreamer-0.10.schemas
446
447 %preun  -n gstreamer-GConf
448 %gconf_schema_uninstall gstreamer-0.10.schemas
449
450 %files -f %{gstname}-%{gst_major_ver}.lang
451 %defattr(644,root,root,755)
452 %doc AUTHORS ChangeLog NEWS README RELEASE 
453 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
454 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
455 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
456 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
457 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
458 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
459 %attr(755,root,root) %{gstlibdir}/libgstavi.so
460 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
461 %attr(755,root,root) %{gstlibdir}/libgstefence.so
462 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
463 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
464 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
465 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
466 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
467 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
468 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
469 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
470 %attr(755,root,root) %{gstlibdir}/libgstudp.so
471 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
472 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
473 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
474 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
475 %{_gtkdocdir}/gst-plugins-good-plugins-*
476
477 %if %{with gconf}
478 %files -n gstreamer-GConf
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
481 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
482 %endif
483
484 ##
485 ## Plugins
486 ##
487
488 %if %{with aalib}
489 %files -n gstreamer-videosink-aa
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
492 %endif
493
494 %files -n gstreamer-audio-effects-good
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
497 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
498 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
499 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
500
501 %files -n gstreamer-audio-formats
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
504 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
505 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
506
507 %if %{with cairo}
508 %files -n gstreamer-cairo
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
511 %endif
512
513 %if %{with cdio}
514 %files -n gstreamer-cdio
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
517 %endif
518
519 %files -n gstreamer-dv
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{gstlibdir}/libgstdv.so
522
523 %files -n gstreamer-audiosink-esd
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{gstlibdir}/libgstesd.so
526
527 %files -n gstreamer-flac
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{gstlibdir}/libgstflac.so
530
531 %files -n gstreamer-gdkpixbuf
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
534
535 %files -n gstreamer-hal
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
538
539 # disabled in ext/Makefile.am, currently built in plugins-bad
540 #%if %{with ladspa}
541 #%files -n gstreamer-ladspa
542 #%defattr(644,root,root,755)
543 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
544 #%endif
545
546 %if %{with caca}
547 %files -n gstreamer-videosink-libcaca
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
550 %endif
551
552 %files -n gstreamer-libpng
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{gstlibdir}/libgstpng.so
555
556 %files -n gstreamer-audiosink-oss
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
559
560 %files -n gstreamer-raw1394
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{gstlibdir}/libgst1394.so
563
564 %files -n gstreamer-shout2
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
567
568 %if %{with speex}
569 %files -n gstreamer-speex
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
572 %endif
573
574 %files -n gstreamer-taglib
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
577
578 %files -n gstreamer-video-effects
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
581 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
582 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
583 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
584
585 %files -n gstreamer-visualisation
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
588
589 %files -n gstreamer-ximagesrc
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.083697 seconds and 2 git commands to generate.