]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
210ebfddbbc9445b3d4b40d3bf9155abd4b13ea6
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  cdio            # don't build cdio plugin
7 %bcond_without  gconf           # don't build GConf plugin
8 %bcond_without  ladspa          # don't build ladspa plugin
9 %bcond_without  speex           # don't build speex plugin
10 #
11 %define         gstname         gst-plugins-good
12 %define         gst_major_ver   0.10
13 %define         gst_req_ver     0.10.4.1
14 %define         gstpb_req_ver   0.10.5.1
15 #
16 Summary:        Good GStreamer Streaming-media framework plugins
17 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
18 Name:           gstreamer-plugins-good
19 Version:        0.10.3
20 Release:        2
21 License:        LGPL
22 Group:          Libraries
23 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
24 # Source0-md5:  a58bb825bd4b22412764f2a8d2f98b1c
25 Patch0:         %{name}-bashish.patch
26 Patch1:         %{name}-libcaca.patch
27 URL:            http://gstreamer.freedesktop.org/
28 BuildRequires:  autoconf >= 2.59-9
29 BuildRequires:  automake >= 1.5
30 BuildRequires:  glib2-devel >= 1:2.6.0
31 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
32 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
33 BuildRequires:  gtk-doc >= 1.3
34 BuildRequires:  gtk+2-devel >= 2:2.2.0
35 BuildRequires:  liboil-devel >= 0.3.2
36 BuildRequires:  libtool >= 1.4
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 ##
39 ## plugins
40 ##
41 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.0}
42 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
43 %{?with_cairo:BuildRequires:    cairo-devel >= 1.0.0}
44 BuildRequires:  dbus-devel >= 0.32
45 BuildRequires:  esound-devel >= 0.2.12
46 BuildRequires:  flac-devel >= 1.1.2
47 BuildRequires:  hal-devel >= 0.5.6
48 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
49 BuildRequires:  libavc1394-devel
50 %{?with_caca:BuildRequires:     libcaca-devel}
51 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
52 BuildRequires:  libdv-devel >= 0.104
53 BuildRequires:  libjpeg-devel
54 BuildRequires:  libpng-devel >= 1.2.0
55 BuildRequires:  libraw1394-devel
56 BuildRequires:  libshout-devel >= 2.0
57 # for taglib
58 BuildRequires:  libstdc++-devel
59 BuildRequires:  libxml2-devel >= 2.4.9
60 BuildRequires:  python-PyXML
61 BuildRequires:  rpmbuild(macros) >= 1.198
62 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
63 BuildRequires:  taglib-devel >= 1.4
64 BuildRequires:  xorg-lib-libX11-devel
65 BuildRequires:  xorg-lib-libXdamage-devel
66 BuildRequires:  xorg-lib-libXext-devel
67 BuildRequires:  xorg-lib-libXfixes-devel
68 BuildRequires:  zlib-devel
69 Requires:       gstreamer >= %{gst_req_ver}
70 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
71 Obsoletes:      gstreamer-avi
72 Obsoletes:      gstreamer-flx
73 Obsoletes:      gstreamer-matroska
74 Obsoletes:      gstreamer-mixer
75 Obsoletes:      gstreamer-navigation
76 Obsoletes:      gstreamer-rtp
77 Obsoletes:      gstreamer-udp
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
81
82 %description
83 GStreamer is a streaming-media framework, based on graphs of filters
84 which operate on media data. Applications using this library can do
85 anything from real-time sound processing to playing videos, and just
86 about anything else media-related. Its plugin-based architecture means
87 that new data types or processing capabilities can be added simply by
88 installing new plugins.
89
90 %description -l pl
91 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
92 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
93 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
94 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
95 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
96 nowych typów danych lub mo¿liwo¶ci obróbki.
97
98 %package -n gstreamer-GConf
99 Summary:        GStreamer GConf schemas
100 Summary(pl):    Schematy GConf GStreamera
101 Group:          Libraries
102 Requires(post,preun):   GConf2
103 Requires:       gstreamer >= %{gst_req_ver}
104 Obsoletes:      gstreamer-GConf-devel
105
106 %description -n gstreamer-GConf
107 Installation of GStreamer GConf schemas. These set usable defaults
108 used by all GStreamer-enabled GNOME applications.
109
110 %description -n gstreamer-GConf -l pl
111 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
112 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
113
114 ##
115 ## Plugins
116 ##
117
118 %package -n gstreamer-videosink-aa
119 Summary:        GStreamer plugin for Ascii-art output
120 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
121 Group:          Libraries
122 Requires:       gstreamer >= %{gst_req_ver}
123 Provides:       gstreamer-videosink = %{version}
124 Obsoletes:      gstreamer-aalib
125
126 %description -n gstreamer-videosink-aa
127 Plugin for viewing movies in Ascii-art using aalib library.
128
129 %description -n gstreamer-videosink-aa -l pl
130 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
131
132 %package -n gstreamer-audio-effects-good
133 Summary:        Good GStreamer audio effects plugins
134 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
135 Group:          Libraries
136 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
137 Obsoletes:      gstreamer-audio-effects
138
139 %description -n gstreamer-audio-effects-good
140 Good GStreamer audio effects plugins.
141
142 %description -n gstreamer-audio-effects-good -l pl
143 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
144
145 %package -n gstreamer-audio-formats
146 Summary:        GStreamer audio format plugins
147 Summary(pl):    Wtyczki formatów d¼wiêku
148 Group:          Libraries
149 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
150 # for locales in wavparse module
151 Requires:       %{name} = %{version}-%{release}
152
153 %description -n gstreamer-audio-formats
154 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
155
156 %description -n gstreamer-audio-formats -l pl
157 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
158
159 %package -n gstreamer-cairo
160 Summary:        GStreamer cairo plugin
161 Summary(pl):    Wtyczka cairo do GStreamera
162 Group:          Libraries
163 Requires:       gstreamer >= %{gst_req_ver}
164
165 %description -n gstreamer-cairo
166 GStreamer cairo plugin.
167
168 %description -n gstreamer-cairo -l pl
169 Wtyczka cairo do GStreamera.
170
171 %package -n gstreamer-cdio
172 Summary:        GStreamer plugin for CD audio input using libcdio
173 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdio
174 Group:          Libraries
175 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
176 Requires:       libcdio >= 0.71
177
178 %description -n gstreamer-cdio
179 Plugin for playing audio tracks using libcdio under GStreamer.
180
181 %description -n gstreamer-cdio -l pl
182 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
183 libcdio.
184
185 %package -n gstreamer-dv
186 Summary:        GStreamer dv plugin
187 Summary(pl):    Wtyczka dv do GStreamera
188 Group:          Libraries
189 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
190
191 %description -n gstreamer-dv
192 Plugin for digital video support.
193
194 %description -n gstreamer-dv -l pl
195 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
196
197 %package -n gstreamer-audiosink-esd
198 Summary:        GStreamer plugin for ESD sound output
199 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
200 Group:          Libraries
201 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
202 Provides:       gstreamer-audiosink = %{version}
203 Obsoletes:      gstreamer-esound
204
205 %description -n gstreamer-audiosink-esd
206 Output plugin for GStreamer for use with the esound package.
207
208 %description -n gstreamer-audiosink-esd -l pl
209 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
210
211 %package -n gstreamer-flac
212 Summary:        GStreamer plugin for FLAC lossless audio format
213 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
214 Group:          Libraries
215 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
216
217 %description -n gstreamer-flac
218 Plugin for the free FLAC lossless audio format.
219
220 %description -n gstreamer-flac -l pl
221 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
222
223 %package -n gstreamer-gdkpixbuf
224 Summary:        GStreamer images input plugin
225 Summary(pl):    Wtyczka do GStreamera wczytuj±ca obrazki
226 Group:          Libraries
227 Requires:       gstreamer >= %{gst_req_ver}
228
229 %description -n gstreamer-gdkpixbuf
230 This GStreamer plugin load images via gdkpixbuf library.
231
232 %description -n gstreamer-gdkpixbuf -l pl
233 Ta wtyczka GStreamera wczytuje obrazki za po¶rednictwem biblioteki
234 gdkpixbuf.
235
236 %package -n gstreamer-hal
237 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
238 Summary(pl):    Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku z HAL-em
239 Group:          Libraries
240 Requires:       gstreamer >= %{gst_req_ver}
241
242 %description -n gstreamer-hal
243 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
244
245 %description -n gstreamer-hal -l pl
246 Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku miêdzy
247 GStreamerem a HAL-em.
248
249 %package -n gstreamer-ladspa
250 Summary:        GStreamer wrapper for LADSPA plugins
251 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
252 Group:          Libraries
253 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
254
255 %description -n gstreamer-ladspa
256 Plugin which wraps LADSPA plugins for use by GStreamer applications.
257
258 %description -n gstreamer-ladspa -l pl
259 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
260 GStreamera.
261
262 %package -n gstreamer-videosink-libcaca
263 Summary:        GStreamer plugin for libcaca Ascii-art output
264 Summary(pl):    Wtyczka libcaca do GStreamera
265 Group:          Libraries
266 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
267 Provides:       gstreamer-videosink = %{version}
268
269 %description -n gstreamer-videosink-libcaca
270 GStreamer plug-in for libcaca Ascii-art output.
271
272 %description -n gstreamer-videosink-libcaca -l pl
273 Wtyczka libcaca do GStreamera.
274
275 %package -n gstreamer-libpng
276 Summary:        GStreamer plugin to encode png images
277 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
278 Group:          Libraries
279 #Requires:      gstreamer >= %{gst_req_ver}
280 # for locales
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       libpng >= 1.2.0
283
284 %description -n gstreamer-libpng
285 Plugin for encoding png images.
286
287 %description -n gstreamer-libpng -l pl
288 Wtyczka koduj±ca pliki png.
289
290 %package -n gstreamer-audiosink-oss
291 Summary:        GStreamer plugins for input and output using OSS
292 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
293 Group:          Libraries
294 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
295 # for locales
296 Requires:       %{name} = %{version}-%{release}
297 Provides:       gstreamer-audiosink = %{version}
298 Obsoletes:      gstreamer-oss
299
300 %description -n gstreamer-audiosink-oss
301 Plugins for output and input to the OpenSoundSystem audio drivers
302 found in the Linux kernels or commercially available from OpenSound.
303
304 %description -n gstreamer-audiosink-oss -l pl
305 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
306 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
307 od OpenSound.
308
309 %package -n gstreamer-raw1394
310 Summary:        GStreamer raw1394 Firewire plugin
311 Summary(pl):    Wtyczka FireWire dla GStreamera
312 Group:          Libraries
313 Requires:       gstreamer >= %{gst_req_ver}
314
315 %description -n gstreamer-raw1394
316 Plugin for digital video support using raw1394.
317
318 %description -n gstreamer-raw1394 -l pl
319 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
320
321 %package -n gstreamer-shout2
322 Summary:        GStreamer plugin for communicating with Shoutcast servers
323 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
324 Group:          Libraries
325 Requires:       gstreamer >= %{gst_req_ver}
326
327 %description -n gstreamer-shout2
328 GStreamer plugin for communicating with Shoutcast servers.
329
330 %description -n gstreamer-shout2 -l pl
331 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
332
333 %package -n gstreamer-speex
334 Summary:        GStreamer speex codec decoder/encoder plugin
335 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
336 Group:          Libraries
337 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
338 Requires:       speex >= 1:1.1.6
339
340 %description -n gstreamer-speex
341 GStreamer speex codec decoder/encoder plugin.
342
343 %description -n gstreamer-speex -l pl
344 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
345
346 %package -n gstreamer-taglib
347 Summary:        GStreamer tag writing plugin based on taglib
348 Summary(pl):    Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib
349 Group:          Libraries
350 Requires:       gstreamer >= %{gst_req_ver}
351
352 %description -n gstreamer-taglib
353 GStreamer tag writing plugin based on taglib.
354
355 %description -n gstreamer-taglib -l pl
356 Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib.
357
358 %package -n gstreamer-video-effects
359 Summary:        GStreamer video effects plugins
360 Summary(pl):    Wtyczki efektów wideo do GStreamera
361 Group:          Libraries
362 # for locales in jpeg module
363 Requires:       %{name} = %{version}-%{release}
364
365 %description -n gstreamer-video-effects
366 GStreamer video effects plugins.
367
368 %description -n gstreamer-video-effects -l pl
369 Wtyczki efektów wideo do GStreamera.
370
371 %package -n gstreamer-visualisation
372 Summary:        GStreamer visualisations plugins
373 Summary(pl):    Wtyczki wizualizacji do GStreamera
374 Group:          Libraries
375 Requires:       gstreamer >= %{gst_req_ver}
376
377 %description -n gstreamer-visualisation
378 Various plugins for visual effects to use with audio. Included are
379 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
380
381 %description -n gstreamer-visualisation -l pl
382 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
383 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
384
385 %package -n gstreamer-ximagesrc
386 Summary:        GStreamer X11 video input plugin using standard Xlib calls
387 Summary(pl):    Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ Xlib
388 Group:          Libraries
389 Requires:       %{name} = %{version}-%{release}
390
391 %description -n gstreamer-ximagesrc
392 GStreamer X11 video input plugin using standard Xlib calls.
393
394 %description -n gstreamer-ximagesrc -l pl
395 Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ
396 Xlib.
397
398 %prep
399 %setup -q -n %{gstname}-%{version}
400 %patch0 -p1
401 %patch1 -p1
402
403 %build
404 %{__libtoolize}
405 %{__aclocal} -I m4 -I common/m4
406 %{__autoconf}
407 %{__autoheader}
408 %{__automake}
409 %configure \
410         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
411         %{!?with_aalib:--disable-aalib} \
412         %{!?with_caca:--disable-libcaca} \
413         %{!?with_cairo:--disable-cairo} \
414         %{!?with_cdio:--disable-cdio} \
415         %{!?with_ladspa:--disable-ladspa} \
416         %{!?with_speex:--disable-speex} \
417         --disable-static \
418         --enable-gtk-doc \
419         --with-html-dir=%{_gtkdocdir}
420
421 %{__make}
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425
426 %{__make} install \
427         DESTDIR=$RPM_BUILD_ROOT
428
429 # We don't need plugins' *.la files
430 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
431
432 %find_lang %{gstname}-%{gst_major_ver}
433
434 %clean
435 rm -rf $RPM_BUILD_ROOT
436
437 %post   -n gstreamer-GConf
438 %gconf_schema_install gstreamer-0.10.schemas
439
440 %preun  -n gstreamer-GConf
441 %gconf_schema_uninstall gstreamer-0.10.schemas
442
443 %files -f %{gstname}-%{gst_major_ver}.lang
444 %defattr(644,root,root,755)
445 %doc AUTHORS ChangeLog NEWS README RELEASE 
446 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
447 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
448 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
449 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
450 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
451 %attr(755,root,root) %{gstlibdir}/libgstavi.so
452 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
453 %attr(755,root,root) %{gstlibdir}/libgstefence.so
454 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
455 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
456 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
457 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
458 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
459 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
460 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
461 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
462 %attr(755,root,root) %{gstlibdir}/libgstudp.so
463 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
464 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
465 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
466 %{_gtkdocdir}/gst-plugins-good-plugins-*
467
468 %if %{with gconf}
469 %files -n gstreamer-GConf
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
472 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
473 %endif
474
475 ##
476 ## Plugins
477 ##
478
479 %if %{with aalib}
480 %files -n gstreamer-videosink-aa
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
483 %endif
484
485 %files -n gstreamer-audio-effects-good
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
488 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
489 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
490 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
491
492 %files -n gstreamer-audio-formats
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
495 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
496 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
497
498 %if %{with cairo}
499 %files -n gstreamer-cairo
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
502 %endif
503
504 %if %{with cdio}
505 %files -n gstreamer-cdio
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
508 %endif
509
510 %files -n gstreamer-dv
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{gstlibdir}/libgstdv.so
513
514 %files -n gstreamer-audiosink-esd
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{gstlibdir}/libgstesd.so
517
518 %files -n gstreamer-flac
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{gstlibdir}/libgstflac.so
521
522 %files -n gstreamer-gdkpixbuf
523 %defattr(644,root,root,755)
524 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
525
526 %files -n gstreamer-hal
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
529
530 #%if %{with ladspa}
531 #%files -n gstreamer-ladspa
532 #%defattr(644,root,root,755)
533 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
534 #%endif
535
536 %if %{with caca}
537 %files -n gstreamer-videosink-libcaca
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
540 %endif
541
542 %files -n gstreamer-libpng
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{gstlibdir}/libgstpng.so
545
546 %files -n gstreamer-audiosink-oss
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
549
550 %files -n gstreamer-raw1394
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{gstlibdir}/libgst1394.so
553
554 %files -n gstreamer-shout2
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
557
558 %if %{with speex}
559 %files -n gstreamer-speex
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
562 %endif
563
564 %files -n gstreamer-taglib
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
567
568 %files -n gstreamer-video-effects
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
571 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
572 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
573 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
574
575 %files -n gstreamer-visualisation
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
578
579 %files -n gstreamer-ximagesrc
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.066083 seconds and 2 git commands to generate.