]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- release 2 (by relup.sh)
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  aalib           # aa videosink plugin
5 %bcond_without  caca            # caca videosink plugin
6 %bcond_without  cairo           # cairo plugin
7 %bcond_without  gtk             # GTK+ (3.x) elements (video sink plugin)
8 %bcond_without  jack            # JACK audio plugin
9 %bcond_with     jack1           # JACK 1 (0.12x) instead of JACK 2 (1.9.x)
10 %bcond_without  lame            # LAME MP2/MP3 encoding plugin
11 %bcond_without  mpg123          # MPG123-based MP3 plugin
12 %bcond_without  qt              # Qt (5.x) elements (video sink plugin)
13 %bcond_without  soup            # libsoup (2.4 API) http source plugin
14 %bcond_without  speex           # speex plugin
15 %bcond_without  wavpack         # wavpack plugin
16
17 %define         gstname         gst-plugins-good
18 %define         major_ver       1.0
19 %define         gst_req_ver     1.14.4
20 %define         gstpb_req_ver   1.14.4
21
22 %include        /usr/lib/rpm/macros.gstreamer
23 Summary:        Good GStreamer Streaming-media framework plugins
24 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
25 Name:           gstreamer-plugins-good
26 Version:        1.14.4
27 Release:        2
28 License:        LGPL v2+
29 Group:          Libraries
30 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.xz
31 # Source0-md5:  6e3b247097366cf2639f22abfece7113
32 Patch0:         libvpx1.8.patch
33 URL:            https://gstreamer.freedesktop.org/
34 BuildRequires:  autoconf >= 2.69
35 BuildRequires:  automake >= 1:1.14
36 BuildRequires:  docbook-dtd412-xml
37 BuildRequires:  gettext-tools >= 0.17
38 BuildRequires:  glib2-devel >= 1:2.40
39 %if %(locale -a | grep -q '^C\.utf8$'; echo $?)
40 BuildRequires:  glibc-localedb-all
41 %endif
42 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
43 BuildRequires:  gstreamer-gl-devel >= %{gstpb_req_ver}
44 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
45 BuildRequires:  gtk+3-devel >= 3.0.0
46 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.12}
47 BuildRequires:  libtool >= 2:2.2.6
48 BuildRequires:  orc-devel >= 0.4.17
49 BuildRequires:  pkgconfig >= 1:0.9.0
50 BuildRequires:  python >= 2.1
51 BuildRequires:  rpmbuild(macros) >= 1.198
52 BuildRequires:  tar >= 1:1.22
53 BuildRequires:  xz
54 ##
55 ## plugins
56 ##
57 %{?with_qt:BuildRequires:       Qt5Core-devel >= 5.4.0}
58 %{?with_qt:BuildRequires:       Qt5Gui-devel >= 5.4.0}
59 %{?with_qt:BuildRequires:       Qt5Quick-devel >= 5.4.0}
60 %{?with_qt:BuildRequires:       Qt5Qml-devel >= 5.4.0}
61 %{?with_qt:BuildRequires:       Qt5X11Extras-devel >= 5.4.0}
62 %{?with_qt:BuildRequires:       Qt5WaylandClient-devel >= 5.4.0}
63 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
64 BuildRequires:  bzip2-devel
65 %{?with_cairo:BuildRequires:    cairo-devel >= 1.10.0}
66 %{?with_cairo:BuildRequires:    cairo-gobject-devel >= 1.10.0}
67 BuildRequires:  dbus-devel >= 0.91
68 BuildRequires:  flac-devel >= 1.1.4
69 BuildRequires:  gdk-pixbuf2-devel >= 2.8.0
70 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.15.0}
71 %if %{with jack}
72 %{?with_jack1:BuildRequires:    jack-audio-connection-kit-devel >= 0.120.1}
73 %{!?with_jack1:BuildRequires:   jack-audio-connection-kit-devel >= 1.9.7}
74 %endif
75 %{?with_lame:BuildRequires:     lame-libs-devel}
76 BuildRequires:  libavc1394-devel
77 %{?with_caca:BuildRequires:     libcaca-devel}
78 BuildRequires:  libdv-devel >= 0.104
79 BuildRequires:  libiec61883-devel >= 1.0.0
80 BuildRequires:  libjpeg-devel
81 %{?with_mpg123:BuildRequires:   libmpg123-devel >= 1.14}
82 BuildRequires:  libpng-devel >= 2:1.5.1
83 BuildRequires:  libraw1394-devel >= 2.0.0
84 BuildRequires:  libshout-devel >= 2.0
85 %{?with_soup:BuildRequires:     libsoup-devel >= 2.48}
86 BuildRequires:  libstdc++-devel
87 BuildRequires:  libv4l-devel
88 BuildRequires:  libvpx-devel >= 1.4.0
89 BuildRequires:  pulseaudio-devel >= 2.0
90 %{?with_qt:BuildRequires:       qt5-build >= 5.4.0}
91 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
92 BuildRequires:  taglib-devel >= 1.5
93 %{?with_lame:BuildRequires:     twolame-devel >= 0.3.10}
94 BuildRequires:  udev-glib-devel >= 1:147
95 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.60.0}
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xorg-lib-libXdamage-devel
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXfixes-devel
100 BuildRequires:  zlib-devel
101 Requires:       glib2 >= 1:2.40
102 Requires:       gstreamer >= %{gst_req_ver}
103 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
104 Requires:       orc >= 0.4.17
105 Obsoletes:      gstreamer-avi
106 Obsoletes:      gstreamer-flx
107 Obsoletes:      gstreamer-matroska
108 Obsoletes:      gstreamer-mixer
109 Obsoletes:      gstreamer-navigation
110 Obsoletes:      gstreamer-oss4
111 Obsoletes:      gstreamer-rtp
112 Obsoletes:      gstreamer-udp
113 Conflicts:      gstreamer-plugins-bad < 0.10.19
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         gstlibdir       %{_libdir}/gstreamer-%{major_ver}
117
118 %description
119 GStreamer is a streaming-media framework, based on graphs of filters
120 which operate on media data. Applications using this library can do
121 anything from real-time sound processing to playing videos, and just
122 about anything else media-related. Its plugin-based architecture means
123 that new data types or processing capabilities can be added simply by
124 installing new plugins.
125
126 %description -l pl.UTF-8
127 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
128 grafie filtrów operujących na danych medialnych. Aplikacje używające
129 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
130 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
131 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
132 nowych typów danych lub możliwości obróbki.
133
134 %package apidocs
135 Summary:        Good GStreamer streaming-media framework plugins API documentation
136 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
137 Group:          Documentation
138 Requires:       gtk-doc-common
139 %if "%{_rpmversion}" >= "5"
140 BuildArch:      noarch
141 %endif
142
143 %description apidocs
144 Good GStreamer streaming-media framework plugins API documentation.
145
146 %description apidocs -l pl.UTF-8
147 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
148 GStreamer.
149
150 ## ## Plugins ##
151
152 %package -n gstreamer-videosink-aa
153 Summary:        GStreamer plugin for Ascii-art output
154 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
155 Group:          Libraries
156 Requires:       gstreamer >= %{gst_req_ver}
157 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
158 Provides:       gstreamer-videosink = %{version}
159 Obsoletes:      gstreamer-aalib
160
161 %description -n gstreamer-videosink-aa
162 Plugin for viewing movies in Ascii-art using aalib library.
163
164 %description -n gstreamer-videosink-aa -l pl.UTF-8
165 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
166
167 %package -n gstreamer-audio-effects-good
168 Summary:        Good GStreamer audio effects plugins
169 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
170 Group:          Libraries
171 Requires:       gstreamer >= %{gst_req_ver}
172 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
173 Obsoletes:      gstreamer-audio-effects
174
175 %description -n gstreamer-audio-effects-good
176 Good GStreamer audio effects plugins.
177
178 %description -n gstreamer-audio-effects-good -l pl.UTF-8
179 Dobre wtyczki efektów dźwiękowych do GStreamera.
180
181 %package -n gstreamer-audio-formats
182 Summary:        GStreamer audio format plugins
183 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
184 Group:          Libraries
185 Requires:       gstreamer >= %{gst_req_ver}
186 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
187 # for locales in wavparse module
188 Requires:       %{name} = %{version}-%{release}
189
190 %description -n gstreamer-audio-formats
191 Plugin for playback of WAV, au and mod audio files as well as MP3
192 type.
193
194 %description -n gstreamer-audio-formats -l pl.UTF-8
195 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
196
197 %package -n gstreamer-cairo
198 Summary:        GStreamer cairo plugin
199 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
200 Group:          Libraries
201 Requires:       cairo >= 1.10.0
202 Requires:       cairo-gobject >= 1.10.0
203 Requires:       gstreamer >= %{gst_req_ver}
204 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
205
206 %description -n gstreamer-cairo
207 GStreamer cairo plugin.
208
209 %description -n gstreamer-cairo -l pl.UTF-8
210 Wtyczka cairo do GStreamera.
211
212 %package -n gstreamer-dv
213 Summary:        GStreamer dv plugin
214 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
215 Group:          Libraries
216 Requires:       gstreamer >= %{gst_req_ver}
217 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
218 Requires:       libdv >= 0.104
219
220 %description -n gstreamer-dv
221 Plugin for digital video support.
222
223 %description -n gstreamer-dv -l pl.UTF-8
224 Wtyczka do GStreamera obsługująca cyfrowy obraz.
225
226 %package -n gstreamer-flac
227 Summary:        GStreamer plugin for FLAC lossless audio format
228 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
229 Group:          Libraries
230 Requires:       flac >= 1.1.4
231 Requires:       gstreamer >= %{gst_req_ver}
232 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
233
234 %description -n gstreamer-flac
235 Plugin for the free FLAC lossless audio format.
236
237 %description -n gstreamer-flac -l pl.UTF-8
238 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
239
240 %package -n gstreamer-gdkpixbuf
241 Summary:        GStreamer images input plugin
242 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
243 Group:          Libraries
244 Requires:       gdk-pixbuf2 >= 2.8.0
245 Requires:       gstreamer >= %{gst_req_ver}
246 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
247
248 %description -n gstreamer-gdkpixbuf
249 This GStreamer plugin load images via gdkpixbuf library.
250
251 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
252 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
253 gdkpixbuf.
254
255 %package -n gstreamer-videosink-gtk
256 Summary:        GStreamer GTK+ (3.x) output plugin
257 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera
258 Group:          Libraries
259 Requires:       gstreamer >= %{gst_req_ver}
260 Requires:       gstreamer-gl-libs >= %{gstpb_req_ver}
261 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
262 Requires:       gtk+3 >= 3.15.0
263 Provides:       gstreamer-videosink = %{version}
264
265 %description -n gstreamer-videosink-gtk
266 GStreamer GTK+ (3.x) output plugin.
267
268 %description -n gstreamer-videosink-gtk -l pl.UTF-8
269 Wtyczka wyjścia obrazu GTK+ (3.x) dla GStreamera.
270
271 %package -n gstreamer-jack
272 Summary:        GStreamer plugin for the JACK Sound Server
273 Summary(pl.UTF-8):      Wtyczka serwera dźwięku JACK dla GStreamera
274 Group:          Libraries
275 Requires:       gstreamer >= %{gst_req_ver}
276 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
277 %{?with_jack1:Requires: jack-audio-connection-kit-libs >= 0.120.1}
278 %{!?with_jack1:Requires:        jack-audio-connection-kit-libs >= 1.9.7}
279 # for locales
280 Requires:       %{name} = %{version}-%{release}
281 Provides:       gstreamer-audiosink = %{version}
282
283 %description -n gstreamer-jack
284 Plugin for the JACK professional sound server.
285
286 %description -n gstreamer-jack -l pl.UTF-8
287 Wtyczka dla profesjonalnego serwera dźwięku JACK.
288
289 %package -n gstreamer-videosink-libcaca
290 Summary:        GStreamer plugin for libcaca Ascii-art output
291 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
292 Group:          Libraries
293 Requires:       gstreamer >= %{gst_req_ver}
294 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
295 Provides:       gstreamer-videosink = %{version}
296
297 %description -n gstreamer-videosink-libcaca
298 GStreamer plug-in for libcaca Ascii-art output.
299
300 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
301 Wtyczka libcaca do GStreamera.
302
303 %package -n gstreamer-lame
304 Summary:        GStreamer plugin encoding MP3 songs
305 Summary(pl.UTF-8):      Wtyczka do GStreamera kodująca pliki MP3
306 Group:          Libraries
307 # for NLS
308 Requires:       %{name} = %{version}-%{release}
309 Requires:       gstreamer >= %{gst_req_ver}
310 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
311 Requires:       twolame-libs >= 0.3.10
312
313 %description -n gstreamer-lame
314 Plugin for encoding MP3 with lame.
315
316 %description -n gstreamer-lame -l pl.UTF-8
317 Wtyczka do GStreamera kodująca pliki MP3 przy użyciu lame.
318
319 %package -n gstreamer-mpg123
320 Summary:        GStreamer mpg123 plugin
321 Summary(pl.UTF-8):      Wtyczka mpg123 do GStreamera
322 Group:          Libraries
323 Requires:       gstreamer >= %{gst_req_ver}
324 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
325 Requires:       libmpg123 >= 1.14
326 # plugin obsoleted in 1.12.0, functionality in mpg123 plugin (or libav)
327 Obsoletes:      gstreamer-mad < 1.12.0
328
329 %description -n gstreamer-mpg123
330 GStreamer mpg123 plugin for MP3 playback.
331
332 %description -n gstreamer-mpg123 -l pl.UTF-8
333 Wtyczka mpg123 do GStreamera, odtwarzająca MP3.
334
335 %package -n gstreamer-libpng
336 Summary:        GStreamer plugin to encode png images
337 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
338 Group:          Libraries
339 Requires:       gstreamer >= %{gst_req_ver}
340 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
341 # for locales
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       libpng >= 2:1.5.1
344
345 %description -n gstreamer-libpng
346 Plugin for encoding png images.
347
348 %description -n gstreamer-libpng -l pl.UTF-8
349 Wtyczka kodująca pliki png.
350
351 %package -n gstreamer-audiosink-oss
352 Summary:        GStreamer plugins for input and output using OSS
353 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
354 Group:          Libraries
355 Requires:       gstreamer >= %{gst_req_ver}
356 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
357 # for locales
358 Requires:       %{name} = %{version}-%{release}
359 Provides:       gstreamer-audiosink = %{version}
360 Obsoletes:      gstreamer-oss
361
362 %description -n gstreamer-audiosink-oss
363 Plugins for output and input to the OpenSoundSystem audio drivers
364 found in the Linux kernels or commercially available from OpenSound.
365
366 %description -n gstreamer-audiosink-oss -l pl.UTF-8
367 Wtyczki wyjścia i wejścia dźwięku używające sterowników
368 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
369 od OpenSound.
370
371 %package -n gstreamer-pulseaudio
372 Summary:        GStreamer plugin for PulseAudio sound server
373 Summary(pl.UTF-8):      Wtyczka GStreamera dla serwera dźwięku PulseAudio
374 Group:          Libraries
375 Requires:       gstreamer >= %{gst_req_ver}
376 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
377 Requires:       pulseaudio >= 2.0
378 # for locales
379 Requires:       %{name} = %{version}-%{release}
380 Provides:       gstreamer-audiosink = %{version}
381 Obsoletes:      gstreamer-audiosink-polypaudio
382 Obsoletes:      gstreamer-polypaudio
383
384 %description -n gstreamer-pulseaudio
385 GStreamer plugin for PulseAudio sound server.
386
387 %description -n gstreamer-pulseaudio -l pl.UTF-8
388 Wtyczka GStreamera dla serwera dźwięku PulseAudio.
389
390 %package -n gstreamer-videosink-qt
391 Summary:        GStreamer Qt (5.x) output plugin
392 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera
393 Group:          Libraries
394 Requires:       Qt5Core >= 5.4.0
395 Requires:       Qt5Gui >= 5.4.0
396 Requires:       Qt5Quick >= 5.4.0
397 Requires:       gstreamer >= %{gst_req_ver}
398 Requires:       gstreamer-gl-libs >= %{gstpb_req_ver}
399 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
400 Provides:       gstreamer-videosink = %{version}
401
402 %description -n gstreamer-videosink-qt
403 GStreamer Qt (5.x) output plugin.
404
405 %description -n gstreamer-videosink-qt -l pl.UTF-8
406 Wtyczka wyjścia obrazu Qt (5.x) dla GStreamera.
407
408 %package -n gstreamer-raw1394
409 Summary:        GStreamer raw1394 Firewire plugin
410 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
411 Group:          Libraries
412 Requires:       gstreamer >= %{gst_req_ver}
413
414 %description -n gstreamer-raw1394
415 Plugin for digital video support using raw1394.
416
417 %description -n gstreamer-raw1394 -l pl.UTF-8
418 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
419
420 %package -n gstreamer-shout2
421 Summary:        GStreamer plugin for communicating with Shoutcast servers
422 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
423 Group:          Libraries
424 Requires:       gstreamer >= %{gst_req_ver}
425 # for locales
426 Requires:       %{name} = %{version}-%{release}
427
428 %description -n gstreamer-shout2
429 GStreamer plugin for communicating with Shoutcast servers.
430
431 %description -n gstreamer-shout2 -l pl.UTF-8
432 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
433
434 %package -n gstreamer-soup
435 Summary:        GStreamer Soup plugin
436 Summary(pl.UTF-8):      Wtyczka biblioteki Soup dla GStreamera
437 Group:          Libraries
438 Requires:       gstreamer >= %{gst_req_ver}
439 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
440 Requires:       libsoup >= 2.48
441 # for locales
442 Requires:       %{name} = %{version}-%{release}
443
444 %description -n gstreamer-soup
445 GStreamer Plugin for downloading files with Soup library.
446
447 %description -n gstreamer-soup -l pl.UTF-8
448 Wtyczka GStreamera umożliwiająca ściąganie plików za pomocą biblioteki
449 Soup.
450
451 %package -n gstreamer-speex
452 Summary:        GStreamer speex codec decoder/encoder plugin
453 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
454 Group:          Libraries
455 Requires:       gstreamer >= %{gst_req_ver}
456 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
457 Requires:       speex >= 1:1.1.6
458
459 %description -n gstreamer-speex
460 GStreamer speex codec decoder/encoder plugin.
461
462 %description -n gstreamer-speex -l pl.UTF-8
463 Wtyczka do GStreamera obsługująca kodek Speex.
464
465 %package -n gstreamer-taglib
466 Summary:        GStreamer tag writing plugin based on taglib
467 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
468 Group:          Libraries
469 Requires:       gstreamer >= %{gst_req_ver}
470 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
471 Requires:       taglib >= 1.5
472
473 %description -n gstreamer-taglib
474 GStreamer tag writing plugin based on taglib.
475
476 %description -n gstreamer-taglib -l pl.UTF-8
477 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
478
479 %package -n gstreamer-v4l2
480 Summary:        GStreamer Video4Linux2 input plugin
481 Summary(pl.UTF-8):      Wtyczka wejścia Video4Linux2 dla GStreamera
482 Group:          Libraries
483 Requires:       %{name} = %{version}-%{release}
484 Requires:       gstreamer >= %{gst_req_ver}
485 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
486 Requires:       udev-glib >= 1:147
487
488 %description -n gstreamer-v4l2
489 GStreamer plugin for accessing Video4Linux2 devices.
490
491 %description -n gstreamer-v4l2 -l pl.UTF-8
492 Wtyczka GStreamera pozwalająca na dostęp do urządzeń Video4Linux2.
493
494 %package -n gstreamer-video-effects
495 Summary:        GStreamer video effects plugins
496 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
497 Group:          Libraries
498 Requires:       gstreamer >= %{gst_req_ver}
499 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
500 # for locales in jpeg module
501 Requires:       %{name} = %{version}-%{release}
502
503 %description -n gstreamer-video-effects
504 GStreamer video effects plugins.
505
506 %description -n gstreamer-video-effects -l pl.UTF-8
507 Wtyczki efektów wideo do GStreamera.
508
509 %package -n gstreamer-visualisation
510 Summary:        GStreamer visualisations plugins
511 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
512 Group:          Libraries
513 Requires:       gstreamer >= %{gst_req_ver}
514 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
515
516 %description -n gstreamer-visualisation
517 Various plugins for visual effects to use with audio. Included are
518 monoscope, spectrum, goom (2k4) and goom2k1.
519
520 %description -n gstreamer-visualisation -l pl.UTF-8
521 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
522 monoscope, spectrum, goom (2k4) i goom2k1.
523
524 %package -n gstreamer-vpx
525 Summary:        GStreamer plugin for VP8/VP9 video format
526 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca format obrazu VP8/VP9
527 Group:          Libraries
528 Requires:       gstreamer >= %{gst_req_ver}
529 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
530 Requires:       libvpx >= 1.4.0
531 Obsoletes:      gstreamer-vp8
532
533 %description -n gstreamer-vpx
534 GStreamer plugin for VP8/VP9 video format using libvpx library.
535
536 %description -n gstreamer-vpx -l pl.UTF-8
537 Wtyczka do GStreamera obsługująca format obrazu VP8/VP9 przy użyciu
538 biblioteki libvpx.
539
540 %package -n gstreamer-wavpack
541 Summary:        GStreamer plugin for Wavpack lossless audio format
542 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
543 Group:          Libraries
544 Requires:       gstreamer >= %{gst_req_ver}
545 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
546 Requires:       wavpack-libs >= 4.60.0
547
548 %description -n gstreamer-wavpack
549 Plugin for lossless Wavpack audio format.
550
551 %description -n gstreamer-wavpack -l pl.UTF-8
552 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
553
554 %package -n gstreamer-ximagesrc
555 Summary:        GStreamer X11 video input plugin using standard Xlib calls
556 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
557 Group:          Libraries
558 Requires:       %{name} = %{version}-%{release}
559 Requires:       gstreamer >= %{gst_req_ver}
560 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
561
562 %description -n gstreamer-ximagesrc
563 GStreamer X11 video input plugin using standard Xlib calls.
564
565 %description -n gstreamer-ximagesrc -l pl.UTF-8
566 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
567 Xlib.
568
569 %prep
570 %setup -q -n %{gstname}-%{version}
571 %patch0 -p1
572
573 %build
574 %{__libtoolize}
575 %{__aclocal} -I m4 -I common/m4
576 %{__autoconf}
577 %{__autoheader}
578 %{__automake}
579 %configure \
580         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
581         --disable-silent-rules \
582         --disable-static \
583         --enable-experimental \
584         %{!?with_aalib:--disable-aalib} \
585         %{!?with_cairo:--disable-cairo} \
586         %{!?with_gtk:--disable-gtk} \
587         %{!?with_jack:--disable-jack} \
588         %{!?with_lame:--disable-lame --disable-twolame} \
589         %{!?with_caca:--disable-libcaca} \
590         %{!?with_mpg123:--disable-mpg123} \
591         %{!?with_qt:--disable-qt} \
592         %{!?with_soup:--disable-soup} \
593         %{!?with_speex:--disable-speex} \
594         %{!?with_wavpack:--disable-wavpack} \
595         --enable-gtk-doc%{!?with_apidocs:=no} \
596         --enable-orc \
597         --with-html-dir=%{_gtkdocdir}
598
599 LC_ALL=C.UTF-8 \
600 %{__make}
601
602 %install
603 rm -rf $RPM_BUILD_ROOT
604
605 %{__make} install \
606         DESTDIR=$RPM_BUILD_ROOT
607
608 # We don't need plugins' *.la files
609 %{__rm} $RPM_BUILD_ROOT%{gstlibdir}/*.la
610
611 %find_lang %{gstname}-%{major_ver}
612
613 %clean
614 rm -rf $RPM_BUILD_ROOT
615
616 %files -f %{gstname}-%{major_ver}.lang
617 %defattr(644,root,root,755)
618 %doc AUTHORS ChangeLog NEWS README RELEASE
619 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
620 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
621 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
622 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
623 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
624 %attr(755,root,root) %{gstlibdir}/libgstavi.so
625 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
626 %attr(755,root,root) %{gstlibdir}/libgstdtmf.so
627 %attr(755,root,root) %{gstlibdir}/libgstequalizer.so
628 %attr(755,root,root) %{gstlibdir}/libgstdeinterlace.so
629 %attr(755,root,root) %{gstlibdir}/libgstflv.so
630 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
631 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
632 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
633 %attr(755,root,root) %{gstlibdir}/libgstimagefreeze.so
634 %attr(755,root,root) %{gstlibdir}/libgstinterleave.so
635 %attr(755,root,root) %{gstlibdir}/libgstisomp4.so
636 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
637 %attr(755,root,root) %{gstlibdir}/libgstmultifile.so
638 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
639 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
640 %attr(755,root,root) %{gstlibdir}/libgstoss4.so
641 %attr(755,root,root) %{gstlibdir}/libgstreplaygain.so
642 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
643 %attr(755,root,root) %{gstlibdir}/libgstrtpmanager.so
644 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
645 %attr(755,root,root) %{gstlibdir}/libgstshapewipe.so
646 %attr(755,root,root) %{gstlibdir}/libgstudp.so
647 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
648 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
649 %attr(755,root,root) %{gstlibdir}/libgstvideofilter.so
650 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
651 %attr(755,root,root) %{gstlibdir}/libgsty4menc.so
652 %dir %{_datadir}/gstreamer-%{major_ver}
653 %{_datadir}/gstreamer-%{major_ver}/presets
654
655 %if %{with apidocs}
656 %files apidocs
657 %defattr(644,root,root,755)
658 %{_gtkdocdir}/gst-plugins-good-plugins-%{major_ver}
659 %endif
660
661 ##
662 ## Plugins
663 ##
664
665 %if %{with aalib}
666 %files -n gstreamer-videosink-aa
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
669 %endif
670
671 %files -n gstreamer-audio-effects-good
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
674 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
675 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
676 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
677
678 %files -n gstreamer-audio-formats
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
681 %attr(755,root,root) %{gstlibdir}/libgstaudioparsers.so
682 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
683 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
684
685 %if %{with cairo}
686 %files -n gstreamer-cairo
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
689 %endif
690
691 %files -n gstreamer-dv
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{gstlibdir}/libgstdv.so
694
695 %files -n gstreamer-flac
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{gstlibdir}/libgstflac.so
698
699 %files -n gstreamer-gdkpixbuf
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
702
703 %if %{with gtk}
704 %files -n gstreamer-videosink-gtk
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{gstlibdir}/libgstgtk.so
707 %endif
708
709 %if %{with jack}
710 %files -n gstreamer-jack
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{gstlibdir}/libgstjack.so
713 %endif
714
715 %if %{with caca}
716 %files -n gstreamer-videosink-libcaca
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
719 %endif
720
721 %files -n gstreamer-lame
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{gstlibdir}/libgstlame.so
724 %attr(755,root,root) %{gstlibdir}/libgsttwolame.so
725
726 %if %{with mpg123}
727 %files -n gstreamer-mpg123
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{gstlibdir}/libgstmpg123.so
730 %endif
731
732 %files -n gstreamer-libpng
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{gstlibdir}/libgstpng.so
735
736 %files -n gstreamer-audiosink-oss
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
739
740 %files -n gstreamer-pulseaudio
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{gstlibdir}/libgstpulseaudio.so
743
744 %if %{with qt}
745 %files -n gstreamer-videosink-qt
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{gstlibdir}/libgstqmlgl.so
748 %endif
749
750 %files -n gstreamer-raw1394
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{gstlibdir}/libgst1394.so
753
754 %files -n gstreamer-shout2
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
757
758 %if %{with soup}
759 %files -n gstreamer-soup
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{gstlibdir}/libgstsoup.so
762 %endif
763
764 %if %{with speex}
765 %files -n gstreamer-speex
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
768 %endif
769
770 %files -n gstreamer-taglib
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
773
774 %files -n gstreamer-v4l2
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
777
778 %files -n gstreamer-video-effects
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
781 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
782 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
783
784 %files -n gstreamer-visualisation
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
787 %attr(755,root,root) %{gstlibdir}/libgstgoom2k1.so
788 %attr(755,root,root) %{gstlibdir}/libgstmonoscope.so
789 %attr(755,root,root) %{gstlibdir}/libgstspectrum.so
790
791 %files -n gstreamer-vpx
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{gstlibdir}/libgstvpx.so
794
795 %if %{with wavpack}
796 %files -n gstreamer-wavpack
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
799 %endif
800
801 %files -n gstreamer-ximagesrc
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.151731 seconds and 3 git commands to generate.