]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
- updated to 0.10.5, updated libcaca patch
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  caca            # don't build caca videosink plugin
5 %bcond_without  cairo           # don't build cairo plugin
6 %bcond_without  cdio            # don't build cdio plugin
7 %bcond_without  gconf           # don't build GConf plugin
8 %bcond_without  ladspa          # don't build ladspa plugin
9 %bcond_without  speex           # don't build speex plugin
10 #
11 %define         gstname         gst-plugins-good
12 %define         gst_major_ver   0.10
13 %define         gst_req_ver     0.10.10.1
14 %define         gstpb_req_ver   0.10.10.1
15 #
16 Summary:        Good GStreamer Streaming-media framework plugins
17 Summary(pl):    Dobre wtyczki do ¶rodowiska obróbki strumieni GStreamer
18 Name:           gstreamer-plugins-good
19 Version:        0.10.5
20 Release:        1
21 License:        LGPL
22 Group:          Libraries
23 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
24 # Source0-md5:  c45fc9ace9feb4d3df32da0a6d262d84
25 Patch0:         %{name}-bashish.patch
26 Patch1:         %{name}-libcaca.patch
27 Patch2:         %{name}-flac.patch
28 URL:            http://gstreamer.freedesktop.org/
29 BuildRequires:  autoconf >= 2.59-9
30 BuildRequires:  automake >= 1.5
31 BuildRequires:  glib2-devel >= 1:2.12.1
32 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
33 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
34 BuildRequires:  gtk-doc >= 1.7
35 BuildRequires:  gtk+2-devel >= 2:2.10.1
36 BuildRequires:  liboil-devel >= 0.3.6
37 BuildRequires:  libtool >= 1.4
38 BuildRequires:  pkgconfig >= 1:0.9.0
39 BuildRequires:  python >= 2.1
40 BuildRequires:  python-PyXML
41 BuildRequires:  rpmbuild(macros) >= 1.198
42 ##
43 ## plugins
44 ##
45 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.14.0}
46 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
47 %{?with_cairo:BuildRequires:    cairo-devel >= 1.2.0}
48 BuildRequires:  dbus-devel >= 0.91
49 BuildRequires:  esound-devel >= 0.2.12
50 BuildRequires:  flac-devel >= 1.1.3
51 BuildRequires:  hal-devel >= 0.5.7.1
52 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
53 BuildRequires:  libavc1394-devel
54 %{?with_caca:BuildRequires:     libcaca-devel}
55 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
56 BuildRequires:  libdv-devel >= 0.104
57 BuildRequires:  libiec61883-devel >= 1.0.0
58 BuildRequires:  libjpeg-devel
59 BuildRequires:  libpng-devel >= 1.2.0
60 BuildRequires:  libraw1394-devel >= 1.2.1
61 BuildRequires:  libshout-devel >= 2.0
62 # for taglib
63 BuildRequires:  libstdc++-devel
64 BuildRequires:  libxml2-devel >= 1:2.6.26
65 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
66 BuildRequires:  taglib-devel >= 1.4
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXdamage-devel
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXfixes-devel
71 BuildRequires:  zlib-devel
72 Requires:       gstreamer >= %{gst_req_ver}
73 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
74 Obsoletes:      gstreamer-avi
75 Obsoletes:      gstreamer-flx
76 Obsoletes:      gstreamer-matroska
77 Obsoletes:      gstreamer-mixer
78 Obsoletes:      gstreamer-navigation
79 Obsoletes:      gstreamer-rtp
80 Obsoletes:      gstreamer-udp
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
84
85 %description
86 GStreamer is a streaming-media framework, based on graphs of filters
87 which operate on media data. Applications using this library can do
88 anything from real-time sound processing to playing videos, and just
89 about anything else media-related. Its plugin-based architecture means
90 that new data types or processing capabilities can be added simply by
91 installing new plugins.
92
93 %description -l pl
94 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
95 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
96 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
97 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
98 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
99 nowych typów danych lub mo¿liwo¶ci obróbki.
100
101 %package -n gstreamer-GConf
102 Summary:        GStreamer GConf schemas
103 Summary(pl):    Schematy GConf GStreamera
104 Group:          Libraries
105 Requires(post,preun):   GConf2
106 Requires:       gstreamer >= %{gst_req_ver}
107 Obsoletes:      gstreamer-GConf-devel
108
109 %description -n gstreamer-GConf
110 Installation of GStreamer GConf schemas. These set usable defaults
111 used by all GStreamer-enabled GNOME applications.
112
113 %description -n gstreamer-GConf -l pl
114 Schematy GConf dla GStreamera. Zestaw ten ustawia warto¶ci domy¶lne
115 dla wszystkich aplikacji GNOME korzystaj±cych z GStreamera
116
117 ##
118 ## Plugins
119 ##
120
121 %package -n gstreamer-videosink-aa
122 Summary:        GStreamer plugin for Ascii-art output
123 Summary(pl):    Wtyczka wyj¶cia obrazu Ascii-art do GStreamera
124 Group:          Libraries
125 Requires:       gstreamer >= %{gst_req_ver}
126 Provides:       gstreamer-videosink = %{version}
127 Obsoletes:      gstreamer-aalib
128
129 %description -n gstreamer-videosink-aa
130 Plugin for viewing movies in Ascii-art using aalib library.
131
132 %description -n gstreamer-videosink-aa -l pl
133 Wtyczka wyj¶cia obrazu Ascii-art u¿ywaj±ca biblioteki aalib.
134
135 %package -n gstreamer-audio-effects-good
136 Summary:        Good GStreamer audio effects plugins
137 Summary(pl):    Dobre wtyczki efektów d¼wiêkowych do GStreamera
138 Group:          Libraries
139 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
140 Obsoletes:      gstreamer-audio-effects
141
142 %description -n gstreamer-audio-effects-good
143 Good GStreamer audio effects plugins.
144
145 %description -n gstreamer-audio-effects-good -l pl
146 Dobre wtyczki efektów d¼wiêkowych do GStreamera.
147
148 %package -n gstreamer-audio-formats
149 Summary:        GStreamer audio format plugins
150 Summary(pl):    Wtyczki formatów d¼wiêku
151 Group:          Libraries
152 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
153 # for locales in wavparse module
154 Requires:       %{name} = %{version}-%{release}
155
156 %description -n gstreamer-audio-formats
157 Plugin for playback of WAV, au and mod audio files as well as MP3 type.
158
159 %description -n gstreamer-audio-formats -l pl
160 Wtyczka do odwarzania d¼wiêku w formacie au, WAV, mod oraz MP3.
161
162 %package -n gstreamer-cairo
163 Summary:        GStreamer cairo plugin
164 Summary(pl):    Wtyczka cairo do GStreamera
165 Group:          Libraries
166 Requires:       gstreamer >= %{gst_req_ver}
167
168 %description -n gstreamer-cairo
169 GStreamer cairo plugin.
170
171 %description -n gstreamer-cairo -l pl
172 Wtyczka cairo do GStreamera.
173
174 %package -n gstreamer-cdio
175 Summary:        GStreamer plugin for CD audio input using libcdio
176 Summary(pl):    Wtyczka do GStreamera odtwarzaj±ca p³yty CD-Audio przy u¿yciu libcdio
177 Group:          Libraries
178 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
179 Requires:       libcdio >= 0.71
180
181 %description -n gstreamer-cdio
182 Plugin for playing audio tracks using libcdio under GStreamer.
183
184 %description -n gstreamer-cdio -l pl
185 Wtyczka do odtwarzania ¶cie¿ek d¼wiêkowych pod GStreamerem za pomoc±
186 libcdio.
187
188 %package -n gstreamer-dv
189 Summary:        GStreamer dv plugin
190 Summary(pl):    Wtyczka dv do GStreamera
191 Group:          Libraries
192 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
193
194 %description -n gstreamer-dv
195 Plugin for digital video support.
196
197 %description -n gstreamer-dv -l pl
198 Wtyczka do GStreamera obs³uguj±ca cyfrowy obraz.
199
200 %package -n gstreamer-audiosink-esd
201 Summary:        GStreamer plugin for ESD sound output
202 Summary(pl):    Wtyczka wyj¶cia d¼wiêku ESD do GStreamera
203 Group:          Libraries
204 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
205 Provides:       gstreamer-audiosink = %{version}
206 Obsoletes:      gstreamer-esound
207
208 %description -n gstreamer-audiosink-esd
209 Output plugin for GStreamer for use with the esound package.
210
211 %description -n gstreamer-audiosink-esd -l pl
212 Wtyczka wyj¶cia d¼wiêku ESD (esound) dla GStreamera.
213
214 %package -n gstreamer-flac
215 Summary:        GStreamer plugin for FLAC lossless audio format
216 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca bezstratny format d¼wiêku FLAC
217 Group:          Libraries
218 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
219
220 %description -n gstreamer-flac
221 Plugin for the free FLAC lossless audio format.
222
223 %description -n gstreamer-flac -l pl
224 Wtyczka obs³uguj±ca wolnodostêpny, bezstratny format d¼wiêku FLAC.
225
226 %package -n gstreamer-gdkpixbuf
227 Summary:        GStreamer images input plugin
228 Summary(pl):    Wtyczka do GStreamera wczytuj±ca obrazki
229 Group:          Libraries
230 Requires:       gstreamer >= %{gst_req_ver}
231
232 %description -n gstreamer-gdkpixbuf
233 This GStreamer plugin load images via gdkpixbuf library.
234
235 %description -n gstreamer-gdkpixbuf -l pl
236 Ta wtyczka GStreamera wczytuje obrazki za po¶rednictwem biblioteki
237 gdkpixbuf.
238
239 %package -n gstreamer-hal
240 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
241 Summary(pl):    Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku z HAL-em
242 Group:          Libraries
243 Requires:       gstreamer >= %{gst_req_ver}
244
245 %description -n gstreamer-hal
246 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
247
248 %description -n gstreamer-hal -l pl
249 Wtyczka GStreamera spinaj±ca urz±dzenia wej¶cia/wyj¶cia d¼wiêku miêdzy
250 GStreamerem a HAL-em.
251
252 %package -n gstreamer-ladspa
253 Summary:        GStreamer wrapper for LADSPA plugins
254 Summary(pl):    Wrapper do wtyczek LADSPA dla GStreamera
255 Group:          Libraries
256 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
257
258 %description -n gstreamer-ladspa
259 Plugin which wraps LADSPA plugins for use by GStreamer applications.
260
261 %description -n gstreamer-ladspa -l pl
262 Wtyczka pozwalaj±ca na u¿ywanie wtyczek LADSPA przez aplikacje
263 GStreamera.
264
265 %package -n gstreamer-videosink-libcaca
266 Summary:        GStreamer plugin for libcaca Ascii-art output
267 Summary(pl):    Wtyczka libcaca do GStreamera
268 Group:          Libraries
269 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
270 Provides:       gstreamer-videosink = %{version}
271
272 %description -n gstreamer-videosink-libcaca
273 GStreamer plug-in for libcaca Ascii-art output.
274
275 %description -n gstreamer-videosink-libcaca -l pl
276 Wtyczka libcaca do GStreamera.
277
278 %package -n gstreamer-libpng
279 Summary:        GStreamer plugin to encode png images
280 Summary(pl):    Wtyczka GStreamera koduj±ca pliki png
281 Group:          Libraries
282 #Requires:      gstreamer >= %{gst_req_ver}
283 # for locales
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       libpng >= 1.2.0
286
287 %description -n gstreamer-libpng
288 Plugin for encoding png images.
289
290 %description -n gstreamer-libpng -l pl
291 Wtyczka koduj±ca pliki png.
292
293 %package -n gstreamer-audiosink-oss
294 Summary:        GStreamer plugins for input and output using OSS
295 Summary(pl):    Wtyczki wej¶cia i wyj¶cia d¼wiêku OSS do GStreamera
296 Group:          Libraries
297 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
298 # for locales
299 Requires:       %{name} = %{version}-%{release}
300 Provides:       gstreamer-audiosink = %{version}
301 Obsoletes:      gstreamer-oss
302
303 %description -n gstreamer-audiosink-oss
304 Plugins for output and input to the OpenSoundSystem audio drivers
305 found in the Linux kernels or commercially available from OpenSound.
306
307 %description -n gstreamer-audiosink-oss -l pl
308 Wtyczki wyj¶cia i wej¶cia d¼wiêku u¿ywaj±ce sterowników
309 OpenSoundSystem obecnych w j±drach Linuksa lub dostêpnych komercyjnie
310 od OpenSound.
311
312 %package -n gstreamer-raw1394
313 Summary:        GStreamer raw1394 Firewire plugin
314 Summary(pl):    Wtyczka FireWire dla GStreamera
315 Group:          Libraries
316 Requires:       gstreamer >= %{gst_req_ver}
317
318 %description -n gstreamer-raw1394
319 Plugin for digital video support using raw1394.
320
321 %description -n gstreamer-raw1394 -l pl
322 Wtyczka daj±ca dostêp do cyfrowego obrazu przy u¿yciu raw1394.
323
324 %package -n gstreamer-shout2
325 Summary:        GStreamer plugin for communicating with Shoutcast servers
326 Summary(pl):    Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast
327 Group:          Libraries
328 Requires:       gstreamer >= %{gst_req_ver}
329
330 %description -n gstreamer-shout2
331 GStreamer plugin for communicating with Shoutcast servers.
332
333 %description -n gstreamer-shout2 -l pl
334 Wtyczka do GStreamera umo¿liwiaj±ca komunikacjê z serwerami Shoutcast.
335
336 %package -n gstreamer-speex
337 Summary:        GStreamer speex codec decoder/encoder plugin
338 Summary(pl):    Wtyczka do GStreamera obs³uguj±ca kodek Speex
339 Group:          Libraries
340 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
341 Requires:       speex >= 1:1.1.6
342
343 %description -n gstreamer-speex
344 GStreamer speex codec decoder/encoder plugin.
345
346 %description -n gstreamer-speex -l pl
347 Wtyczka do GStreamera obs³uguj±ca kodek Speex.
348
349 %package -n gstreamer-taglib
350 Summary:        GStreamer tag writing plugin based on taglib
351 Summary(pl):    Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib
352 Group:          Libraries
353 Requires:       gstreamer >= %{gst_req_ver}
354
355 %description -n gstreamer-taglib
356 GStreamer tag writing plugin based on taglib.
357
358 %description -n gstreamer-taglib -l pl
359 Wtyczka GStreamera zapisuj±ca znaczniki oparta na bibliotece taglib.
360
361 %package -n gstreamer-video-effects
362 Summary:        GStreamer video effects plugins
363 Summary(pl):    Wtyczki efektów wideo do GStreamera
364 Group:          Libraries
365 # for locales in jpeg module
366 Requires:       %{name} = %{version}-%{release}
367
368 %description -n gstreamer-video-effects
369 GStreamer video effects plugins.
370
371 %description -n gstreamer-video-effects -l pl
372 Wtyczki efektów wideo do GStreamera.
373
374 %package -n gstreamer-visualisation
375 Summary:        GStreamer visualisations plugins
376 Summary(pl):    Wtyczki wizualizacji do GStreamera
377 Group:          Libraries
378 Requires:       gstreamer >= %{gst_req_ver}
379
380 %description -n gstreamer-visualisation
381 Various plugins for visual effects to use with audio. Included are
382 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
383
384 %description -n gstreamer-visualisation -l pl
385 Ró¿ne wtyczki efektów wizualnych do u¿ywania z d¼wiêkiem. Za³±czone:
386 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
387
388 %package -n gstreamer-ximagesrc
389 Summary:        GStreamer X11 video input plugin using standard Xlib calls
390 Summary(pl):    Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ Xlib
391 Group:          Libraries
392 Requires:       %{name} = %{version}-%{release}
393
394 %description -n gstreamer-ximagesrc
395 GStreamer X11 video input plugin using standard Xlib calls.
396
397 %description -n gstreamer-ximagesrc -l pl
398 Wtyczka wej¶cia obrazu X11 GStreamera u¿ywaj±ca standardowych wywo³añ
399 Xlib.
400
401 %prep
402 %setup -q -n %{gstname}-%{version}
403 %patch0 -p1
404 %patch1 -p1
405 %patch2 -p1
406
407 %build
408 %{__libtoolize}
409 %{__aclocal} -I m4 -I common/m4
410 %{__autoconf}
411 %{__autoheader}
412 %{__automake}
413 %configure \
414         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
415         %{!?with_aalib:--disable-aalib} \
416         %{!?with_caca:--disable-libcaca} \
417         %{!?with_cairo:--disable-cairo} \
418         %{!?with_cdio:--disable-cdio} \
419         %{?with_ladspa:--enable-ladspa} \
420         %{!?with_speex:--disable-speex} \
421         --disable-static \
422         --enable-gtk-doc \
423         --with-html-dir=%{_gtkdocdir}
424
425 %{__make}
426
427 %install
428 rm -rf $RPM_BUILD_ROOT
429
430 %{__make} install \
431         DESTDIR=$RPM_BUILD_ROOT
432
433 # We don't need plugins' *.la files
434 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
435
436 %find_lang %{gstname}-%{gst_major_ver}
437
438 %clean
439 rm -rf $RPM_BUILD_ROOT
440
441 %post   -n gstreamer-GConf
442 %gconf_schema_install gstreamer-0.10.schemas
443
444 %preun  -n gstreamer-GConf
445 %gconf_schema_uninstall gstreamer-0.10.schemas
446
447 %files -f %{gstname}-%{gst_major_ver}.lang
448 %defattr(644,root,root,755)
449 %doc AUTHORS ChangeLog NEWS README RELEASE 
450 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
451 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
452 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
453 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
454 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
455 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
456 %attr(755,root,root) %{gstlibdir}/libgstavi.so
457 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
458 %attr(755,root,root) %{gstlibdir}/libgstefence.so
459 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
460 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
461 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
462 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
463 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
464 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
465 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
466 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
467 %attr(755,root,root) %{gstlibdir}/libgstudp.so
468 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
469 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
470 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
471 %{_gtkdocdir}/gst-plugins-good-plugins-*
472
473 %if %{with gconf}
474 %files -n gstreamer-GConf
475 %defattr(644,root,root,755)
476 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
477 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
478 %endif
479
480 ##
481 ## Plugins
482 ##
483
484 %if %{with aalib}
485 %files -n gstreamer-videosink-aa
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
488 %endif
489
490 %files -n gstreamer-audio-effects-good
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
493 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
494 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
495 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
496
497 %files -n gstreamer-audio-formats
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
500 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
501 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
502
503 %if %{with cairo}
504 %files -n gstreamer-cairo
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
507 %endif
508
509 %if %{with cdio}
510 %files -n gstreamer-cdio
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
513 %endif
514
515 %files -n gstreamer-dv
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{gstlibdir}/libgstdv.so
518
519 %files -n gstreamer-audiosink-esd
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{gstlibdir}/libgstesd.so
522
523 %files -n gstreamer-flac
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{gstlibdir}/libgstflac.so
526
527 %files -n gstreamer-gdkpixbuf
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
530
531 %files -n gstreamer-hal
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
534
535 # disabled in ext/Makefile.am
536 #%if %{with ladspa}
537 #%files -n gstreamer-ladspa
538 #%defattr(644,root,root,755)
539 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
540 #%endif
541
542 %if %{with caca}
543 %files -n gstreamer-videosink-libcaca
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
546 %endif
547
548 %files -n gstreamer-libpng
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{gstlibdir}/libgstpng.so
551
552 %files -n gstreamer-audiosink-oss
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
555
556 %files -n gstreamer-raw1394
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{gstlibdir}/libgst1394.so
559
560 %files -n gstreamer-shout2
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
563
564 %if %{with speex}
565 %files -n gstreamer-speex
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
568 %endif
569
570 %files -n gstreamer-taglib
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
573
574 %files -n gstreamer-video-effects
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
577 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
578 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
579 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
580
581 %files -n gstreamer-visualisation
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
584
585 %files -n gstreamer-ximagesrc
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.067414 seconds and 3 git commands to generate.