]> git.pld-linux.org Git - packages/gstreamer-plugins-good.git/blob - gstreamer-plugins-good.spec
05e019ad534333c5bb3a165bee5069ff7a908cba
[packages/gstreamer-plugins-good.git] / gstreamer-plugins-good.spec
1 #
2 # Conditional build:
3 %bcond_without  aalib           # don't build aa videosink plugin
4 %bcond_without  apidocs         # disable gtk-doc
5 %bcond_without  caca            # don't build caca videosink plugin
6 %bcond_without  cairo           # don't build cairo plugin
7 %bcond_without  cdio            # don't build cdio plugin
8 %bcond_without  gconf           # don't build GConf plugin
9 %bcond_with     ladspa          # build ladspa plugin [currently built in plugins-bad]
10 %bcond_without  speex           # don't build speex plugin
11 %bcond_without  wavpack         # don't build wavpack plugin
12 #
13 %define         gstname         gst-plugins-good
14 %define         gst_major_ver   0.10
15 %define         gst_req_ver     0.10.10.1
16 %define         gstpb_req_ver   0.10.13
17 #
18 Summary:        Good GStreamer Streaming-media framework plugins
19 Summary(pl.UTF-8):      Dobre wtyczki do środowiska obróbki strumieni GStreamer
20 Name:           gstreamer-plugins-good
21 Version:        0.10.6
22 Release:        1
23 License:        LGPL
24 Group:          Libraries
25 Source0:        http://gstreamer.freedesktop.org/src/gst-plugins-good/%{gstname}-%{version}.tar.bz2
26 # Source0-md5:  25f111360c2930705b91b4fcf93ae5c5
27 Patch0:         %{name}-bashish.patch
28 Patch1:         %{name}-libcaca.patch
29 URL:            http://gstreamer.freedesktop.org/
30 BuildRequires:  autoconf >= 2.59-9
31 BuildRequires:  automake >= 1.5
32 BuildRequires:  glib2-devel >= 1:2.12.1
33 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
34 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
35 BuildRequires:  gtk+2-devel >= 2:2.10.1
36 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
37 BuildRequires:  liboil-devel >= 0.3.6
38 BuildRequires:  libtool >= 1.4
39 BuildRequires:  pkgconfig >= 1:0.9.0
40 BuildRequires:  python >= 2.1
41 BuildRequires:  python-PyXML
42 BuildRequires:  rpmbuild(macros) >= 1.198
43 ##
44 ## plugins
45 ##
46 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.14.0}
47 %{?with_aalib:BuildRequires:    aalib-devel >= 0.11.0}
48 %{?with_cairo:BuildRequires:    cairo-devel >= 1.2.0}
49 BuildRequires:  dbus-devel >= 0.91
50 BuildRequires:  esound-devel >= 0.2.12
51 BuildRequires:  flac-devel >= 1.1.3
52 BuildRequires:  hal-devel >= 0.5.7.1
53 %{?with_ladspa:BuildRequires:   ladspa-devel >= 1.12}
54 BuildRequires:  libavc1394-devel
55 %{?with_caca:BuildRequires:     libcaca-devel}
56 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.71}
57 BuildRequires:  libdv-devel >= 0.104
58 BuildRequires:  libiec61883-devel >= 1.0.0
59 BuildRequires:  libjpeg-devel
60 BuildRequires:  libpng-devel >= 1.2.0
61 BuildRequires:  libraw1394-devel >= 1.2.1
62 BuildRequires:  libshout-devel >= 2.0
63 # for taglib
64 BuildRequires:  libstdc++-devel
65 BuildRequires:  libxml2-devel >= 1:2.6.26
66 %{?with_speex:BuildRequires:    speex-devel >= 1:1.1.6}
67 BuildRequires:  taglib-devel >= 1.4
68 %{?with_wavpack:BuildRequires:  wavpack-devel >= 4.40.0}
69 BuildRequires:  xorg-lib-libX11-devel
70 BuildRequires:  xorg-lib-libXdamage-devel
71 BuildRequires:  xorg-lib-libXext-devel
72 BuildRequires:  xorg-lib-libXfixes-devel
73 BuildRequires:  zlib-devel
74 Requires:       gstreamer >= %{gst_req_ver}
75 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
76 Obsoletes:      gstreamer-avi
77 Obsoletes:      gstreamer-flx
78 Obsoletes:      gstreamer-matroska
79 Obsoletes:      gstreamer-mixer
80 Obsoletes:      gstreamer-navigation
81 Obsoletes:      gstreamer-rtp
82 Obsoletes:      gstreamer-udp
83 Obsoletes:      gstreamer-v4l2
84 Conflicts:      gstreamer-plugins-bad < 0.10.4
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         gstlibdir       %{_libdir}/gstreamer-%{gst_major_ver}
88
89 %description
90 GStreamer is a streaming-media framework, based on graphs of filters
91 which operate on media data. Applications using this library can do
92 anything from real-time sound processing to playing videos, and just
93 about anything else media-related. Its plugin-based architecture means
94 that new data types or processing capabilities can be added simply by
95 installing new plugins.
96
97 %description -l pl.UTF-8
98 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
99 grafie filtrów operujących na danych medialnych. Aplikacje używające
100 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
101 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
102 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
103 nowych typów danych lub możliwości obróbki.
104
105 %package apidocs
106 Summary:        Good GStreamer streaming-media framework plugins API documentation
107 Summary(pl.UTF-8):      Dokumentacja API dobrych wtyczek środowiska obróbki strumieni GStreamer
108 Group:          Documentation
109 Requires:       gtk-doc-common
110
111 %description apidocs
112 Good GStreamer streaming-media framework plugins API documentation.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API dobrych wtyczek środowiska obróbki strumieni
116 GStreamer.
117
118 %package -n gstreamer-GConf
119 Summary:        GStreamer GConf schemas
120 Summary(pl.UTF-8):      Schematy GConf GStreamera
121 Group:          Libraries
122 Requires(post,preun):   GConf2
123 Requires:       gstreamer >= %{gst_req_ver}
124 Obsoletes:      gstreamer-GConf-devel
125
126 %description -n gstreamer-GConf
127 Installation of GStreamer GConf schemas. These set usable defaults
128 used by all GStreamer-enabled GNOME applications.
129
130 %description -n gstreamer-GConf -l pl.UTF-8
131 Schematy GConf dla GStreamera. Zestaw ten ustawia wartości domyślne
132 dla wszystkich aplikacji GNOME korzystających z GStreamera
133
134 ## ## Plugins ##
135
136 %package -n gstreamer-videosink-aa
137 Summary:        GStreamer plugin for Ascii-art output
138 Summary(pl.UTF-8):      Wtyczka wyjścia obrazu Ascii-art do GStreamera
139 Group:          Libraries
140 Requires:       gstreamer >= %{gst_req_ver}
141 Provides:       gstreamer-videosink = %{version}
142 Obsoletes:      gstreamer-aalib
143
144 %description -n gstreamer-videosink-aa
145 Plugin for viewing movies in Ascii-art using aalib library.
146
147 %description -n gstreamer-videosink-aa -l pl.UTF-8
148 Wtyczka wyjścia obrazu Ascii-art używająca biblioteki aalib.
149
150 %package -n gstreamer-audio-effects-good
151 Summary:        Good GStreamer audio effects plugins
152 Summary(pl.UTF-8):      Dobre wtyczki efektów dźwiękowych do GStreamera
153 Group:          Libraries
154 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
155 Obsoletes:      gstreamer-audio-effects
156
157 %description -n gstreamer-audio-effects-good
158 Good GStreamer audio effects plugins.
159
160 %description -n gstreamer-audio-effects-good -l pl.UTF-8
161 Dobre wtyczki efektów dźwiękowych do GStreamera.
162
163 %package -n gstreamer-audio-formats
164 Summary:        GStreamer audio format plugins
165 Summary(pl.UTF-8):      Wtyczki formatów dźwięku
166 Group:          Libraries
167 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
168 # for locales in wavparse module
169 Requires:       %{name} = %{version}-%{release}
170
171 %description -n gstreamer-audio-formats
172 Plugin for playback of WAV, au and mod audio files as well as MP3
173 type.
174
175 %description -n gstreamer-audio-formats -l pl.UTF-8
176 Wtyczka do odwarzania dźwięku w formacie au, WAV, mod oraz MP3.
177
178 %package -n gstreamer-cairo
179 Summary:        GStreamer cairo plugin
180 Summary(pl.UTF-8):      Wtyczka cairo do GStreamera
181 Group:          Libraries
182 Requires:       gstreamer >= %{gst_req_ver}
183
184 %description -n gstreamer-cairo
185 GStreamer cairo plugin.
186
187 %description -n gstreamer-cairo -l pl.UTF-8
188 Wtyczka cairo do GStreamera.
189
190 %package -n gstreamer-cdio
191 Summary:        GStreamer plugin for CD audio input using libcdio
192 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdio
193 Group:          Libraries
194 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
195 Requires:       libcdio >= 0.71
196
197 %description -n gstreamer-cdio
198 Plugin for playing audio tracks using libcdio under GStreamer.
199
200 %description -n gstreamer-cdio -l pl.UTF-8
201 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
202 libcdio.
203
204 %package -n gstreamer-dv
205 Summary:        GStreamer dv plugin
206 Summary(pl.UTF-8):      Wtyczka dv do GStreamera
207 Group:          Libraries
208 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
209
210 %description -n gstreamer-dv
211 Plugin for digital video support.
212
213 %description -n gstreamer-dv -l pl.UTF-8
214 Wtyczka do GStreamera obsługująca cyfrowy obraz.
215
216 %package -n gstreamer-audiosink-esd
217 Summary:        GStreamer plugin for ESD sound output
218 Summary(pl.UTF-8):      Wtyczka wyjścia dźwięku ESD do GStreamera
219 Group:          Libraries
220 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
221 Provides:       gstreamer-audiosink = %{version}
222 Obsoletes:      gstreamer-esound
223
224 %description -n gstreamer-audiosink-esd
225 Output plugin for GStreamer for use with the esound package.
226
227 %description -n gstreamer-audiosink-esd -l pl.UTF-8
228 Wtyczka wyjścia dźwięku ESD (esound) dla GStreamera.
229
230 %package -n gstreamer-flac
231 Summary:        GStreamer plugin for FLAC lossless audio format
232 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku FLAC
233 Group:          Libraries
234 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
235
236 %description -n gstreamer-flac
237 Plugin for the free FLAC lossless audio format.
238
239 %description -n gstreamer-flac -l pl.UTF-8
240 Wtyczka obsługująca wolnodostępny, bezstratny format dźwięku FLAC.
241
242 %package -n gstreamer-gdkpixbuf
243 Summary:        GStreamer images input plugin
244 Summary(pl.UTF-8):      Wtyczka do GStreamera wczytująca obrazki
245 Group:          Libraries
246 Requires:       gstreamer >= %{gst_req_ver}
247
248 %description -n gstreamer-gdkpixbuf
249 This GStreamer plugin load images via gdkpixbuf library.
250
251 %description -n gstreamer-gdkpixbuf -l pl.UTF-8
252 Ta wtyczka GStreamera wczytuje obrazki za pośrednictwem biblioteki
253 gdkpixbuf.
254
255 %package -n gstreamer-hal
256 Summary:        GStreamer plugin to wrap the GStreamer/HAL audio input/output devices
257 Summary(pl.UTF-8):      Wtyczka GStreamera spinająca urządzenia wejścia/wyjścia dźwięku z HAL-em
258 Group:          Libraries
259 Requires:       gstreamer >= %{gst_req_ver}
260
261 %description -n gstreamer-hal
262 GStreamer plugin to wrap the GStreamer/HAL audio input/output devices.
263
264 %description -n gstreamer-hal -l pl.UTF-8
265 Wtyczka GStreamera spinająca urządzenia wejścia/wyjścia dźwięku między
266 GStreamerem a HAL-em.
267
268 %package -n gstreamer-ladspa
269 Summary:        GStreamer wrapper for LADSPA plugins
270 Summary(pl.UTF-8):      Wrapper do wtyczek LADSPA dla GStreamera
271 Group:          Libraries
272 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
273
274 %description -n gstreamer-ladspa
275 Plugin which wraps LADSPA plugins for use by GStreamer applications.
276
277 %description -n gstreamer-ladspa -l pl.UTF-8
278 Wtyczka pozwalająca na używanie wtyczek LADSPA przez aplikacje
279 GStreamera.
280
281 %package -n gstreamer-videosink-libcaca
282 Summary:        GStreamer plugin for libcaca Ascii-art output
283 Summary(pl.UTF-8):      Wtyczka libcaca do GStreamera
284 Group:          Libraries
285 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
286 Provides:       gstreamer-videosink = %{version}
287
288 %description -n gstreamer-videosink-libcaca
289 GStreamer plug-in for libcaca Ascii-art output.
290
291 %description -n gstreamer-videosink-libcaca -l pl.UTF-8
292 Wtyczka libcaca do GStreamera.
293
294 %package -n gstreamer-libpng
295 Summary:        GStreamer plugin to encode png images
296 Summary(pl.UTF-8):      Wtyczka GStreamera kodująca pliki png
297 Group:          Libraries
298 #Requires:      gstreamer >= %{gst_req_ver}
299 # for locales
300 Requires:       %{name} = %{version}-%{release}
301 Requires:       libpng >= 1.2.0
302
303 %description -n gstreamer-libpng
304 Plugin for encoding png images.
305
306 %description -n gstreamer-libpng -l pl.UTF-8
307 Wtyczka kodująca pliki png.
308
309 %package -n gstreamer-audiosink-oss
310 Summary:        GStreamer plugins for input and output using OSS
311 Summary(pl.UTF-8):      Wtyczki wejścia i wyjścia dźwięku OSS do GStreamera
312 Group:          Libraries
313 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
314 # for locales
315 Requires:       %{name} = %{version}-%{release}
316 Provides:       gstreamer-audiosink = %{version}
317 Obsoletes:      gstreamer-oss
318
319 %description -n gstreamer-audiosink-oss
320 Plugins for output and input to the OpenSoundSystem audio drivers
321 found in the Linux kernels or commercially available from OpenSound.
322
323 %description -n gstreamer-audiosink-oss -l pl.UTF-8
324 Wtyczki wyjścia i wejścia dźwięku używające sterowników
325 OpenSoundSystem obecnych w jądrach Linuksa lub dostępnych komercyjnie
326 od OpenSound.
327
328 %package -n gstreamer-raw1394
329 Summary:        GStreamer raw1394 Firewire plugin
330 Summary(pl.UTF-8):      Wtyczka FireWire dla GStreamera
331 Group:          Libraries
332 Requires:       gstreamer >= %{gst_req_ver}
333
334 %description -n gstreamer-raw1394
335 Plugin for digital video support using raw1394.
336
337 %description -n gstreamer-raw1394 -l pl.UTF-8
338 Wtyczka dająca dostęp do cyfrowego obrazu przy użyciu raw1394.
339
340 %package -n gstreamer-shout2
341 Summary:        GStreamer plugin for communicating with Shoutcast servers
342 Summary(pl.UTF-8):      Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast
343 Group:          Libraries
344 Requires:       gstreamer >= %{gst_req_ver}
345
346 %description -n gstreamer-shout2
347 GStreamer plugin for communicating with Shoutcast servers.
348
349 %description -n gstreamer-shout2 -l pl.UTF-8
350 Wtyczka do GStreamera umożliwiająca komunikację z serwerami Shoutcast.
351
352 %package -n gstreamer-speex
353 Summary:        GStreamer speex codec decoder/encoder plugin
354 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca kodek Speex
355 Group:          Libraries
356 #Requires:      gstreamer-plugins-base >= %{gstpb_req_ver}
357 Requires:       speex >= 1:1.1.6
358
359 %description -n gstreamer-speex
360 GStreamer speex codec decoder/encoder plugin.
361
362 %description -n gstreamer-speex -l pl.UTF-8
363 Wtyczka do GStreamera obsługująca kodek Speex.
364
365 %package -n gstreamer-taglib
366 Summary:        GStreamer tag writing plugin based on taglib
367 Summary(pl.UTF-8):      Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib
368 Group:          Libraries
369 Requires:       gstreamer >= %{gst_req_ver}
370
371 %description -n gstreamer-taglib
372 GStreamer tag writing plugin based on taglib.
373
374 %description -n gstreamer-taglib -l pl.UTF-8
375 Wtyczka GStreamera zapisująca znaczniki oparta na bibliotece taglib.
376
377 %package -n gstreamer-video-effects
378 Summary:        GStreamer video effects plugins
379 Summary(pl.UTF-8):      Wtyczki efektów wideo do GStreamera
380 Group:          Libraries
381 # for locales in jpeg module
382 Requires:       %{name} = %{version}-%{release}
383
384 %description -n gstreamer-video-effects
385 GStreamer video effects plugins.
386
387 %description -n gstreamer-video-effects -l pl.UTF-8
388 Wtyczki efektów wideo do GStreamera.
389
390 %package -n gstreamer-visualisation
391 Summary:        GStreamer visualisations plugins
392 Summary(pl.UTF-8):      Wtyczki wizualizacji do GStreamera
393 Group:          Libraries
394 Requires:       gstreamer >= %{gst_req_ver}
395
396 %description -n gstreamer-visualisation
397 Various plugins for visual effects to use with audio. Included are
398 smoothwave, spectrum, goom, chart, monoscope and synaesthesia.
399
400 %description -n gstreamer-visualisation -l pl.UTF-8
401 Różne wtyczki efektów wizualnych do używania z dźwiękiem. Załączone:
402 smoothwave, spectrum, goom, chart, monoscope i synaesthesia.
403
404 %package -n gstreamer-ximagesrc
405 Summary:        GStreamer X11 video input plugin using standard Xlib calls
406 Summary(pl.UTF-8):      Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań Xlib
407 Group:          Libraries
408 Requires:       %{name} = %{version}-%{release}
409
410 %description -n gstreamer-ximagesrc
411 GStreamer X11 video input plugin using standard Xlib calls.
412
413 %description -n gstreamer-ximagesrc -l pl.UTF-8
414 Wtyczka wejścia obrazu X11 GStreamera używająca standardowych wywołań
415 Xlib.
416
417 %package -n gstreamer-wavpack
418 Summary:        GStreamer plugin for Wavpack lossless audio format
419 Summary(pl.UTF-8):      Wtyczka do GStreamera obsługująca bezstratny format dźwięku Wavpack
420 Group:          Libraries
421 Requires:       gstreamer >= %{gst_req_ver}
422
423 %description -n gstreamer-wavpack
424 Plugin for lossless Wavpack audio format.
425
426 %description -n gstreamer-wavpack -l pl.UTF-8
427 Wtyczka obsługująca bezstratny format dźwięku Wavpack.
428
429 %prep
430 %setup -q -n %{gstname}-%{version}
431 %patch0 -p1
432 %patch1 -p1
433
434 %build
435 %{__libtoolize}
436 %{__aclocal} -I m4 -I common/m4
437 %{__autoconf}
438 %{__autoheader}
439 %{__automake}
440 %configure \
441         ac_cv_lib_jpeg_mmx_jpeg_set_defaults=no \
442         %{!?with_aalib:--disable-aalib} \
443         %{!?with_caca:--disable-libcaca} \
444         %{!?with_cairo:--disable-cairo} \
445         %{!?with_cdio:--disable-cdio} \
446         --enable-experimental \
447         %{?with_ladspa:--enable-ladspa} \
448         %{!?with_speex:--disable-speex} \
449         %{!?with_wavpack:--disable-wavpack} \
450         --disable-static \
451         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
452         --with-html-dir=%{_gtkdocdir}
453
454 %{__make}
455
456 %install
457 rm -rf $RPM_BUILD_ROOT
458
459 %{__make} install \
460         DESTDIR=$RPM_BUILD_ROOT
461
462 # We don't need plugins' *.la files
463 rm -f $RPM_BUILD_ROOT%{gstlibdir}/*.la
464
465 %find_lang %{gstname}-%{gst_major_ver}
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %post   -n gstreamer-GConf
471 %gconf_schema_install gstreamer-0.10.schemas
472
473 %preun  -n gstreamer-GConf
474 %gconf_schema_uninstall gstreamer-0.10.schemas
475
476 %files -f %{gstname}-%{gst_major_ver}.lang
477 %defattr(644,root,root,755)
478 %doc AUTHORS ChangeLog NEWS README RELEASE
479 %attr(755,root,root) %{gstlibdir}/libgstalphacolor.so
480 %attr(755,root,root) %{gstlibdir}/libgstalpha.so
481 %attr(755,root,root) %{gstlibdir}/libgstannodex.so
482 %attr(755,root,root) %{gstlibdir}/libgstapetag.so
483 %attr(755,root,root) %{gstlibdir}/libgstaudiofx.so
484 %attr(755,root,root) %{gstlibdir}/libgstautodetect.so
485 %attr(755,root,root) %{gstlibdir}/libgstavi.so
486 %attr(755,root,root) %{gstlibdir}/libgstdebug.so
487 %attr(755,root,root) %{gstlibdir}/libgstefence.so
488 %attr(755,root,root) %{gstlibdir}/libgstflxdec.so
489 %attr(755,root,root) %{gstlibdir}/libgstgamma.so
490 %attr(755,root,root) %{gstlibdir}/libgsticydemux.so
491 %attr(755,root,root) %{gstlibdir}/libgstid3demux.so
492 %attr(755,root,root) %{gstlibdir}/libgstmatroska.so
493 %attr(755,root,root) %{gstlibdir}/libgstmonoscope.so
494 %attr(755,root,root) %{gstlibdir}/libgstmultipart.so
495 %attr(755,root,root) %{gstlibdir}/libgstnavigationtest.so
496 %attr(755,root,root) %{gstlibdir}/libgstqtdemux.so
497 %attr(755,root,root) %{gstlibdir}/libgstrtp.so
498 %attr(755,root,root) %{gstlibdir}/libgstrtsp.so
499 %attr(755,root,root) %{gstlibdir}/libgstudp.so
500 %attr(755,root,root) %{gstlibdir}/libgstvideo4linux2.so
501 %attr(755,root,root) %{gstlibdir}/libgstvideobalance.so
502 %attr(755,root,root) %{gstlibdir}/libgstvideobox.so
503 %attr(755,root,root) %{gstlibdir}/libgstvideocrop.so
504 %attr(755,root,root) %{gstlibdir}/libgstvideomixer.so
505
506 %if %{with apidocs}
507 %files apidocs
508 %defattr(644,root,root,755)
509 %{_gtkdocdir}/gst-plugins-good-plugins-*
510 %endif
511
512 %if %{with gconf}
513 %files -n gstreamer-GConf
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{gstlibdir}/libgstgconfelements.so
516 %{_sysconfdir}/gconf/schemas/gstreamer-0.10.schemas
517 %endif
518
519 ##
520 ## Plugins
521 ##
522
523 %if %{with aalib}
524 %files -n gstreamer-videosink-aa
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{gstlibdir}/libgstaasink.so
527 %endif
528
529 %files -n gstreamer-audio-effects-good
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{gstlibdir}/libgstalaw.so
532 %attr(755,root,root) %{gstlibdir}/libgstlevel.so
533 %attr(755,root,root) %{gstlibdir}/libgstmulaw.so
534 %attr(755,root,root) %{gstlibdir}/libgstcutter.so
535
536 %files -n gstreamer-audio-formats
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{gstlibdir}/libgstauparse.so
539 %attr(755,root,root) %{gstlibdir}/libgstwavparse.so
540 %attr(755,root,root) %{gstlibdir}/libgstwavenc.so
541
542 %if %{with cairo}
543 %files -n gstreamer-cairo
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{gstlibdir}/libgstcairo.so
546 %endif
547
548 %if %{with cdio}
549 %files -n gstreamer-cdio
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
552 %endif
553
554 %files -n gstreamer-dv
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{gstlibdir}/libgstdv.so
557
558 %files -n gstreamer-audiosink-esd
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{gstlibdir}/libgstesd.so
561
562 %files -n gstreamer-flac
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{gstlibdir}/libgstflac.so
565
566 %files -n gstreamer-gdkpixbuf
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{gstlibdir}/libgstgdkpixbuf.so
569
570 %files -n gstreamer-hal
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{gstlibdir}/libgsthalelements.so
573
574 # disabled in ext/Makefile.am, currently built in plugins-bad
575 #%if %{with ladspa}
576 #%files -n gstreamer-ladspa
577 #%defattr(644,root,root,755)
578 #%attr(755,root,root) %{gstlibdir}/libgstladspa.so
579 #%endif
580
581 %if %{with caca}
582 %files -n gstreamer-videosink-libcaca
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{gstlibdir}/libgstcacasink.so
585 %endif
586
587 %files -n gstreamer-libpng
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{gstlibdir}/libgstpng.so
590
591 %files -n gstreamer-audiosink-oss
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{gstlibdir}/libgstossaudio.so
594
595 %files -n gstreamer-raw1394
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{gstlibdir}/libgst1394.so
598
599 %files -n gstreamer-shout2
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{gstlibdir}/libgstshout2.so
602
603 %if %{with speex}
604 %files -n gstreamer-speex
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{gstlibdir}/libgstspeex.so
607 %endif
608
609 %files -n gstreamer-taglib
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{gstlibdir}/libgsttaglib.so
612
613 %files -n gstreamer-video-effects
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{gstlibdir}/libgsteffectv.so
616 %attr(755,root,root) %{gstlibdir}/libgstjpeg.so
617 %attr(755,root,root) %{gstlibdir}/libgstsmpte.so
618 %attr(755,root,root) %{gstlibdir}/libgstvideoflip.so
619
620 %files -n gstreamer-visualisation
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{gstlibdir}/libgstgoom.so
623
624 %if %{with wavpack}
625 %files -n gstreamer-wavpack
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{gstlibdir}/libgstwavpack.so
628 %endif
629
630 %files -n gstreamer-ximagesrc
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{gstlibdir}/libgstximagesrc.so
This page took 0.082562 seconds and 2 git commands to generate.