]> git.pld-linux.org Git - packages/grive2.git/commitdiff
- grive2 is maintained fork of grive (but no bgrive) auto/th/grive2-0.5.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 May 2020 13:48:12 +0000 (15:48 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 May 2020 13:48:12 +0000 (15:48 +0200)
build.patch [deleted file]
grive-bgrive_cmake_fix.patch [deleted file]
grive-json-c-0.14.patch [deleted file]
grive.spec [deleted file]
grive2.spec [new file with mode: 0644]
json-c.patch [deleted file]

diff --git a/build.patch b/build.patch
deleted file mode 100644 (file)
index c33d49b..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/drive/State.cc~        2013-05-02 18:40:04.000000000 +0200
-+++ grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/drive/State.cc 2013-12-04 11:38:00.382356428 +0100
-@@ -248,12 +248,12 @@
- void State::Write( const fs::path& filename ) const
- {
-       Json last_sync ;
--      last_sync.Add( "sec",   Json(m_last_sync.Sec() ) );
--      last_sync.Add( "nsec",  Json(m_last_sync.NanoSec() ) );
-+      last_sync.Add( "sec",   Json((std::size_t)m_last_sync.Sec() ) );
-+      last_sync.Add( "nsec",  Json((std::size_t)m_last_sync.NanoSec() ) );
-       
-       Json result ;
-       result.Add( "last_sync", last_sync ) ;
--      result.Add( "change_stamp", Json(m_cstamp) ) ;
-+      result.Add( "change_stamp", Json((std::size_t)m_cstamp) ) ;
-       
-       std::ofstream fs( filename.string().c_str() ) ;
-       fs << result ;
diff --git a/grive-bgrive_cmake_fix.patch b/grive-bgrive_cmake_fix.patch
deleted file mode 100644 (file)
index a5fb116..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-diff --git a/bgrive/CMakeLists.txt b/bgrive/CMakeLists.txt
-index 074ab38..7bb3269 100644
---- a/bgrive/CMakeLists.txt
-+++ b/bgrive/CMakeLists.txt
-@@ -40,4 +40,3 @@ set_target_properties( bgrive_executable
- )
- install(TARGETS bgrive_executable RUNTIME DESTINATION bin)
--install(FILES doc/grive.1 DESTINATION share/man/man1 )
diff --git a/grive-json-c-0.14.patch b/grive-json-c-0.14.patch
deleted file mode 100644 (file)
index 344b4bd..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
---- grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/protocol/Json.cc.orig  2020-05-02 09:07:09.733415940 +0200
-+++ grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/protocol/Json.cc       2020-05-02 09:11:48.378573057 +0200
-@@ -254,7 +254,7 @@
- bool Json::Has( const std::string& key ) const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_object_get_ex( m_json, key.c_str(), 0 ) == TRUE ;
-+      return ::json_object_object_get_ex( m_json, key.c_str(), 0 ) == 1 ;
- }
- bool Json::Get( const std::string& key, Json& json ) const
-@@ -294,14 +294,14 @@
- bool Json::Bool() const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_get_boolean( m_json ) == TRUE ;
-+      return ::json_object_get_boolean( m_json ) == 1 ;
- }
- template <>
- bool Json::Is<bool>() const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_is_type( m_json, json_type_boolean ) == TRUE ;
-+      return ::json_object_is_type( m_json, json_type_boolean ) == 1 ;
- }
- template <>
-@@ -320,7 +320,7 @@
- bool Json::Is<std::string>() const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_is_type( m_json, json_type_string ) == TRUE ;
-+      return ::json_object_is_type( m_json, json_type_string ) == 1 ;
- }
- template <>
-@@ -339,7 +339,7 @@
- bool Json::Is<int>() const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_is_type( m_json, json_type_int ) == TRUE ;
-+      return ::json_object_is_type( m_json, json_type_int ) == 1 ;
- }
- template <>
-@@ -402,7 +402,7 @@
- bool Json::Is<Json::Object>() const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_is_type( m_json, json_type_object ) == TRUE ;
-+      return ::json_object_is_type( m_json, json_type_object ) == 1 ;
- }
- template <>
-@@ -426,7 +426,7 @@
- bool Json::Is<Json::Array>() const
- {
-       assert( m_json != 0 ) ;
--      return ::json_object_is_type( m_json, json_type_array ) == TRUE ;
-+      return ::json_object_is_type( m_json, json_type_array ) == 1 ;
- }
- template <>
diff --git a/grive.spec b/grive.spec
deleted file mode 100644 (file)
index f450b53..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-%define                commit          27817e835fe115ebbda5410ec904aa49a2ad01f1
-# bash: %%(c=%{commit}; echo ${c:0:7})
-%define                shortcommit     27817e8
-%define                cdate           20130702
-%define                rel             31
-Summary:       An open source Linux client for Google Drive
-Summary(pl.UTF-8):     Linuksowy, mające otwarte źródła klient Google Drive
-Name:          grive
-Version:       0.3.0
-Release:       0.%{cdate}git%{shortcommit}.%{rel}
-License:       GPL v2
-Group:         Applications/Networking
-Source0:       https://github.com/Grive/grive/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
-# Source0-md5: 4f3c3411588f889801bd5b9297e6e2c9
-# https://github.com/Grive/grive/issues/187
-Patch0:                json-c.patch
-Patch1:                %{name}-bgrive_cmake_fix.patch
-Patch2:                build.patch
-Patch3:                binutils-2.34.patch
-Patch4:                %{name}-json-c-0.14.patch
-URL:           https://github.com/Grive/grive
-BuildRequires: QtCore-devel >= 4
-BuildRequires: QtGui-devel >= 4
-BuildRequires: binutils-devel
-BuildRequires: boost-devel >= 1.40.0
-BuildRequires: cmake >= 2.8
-BuildRequires: curl-devel
-BuildRequires: expat-devel
-BuildRequires: json-c-devel >= 0.11
-BuildRequires: libgcrypt-devel
-BuildRequires: libstdc++-devel
-BuildRequires: openssl-devel
-BuildRequires: yajl-devel
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-%description
-The purpose of this project is to provide an independent
-implementation of Google Drive client. It uses the Google Document
-List API to talk to the servers in Google.
-
-%description -l pl.UTF-8
-Celem tego projektu jest zapewnienie niezależnej implementacji klienta
-Google Drive. Do komunikacji z serwerami Google'a wykorzystuje API
-Google Document List.
-
-%package -n bgrive
-Summary:       Qt frontend for Grive
-Summary(pl.UTF-8):     Interfejs Qt do Grive
-Group:         Applications/Networking
-Requires:      %{name} = %{version}-%{release}
-
-%description -n bgrive
-GUI frontend for Grive.
-
-%description -n bgrive -l pl.UTF-8
-Graficzny interfejs użytkownika do Grive.
-
-%prep
-%setup -q -n %{name}-%{commit}
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-
-%build
-install -d build
-cd build
-%cmake ..
-%{__make}
-
-%install
-rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files
-%defattr(644,root,root,755)
-%doc README
-%attr(755,root,root) %{_bindir}/grive
-%{_mandir}/man1/grive.1*
-
-%files -n bgrive
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/bgrive
diff --git a/grive2.spec b/grive2.spec
new file mode 100644 (file)
index 0000000..3b59d2e
--- /dev/null
@@ -0,0 +1,65 @@
+Summary:       An open source Linux client for Google Drive
+Summary(pl.UTF-8):     Linuksowy, mające otwarte źródła klient Google Drive
+Name:          grive2
+Version:       0.5.1
+Release:       1
+License:       GPL v2
+Group:         Applications/Networking
+#Source0Download: https://github.com/vitalif/grive2/releases
+Source0:       https://github.com/vitalif/grive2/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 2ffb02ae2ddaba51fc8f31bb322efd93
+Patch0:                binutils-2.34.patch
+URL:           https://github.com/vitalif/grive2
+BuildRequires: binutils-devel
+BuildRequires: boost-devel >= 1.40.0
+BuildRequires: cmake >= 2.8
+BuildRequires: curl-devel
+BuildRequires: expat-devel
+BuildRequires: libgcrypt-devel
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: yajl-devel
+Obsoletes:     grive < 0.3.0-1
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The purpose of this project is to provide an independent
+implementation of Google Drive client. It uses the Google Document
+List API to talk to the servers in Google.
+
+%description -l pl.UTF-8
+Celem tego projektu jest zapewnienie niezależnej implementacji klienta
+Google Drive. Do komunikacji z serwerami Google'a wykorzystuje API
+Google Document List.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+install -d build
+cd build
+%cmake ..
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README.md
+%attr(755,root,root) %{_bindir}/grive
+%dir %{_prefix}/lib/grive
+%attr(755,root,root) %{_prefix}/lib/grive/grive-sync.sh
+%{systemduserunitdir}/grive-changes@.service
+%{systemduserunitdir}/grive-timer@.service
+%{systemduserunitdir}/grive-timer@.timer
+%{_mandir}/man1/grive.1*
diff --git a/json-c.patch b/json-c.patch
deleted file mode 100644 (file)
index 4cd3c81..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/cmake/Modules/FindJSONC.cmake~      2013-05-02 18:40:04.000000000 +0200
-+++ grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/cmake/Modules/FindJSONC.cmake       2013-12-04 01:11:58.326961184 +0100
-@@ -6,8 +6,8 @@
- #  JSONC_INCLUDE_DIR - The JSON-C include directory.
- #  JSONC_LIBRARY     - The JSON-C library to link against.
--FIND_PATH(JSONC_INCLUDE_DIR json/json.h)
--FIND_LIBRARY(JSONC_LIBRARY NAMES json)
-+FIND_PATH(JSONC_INCLUDE_DIR json-c/json.h)
-+FIND_LIBRARY(JSONC_LIBRARY NAMES json-c)
- IF (JSONC_INCLUDE_DIR AND JSONC_LIBRARY)
-    SET(JSONC_FOUND TRUE)
---- grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/protocol/Json.cc~      2013-05-02 18:40:04.000000000 +0200
-+++ grive-27817e835fe115ebbda5410ec904aa49a2ad01f1/libgrive/src/protocol/Json.cc       2015-02-18 18:11:40.664989070 +0100
-@@ -29,8 +29,8 @@
-       #pragma warning(push)
-       #pragma warning(disable: 4005)
- #endif
--#include <json/json_tokener.h>
--#include <json/linkhash.h>
-+#include <json-c/json_tokener.h>
-+#include <json-c/linkhash.h>
- #ifdef _MSC_VER
-       #pragma warning(pop)
- #endif
This page took 0.303286 seconds and 4 git commands to generate.