]> git.pld-linux.org Git - packages/grace.git/commitdiff
- up to 5.1.23; source-hardening patch from debian auto/th/grace-5.1.23-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 8 Nov 2013 09:22:39 +0000 (10:22 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 8 Nov 2013 09:22:39 +0000 (10:22 +0100)
grace-libpng15.patch [deleted file]
grace.spec
source-hardening.diff [new file with mode: 0644]

diff --git a/grace-libpng15.patch b/grace-libpng15.patch
deleted file mode 100644 (file)
index e4af849..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- grace-5.1.22/src/rstdrv.c~ 2004-07-03 22:47:46.000000000 +0200
-+++ grace-5.1.22/src/rstdrv.c  2012-02-12 22:16:50.451780508 +0100
-@@ -54,6 +54,7 @@
- #ifdef HAVE_LIBPNG
- #  include <png.h>
-+#  include <zlib.h>
- #endif
- #ifndef NONE_GUI
-@@ -886,7 +886,7 @@
-         return;
-     }
--    if (setjmp(png_ptr->jmpbuf)) {
-+    if (setjmp(png_jmpbuf(png_ptr))) {
-         png_destroy_write_struct(&png_ptr, &info_ptr);
-         return;
-     }
index 7851dcf8dd2a187a71117aa481557155f9d0606d..da5c28553bf87e5ce72cccf51eaacbb9231b678d 100644 (file)
@@ -1,18 +1,18 @@
 Summary:       Numerical Data Processing and Visualization Tool (grace)
 Summary(pl.UTF-8):     Narzędzie do numerycznej obróbki i wizualizacji danych
 Name:          grace
-Version:       5.1.22
-Release:       9
+Version:       5.1.23
+Release:       1
 License:       GPL
 Group:         Applications/Math
 Source0:       ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/%{name}-%{version}.tar.gz
-# Source0-md5: 672356466f18fe59ed21a8fb44f9851d
+# Source0-md5: e2b28ebe31288952d899fbb5c97858ae
 Source1:       %{name}.desktop
 Patch0:                %{name}-FHS.patch
 Patch1:                %{name}-home_etc.patch
 Patch2:                %{name}-etc.patch
 Patch3:                %{name}-fontsdir.patch
-Patch4:                %{name}-libpng15.patch
+Patch4:                source-hardening.diff
 URL:           http://plasma-gate.weizmann.ac.il/Grace/
 BuildRequires: Xbae-devel
 BuildRequires: XmHTML-devel >= 1.1.5
diff --git a/source-hardening.diff b/source-hardening.diff
new file mode 100644 (file)
index 0000000..9431de9
--- /dev/null
@@ -0,0 +1,59 @@
+Description: Permit compilation with hardening flags in dpkg >= 1.16.0
+Origin: vendor
+Author: Nicholas Breen
+Index: grace-5.1.22/src/utils.c
+===================================================================
+--- grace-5.1.22.orig/src/utils.c      2012-05-17 19:00:52.144748609 -0700
++++ grace-5.1.22/src/utils.c   2012-05-17 19:00:54.000000000 -0700
+@@ -1171,12 +1171,12 @@
+     if (inwin) {
+         stufftextwin(s);
+     } else {
+-        printf(s);
++        printf("%s", s);
+     }
+ #endif
+     /* log results to file */
+     if (resfp != NULL) {
+-      fprintf(resfp, s);
++      fprintf(resfp, "%s", s);
+     }
+ }
+@@ -1222,7 +1222,9 @@
+     char buf[GR_MAXPATHLEN];
+     
+     if (wd == NULL) {
+-        getcwd(workingdir, GR_MAXPATHLEN - 1);
++        if (getcwd(workingdir, GR_MAXPATHLEN - 1) == NULL) {
++          return RETURN_FAILURE;
++        }
+         if (workingdir[strlen(workingdir)-1] != '/') {
+             strcat(workingdir, "/");
+         }
+Index: grace-5.1.22/src/svgdrv.c
+===================================================================
+--- grace-5.1.22.orig/src/svgdrv.c     2012-05-17 19:00:52.144748609 -0700
++++ grace-5.1.22/src/svgdrv.c  2012-05-17 19:00:54.000000000 -0700
+@@ -745,7 +745,7 @@
+             -tm->cxy, -tm->cyy,
+             scaleval(vp.x), scaleval(vp.y));
+-    fprintf(prstream, escape_specials((unsigned char *) s, len));
++    fprintf(prstream, "%s", escape_specials((unsigned char *) s, len));
+     fprintf(prstream, "</text>\n");
+ }
+Index: grace-5.1.22/auxiliary/Makefile
+===================================================================
+--- grace-5.1.22.orig/auxiliary/Makefile       2012-05-17 19:00:52.144748609 -0700
++++ grace-5.1.22/auxiliary/Makefile    2012-05-17 19:08:21.791557072 -0700
+@@ -22,7 +22,7 @@
+ devclean : distclean
+ convcal$(EXE) : convcal.c
+-      $(CC) $(CFLAGS0) $(CPPFLAGS) -o $@ convcal.c $(NOGUI_LIBS)
++      $(CC) $(CFLAGS0) $(CPPFLAGS) -Wl,-z,relro -Wl,-z,now -o $@ convcal.c $(NOGUI_LIBS)
+ install : $(AUXILIARIES) $(PROGRAMS) $(SCRIPTS)
+       $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
This page took 0.125124 seconds and 4 git commands to generate.