]> git.pld-linux.org Git - packages/grace.git/blobdiff - grace.spec
- added ac+tirpc patch (autoconf fix + tirpc support)
[packages/grace.git] / grace.spec
index 8b2fde594fba5d58c7a04984d52550215b8d5206..dae892b6f6bc93b8c18e2be5c9e69e9fedff8bde 100644 (file)
@@ -1,40 +1,46 @@
+#
+# Conditional build:
+%bcond_with    pdflib  # PDF driver (based on PDFlib, non-free)
+
 Summary:       Numerical Data Processing and Visualization Tool (grace)
-Summary(pl):   Narzêdzie do numerycznej obróbki i wizualizacji danych
+Summary(pl.UTF-8):     Narzędzie do numerycznej obróbki i wizualizacji danych
 Name:          grace
-Version:       5.1.2
-Release:       4
-License:       GPL
+Version:       5.1.25
+Release:       3
+License:       GPL v2+
 Group:         Applications/Math
-Source0:       ftp://plasma-gate.weizmann.ac.il/pub/grace/src/%{name}-%{version}.tar.gz
-Patch0:                %{name}-DESTDIR.patch
+Source0:       ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/%{name}-%{version}.tar.gz
+# Source0-md5: c0482b1f18b113192946a96f5ff35a4d
+Source1:       %{name}.desktop
+Patch0:                %{name}-FHS.patch
 Patch1:                %{name}-home_etc.patch
-Patch2:                %{name}-PDFlib.patch
-Patch3:                %{name}-etc.patch
-Patch4:                %{name}-fontsdir.patch
-Patch5:                %{name}-ac25x.patch
-URL:           http://plasma-gate.weizmann.ac.il/Grace/
-BuildRequires: XFree86-devel
+Patch2:                %{name}-etc.patch
+Patch3:                %{name}-fontsdir.patch
+Patch4:                source-hardening.diff
+Patch5:                %{name}-ac+tirpc.patch
+URL:           https://plasma-gate.weizmann.ac.il/Grace/
 BuildRequires: Xbae-devel
 BuildRequires: XmHTML-devel >= 1.1.5
 BuildRequires: autoconf
-BuildRequires: fftw-devel
-BuildRequires: lesstif-devel
+BuildRequires: automake
+BuildRequires: fftw-devel >= 2.1.3
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel >= 0.9.6
-BuildRequires: libtiff-devel
+BuildRequires: libtirpc-devel
+BuildRequires: motif-devel >= 1.2
 BuildRequires: netcdf-devel >= 3.0
-BuildRequires: pdflib-devel >= 3.0
-BuildRequires: t1lib-devel
-Requires:      ghostscript-fonts-std
+%{?with_pdflib:BuildRequires:  pdflib-lite-devel >= 5.0.0}
+BuildRequires: t1lib-devel >= 5.0.0
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXpm-devel
+BuildRequires: xorg-lib-libXt-devel
+Requires:      fonts-Type1-urw
 Requires:      libpng >= 0.9.6
-Requires:      pdflib >= 3.0
+%{?with_pdflib:Requires:       pdflib-lite >= 5.0.0}
 Requires:      zlib >= 1.0.3
 Obsoletes:     xmgr
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
 Grace is a Motif application for two-dimensional data visualization.
 Grace can transform the data using free equations, FFT, cross- and
@@ -43,12 +49,12 @@ The generated figures are of high quality. Grace is a very convenient
 tool for data inspection, data transformation, and and for making
 figures for publications.
 
-%description -l pl
-Grace jest Motiffow± aplikacj± s³u¿±c± do dwuwymiarowej wizualizacji
-danych. Mo¿e przekszta³caæ dane za pomoc± wolnych równañ, FFT,
-autokorelacji, ró¿niczek, ca³ek, histogramów itd. Powsta³e wykresy
-maj± wysok± jako¶æ. Grace jest bardzo u¿ytecznym narzêdziem je¶li
-chodzi o monitorowanie i transformacjê danych oraz tworzenie wykresów
+%description -l pl.UTF-8
+Grace jest motifową aplikacją służącą do dwuwymiarowej wizualizacji
+danych. Może przekształcać dane za pomocą wolnych równań, FFT,
+autokorelacji, różniczek, całek, histogramów itd. Powstałe wykresy
+mają wysoką jakość. Grace jest bardzo użytecznym narzędziem jeśli
+chodzi o monitorowanie i transformację danych oraz tworzenie wykresów
 do publikacji.
 
 %prep
@@ -61,27 +67,27 @@ do publikacji.
 %patch5 -p1
 
 %build
-cp -f ac-tools/configure.in .
-%{__autoconf}
-if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
-       CPPFLAGS="`pkg-config libpng12 --cflags`"
-fi
-%configure CPPFLAGS="$CPPFLAGS" \
-       --enable-grace-home=%{_datadir}/%{name} \
+cp -f /usr/share/automake/config.* ac-tools
+%{__autoconf} ac-tools/configure.in > configure
+%configure \
+       %{!?debug:--disable-debug} \
        --enable-editres \
-       --enable-extra-incpath=$PKG_BUILD_DIR/include \
-       --enable-extra-ldpath=$PKG_BUILD_DIR/lib \
-       %{!?debug:--disable-debug}
+       --enable-grace-home=%{_datadir}/%{name} \
+       %{!?with_pdflib:--disable-pdfdrv} \
+       --without-bundled-xbae
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{_datadir}/grace/doc/{*.sgml,*.dvi,*.1} \
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/grace/doc/*.1 \
        $RPM_BUILD_ROOT%{_datadir}/grace/examples/dotest
 
+install -D %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
+
 gzip -9nf $RPM_BUILD_ROOT%{_datadir}/grace/doc/*.dat \
        $RPM_BUILD_ROOT%{_datadir}/grace/doc/*.agr \
        $RPM_BUILD_ROOT%{_datadir}/grace/doc/*.sh
@@ -96,15 +102,26 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/grace/doc
 %{_datadir}/grace/examples
 %dir %{_sysconfdir}/grace
-
-%config(noreplace) %verify(not size, mtime, md5) %{_sysconfdir}/grace/*
-%attr(755,root,root)%{_bindir}/*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/grace/gracerc
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/grace/gracerc.user
+%attr(755,root,root) %{_bindir}/convcal
+%attr(755,root,root) %{_bindir}/fdf2fit
+%attr(755,root,root) %{_bindir}/gracebat
+%attr(755,root,root) %{_bindir}/grconvert
+%attr(755,root,root) %{_bindir}/xmgrace
+%{_mandir}/man1/convcal.1*
+%{_mandir}/man1/grace.1*
+%{_mandir}/man1/gracebat.1*
+%{_mandir}/man1/grconvert.1*
+%{_mandir}/man1/xmgrace.1*
 %{_libdir}/grace
-%{_includedir}/*
+%{_includedir}/grace_np.h
 %dir %{_datadir}/grace
 %{_datadir}/grace/auxiliary
 %dir %{_datadir}/grace/templates
-%config(noreplace) %verify(not size, mtime, md5) %{_datadir}/grace/templates/*
+%config(noreplace) %verify(not md5 mtime size) %{_datadir}/grace/templates/*
 %dir %{_datadir}/grace/fonts
 %{_datadir}/grace/fonts/enc
+%{_datadir}/grace/fonts/type1
 %{_datadir}/grace/fonts/FontDataBase
+%{_desktopdir}/grace.desktop
This page took 0.06842 seconds and 4 git commands to generate.