]> git.pld-linux.org Git - packages/google-chrome.git/commitdiff
update to 71.0.3578.98
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 25 Jan 2019 11:26:41 +0000 (13:26 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 25 Jan 2019 11:26:46 +0000 (13:26 +0200)
xml parse is broken, so specify version manually:
$ ./update-source.sh stable 71.0.3578.98

google-chrome.spec
update-source.sh

index 5bc93e1c044fc38543c7d2218ae4b3305b7770ed..b4cbaeba6589d352ca49dcd2225e11497ed3e810 100644 (file)
 %endif
 Summary:       Google Chrome
 Name:          google-chrome%{?gcsuffix}
-Version:       70.0.3538.67
+Version:       71.0.3578.98
 Release:       1
 License:       Multiple, see http://chrome.google.com/
 Group:         Applications/Networking
 Source0:       http://dl.google.com/linux/chrome/rpm/stable/x86_64/google-chrome-%{state}-%{version}-%{release}.x86_64.rpm
-# NoSource0-md5:       08255d912e6fb3261ba345143c7b8422
+# NoSource0-md5:       90f4c696357da96926c8724365bdce0d
 NoSource:      0
 Source1:       google-chrome.sh
 Source2:       find-lang.sh
index e7ae7440488372965ce3fd42f066051f4fad8f5d..4575a569ef7b27736b1d59bacd5ddacb083967a9 100755 (executable)
@@ -35,25 +35,34 @@ sourceurl=https://dl.google.com/linux/$product/rpm/stable/$arch
 
 set -e
 
-echo -n "Fetching latest version... "
-t=$(mktemp)
-
-# poldek is buggy, see https://bugs.launchpad.net/poldek/+bug/1026762
-#poldek -q --st=metadata --source "$sourceurl/" --update
-#poldek -q --skip-installed --st=metadata --source "$sourceurl/" --cmd "ls google-chrome-$branch" > $t
-
-repodata=primary-$branch-$(date +%Y%m%d).xml
-[ "$cache" = "yes" ] || rm -f "$repodata"
-test -e $repodata || {
-       wget $sourceurl/repodata/primary.xml.gz -O $repodata.gz
-       gzip -dc $repodata.gz > $repodata || test -s $repodata
-}
-perl -ne 'm{<name>google-'$product-$branch'</name>} and m{<version epoch="0" ver="([\d.]+)" rel="(\d+)"/>} and print "$1 $2"' > $t < $repodata
+fetch_version() {
+       echo -n "Fetching latest version... "
+       t=$(mktemp)
+
+       # poldek is buggy, see https://bugs.launchpad.net/poldek/+bug/1026762
+       #poldek -q --st=metadata --source "$sourceurl/" --update
+       #poldek -q --skip-installed --st=metadata --source "$sourceurl/" --cmd "ls google-chrome-$branch" > $t
 
-set -- $(sed -re "s,^.+-([^-]+)-([^-]+).$arch$,\1 \2," $t)
+       repodata=primary-$branch-$(date +%Y%m%d).xml
+       [ "$cache" = "yes" ] || rm -f "$repodata"
+       test -e $repodata || {
+               wget $sourceurl/repodata/primary.xml.gz -O $repodata.gz
+               gzip -dc $repodata.gz > $repodata || test -s $repodata
+       }
+       perl -ne 'm{<name>google-'$product-$branch'</name>} and m{<version epoch="0" ver="([\d.]+)" rel="(\d+)"/>} and print "$1 $2"' > $t < $repodata
 
-ver=$1
-rel=$2
+       set -- $(sed -re "s,^.+-([^-]+)-([^-]+).$arch$,\1 \2," $t)
+
+       ver=$1
+       rel=$2
+}
+
+if [ -n "$2" ];  then
+       ver=$2
+       rel=1
+else
+       fetch_version
+fi
 
 if [ -z "$ver" -o -z "$rel" ]; then
        die "Error: xml file is missing data for ${branch} type"
This page took 0.111132 seconds and 4 git commands to generate.