]> git.pld-linux.org Git - packages/golang.git/commitdiff
up to 1.10.3 auto/th/golang-1.10.3-1
authorJan Palus <atler@pld-linux.org>
Thu, 19 Jul 2018 18:05:30 +0000 (20:05 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 19 Jul 2018 18:05:30 +0000 (20:05 +0200)
- golang-1.2-verbose-build dropped (also dropped in fedora)
- go1.5-zoneinfo_testing_only replaced with new version from fedora

0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch [new file with mode: 0644]
go1.5-zoneinfo_testing_only.patch [deleted file]
golang-1.2-verbose-build.patch [deleted file]
golang.spec

diff --git a/0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch b/0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
new file mode 100644 (file)
index 0000000..422ca2b
--- /dev/null
@@ -0,0 +1,88 @@
+From edce31a2904846ae74e3c011f2cf5fddc963459e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jakub=20=C4=8Cajka?= <jcajka@redhat.com>
+Date: Thu, 22 Mar 2018 12:07:32 +0100
+Subject: [PATCH 1/3] Don't use the bundled tzdata at runtime, except for the
+ internal test suite
+
+---
+ src/time/internal_test.go | 7 +++++--
+ src/time/zoneinfo_test.go | 3 ++-
+ src/time/zoneinfo_unix.go | 2 --
+ 3 files changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/src/time/internal_test.go b/src/time/internal_test.go
+index 76d5524124..e81ace5f64 100644
+--- a/src/time/internal_test.go
++++ b/src/time/internal_test.go
+@@ -4,13 +4,15 @@
+ package time
++import "runtime"
++
+ func init() {
+       // force US/Pacific for time zone tests
+       ForceUSPacificForTesting()
+ }
+ func initTestingZone() {
+-      z, err := loadLocation("America/Los_Angeles", zoneSources[len(zoneSources)-1:])
++      z, err := loadLocation("America/Los_Angeles", zoneSources)
+       if err != nil {
+               panic("cannot load America/Los_Angeles for testing: " + err.Error())
+       }
+@@ -21,8 +23,9 @@ func initTestingZone() {
+ var OrigZoneSources = zoneSources
+ func forceZipFileForTesting(zipOnly bool) {
+-      zoneSources = make([]string, len(OrigZoneSources))
++      zoneSources = make([]string, len(OrigZoneSources)+1)
+       copy(zoneSources, OrigZoneSources)
++      zoneSources = append(zoneSources, runtime.GOROOT()+"/lib/time/zoneinfo.zip")
+       if zipOnly {
+               zoneSources = zoneSources[len(zoneSources)-1:]
+       }
+diff --git a/src/time/zoneinfo_test.go b/src/time/zoneinfo_test.go
+index 7a55d4f618..6063ca1195 100644
+--- a/src/time/zoneinfo_test.go
++++ b/src/time/zoneinfo_test.go
+@@ -8,6 +8,7 @@ import (
+       "fmt"
+       "os"
+       "reflect"
++      "runtime"
+       "testing"
+       "time"
+ )
+@@ -128,7 +129,7 @@ func TestLoadLocationFromTZData(t *testing.T) {
+               t.Fatal(err)
+       }
+-      tzinfo, err := time.LoadTzinfo(locationName, time.OrigZoneSources[len(time.OrigZoneSources)-1])
++      tzinfo, err := time.LoadTzinfo(locationName, runtime.GOROOT()+"/lib/time/zoneinfo.zip")
+       if err != nil {
+               t.Fatal(err)
+       }
+diff --git a/src/time/zoneinfo_unix.go b/src/time/zoneinfo_unix.go
+index 88313aa0ed..d9596115ef 100644
+--- a/src/time/zoneinfo_unix.go
++++ b/src/time/zoneinfo_unix.go
+@@ -12,7 +12,6 @@
+ package time
+ import (
+-      "runtime"
+       "syscall"
+ )
+@@ -22,7 +21,6 @@ var zoneSources = []string{
+       "/usr/share/zoneinfo/",
+       "/usr/share/lib/zoneinfo/",
+       "/usr/lib/locale/TZ/",
+-      runtime.GOROOT() + "/lib/time/zoneinfo.zip",
+ }
+ func initLocal() {
+-- 
+2.14.3
+
diff --git a/go1.5-zoneinfo_testing_only.patch b/go1.5-zoneinfo_testing_only.patch
deleted file mode 100644 (file)
index 35c7d08..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-# we had been just removing the zoneinfo.zip, but that caused tests to fail for users that
-# later run `go test -a std`. This makes it only use the zoneinfo.zip where needed in tests.
-diff --git a/src/time/zoneinfo_unix.go b/src/time/zoneinfo_unix.go
-index ed9502d..c2569e7 100644
---- a/src/time/zoneinfo_unix.go
-+++ b/src/time/zoneinfo_unix.go
-@@ -32,14 +32,14 @@ var zoneDirs = []string{
-       "/usr/share/zoneinfo/",
-       "/usr/share/lib/zoneinfo/",
-       "/usr/lib/locale/TZ/",
--      runtime.GOROOT() + "/lib/time/zoneinfo.zip",
- }
- var origZoneDirs = zoneDirs
- func forceZipFileForTesting(zipOnly bool) {
--      zoneDirs = make([]string, len(origZoneDirs))
-+      zoneDirs = make([]string, len(origZoneDirs)+1)
-       copy(zoneDirs, origZoneDirs)
-+      zoneDirs = append(zoneDirs, runtime.GOROOT()+"/lib/time/zoneinfo.zip")
-       if zipOnly {
-               for i := 0; i < len(zoneDirs)-1; i++ {
-                       zoneDirs[i] = "/XXXNOEXIST"
diff --git a/golang-1.2-verbose-build.patch b/golang-1.2-verbose-build.patch
deleted file mode 100644 (file)
index 67adc8f..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- golang-1.9.3/src/make.bash.orig    2018-01-27 14:02:08.808740661 +0100
-+++ golang-1.9.3/src/make.bash 2018-01-27 14:04:37.817549145 +0100
-@@ -167,7 +167,7 @@
-       # CC_FOR_TARGET is recorded as the default compiler for the go tool. When building for the host, however,
-       # use the host compiler, CC, from `cmd/dist/dist env` instead.
-       CC=$CC GOOS=$GOHOSTOS GOARCH=$GOHOSTARCH \
--              "$GOTOOLDIR"/go_bootstrap install -gcflags "$GO_GCFLAGS" -ldflags "$GO_LDFLAGS" -v std cmd
-+              "$GOTOOLDIR"/go_bootstrap install -gcflags "$GO_GCFLAGS" -ldflags "$GO_LDFLAGS" -v -x std cmd
-       echo
- fi
-@@ -175,7 +175,7 @@
- old_bin_files=$(cd $GOROOT/bin && echo *)
--CC=$CC_FOR_TARGET "$GOTOOLDIR"/go_bootstrap install $GO_FLAGS -gcflags "$GO_GCFLAGS" -ldflags "$GO_LDFLAGS" -v std cmd
-+CC=$CC_FOR_TARGET "$GOTOOLDIR"/go_bootstrap install $GO_FLAGS -gcflags "$GO_GCFLAGS" -ldflags "$GO_LDFLAGS" -v -x std cmd
- # Check that there are no new files in $GOROOT/bin other than go and gofmt
- # and $GOOS_$GOARCH (a directory used when cross-compiling).
index aba4e778b78b846df18443fc376062d971c46717..78a3695a6575d68d25e8404918109ecd557f8e7c 100644 (file)
 Summary:       Go compiler and tools
 Summary(pl.UTF-8):     Kompilator języka Go i narzędzia
 Name:          golang
-Version:       1.9.4
+Version:       1.10.3
 Release:       1
 # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
 License:       BSD and Public Domain
 Group:         Development/Languages
 # Source0Download: https://golang.org/dl/
 Source0:       https://storage.googleapis.com/golang/go%{version}.src.tar.gz
-# Source0-md5: 6816441fd6680c63865cdd5cb8bc1960
+# Source0-md5: d15dfb264105c5e84fbe33f4a4aa5021
 Patch0:                ca-certs.patch
-Patch2:                %{name}-1.2-verbose-build.patch
-Patch5:                go1.5-zoneinfo_testing_only.patch
+Patch1:                0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
 URL:           http://golang.org/
 BuildRequires: bash
 BuildRequires: rpm-pythonprov
@@ -128,8 +127,7 @@ Dokumentacja do języka Go.
 %setup -qc
 %{__mv} go/* .
 %patch0 -p1
-%patch2 -p1
-%patch5 -p1
+%patch1 -p1
 
 # clean patch backups
 find . -name '*.orig' | xargs -r %{__rm}
@@ -246,6 +244,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/addr2line
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/api
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/asm
+%attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/buildid
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/cgo
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/compile
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/cover
@@ -257,12 +256,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/objdump
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/pack
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/pprof
+%attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/test2json
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/trace
 %attr(755,root,root) %{_libdir}/%{name}/pkg/tool/linux_%{GOARCH}/vet
 
 %dir %{_libdir}/%{name}/pkg/bootstrap
 %dir %{_libdir}/%{name}/pkg/bootstrap/bin
 %attr(755,root,root) %{_libdir}/%{name}/pkg/bootstrap/bin/asm
+%attr(755,root,root) %{_libdir}/%{name}/pkg/bootstrap/bin/cgo
 %attr(755,root,root) %{_libdir}/%{name}/pkg/bootstrap/bin/compile
 %attr(755,root,root) %{_libdir}/%{name}/pkg/bootstrap/bin/link
 %{_libdir}/%{name}/pkg/bootstrap/pkg
This page took 0.579283 seconds and 4 git commands to generate.