]> git.pld-linux.org Git - packages/gnuradio.git/commitdiff
- fix building with boost 1.70 auto/th/gnuradio-3.7.13.4-3
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 22 Apr 2019 19:19:33 +0000 (21:19 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 22 Apr 2019 19:19:33 +0000 (21:19 +0200)
- rel 3

boost-1.70.patch [new file with mode: 0644]
gnuradio.spec

diff --git a/boost-1.70.patch b/boost-1.70.patch
new file mode 100644 (file)
index 0000000..0e8a9ec
--- /dev/null
@@ -0,0 +1,16 @@
+--- gnuradio-3.7.13.4/gr-blocks/lib/socket_pdu_impl.cc.orig    2018-07-15 18:09:20.000000000 +0200
++++ gnuradio-3.7.13.4/gr-blocks/lib/socket_pdu_impl.cc 2019-04-22 20:56:25.097648774 +0200
+@@ -165,7 +165,12 @@
+     void
+     socket_pdu_impl::start_tcp_accept()
+     {
+-      tcp_connection::sptr new_connection = tcp_connection::make(d_acceptor_tcp->get_io_service(), d_rxbuf.size(), d_tcp_no_delay);
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s)->get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s)->get_io_service())
++#endif
++      tcp_connection::sptr new_connection = tcp_connection::make(GET_IO_SERVICE(d_acceptor_tcp), d_rxbuf.size(), d_tcp_no_delay);
+       d_acceptor_tcp->async_accept(new_connection->socket(),
+         boost::bind(&socket_pdu_impl::handle_tcp_accept, this,
index d10f339e6407919b3463b99995cbf40ca254b626..48d856c3ac2a2bba2bb7536a481c5a2045a72549 100644 (file)
@@ -6,7 +6,7 @@
 Summary:       Software defined radio framework
 Name:          gnuradio
 Version:       3.7.13.4
-Release:       2
+Release:       3
 License:       GPL v3
 Group:         Applications/Engineering
 Source0:       http://gnuradio.org/releases/gnuradio/%{name}-%{version}.tar.gz
@@ -15,6 +15,7 @@ Patch0:               link.patch
 Patch1:                gsl.patch
 Patch2:                libexec.patch
 Patch3:                qwt-includes.patch
+Patch4:                boost-1.70.patch
 URL:           http://www.gnuradio.org/
 BuildRequires: Qt3Support >= 4.8
 BuildRequires: QtCLucene-devel >= 4.8
@@ -133,6 +134,7 @@ GNU Radio examples.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__mkdir_p} build
This page took 0.168209 seconds and 4 git commands to generate.