]> git.pld-linux.org Git - packages/gnuchess.git/commitdiff
- added compile.patch auto/ti/gnuchess-5_07-7
authorSzymon Siwek <sls@pld-linux.org>
Mon, 14 Dec 2009 23:18:41 +0000 (23:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    compile.patch -> 1.1
    gnuchess.spec -> 1.52

compile.patch [new file with mode: 0644]
gnuchess.spec

diff --git a/compile.patch b/compile.patch
new file mode 100644 (file)
index 0000000..ab6d8fc
--- /dev/null
@@ -0,0 +1,39 @@
+--- gnuchess-5.07/src/common.h.orig    2009-12-15 00:04:30.233924867 +0100
++++ gnuchess-5.07/src/common.h 2009-12-15 00:05:24.416211779 +0100
+@@ -744,7 +744,7 @@ void wait_for_input(void);
+  * Input routine, initialized to one of the specific
+  * input routines. The given argument is the prompt.
+  */
+-void (*getline) (char *);
++void (*gc_getline) (char *);
+ #define MAXSTR 128
+ extern char inputstr[MAXSTR];
+--- gnuchess-5.07/src/input.c.orig     2009-12-15 00:05:36.836210664 +0100
++++ gnuchess-5.07/src/input.c  2009-12-15 00:07:10.419534417 +0100
+@@ -127,7 +127,7 @@ void *input_func(void *arg __attribute__
+             (RealGameCnt+1)/2 + 1 );
+     }
+     pthread_mutex_lock(&input_mutex);
+-    getline(prompt);
++    gc_getline(prompt);
+     input_status = INPUT_AVAILABLE;
+     pthread_cond_signal(&input_cond);
+     pthread_mutex_unlock(&input_mutex);
+@@ -173,13 +173,13 @@ void InitInput(void)
+ {
+ #ifdef HAVE_LIBREADLINE
+   if (isatty(STDIN_FILENO)) {
+-    getline = getline_readline;
++    gc_getline = getline_readline;
+     using_history();
+   } else {
+-    getline = getline_standard;
++    gc_getline = getline_standard;
+   }
+ #else
+-  getline = getline_standard;
++  gc_getline = getline_standard;
+ #endif
+   /* Start input thread */
+   pthread_create(&input_thread, NULL, input_func, NULL);
index 3e0ff2ef312d3faa779df0acd0ff0d938d4b68a1..609f25589403b6d79a34f90e40cfe6aeab3241e3 100644 (file)
@@ -17,6 +17,7 @@ Source0:      http://ftp.gnu.org/gnu/chess/%{name}-%{version}.tar.gz
 Source1:       xchess.png
 Source2:       %{name}.desktop
 Patch0:                %{name}-gcc4.patch
+Patch1:                compile.patch
 URL:           http://www.gnu.org/software/chess/chess.html
 BuildRequires: automake
 BuildRequires: flex
@@ -71,6 +72,7 @@ programı ile birlikte kullanılarak X altında da oynanabilir.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 cp -f /usr/share/automake/config.* .
This page took 0.084165 seconds and 4 git commands to generate.