]> git.pld-linux.org Git - packages/gnome-terminal.git/blobdiff - gnome-terminal.spec
up to 3.8.1
[packages/gnome-terminal.git] / gnome-terminal.spec
index 0499bea7ec7b2ef072024ec25717aadc1d90e962..273977a5f208dcce90d9fbcd7a76486bcdb73a3e 100644 (file)
@@ -1,55 +1,40 @@
-#
-# Conditional build:
-# This causes <prev-tab> key do nothing on the first tab (instead of 
-# passing the keypress to the application running in the terminal). Ditto 
-# for the last tab. This is kinda annoying.
-%bcond_with    disable_prev_next_tab_sensitivity_changes
-# This is specific to PLD and causes an "unknown term type" on most other
-# hosts I have to work on (the rest of the world uses xterm for g-t)
-%bcond_with    term_voodoo
-# This allows to mark on-terminal urls containing square brackets (eg. to
-# copy them or to open in external browser).
-%bcond_with    classify_square_brackets_into_url_paths
-#
 Summary:       GNOME Terminal
 Summary(pl.UTF-8):     Terminal dla GNOME
 Name:          gnome-terminal
-Version:       2.18.4
+Version:       3.8.1
 Release:       1
-License:       GPL
+License:       GPL v2+
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/2.18/%{name}-%{version}.tar.bz2
-# Source0-md5: e4429d66d0d2ede8e14756cfbc15d30a
-Patch0:                %{name}-TERM.patch
-Patch1:                %{name}-disable-prev_next-tab-sensitivity-changes.patch
-Patch2:                %{name}-desktop.patch
-Patch3:                %{name}-save-session-crash.patch
-Patch4:                %{name}-url-regex.patch
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/3.8/%{name}-%{version}.tar.xz
+# Source0-md5: e94217c5b522984c18fdfdc5a2b5b220
+Patch0:                %{name}-desktop.patch
+Patch1:                wordseps.patch
 URL:           http://www.gnome.org/
-BuildRequires: GConf2-devel >= 2.20.0
+BuildRequires: GConf2-devel >= 2.32.0
 BuildRequires: autoconf >= 2.53
-BuildRequires: automake
-BuildRequires: gtk+2-devel >= 2:2.12.0
-BuildRequires: gnome-common >= 2.20.0
-BuildRequires: gnome-doc-utils >= 0.12.0
-BuildRequires: gnome-vfs2-devel >= 2.20.0
-BuildRequires: intltool >= 0.36.2
-BuildRequires: libglade2-devel >= 1:2.6.2
-BuildRequires: libgnomeui-devel >= 2.20.0
+BuildRequires: automake >= 1:1.9
+BuildRequires: dconf-devel >= 0.12
+BuildRequires: docbook-dtd412-xml
+BuildRequires: gettext-devel
+BuildRequires: glib2-devel >= 1:2.33.2
+BuildRequires: gnome-common
+BuildRequires: gsettings-desktop-schemas-devel >= 0.1.0
+BuildRequires: gtk+3-devel >= 3.6.0
+BuildRequires: intltool >= 0.40.0
 BuildRequires: libtool
+BuildRequires: libxml2-progs
 BuildRequires: pkgconfig >= 1:0.12.0
 BuildRequires: rpmbuild(find_lang) >= 1.23
 BuildRequires: rpmbuild(macros) >= 1.197
-BuildRequires: scrollkeeper
-BuildRequires: sed >= 4.0
-BuildRequires: startup-notification-devel >= 0.8
-BuildRequires: vte-devel >= 0.16.9
-Requires(post,preun):  GConf2
-Requires(post,postun): scrollkeeper
-Requires:      libgnomeui >= 2.20.0
-Requires:      startup-notification >= 0.8
-Requires:      vte >= 0.16.9
+BuildRequires: tar >= 1:1.22
+BuildRequires: vte-devel >= 0.34.0
+BuildRequires: xz
+BuildRequires: yelp-tools
+Requires(post,postun): glib2 >= 2.33.2
+Requires:      glib2 >= 1:2.33.2
+Requires:      gsettings-desktop-schemas >= 0.1.0
 Requires:      terminfo
+Requires:      vte >= 0.34.0
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -62,20 +47,8 @@ To jest terminal, na razie całkowicie nie dokończony.
 
 %prep
 %setup -q
-%if %{with term_voodoo}
 %patch0 -p1
-%endif
-%if %{with disable_prev_next_tab_sensitivity_changes}
 %patch1 -p1
-%endif
-%patch2 -p1
-%patch3 -p1
-%if %{with classify_square_brackets_into_url_paths}
-%patch4 -p1
-%endif
-
-sed -i -e 's#sr\@Latn#sr\@latin#' po/LINGUAS
-mv po/sr\@{Latn,latin}.po
 
 %build
 %{__intltoolize}
@@ -83,10 +56,10 @@ mv po/sr\@{Latn,latin}.po
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
-       --disable-schemas-install \
-       --disable-scrollkeeper
+       --disable-silent-rules
 %{__make}
 
 %install
@@ -94,32 +67,27 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
        localedir=%{_localedir}
 
-rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
-
-%find_lang %{name} --with-gnome --with-omf --all-name
+%find_lang %{name} --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%gconf_schema_install gnome-terminal.schemas
-%scrollkeeper_update_post
-
-%preun
-%gconf_schema_uninstall gnome-terminal.schemas
+%glib_compile_schemas
 
 %postun
-%scrollkeeper_update_postun
+if [ "$1" = "0" ]; then
+    %glib_compile_schemas
+fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_bindir}/*
-%{_libdir}/bonobo/servers/*
-%{_datadir}/%{name}
-%{_desktopdir}/*.desktop
-%{_pixmapsdir}/*
-%{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
+%doc AUTHORS ChangeLog NEWS
+%attr(755,root,root) %{_bindir}/gnome-terminal
+%attr(755,root,root) %{_libdir}/gnome-terminal-migration
+%attr(755,root,root) %{_libdir}/gnome-terminal-server
+%{_datadir}/dbus-1/services/org.gnome.Terminal.service
+%{_datadir}/glib-2.0/schemas/org.gnome.Terminal.gschema.xml
+%{_desktopdir}/gnome-terminal.desktop
This page took 0.115904 seconds and 4 git commands to generate.