]> git.pld-linux.org Git - packages/gnome-terminal.git/blob - gnome-terminal.spec
- do not list %{_desktopdir}/* -- dangerous, could list directories unexpectedly
[packages/gnome-terminal.git] / gnome-terminal.spec
1 #
2 # Conditional build:
3 # This causes <prev-tab> key do nothing on the first tab (instead of 
4 # passing the keypress to the application running in the terminal). Ditto 
5 # for the last tab. This is kinda annoying.
6 %bcond_with     disable_prev_next_tab_sensitivity_changes
7 # This is specific to PLD and causes an "unknown term type" on most other
8 # hosts I have to work on (the rest of the world uses xterm for g-t)
9 %bcond_with     term_voodoo
10 #
11 Summary:        GNOME Terminal
12 Summary(pl):    Terminal dla GNOME
13 Name:           gnome-terminal
14 Version:        2.16.1
15 Release:        1
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-terminal/2.16/%{name}-%{version}.tar.bz2
19 # Source0-md5:  861e1b780819214b4d5a398e7999c093
20 Patch0:         %{name}-TERM.patch
21 Patch1:         %{name}-disable-prev_next-tab-sensitivity-changes.patch
22 Patch2:         %{name}-desktop.patch
23 Patch3:         %{name}-save-session-crash.patch
24 URL:            http://www.gnome.org/
25 BuildRequires:  GConf2-devel >= 2.14.0
26 BuildRequires:  autoconf >= 2.53
27 BuildRequires:  automake
28 BuildRequires:  gtk+2-devel >= 2:2.10.6
29 BuildRequires:  gnome-common >= 2.12.0
30 BuildRequires:  gnome-vfs2-devel >= 2.16.1
31 BuildRequires:  intltool >= 0.35
32 BuildRequires:  libglade2-devel >= 1:2.6.0
33 BuildRequires:  libgnomeui-devel >= 2.16.0
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig >= 1:0.12.0
36 BuildRequires:  rpmbuild(macros) >= 1.197
37 BuildRequires:  scrollkeeper
38 BuildRequires:  startup-notification-devel >= 0.8
39 BuildRequires:  vte-devel >= 0.14.1
40 Requires(post,preun):   GConf2 >= 2.14.0
41 Requires(post,postun):  scrollkeeper
42 Requires:       libgnomeui >= 2.16.0
43 Requires:       startup-notification >= 0.8
44 Requires:       vte >= 0.14.1
45 Requires:       terminfo
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 This is a terminal thing that isn't finished at all.
50
51 %description -l pl
52 To jest terminal, na razie ca³kowicie nie dokoñczony.
53
54 %prep
55 %setup -q
56 %if %{with term_voodoo}
57 %patch0 -p1
58 %endif
59 %if %{with disable_prev_next_tab_sensitivity_changes}
60 %patch1 -p1
61 %endif
62 %patch2 -p1
63 %patch3 -p1
64
65 %build
66 %{__intltoolize}
67 %{__gnome_doc_common}
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__automake}
72 %configure \
73         --disable-schemas-install \
74         --disable-scrollkeeper
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT \
82         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
83         localedir=%{_localedir}
84
85 rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
86
87 %find_lang %{name} --with-gnome --all-name
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 %gconf_schema_install gnome-terminal.schemas
94 %scrollkeeper_update_post
95
96 %preun
97 %gconf_schema_uninstall gnome-terminal.schemas
98
99 %postun
100 %scrollkeeper_update_postun
101
102 %files -f %{name}.lang
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog NEWS README
105 %doc %{_omf_dest_dir}/%{name}
106 %attr(755,root,root) %{_bindir}/*
107 %{_libdir}/bonobo/servers/*
108 %{_datadir}/%{name}
109 %{_desktopdir}/*.desktop
110 %{_pixmapsdir}/*
111 %{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
This page took 0.069823 seconds and 4 git commands to generate.