]> git.pld-linux.org Git - packages/gnome-terminal.git/blob - gnome-terminal.spec
- added url-regex patch, allowing to classify square brackets as parts
[packages/gnome-terminal.git] / gnome-terminal.spec
1 #
2 # Conditional build:
3 # This causes <prev-tab> key do nothing on the first tab (instead of 
4 # passing the keypress to the application running in the terminal). Ditto 
5 # for the last tab. This is kinda annoying.
6 %bcond_with     disable_prev_next_tab_sensitivity_changes
7 # This is specific to PLD and causes an "unknown term type" on most other
8 # hosts I have to work on (the rest of the world uses xterm for g-t)
9 %bcond_with     term_voodoo
10 # This allows to mark on-terminal urls containing square brackets (eg. to
11 # copy them or to open in external browser).
12 %bcond_with classify_square_brackets_into_url_paths
13 #
14 Summary:        GNOME Terminal
15 Summary(pl):    Terminal dla GNOME
16 Name:           gnome-terminal
17 Version:        2.16.1
18 Release:        2
19 License:        GPL
20 Group:          X11/Applications
21 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-terminal/2.16/%{name}-%{version}.tar.bz2
22 # Source0-md5:  861e1b780819214b4d5a398e7999c093
23 Patch0:         %{name}-TERM.patch
24 Patch1:         %{name}-disable-prev_next-tab-sensitivity-changes.patch
25 Patch2:         %{name}-desktop.patch
26 Patch3:         %{name}-save-session-crash.patch
27 Patch4:         %{name}-url-regex.patch
28 URL:            http://www.gnome.org/
29 BuildRequires:  GConf2-devel >= 2.14.0
30 BuildRequires:  autoconf >= 2.53
31 BuildRequires:  automake
32 BuildRequires:  gtk+2-devel >= 2:2.10.6
33 BuildRequires:  gnome-common >= 2.12.0
34 BuildRequires:  gnome-doc-utils >= 0.8.0
35 BuildRequires:  gnome-vfs2-devel >= 2.16.1
36 BuildRequires:  intltool >= 0.35
37 BuildRequires:  libglade2-devel >= 1:2.6.0
38 BuildRequires:  libgnomeui-devel >= 2.16.0
39 BuildRequires:  libtool
40 BuildRequires:  pkgconfig >= 1:0.12.0
41 BuildRequires:  rpmbuild(macros) >= 1.197
42 BuildRequires:  scrollkeeper
43 BuildRequires:  startup-notification-devel >= 0.8
44 BuildRequires:  vte-devel >= 0.14.1
45 Requires(post,preun):   GConf2 >= 2.14.0
46 Requires(post,postun):  scrollkeeper
47 Requires:       libgnomeui >= 2.16.0
48 Requires:       startup-notification >= 0.8
49 Requires:       vte >= 0.14.1
50 Requires:       terminfo
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 This is a terminal thing that isn't finished at all.
55
56 %description -l pl
57 To jest terminal, na razie ca³kowicie nie dokoñczony.
58
59 %prep
60 %setup -q
61 %if %{with term_voodoo}
62 %patch0 -p1
63 %endif
64 %if %{with disable_prev_next_tab_sensitivity_changes}
65 %patch1 -p1
66 %endif
67 %patch2 -p1
68 %patch3 -p1
69 %if %{with classify_square_brackets_into_url_paths}
70 %patch4 -p1
71 %endif
72
73 %build
74 %{__intltoolize}
75 %{__gnome_doc_common}
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         --disable-schemas-install \
82         --disable-scrollkeeper
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT \
90         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
91         localedir=%{_localedir}
92
93 rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
94
95 %find_lang %{name} --with-gnome --all-name
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 %gconf_schema_install gnome-terminal.schemas
102 %scrollkeeper_update_post
103
104 %preun
105 %gconf_schema_uninstall gnome-terminal.schemas
106
107 %postun
108 %scrollkeeper_update_postun
109
110 %files -f %{name}.lang
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog NEWS README
113 %doc %{_omf_dest_dir}/%{name}
114 %attr(755,root,root) %{_bindir}/*
115 %{_libdir}/bonobo/servers/*
116 %{_datadir}/%{name}
117 %{_desktopdir}/*.desktop
118 %{_pixmapsdir}/*
119 %{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
This page took 0.110383 seconds and 4 git commands to generate.