]> git.pld-linux.org Git - packages/gnome-terminal.git/blob - gnome-terminal.spec
- use proper patch
[packages/gnome-terminal.git] / gnome-terminal.spec
1 #
2 # This causes <prev-tab> key do nothing on the first tab (instead of 
3 # passing the keypress to the application running in the terminal). Ditto 
4 # for the last tab. This is kinda annoying.
5 %bcond_with     disable_prev_next_tab_sensitivity_changes
6 #
7 Summary:        GNOME Terminal
8 Summary(pl):    Terminal dla GNOME
9 Name:           gnome-terminal
10 Version:        2.8.0
11 Release:        2
12 License:        GPL
13 Group:          X11/Applications
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/2.8/%{name}-%{version}.tar.bz2
15 # Source0-md5:  93e59f24b35bd867653664565adb4672
16 Patch0:         %{name}-TERM.patch
17 Patch1:         %{name}-disable-prev_next-tab-sensitivity-changes.patch
18 Patch2:         %{name}-desktop.patch
19 Patch3:         %{name}-font_smoothing.patch
20 URL:            http://www.gnome.org/
21 BuildRequires:  GConf2-devel >= 2.8.0.1
22 Buildrequires:  autoconf >= 2.53
23 BuildRequires:  automake
24 BuildRequires:  gtk+2-devel >= 2:2.4.0
25 Buildrequires:  gnome-vfs2-devel >= 2.8.0
26 BuildRequires:  intltool
27 BuildRequires:  libglade2-devel >= 1:2.4.0
28 BuildRequires:  libgnomeui-devel >= 2.8.0
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig >= 0.12.0
31 BuildRequires:  rpm-build >= 4.1-10
32 BuildRequires:  scrollkeeper
33 BuildRequires:  startup-notification-devel >= 0.7
34 BuildRequires:  vte-devel >= 0.11.11
35 BuildRequires:  xft-devel >= 2.1-2
36 Requires(post): GConf2
37 Requires(post): scrollkeeper
38 Requires:       libgnomeui >= 2.8.0
39 Requires:       terminfo
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This is a terminal thing that isn't finished at all.
44
45 %description -l pl
46 To jest terminal, na razie ca³kowicie nie dokoñczony.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %if %{with disable_prev_next_tab_sensitivity_changes}
52 %patch1 -p1
53 %endif
54 %patch2 -p1
55 %patch3 -p0
56
57 %build
58 %{__libtoolize}
59 %{__aclocal}
60 %{__autoconf}
61 %{__automake}
62 %configure
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT \
70         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
71         localedir=%{_localedir}
72
73 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
74
75 %find_lang %{name} --with-gnome --all-name
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 /usr/bin/scrollkeeper-update
82 %gconf_schema_install
83
84 %postun -p /usr/bin/scrollkeeper-update
85
86 %files -f %{name}.lang
87 %defattr(644,root,root,755)
88 %doc README ChangeLog NEWS TODO AUTHORS
89 %doc %{_omf_dest_dir}/%{name}
90 %attr(755,root,root) %{_bindir}/*
91 %{_sysconfdir}/gconf/schemas/*
92 %{_datadir}/%{name}
93 %{_libdir}/bonobo/servers/*
94 %{_desktopdir}/*
95 %{_pixmapsdir}/*
96 %{_datadir}/application-registry/*
This page took 0.050815 seconds and 4 git commands to generate.