]> git.pld-linux.org Git - packages/gnome-terminal.git/blob - gnome-terminal.spec
- merged from DEVEL
[packages/gnome-terminal.git] / gnome-terminal.spec
1 #
2 # This causes <prev-tab> key do nothing on the first tab (instead of 
3 # passing the keypress to the application running in the terminal). Ditto 
4 # for the last tab. This is kinda annoying.
5 %bcond_with     disable_prev_next_tab_sensitivity_changes
6 # This is specific to PLD and causes an "unknown term type" on most other
7 # hosts I have to work on (the rest of the world uses xterm for g-t)
8 %bcond_with     term_voodoo
9 #
10 Summary:        GNOME Terminal
11 Summary(pl):    Terminal dla GNOME
12 Name:           gnome-terminal
13 Version:        2.14.0
14 Release:        1
15 License:        GPL
16 Group:          X11/Applications
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-terminal/2.14/%{name}-%{version}.tar.bz2
18 # Source0-md5:  a05bac2c9d7b3860f137193c98d3d9a8
19 Patch0:         %{name}-TERM.patch
20 Patch1:         %{name}-disable-prev_next-tab-sensitivity-changes.patch
21 Patch2:         %{name}-desktop.patch
22 URL:            http://www.gnome.org/
23 BuildRequires:  GConf2-devel >= 2.10.0
24 BuildRequires:  autoconf >= 2.53
25 BuildRequires:  automake
26 BuildRequires:  gtk+2-devel >= 2:2.8.0
27 BuildRequires:  gnome-common >= 2.8.0-2
28 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
29 BuildRequires:  intltool
30 BuildRequires:  libglade2-devel >= 1:2.5.1
31 BuildRequires:  libgnomeui-devel >= 2.10.0
32 BuildRequires:  libtool
33 BuildRequires:  pkgconfig >= 1:0.12.0
34 BuildRequires:  rpmbuild(macros) >= 1.197
35 BuildRequires:  scrollkeeper
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  vte-devel >= 0.11.12
38 Requires(post,preun):   GConf2
39 Requires(post,postun):  scrollkeeper
40 Requires:       libgnomeui >= 2.10.0
41 Requires:       startup-notification >= 0.8
42 Requires:       terminfo
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 This is a terminal thing that isn't finished at all.
47
48 %description -l pl
49 To jest terminal, na razie ca³kowicie nie dokoñczony.
50
51 %prep
52 %setup -q
53 %if %{with term_voodoo}
54 %patch0 -p1
55 %endif
56 %if %{with disable_prev_next_tab_sensitivity_changes}
57 %patch1 -p1
58 %endif
59 %patch2 -p1
60
61 %build
62 %{__intltoolize}
63 %{__gnome_doc_common}
64 %{__libtoolize}
65 %{__aclocal}
66 %{__autoconf}
67 %{__automake}
68 %configure
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT \
76         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
77         localedir=%{_localedir}
78
79 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
80 rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
81
82 %find_lang %{name} --with-gnome --all-name
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post
88 %gconf_schema_install gnome-terminal.schemas
89 %scrollkeeper_update_post
90
91 %preun
92 %gconf_schema_uninstall gnome-terminal.schemas
93
94 %postun
95 %scrollkeeper_update_postun
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc AUTHORS ChangeLog NEWS README
100 %doc %{_omf_dest_dir}/%{name}
101 %attr(755,root,root) %{_bindir}/*
102 %{_libdir}/bonobo/servers/*
103 %{_datadir}/%{name}
104 %{_desktopdir}/*
105 %{_pixmapsdir}/*
106 %{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
This page took 0.117775 seconds and 4 git commands to generate.