]> git.pld-linux.org Git - packages/gnome-shell.git/blame_incremental - gnome-shell.spec
- added dir for search providers
[packages/gnome-shell.git] / gnome-shell.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without systemd # by default use systemd for session tracking instead of ConsoleKit (fallback to ConsoleKit on runtime)
4#
5Summary: Window manager and application launcher for GNOME
6Name: gnome-shell
7Version: 3.4.0
8Release: 2
9License: GPL v2+
10Group: X11/Window Managers
11Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.4/%{name}-%{version}.tar.xz
12# Source0-md5: 0f0a063dfe10a399b4280396cd79ae80
13URL: http://live.gnome.org/GnomeShell
14BuildRequires: NetworkManager-devel >= 0.8.999
15BuildRequires: autoconf >= 2.63
16BuildRequires: automake >= 1:1.11
17BuildRequires: clutter-devel >= 1.9.16
18BuildRequires: dbus-glib-devel
19BuildRequires: evolution-data-server-devel >= 3.1.90
20BuildRequires: folks-devel >= 0.6.1
21BuildRequires: gcr-devel >= 3.3.90
22BuildRequires: gettext-devel >= 0.17
23BuildRequires: gjs-devel >= 1.31.10
24BuildRequires: glib2-devel >= 1:2.31.6
25BuildRequires: gnome-bluetooth-devel >= 3.1.0
26BuildRequires: gnome-desktop-devel >= 3.1.90
27BuildRequires: gnome-menus-devel >= 3.1.90
28BuildRequires: gobject-introspection-devel >= 0.10.1
29BuildRequires: gsettings-desktop-schemas-devel >= 3.1.90
30BuildRequires: gstreamer-devel >= 0.10.21
31BuildRequires: gstreamer-plugins-base-devel >= 0.10.21
32BuildRequires: gtk+3-devel >= 3.3.9
33BuildRequires: intltool >= 0.40
34BuildRequires: json-glib-devel >= 0.13.90
35BuildRequires: libcanberra-devel
36BuildRequires: libcroco-devel >= 0.6.2
37BuildRequires: libgnome-keyring-devel
38BuildRequires: libsoup-devel
39BuildRequires: libtool >= 2:2.2.6
40BuildRequires: libxml2-devel
41BuildRequires: mutter-devel >= 3.4.0
42BuildRequires: pkgconfig >= 1:0.22
43BuildRequires: polkit-devel >= 0.100
44BuildRequires: pulseaudio-devel
45BuildRequires: rpm-pythonprov
46BuildRequires: rpmbuild(macros) >= 1.601
47BuildRequires: startup-notification-devel >= 0.11
48%{?with_systemd:BuildRequires: systemd-devel}
49BuildRequires: tar >= 1:1.22
50BuildRequires: telepathy-glib-devel >= 0.17.5
51BuildRequires: telepathy-logger-devel >= 0.2.4
52BuildRequires: xorg-lib-libXfixes-devel
53BuildRequires: xz
54Requires(post,postun): glib2 >= 1:2.26.0
55Requires: caribou >= 0.3.5
56Requires: evolution-data-server >= 3.1.90
57Requires: gjs >= 1.31.10
58Requires: glib2 >= 1:2.31.6
59Requires: gnome-bluetooth-libs >= 3.1.0
60Requires: gnome-menus >= 3.1.90
61Requires: gnome-settings-daemon >= 3.1.90
62Requires: gsettings-desktop-schemas >= 3.1.90
63Requires: gtk+3 >= 3.3.9
64Requires: mutter >= 3.4.0
65Requires: nautilus >= 3.2.0
66Requires: telepathy-logger >= 0.2.4
67Suggests: gnome-contacts >= 3.2.0
68Suggests: gnome-icon-theme-symbolic >= 3.0.0
69Provides: gdm-wm = 3.4.0
70BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72%description
73GNOME Shell is the defining technology of the GNOME 3 desktop user
74experience. It provides core interface functions like switching to
75windows and launching applications. GNOME Shell takes advantage of the
76capabilities of modern graphics hardware and introduces innovative
77user interface concepts to provide a delightful and easy to use
78experience.
79
80%package apidocs
81Summary: GNOME Shell API documentation
82Summary(pl.UTF-8): Dokumentacja API GNOME Shell
83Group: Documentation
84Requires: gtk-doc-common
85
86%description apidocs
87This package provides GNOME Shell API documentation.
88
89%description apidocs -l pl.UTF-8
90Ten pakiet dostarcza dokumentację API GNOME Shell.
91
92%package -n browser-plugin-%{name}
93Summary: gnome-shell plugin for WWW browsers
94Summary(pl.UTF-8): Wtyczka gnome-shell do przeglądarek WWW
95Group: X11/Libraries
96Requires: %{name} = %{version}-%{release}
97Requires: browser-plugins >= 2.0
98Requires: browser-plugins(%{_target_base_arch})
99Provides: mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
100Provides: mozilla-plugin-gnome-shell = %{version}-%{release}
101Obsoletes: mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
102Obsoletes: mozilla-plugin-gnome-shell < %{version}-%{release}
103
104%description -n browser-plugin-%{name}
105gnome-shell plugin for WWW browsers.
106
107%description -n browser-plugin-%{name} -l pl.UTF-8
108Wtyczka gnome-shell do przeglądarek WWW.
109
110%prep
111%setup -q
112
113%build
114%{__intltoolize}
115%{__libtoolize}
116%{__aclocal} -I m4
117%{__autoconf}
118%{__autoheader}
119%{__automake}
120%configure \
121 --with-ca-certificates=/etc/certs/ca-certificates.crt \
122 --enable-gtk-doc \
123 --disable-silent-rules \
124 --disable-static \
125 %{__enable_disable systemd systemd} \
126 --with-html-dir=%{_gtkdocdir}
127%{__make} -j1
128
129%install
130rm -rf $RPM_BUILD_ROOT
131install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
132
133%{__make} install \
134 INSTALL="install -p" \
135 install_sh="install -p" \
136 DESTDIR=$RPM_BUILD_ROOT \
137 mozillalibdir=%{_browserpluginsdir}
138
139%{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/*.la \
140 $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
141
142%find_lang %{name}
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post
148%glib_compile_schemas
149
150%postun
151if [ "$1" = "0" ]; then
152 %glib_compile_schemas
153fi
154
155%post -n browser-plugin-%{name}
156%update_browser_plugins
157
158%postun -n browser-plugin-%{name}
159if [ "$1" = 0 ]; then
160 %update_browser_plugins
161fi
162
163%files -f %{name}.lang
164%defattr(644,root,root,755)
165%attr(755,root,root) %{_bindir}/gnome-shell
166%attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
167%attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
168%attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
169%attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
170%attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
171%dir %{_libdir}/gnome-shell
172%attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
173%attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-js.so
174%{_libdir}/gnome-shell/Gvc-1.0.typelib
175%{_libdir}/gnome-shell/Shell-0.1.typelib
176%{_libdir}/gnome-shell/ShellJS-0.1.typelib
177%{_libdir}/gnome-shell/St-1.0.typelib
178%{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
179%{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
180%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
181%{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
182%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
183%{_datadir}/gnome-shell
184%{_desktopdir}/gnome-shell.desktop
185%{_desktopdir}/gnome-shell-extension-prefs.desktop
186%{_mandir}/man1/gnome-shell.1*
187
188%files apidocs
189%defattr(644,root,root,755)
190%{_gtkdocdir}/shell
191%{_gtkdocdir}/st
192
193%files -n browser-plugin-%{name}
194%defattr(644,root,root,755)
195%attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.063373 seconds and 4 git commands to generate.