]> git.pld-linux.org Git - packages/gnome-shell.git/blame - gnome-shell.spec
- release 7
[packages/gnome-shell.git] / gnome-shell.spec
CommitLineData
80f1cab6 1Summary: Window manager and application launcher for GNOME
1a7ebb2b 2Name: gnome-shell
46d92bde 3Version: 3.0.2
5641c11a 4Release: 7
1a7ebb2b 5License: GPL v2+
6Group: X11/Window Managers
80f1cab6 7Source0: http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.0/%{name}-%{version}.tar.bz2
46d92bde 8# Source0-md5: ea5194dc27301ca7ee00a97f5f3ab625
80f1cab6
ŁK
9URL: http://live.gnome.org/GnomeShell
10BuildRequires: GConf2-devel
46d92bde 11BuildRequires: NetworkManager-devel >= 0.8.999
80f1cab6
ŁK
12BuildRequires: autoconf >= 2.63
13BuildRequires: automake >= 1:1.10
14BuildRequires: clutter-devel >= 1.6.0
15BuildRequires: dbus-glib-devel
a41c286f 16BuildRequires: evolution-data-server-devel >= 3.0.0
76380569 17BuildRequires: gettext-devel
80f1cab6
ŁK
18BuildRequires: gjs-devel >= 0.7.11
19BuildRequires: glib2-devel >= 1:2.28.0
a41c286f
MB
20BuildRequires: gnome-bluetooth-devel >= 3.0.0
21BuildRequires: gnome-desktop-devel >= 3.0.0
a985b63a 22BuildRequires: gnome-menus-devel
80f1cab6 23BuildRequires: gobject-introspection-devel >= 0.10.1
a41c286f 24BuildRequires: gsettings-desktop-schemas-devel >= 3.0.0
80f1cab6
ŁK
25BuildRequires: gstreamer-devel >= 0.10.21
26BuildRequires: gstreamer-plugins-base-devel >= 0.10.21
27BuildRequires: gtk+3-devel >= 3.0.0
76380569 28BuildRequires: intltool >= 0.26
80f1cab6
ŁK
29BuildRequires: libcanberra-devel
30BuildRequires: libcroco-devel
31BuildRequires: libtool >= 2:2.2.6
32BuildRequires: libxml2-devel
a41c286f 33BuildRequires: mutter-devel >= 3.0.1
80f1cab6
ŁK
34BuildRequires: pkgconfig >= 1:0.22
35BuildRequires: polkit-devel >= 0.100
36BuildRequires: pulseaudio-devel
a985b63a 37BuildRequires: rpm-pythonprov
80f1cab6
ŁK
38BuildRequires: rpmbuild(macros) >= 1.601
39BuildRequires: startup-notification-devel
a41c286f 40BuildRequires: telepathy-glib-devel >= 0.14.0
80f1cab6
ŁK
41BuildRequires: telepathy-logger-devel >= 0.2.4
42BuildRequires: xorg-lib-libXfixes-devel
86502514 43# for libmozjs.so
44BuildRequires: xulrunner-libs
80f1cab6
ŁK
45Requires(post,postun): glib2 >= 1:2.26.0
46Requires(post,preun): GConf2
a41c286f
MB
47Requires: gnome-bluetooth-libs >= 3.0.0
48Requires: gnome-settings-daemon >= 3.0.0
80f1cab6 49Requires: gsettings-desktop-schemas >= 0.1.7
a41c286f 50Requires: mutter >= 3.0.1
80f1cab6 51%requires_eq xulrunner-libs
76f6a6f7 52Suggests: gnome-icon-theme-symbolic >= 3.0.0
1a7ebb2b 53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%description
80f1cab6
ŁK
56GNOME Shell is the defining technology of the GNOME 3 desktop user
57experience. It provides core interface functions like switching to
58windows and launching applications. GNOME Shell takes advantage of the
59capabilities of modern graphics hardware and introduces innovative
60user interface concepts to provide a delightful and easy to use
61experience.
1a7ebb2b 62
63%prep
64%setup -q
65
66%build
80f1cab6
ŁK
67%{__intltoolize}
68%{__libtoolize}
f5486c89 69%{__aclocal} -I m4
80f1cab6
ŁK
70%{__autoconf}
71%{__autoheader}
72%{__automake}
184c4ba1 73export LD_LIBRARY_PATH=%{_libdir}/xulrunner
1a7ebb2b 74%configure \
75 --disable-schemas-install \
184c4ba1 76 --disable-silent-rules \
1a7ebb2b 77 --disable-static
80f1cab6 78%{__make} -j1
1a7ebb2b 79
80%install
81rm -rf $RPM_BUILD_ROOT
cd647269 82install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
1a7ebb2b 83
84%{__make} install \
85 DESTDIR=$RPM_BUILD_ROOT
86
cf407b77 87# TODO use rpath at link time instead of this hack
80f1cab6
ŁK
88mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
89cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
90#!/bin/sh
91LD_LIBRARY_PATH=%{_libdir}/xulrunner
92export LD_LIBRARY_PATH
cf407b77 93exec %{_bindir}/gnome-shell.bin "$@"
80f1cab6
ŁK
94EOF
95chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
96
97%{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la
98
99%find_lang %{name}
1a7ebb2b 100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
105%gconf_schema_install gnome-shell.schemas
80f1cab6 106%glib_compile_schemas
1a7ebb2b 107
108%preun
109%gconf_schema_uninstall gnome-shell.schemas
110
80f1cab6
ŁK
111%postun
112if [ "$1" = "0" ]; then
113 %glib_compile_schemas
114fi
1a7ebb2b 115
116%files -f %{name}.lang
117%defattr(644,root,root,755)
9f710482 118%attr(755,root,root) %{_bindir}/gnome-shell
80f1cab6
ŁK
119%attr(755,root,root) %{_bindir}/gnome-shell.bin
120%attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
121%attr(755,root,root) %{_libdir}/gnome-shell-calendar-server
122%attr(755,root,root) %{_libdir}/gnome-shell-perf-helper
123%{_sysconfdir}/gconf/schemas/gnome-shell.schemas
124%dir %{_libdir}/gnome-shell
125%attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
126%{_libdir}/gnome-shell/Gdm-1.0.typelib
127%{_libdir}/gnome-shell/Gvc-1.0.typelib
128%{_libdir}/gnome-shell/Shell-0.1.typelib
129%{_libdir}/gnome-shell/St-1.0.typelib
130%{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
131%{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
132%{_datadir}/gnome-shell
133%{_desktopdir}/gnome-shell.desktop
134%{_mandir}/man1/gnome-shell.1*
This page took 0.048825 seconds and 4 git commands to generate.