]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
2c1845a3f3e579996a391febe44f4f049e26c128
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        3.20.1
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-keyring/3.20/%{name}-%{version}.tar.xz
15 # Source0-md5:  9b4b2c59dc1db3a1309cbe1fa1f2c2e7
16 URL:            http://live.gnome.org/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gcr-devel >= 3.5.3
21 BuildRequires:  gettext-tools
22 BuildRequires:  glib2-devel >= 1:2.38.0
23 BuildRequires:  intltool >= 0.40.0
24 BuildRequires:  libcap-ng-devel
25 BuildRequires:  libgcrypt-devel >= 1.2.2
26 BuildRequires:  libselinux-devel
27 # for some test only
28 BuildRequires:  libtasn1-devel >= 0.3.4
29 BuildRequires:  libtool
30 BuildRequires:  p11-kit-devel >= 0.16
31 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
32 BuildRequires:  pam-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.592
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires(post,postun):  glib2 >= 1:2.38.0
38 Requires:       filesystem >= 4.0-28
39 Requires:       gcr >= 3.5.3
40 Requires:       glib2 >= 1:2.38.0
41 Requires:       hicolor-icon-theme
42 Requires:       p11-kit >= 0.16
43 Conflicts:      rpm < 4.4.2-0.2
44 # sr@Latn vs. sr@latin
45 Conflicts:      glibc-misc < 6:2.7
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _libexecdir     %{_libdir}/%{name}
49
50 %description
51 GNOME Keyring is a program that keeps password and other secrets for
52 users. It is run as a daemon in the session, similar to ssh-agent, and
53 other applications can locate it by an environment variable.
54
55 %description -l pl.UTF-8
56 GNOME Keyring to program do przechowywania haseł i innych tajnych
57 danych użytkowników. Działa jako demon w sesji, podobnie do
58 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
59 środowiskową.
60
61 %package -n pam-pam_gnome_keyring
62 Summary:        A PAM module for unlocking keyrings at login time
63 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
64 License:        LGPL v2+
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Obsoletes:      gnome-keyring-pam
68
69 %description -n pam-pam_gnome_keyring
70 A PAM module that can automatically unlock the "login" keyring when
71 the user logs in and start the keyring daemon.
72
73 %description -n pam-pam_gnome_keyring -l pl.UTF-8
74 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
75 w czasie logowania użytkownika i uruchamiania demona keyring.
76
77 %prep
78 %setup -q
79
80 %build
81 %{__glib_gettextize}
82 %{__intltoolize}
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --disable-silent-rules \
90         %{!?with_p11_tests:--disable-p11-tests} \
91         --with-pam-dir=/%{_lib}/security \
92         --with-root-certs=%{_sysconfdir}/certs \
93         --with-ca-certificates=%{_sysconfdir}/certs/ca-certificates.crt
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install install-pam \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
105
106 %find_lang %{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %glib_compile_schemas
113
114 %postun
115 %glib_compile_schemas
116
117 %files -f %{name}.lang
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README
120 %attr(755,root,root) %{_bindir}/gnome-keyring
121 %attr(755,root,root) %{_bindir}/gnome-keyring-3
122 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
123 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
124 %dir %{_libdir}/%{name}
125 %dir %{_libdir}/%{name}/devel
126 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
127 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
128 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
129 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
130 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
131 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
132 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
133 %{_datadir}/GConf/gsettings/org.gnome.crypto.cache.convert
134 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
135 %{_datadir}/dbus-1/services/org.gnome.keyring.service
136 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
137 %{_datadir}/p11-kit/modules/gnome-keyring.module
138 %{_mandir}/man1/gnome-keyring.1*
139 %{_mandir}/man1/gnome-keyring-3.1*
140 %{_mandir}/man1/gnome-keyring-daemon.1*
141
142 %files -n pam-pam_gnome_keyring
143 %defattr(644,root,root,755)
144 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.074714 seconds and 2 git commands to generate.