- updated to 3.36.3 auto/th/gnome-flashback-3.36.3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 9 Jun 2020 04:11:12 +0000 (06:11 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 9 Jun 2020 04:11:12 +0000 (06:11 +0200)
gnome-flashback.spec

index 4fb7dab1699283b9e048b46b1287da9e179693f5..326e8f9bd22fd9a01e5bdfc1a1c90e74ad462a64 100644 (file)
@@ -1,32 +1,36 @@
 Summary:       GNOME Flashback module - GNOME 3 shell similar to GNOME 2
 Summary(pl.UTF-8):     Moduł GNOME Flashback - powłoka GNOME 3 podobna do GNOME 2
 Name:          gnome-flashback
 Summary:       GNOME Flashback module - GNOME 3 shell similar to GNOME 2
 Summary(pl.UTF-8):     Moduł GNOME Flashback - powłoka GNOME 3 podobna do GNOME 2
 Name:          gnome-flashback
-Version:       3.36.1
+Version:       3.36.3
 Release:       1
 License:       GPL v3+
 Group:         X11/Applications
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-flashback/3.36/%{name}-%{version}.tar.xz
 Release:       1
 License:       GPL v3+
 Group:         X11/Applications
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-flashback/3.36/%{name}-%{version}.tar.xz
-# Source0-md5: 768ef0f776b5984dca15ca817a5297ff
+# Source0-md5: 690b0d78c7d9265183ef18387b12fa50
 URL:           https://wiki.gnome.org/Projects/GnomeFlashback
 URL:           https://wiki.gnome.org/Projects/GnomeFlashback
+BuildRequires: alsa-lib-devel
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.13
 BuildRequires: gdk-pixbuf2-devel >= 2.32.2
 BuildRequires: gdm-devel
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake >= 1:1.13
 BuildRequires: gdk-pixbuf2-devel >= 2.32.2
 BuildRequires: gdm-devel
-BuildRequires: gettext-tools >= 0.19.4
+BuildRequires: gettext-tools >= 0.19.6
 BuildRequires: glib2-devel >= 1:2.44.0
 BuildRequires: gnome-bluetooth-devel >= 3.0
 BuildRequires: glib2-devel >= 1:2.44.0
 BuildRequires: gnome-bluetooth-devel >= 3.0
-BuildRequires: gnome-desktop-devel >= 3.12.0
+BuildRequires: gnome-desktop-devel >= 3.35.4
 BuildRequires: gnome-panel-devel >= 3.35.2
 BuildRequires: gsettings-desktop-schemas-devel >= 3.31.0
 BuildRequires: gtk+3-devel >= 3.22.0
 BuildRequires: ibus-devel >= 1.5.2
 BuildRequires: libcanberra-gtk3-devel >= 0.13
 BuildRequires: gnome-panel-devel >= 3.35.2
 BuildRequires: gsettings-desktop-schemas-devel >= 3.31.0
 BuildRequires: gtk+3-devel >= 3.22.0
 BuildRequires: ibus-devel >= 1.5.2
 BuildRequires: libcanberra-gtk3-devel >= 0.13
+# libcompizconfig >= 0.9.14.0 ?
 BuildRequires: libtool >= 2:2
 BuildRequires: libxcb-devel
 BuildRequires: libtool >= 2:2
 BuildRequires: libxcb-devel
-BuildRequires: pango-devel
+BuildRequires: pam-devel
+BuildRequires: pango-devel >= 1:1.44.0
 BuildRequires: pkgconfig
 BuildRequires: polkit-devel >= 0.97
 BuildRequires: pulseaudio-devel
 BuildRequires: pkgconfig
 BuildRequires: polkit-devel >= 0.97
 BuildRequires: pulseaudio-devel
+BuildRequires: systemd-devel >= 1:209
 BuildRequires: tar >= 1:1.22
 BuildRequires: upower-devel >= 0.99.0
 BuildRequires: xkeyboard-config
 BuildRequires: tar >= 1:1.22
 BuildRequires: upower-devel >= 0.99.0
 BuildRequires: xkeyboard-config
@@ -35,21 +39,25 @@ BuildRequires:      xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXi-devel >= 1.6.0
 BuildRequires: xorg-lib-libXrandr-devel >= 1.5.0
 BuildRequires: xorg-lib-libXfixes-devel
 BuildRequires: xorg-lib-libXi-devel >= 1.6.0
 BuildRequires: xorg-lib-libXrandr-devel >= 1.5.0
+BuildRequires: xorg-lib-libXxf86vm-devel >= 1.1.4
 BuildRequires: xorg-lib-libxkbfile-devel
 BuildRequires: xz
 Requires(post,postun): glib2 >= 1:2.44.0
 Requires:      gdk-pixbuf2 >= 2.32.2
 Requires:      glib2 >= 1:2.44.0
 Requires:      gnome-bluetooth-libs >= 3.0
 BuildRequires: xorg-lib-libxkbfile-devel
 BuildRequires: xz
 Requires(post,postun): glib2 >= 1:2.44.0
 Requires:      gdk-pixbuf2 >= 2.32.2
 Requires:      glib2 >= 1:2.44.0
 Requires:      gnome-bluetooth-libs >= 3.0
-Requires:      gnome-desktop >= 3.12.0
+Requires:      gnome-desktop >= 3.35.4
+Requires:      gnome-panel >= 3.35.2
 Requires:      gsettings-desktop-schemas >= 3.31.0
 Requires:      gtk+3 >= 3.22.0
 Requires:      ibus-libs >= 1.5.2
 Requires:      libcanberra-gtk3 >= 0.13
 Requires:      gsettings-desktop-schemas >= 3.31.0
 Requires:      gtk+3 >= 3.22.0
 Requires:      ibus-libs >= 1.5.2
 Requires:      libcanberra-gtk3 >= 0.13
+Requires:      pango >= 1:1.44.0
 Requires:      polkit >= 0.97
 Requires:      upower-libs >= 0.99.0
 Requires:      xorg-lib-libXi >= 1.6.0
 Requires:      xorg-lib-libXrandr >= 1.5.0
 Requires:      polkit >= 0.97
 Requires:      upower-libs >= 0.99.0
 Requires:      xorg-lib-libXi >= 1.6.0
 Requires:      xorg-lib-libXrandr >= 1.5.0
+Requires:      xorg-lib-libXxf86vm >= 1.1.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -84,6 +92,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-panel/modules/system_indicators.la
+
 %find_lang %{name}
 
 %clean
 %find_lang %{name}
 
 %clean
@@ -99,8 +109,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc NEWS
 %attr(755,root,root) %{_bindir}/gnome-flashback
 %defattr(644,root,root,755)
 %doc NEWS
 %attr(755,root,root) %{_bindir}/gnome-flashback
+%attr(755,root,root) %{_libexecdir}/gnome-flashback-clipboard
 %attr(755,root,root) %{_libexecdir}/gnome-flashback-metacity
 %attr(755,root,root) %{_libdir}/gnome-panel/modules/system_indicators.so
 %attr(755,root,root) %{_libexecdir}/gnome-flashback-metacity
 %attr(755,root,root) %{_libdir}/gnome-panel/modules/system_indicators.so
+/etc/xdg/autostart/gnome-flashback-clipboard.desktop
 /etc/xdg/autostart/gnome-flashback-nm-applet.desktop
 /etc/xdg/menus/gnome-flashback-applications.menu
 %{_desktopdir}/gnome-flashback.desktop
 /etc/xdg/autostart/gnome-flashback-nm-applet.desktop
 /etc/xdg/menus/gnome-flashback-applications.menu
 %{_desktopdir}/gnome-flashback.desktop
This page took 0.04514 seconds and 4 git commands to generate.