]> git.pld-linux.org Git - packages/gnome-color-manager.git/commitdiff
- up to 3.30 auto/th/gnome-color-manager-3.30.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 12 Feb 2019 07:07:51 +0000 (08:07 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 12 Feb 2019 07:07:51 +0000 (08:07 +0100)
exiv2-0.27.patch [new file with mode: 0644]
gnome-color-manager-symlinks.patch [deleted file]
gnome-color-manager.spec

diff --git a/exiv2-0.27.patch b/exiv2-0.27.patch
new file mode 100644 (file)
index 0000000..9149de9
--- /dev/null
@@ -0,0 +1,53 @@
+From 6ef6bf5e3909531b874f86cb95381fa0668cf90b Mon Sep 17 00:00:00 2001
+From: Ting-Wei Lan <lantw@src.gnome.org>
+Date: Sun, 18 Nov 2018 14:09:08 +0800
+Subject: [PATCH] Fix build with Exiv2 0.27
+
+The first parameter of Exiv2::Error has changed from an int to an
+Exiv2::ErrorCode enum.
+---
+ src/gcm-helper-exiv.cpp | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/src/gcm-helper-exiv.cpp b/src/gcm-helper-exiv.cpp
+index 9854e79..ffbc82c 100644
+--- a/src/gcm-helper-exiv.cpp
++++ b/src/gcm-helper-exiv.cpp
+@@ -24,6 +24,10 @@
+ #include <iostream>
+ #include <iomanip>
++#if EXIV2_MAJOR_VERSION >= 1 || (EXIV2_MAJOR_VERSION == 0 && EXIV2_MINOR_VERSION >= 27)
++#define HAVE_EXIV2_ERROR_CODE
++#endif
++
+ int
+ main (int argc, char* const argv[])
+ {
+@@ -51,7 +55,11 @@ main (int argc, char* const argv[])
+               if (argc == 2)
+                       filename = argv[1];
+               if (filename.empty())
++#ifdef HAVE_EXIV2_ERROR_CODE
++                      throw Exiv2::Error(Exiv2::kerErrorMessage, "No filename specified");
++#else
+                       throw Exiv2::Error(1, "No filename specified");
++#endif
+               image = Exiv2::ImageFactory::open(filename);
+               image->readMetadata();
+@@ -60,7 +68,11 @@ main (int argc, char* const argv[])
+               if (exifData.empty()) {
+                       std::string error(argv[1]);
+                       error += ": No Exif data found in the file";
++#ifdef HAVE_EXIV2_ERROR_CODE
++                      throw Exiv2::Error(Exiv2::kerErrorMessage, error);
++#else
+                       throw Exiv2::Error(1, error);
++#endif
+               }
+               /* try to find make, model and serial number */
+-- 
+2.18.1
+
diff --git a/gnome-color-manager-symlinks.patch b/gnome-color-manager-symlinks.patch
deleted file mode 100644 (file)
index 469565d..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
---- gnome-color-manager-3.18.0/data/icons/16x16/Makefile.am.orig       2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/16x16/Makefile.am    2015-11-15 08:37:29.554534670 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/22x22/Makefile.am.orig       2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/22x22/Makefile.am    2015-11-15 08:37:48.561200509 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/24x24/Makefile.am.orig       2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/24x24/Makefile.am    2015-11-15 08:38:05.651199278 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/256x256/Makefile.am.orig     2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/256x256/Makefile.am  2015-11-15 08:38:17.937865942 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/32x32/Makefile.am.orig       2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/32x32/Makefile.am    2015-11-15 08:38:30.904532080 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/48x48/Makefile.am.orig       2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/48x48/Makefile.am    2015-11-15 08:38:43.261198508 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/64x64/Makefile.am.orig       2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/64x64/Makefile.am    2015-11-15 08:39:10.224530429 +0100
-@@ -9,7 +9,7 @@ icons_DATA =                           \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
-+      ln -fs ../apps/gnome-color-manager.png $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.png;
- EXTRA_DIST =          \
-       $(icons_DATA)
---- gnome-color-manager-3.18.0/data/icons/scalable/Makefile.am.orig    2015-04-22 12:18:32.000000000 +0200
-+++ gnome-color-manager-3.18.0/data/icons/scalable/Makefile.am 2015-11-15 08:35:22.674540143 +0100
-@@ -14,7 +14,7 @@ appicons_DATA =                      \
- install-data-hook:
-       mkdir -p $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes;
--      ln -fs $(iconsdir)/gnome-color-manager.svg $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.svg;
-+      ln -fs ../apps/gnome-color-manager.svg $(DESTDIR)$(DATADIR)/icons/hicolor/$(size)/mimetypes/application-vnd.iccprofile.svg;
- EXTRA_DIST =                          \
-       $(icons_DATA)                   \
index 0d043a00e1b59c3b5392fc4049e606120f06d0a9..7ed162f06fe5ae3facf88010fc0ec4603ef91735 100644 (file)
@@ -1,21 +1,15 @@
 Summary:       Color management tools for GNOME
 Summary(pl.UTF-8):     Narzędzia do zarządzania kolorami dla GNOME
 Name:          gnome-color-manager
-Version:       3.24.0
-Release:       2
+Version:       3.30.0
+Release:       1
 License:       GPL v2
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-color-manager/3.24/%{name}-%{version}.tar.xz
-# Source0-md5: 47b7f7ef50e9e28f07db14c604ef08c9
-# rpm glob again has some problem with absolute symlinks (dead at the time of packaging);
-# use relative ones (they don't go across /)
-Patch0:                %{name}-symlinks.patch
-# dead, wiki.gnome.org GnomeColorManager page is in Attic too
-#URL:          http://projects.gnome.org/gnome-color-manager/
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-color-manager/3.30/%{name}-%{version}.tar.xz
+# Source0-md5: f1caa9d4ece97e21b4ff1147201b6dd3
+Patch0:                exiv2-0.27.patch
 URL:           https://github.com/GNOME/gnome-color-manager
 BuildRequires: appstream-glib-devel
-BuildRequires: autoconf >= 2.63
-BuildRequires: automake >= 1:1.11
 BuildRequires: colord-devel >= 1.3.1
 BuildRequires: colord-gtk-devel >= 0.1.20
 BuildRequires: docbook-dtd41-sgml
@@ -31,8 +25,9 @@ BuildRequires:        libcanberra-gtk3-devel >= 0.10
 BuildRequires: libexif-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
-BuildRequires: libtool >= 2:2
 BuildRequires: libxslt-progs
+BuildRequires: meson
+BuildRequires: ninja
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(find_lang) >= 1.23
 BuildRequires: rpmbuild(macros) >= 1.601
@@ -69,22 +64,14 @@ kolorów.
 %patch0 -p1
 
 %build
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       --disable-silent-rules \
-       --disable-schemas-compile \
-       --disable-static
-%{__make}
+%meson build
+
+%ninja_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %find_lang %{name} --with-gnome
 
@@ -105,23 +92,21 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog MAINTAINERS NEWS README
+%doc AUTHORS MAINTAINERS README
 %attr(755,root,root) %{_bindir}/gcm-calibrate
 %attr(755,root,root) %{_bindir}/gcm-import
 %attr(755,root,root) %{_bindir}/gcm-inspect
 %attr(755,root,root) %{_bindir}/gcm-picker
 %attr(755,root,root) %{_bindir}/gcm-viewer
 %attr(755,root,root) %{_libexecdir}/gcm-helper-exiv
-%{_datadir}/appdata/org.gnome.ColorProfileViewer.appdata.xml
+%{_datadir}/metainfo/org.gnome.ColorProfileViewer.appdata.xml
 %{_datadir}/gnome-color-manager
 %{_desktopdir}/gcm-calibrate.desktop
 %{_desktopdir}/gcm-import.desktop
 %{_desktopdir}/gcm-picker.desktop
 %{_desktopdir}/org.gnome.ColorProfileViewer.desktop
 %{_iconsdir}/hicolor/*x*/apps/gnome-color-manager.png
-%{_iconsdir}/hicolor/*/mimetypes/application-vnd.iccprofile.png
 %{_iconsdir}/hicolor/scalable/apps/gnome-color-manager.svg
-%{_iconsdir}/hicolor/scalable/mimetypes/application-vnd.iccprofile.svg
 %{_mandir}/man1/gcm-calibrate.1*
 %{_mandir}/man1/gcm-import.1*
 %{_mandir}/man1/gcm-inspect.1*
This page took 0.098166 seconds and 4 git commands to generate.