]> git.pld-linux.org Git - packages/gnome-abrt.git/commitdiff
- rel 3; fix python 3.5 build auto/th/gnome-abrt-1.2.0-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 18 Sep 2015 07:39:37 +0000 (09:39 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 18 Sep 2015 07:39:37 +0000 (09:39 +0200)
gnome-abrt-python.patch [new file with mode: 0644]
gnome-abrt.spec

diff --git a/gnome-abrt-python.patch b/gnome-abrt-python.patch
new file mode 100644 (file)
index 0000000..c1afef1
--- /dev/null
@@ -0,0 +1,14 @@
+--- gnome-abrt-1.2.0/src/gnome_abrt/wrappers/module.c~ 2015-06-03 05:36:53.000000000 +0200
++++ gnome-abrt-1.2.0/src/gnome_abrt/wrappers/module.c  2015-09-18 09:37:15.949588371 +0200
+@@ -41,7 +41,11 @@
+             .m_doc = module_doc,
+             .m_size = -1,
+             .m_methods = module_methods,
++#if PY_MAJOR_VERSION >= 3 && PY_MINOR_VERSION >= 5
++            .m_slots = NULL,
++#else
+             .m_reload = NULL,
++#endif
+             .m_traverse = NULL,
+             .m_clear = NULL,
+             .m_free = NULL,
index 53ccdc454dfe2bef0c0c64d150078e43e5578bc6..09cec88fe64401f4a1f7b01d62a6d11a0064a3f7 100644 (file)
@@ -6,19 +6,23 @@ Summary:      A utility for viewing problems that have occurred with the system
 Summary(pl.UTF-8):     Narzędzie do przeglądania problemów, które wystąpiły w systemie
 Name:          gnome-abrt
 Version:       1.2.0
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         Applications/System
 Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
 # Source0-md5: 9b2d3e364e735f6a7401a84462951232
 Patch0:                %{name}-pylint.patch
+Patch1:                %{name}-python.patch
 URL:           https://github.com/abrt/abrt/wiki/ABRT-Project
 BuildRequires: abrt-gui-devel >= 2.1.7
 BuildRequires: asciidoc
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: gettext-tools >= 0.17
 BuildRequires: gtk+3-devel >= 3.0
 BuildRequires: intltool >= 0.35.0
 BuildRequires: libreport-gtk-devel >= 2.0.20
+BuildRequires: libtool
 BuildRequires: pkgconfig
 %{?with_tests:BuildRequires:   pylint}
 BuildRequires: python3-devel >= 1:3.4
@@ -49,10 +53,16 @@ zapewniająca wygodny sposób zarządzania tymi problemami.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
+%{__sed} -i -e 's#-pedantic##g' configure.ac
 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
 
 %build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__automake}
 %configure \
        --disable-silent-rules \
        %{!?with_tests:--with-nopylint}
This page took 0.06816 seconds and 4 git commands to generate.