]> git.pld-linux.org Git - packages/gnome-abrt.git/blobdiff - gnome-abrt.spec
- drop version from humanize, it was just a copy-pasto
[packages/gnome-abrt.git] / gnome-abrt.spec
index 7f4d395f1beece08c798be4b5d7f254686f79e9a..ab6a102fe07ca40dd30f23f4772b153f636ecd12 100644 (file)
@@ -1,35 +1,44 @@
 #
 # Conditional build:
 %bcond_with    tests   # "make check" run (some pylint false positive?)
-#
+
 Summary:       A utility for viewing problems that have occurred with the system
 Summary(pl.UTF-8):     Narzędzie do przeglądania problemów, które wystąpiły w systemie
 Name:          gnome-abrt
-Version:       0.2.10
-Release:       1
+Version:       1.3.1
+Release:       3
 License:       GPL v2+
 Group:         Applications/System
-Source0:       https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
-# Source0-md5: 9cdb88de911163980add38fad1e3df72
-Patch0:                %{name}-pylint.patch
-URL:           https://fedorahosted.org/abrt/
+#Source0Download: https://github.com/abrt/gnome-abrt/releases
+Source0:       https://github.com/abrt/gnome-abrt/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 2529440838d44afe7c4696e2f76b4986
+URL:           https://github.com/abrt/abrt/wiki/gnome-abrt
+BuildRequires: abrt-gui-devel >= 2.4.0
 BuildRequires: asciidoc
-BuildRequires: gettext-devel >= 0.17
+BuildRequires: gettext-tools >= 0.17
 BuildRequires: gtk+3-devel >= 3.0
-BuildRequires: intltool >= 0.35.0
-BuildRequires: libreport-gtk-devel >= 2.0.19
-%{?with_tests:BuildRequires:   libreport-python}
+BuildRequires: libreport-gtk-devel >= 2.4.0
+BuildRequires: meson >= 0.51.0
+BuildRequires: ninja >= 1.5
 BuildRequires: pkgconfig
 %{?with_tests:BuildRequires:   pylint}
-BuildRequires: python-devel >= 1:2.7
-BuildRequires: python-pygobject3 >= 3.0
+BuildRequires: python3-devel >= 1:3.4
+%{?with_tests:BuildRequires:   python3-humanize}
+%{?with_tests:BuildRequires:   python3-libreport}
+BuildRequires: python3-pygobject3-devel >= 3.29.1
 BuildRequires: rpmbuild(macros) >= 1.596
+BuildRequires: sed >= 4.0
 BuildRequires: xmlto
 Requires(post,postun): gtk-update-icon-cache
+Requires:      abrt-dbus
+Requires:      abrt-gui-libs >= 2.4.0
 Requires:      hicolor-icon-theme
-Requires:      python-dbus
-Requires:      python-inotify
-Requires:      python-pygobject3
+Requires:      libreport-gtk >= 2.4.0
+Requires:      python3-dbus
+Requires:      python3-humanize
+Requires:      python3-libreport >= 2.4.0
+Requires:      python3-pygobject3 >= 3.29.1
+Requires:      python3-pyinotify
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -42,27 +51,24 @@ zapewniająca wygodny sposób zarządzania tymi problemami.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
-%configure \
-       %{!?with_tests:PYLINT=/bin/true} \
-       --disable-silent-rules
+%meson build \
+       %{!?with_tests:-Dlint=false}
 
-%{__make}
+%ninja_build -C build
 
-%{?with_tests:%{__make} check}
+%if %{with tests}
+%ninja_test -C build
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
 
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gnome_abrt/wrappers/*.la
-%py_postclean
+%ninja_install -C build
 
-# just a copy of cs
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/cs_CZ
+%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
+%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
 
 %find_lang %{name}
 
@@ -77,14 +83,21 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
+%doc README.md
 %attr(755,root,root) %{_bindir}/gnome-abrt
-%dir %{py_sitedir}/gnome_abrt
-%{py_sitedir}/gnome_abrt/*.py[co]
-%dir %{py_sitedir}/gnome_abrt/wrappers
-%{py_sitedir}/gnome_abrt/wrappers/__init__.py[co]
-%attr(755,root,root) %{py_sitedir}/gnome_abrt/wrappers/_wrappers.so
+%dir %{py3_sitedir}/gnome_abrt
+%{py3_sitedir}/gnome_abrt/*.py
+%{py3_sitedir}/gnome_abrt/__pycache__
+%dir %{py3_sitedir}/gnome_abrt/url
+%{py3_sitedir}/gnome_abrt/url/*.py
+%{py3_sitedir}/gnome_abrt/url/__pycache__
+%dir %{py3_sitedir}/gnome_abrt/wrappers
+%{py3_sitedir}/gnome_abrt/wrappers/__init__.py
+%{py3_sitedir}/gnome_abrt/wrappers/__pycache__
+%attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.cpython-*.so
 %{_datadir}/gnome-abrt
-%{_desktopdir}/gnome-abrt.desktop
-%{_iconsdir}/hicolor/*/apps/gnome-abrt.png
-%{_iconsdir}/hicolor/*/status/gnome-abrt.png
-%{_mandir}/man6/gnome-abrt.6*
+%{_datadir}/metainfo/org.freedesktop.GnomeAbrt.appdata.xml
+%{_desktopdir}/org.freedesktop.GnomeAbrt.desktop
+%{_iconsdir}/hicolor/scalable/apps/org.freedesktop.GnomeAbrt.svg
+%{_iconsdir}/hicolor/symbolic/apps/org.freedesktop.GnomeAbrt-symbolic.svg
+%{_mandir}/man1/gnome-abrt.1*
This page took 0.086467 seconds and 4 git commands to generate.