]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- new URLs, updated to 1.3.1
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        1.3.1
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 #Source0Download: https://github.com/abrt/gnome-abrt/releases
13 Source0:        https://github.com/abrt/gnome-abrt/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  2529440838d44afe7c4696e2f76b4986
15 URL:            https://github.com/abrt/abrt/wiki/gnome-abrt
16 BuildRequires:  abrt-devel >= 2.4.0
17 BuildRequires:  asciidoc
18 BuildRequires:  gettext-tools >= 0.17
19 BuildRequires:  gtk+3-devel >= 3.0
20 BuildRequires:  libreport-gtk-devel >= 2.4.0
21 BuildRequires:  meson >= 0.51.0
22 BuildRequires:  ninja >= 1.5
23 BuildRequires:  pkgconfig
24 %{?with_tests:BuildRequires:    pylint}
25 BuildRequires:  python3-devel >= 1:3.4
26 %{?with_tests:BuildRequires:    python3-libreport}
27 BuildRequires:  python3-pygobject3-devel >= 3.29.1
28 BuildRequires:  rpmbuild(macros) >= 1.596
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  xmlto
31 Requires(post,postun):  gtk-update-icon-cache
32 Requires:       abrt-dbus
33 Requires:       abrt-gui-libs >= 2.4.0
34 Requires:       hicolor-icon-theme
35 Requires:       libreport-gtk >= 2.4.0
36 Requires:       python3-dbus
37 Requires:       python3-libreport >= 2.4.0
38 Requires:       python3-pygobject3 >= 3.29.1
39 Requires:       python3-pyinotify
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 A GNOME application allows users to browse through detected problems
44 and provides them with convenient way for managing these problems.
45
46 %description -l pl.UTF-8
47 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
48 zapewniająca wygodny sposób zarządzania tymi problemami.
49
50 %prep
51 %setup -q
52
53 %build
54 %meson build \
55         %{!?with_tests:-Dlint=false}
56
57 %ninja_build -C build
58
59 %if %{with tests}
60 %ninja_test -C build
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %ninja_install -C build
67
68 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
69 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
70
71 %find_lang %{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 %update_icon_cache hicolor
78
79 %postun
80 %update_icon_cache hicolor
81
82 %files -f %{name}.lang
83 %defattr(644,root,root,755)
84 %doc README.md
85 %attr(755,root,root) %{_bindir}/gnome-abrt
86 %dir %{py3_sitedir}/gnome_abrt
87 %{py3_sitedir}/gnome_abrt/*.py
88 %{py3_sitedir}/gnome_abrt/__pycache__
89 %dir %{py3_sitedir}/gnome_abrt/url
90 %{py3_sitedir}/gnome_abrt/url/*.py
91 %{py3_sitedir}/gnome_abrt/url/__pycache__
92 %dir %{py3_sitedir}/gnome_abrt/wrappers
93 %{py3_sitedir}/gnome_abrt/wrappers/__init__.py
94 %{py3_sitedir}/gnome_abrt/wrappers/__pycache__
95 %attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.cpython-*.so
96 %{_datadir}/gnome-abrt
97 %{_datadir}/metainfo/org.freedesktop.GnomeAbrt.appdata.xml
98 %{_desktopdir}/org.freedesktop.GnomeAbrt.desktop
99 %{_iconsdir}/hicolor/scalable/apps/org.freedesktop.GnomeAbrt.svg
100 %{_iconsdir}/hicolor/symbolic/apps/org.freedesktop.GnomeAbrt-symbolic.svg
101 %{_mandir}/man1/gnome-abrt.1*
This page took 0.056276 seconds and 4 git commands to generate.