]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- updated to 0.3.3
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4 #
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        0.3.3
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  ba51ea0a7684d164f57740ff3ab81d26
14 Patch0:         %{name}-pylint.patch
15 URL:            https://fedorahosted.org/abrt/
16 BuildRequires:  abrt-gui-devel >= 2.1.7
17 BuildRequires:  asciidoc
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gtk+3-devel >= 3.0
20 BuildRequires:  intltool >= 0.35.0
21 BuildRequires:  libreport-gtk-devel >= 2.0.20
22 %{?with_tests:BuildRequires:    libreport-python}
23 BuildRequires:  pkgconfig
24 %{?with_tests:BuildRequires:    pylint}
25 BuildRequires:  python-devel >= 1:2.7
26 BuildRequires:  python-pygobject3-devel >= 3.0
27 BuildRequires:  rpmbuild(macros) >= 1.596
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  xmlto
30 Requires(post,postun):  gtk-update-icon-cache
31 Requires:       abrt-gui-libs >= 2.1.7
32 Requires:       hicolor-icon-theme
33 Requires:       libreport-python
34 Requires:       python-dbus
35 Requires:       python-inotify
36 Requires:       python-pygobject3
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A GNOME application allows users to browse through detected problems
41 and provides them with convenient way for managing these problems.
42
43 %description -l pl.UTF-8
44 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
45 zapewniająca wygodny sposób zarządzania tymi problemami.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
52
53 %build
54 %configure \
55         --disable-silent-rules \
56         %{!?with_tests:--with-nopylint}
57
58 %{__make}
59
60 %{?with_tests:%{__make} check}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gnome_abrt/wrappers/*.la
68 %py_postclean
69
70 # just a copy of cs
71 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/cs_CZ
72
73 %find_lang %{name}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 %update_icon_cache hicolor
80
81 %postun
82 %update_icon_cache hicolor
83
84 %files -f %{name}.lang
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_bindir}/gnome-abrt
87 %dir %{py_sitedir}/gnome_abrt
88 %{py_sitedir}/gnome_abrt/*.py[co]
89 %dir %{py_sitedir}/gnome_abrt/url
90 %{py_sitedir}/gnome_abrt/url/*.py[co]
91 %dir %{py_sitedir}/gnome_abrt/wrappers
92 %{py_sitedir}/gnome_abrt/wrappers/__init__.py[co]
93 %attr(755,root,root) %{py_sitedir}/gnome_abrt/wrappers/_wrappers.so
94 %{_datadir}/gnome-abrt
95 %{_datadir}/appdata/gnome-abrt.appdata.xml
96 %{_desktopdir}/gnome-abrt.desktop
97 %{_iconsdir}/hicolor/*/apps/gnome-abrt.png
98 %{_iconsdir}/hicolor/*/status/gnome-abrt.png
99 %{_mandir}/man1/gnome-abrt.1*
This page took 0.054711 seconds and 4 git commands to generate.