]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- libffi rebuild
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        1.0.0
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  768273f4f8729fe98aa8913041027532
14 Patch0:         %{name}-pylint.patch
15 URL:            https://github.com/abrt/abrt/wiki/ABRT-Project
16 BuildRequires:  abrt-gui-devel >= 2.1.7
17 BuildRequires:  asciidoc
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gtk+3-devel >= 3.0
20 BuildRequires:  intltool >= 0.35.0
21 BuildRequires:  libreport-gtk-devel >= 2.0.20
22 BuildRequires:  pkgconfig
23 %{?with_tests:BuildRequires:    pylint}
24 BuildRequires:  python-devel >= 1:2.7
25 %{?with_tests:BuildRequires:    python-libreport}
26 BuildRequires:  python-pygobject3-devel >= 3.0
27 BuildRequires:  rpmbuild(macros) >= 1.596
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  xmlto
30 Requires(post,postun):  gtk-update-icon-cache
31 Requires:       abrt-dbus
32 Requires:       abrt-gui-libs >= 2.1.7
33 Requires:       hicolor-icon-theme
34 Requires:       libreport-python
35 Requires:       python-dbus
36 Requires:       python-pygobject3 >= 3.0
37 Requires:       python-pyinotify
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 A GNOME application allows users to browse through detected problems
42 and provides them with convenient way for managing these problems.
43
44 %description -l pl.UTF-8
45 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
46 zapewniająca wygodny sposób zarządzania tymi problemami.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
53
54 %build
55 %configure \
56         --disable-silent-rules \
57         %{!?with_tests:--with-nopylint}
58
59 %{__make}
60
61 %{?with_tests:%{__make} check}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gnome_abrt/wrappers/*.la
69 %py_postclean
70
71 # just a copy of cs
72 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs_CZ
73
74 %find_lang %{name}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post
80 %update_icon_cache hicolor
81
82 %postun
83 %update_icon_cache hicolor
84
85 %files -f %{name}.lang
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_bindir}/gnome-abrt
88 %dir %{py_sitedir}/gnome_abrt
89 %{py_sitedir}/gnome_abrt/*.py[co]
90 %dir %{py_sitedir}/gnome_abrt/url
91 %{py_sitedir}/gnome_abrt/url/*.py[co]
92 %dir %{py_sitedir}/gnome_abrt/wrappers
93 %{py_sitedir}/gnome_abrt/wrappers/__init__.py[co]
94 %attr(755,root,root) %{py_sitedir}/gnome_abrt/wrappers/_wrappers.so
95 %{_datadir}/gnome-abrt
96 %{_datadir}/appdata/gnome-abrt.appdata.xml
97 %{_desktopdir}/gnome-abrt.desktop
98 %{_iconsdir}/hicolor/*/apps/gnome-abrt.png
99 %{_iconsdir}/hicolor/*/status/gnome-abrt.png
100 %{_mandir}/man1/gnome-abrt.1*
This page took 0.129436 seconds and 4 git commands to generate.