]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- python 3.5 rebuild
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        1.2.0
9 Release:        2
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  9b2d3e364e735f6a7401a84462951232
14 Patch0:         %{name}-pylint.patch
15 URL:            https://github.com/abrt/abrt/wiki/ABRT-Project
16 BuildRequires:  abrt-gui-devel >= 2.1.7
17 BuildRequires:  asciidoc
18 BuildRequires:  gettext-tools >= 0.17
19 BuildRequires:  gtk+3-devel >= 3.0
20 BuildRequires:  intltool >= 0.35.0
21 BuildRequires:  libreport-gtk-devel >= 2.0.20
22 BuildRequires:  pkgconfig
23 %{?with_tests:BuildRequires:    pylint}
24 BuildRequires:  python3-devel >= 1:3.4
25 %{?with_tests:BuildRequires:    python3-libreport}
26 BuildRequires:  python3-pygobject3-devel >= 3.0
27 BuildRequires:  rpmbuild(macros) >= 1.596
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  xmlto
30 BuildRequires:  xorg-lib-libX11-devel
31 Requires(post,postun):  gtk-update-icon-cache
32 Requires:       abrt-dbus
33 Requires:       abrt-gui-libs >= 2.1.7
34 Requires:       hicolor-icon-theme
35 Requires:       python3-dbus
36 Requires:       python3-libreport
37 Requires:       python3-pygobject3 >= 3.0
38 Requires:       python3-pyinotify
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A GNOME application allows users to browse through detected problems
43 and provides them with convenient way for managing these problems.
44
45 %description -l pl.UTF-8
46 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
47 zapewniająca wygodny sposób zarządzania tymi problemami.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
54
55 %build
56 %configure \
57         --disable-silent-rules \
58         %{!?with_tests:--with-nopylint}
59
60 %{__make}
61
62 %{?with_tests:%{__make} check}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gnome_abrt/wrappers/*.la
70 %py_postclean
71
72 # just a copy of cs
73 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs_CZ
74
75 %find_lang %{name}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %update_icon_cache hicolor
82
83 %postun
84 %update_icon_cache hicolor
85
86 %files -f %{name}.lang
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_bindir}/gnome-abrt
89 %dir %{py3_sitedir}/gnome_abrt
90 %{py3_sitedir}/gnome_abrt/*.py
91 %{py3_sitedir}/gnome_abrt/__pycache__
92 %dir %{py3_sitedir}/gnome_abrt/url
93 %{py3_sitedir}/gnome_abrt/url/*.py
94 %{py3_sitedir}/gnome_abrt/url/__pycache__
95 %dir %{py3_sitedir}/gnome_abrt/wrappers
96 %{py3_sitedir}/gnome_abrt/wrappers/__init__.py
97 %{py3_sitedir}/gnome_abrt/wrappers/__pycache__
98 %attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.so
99 %{_datadir}/gnome-abrt
100 %{_datadir}/appdata/gnome-abrt.appdata.xml
101 %{_desktopdir}/gnome-abrt.desktop
102 %{_iconsdir}/hicolor/*x*/apps/gnome-abrt.png
103 %{_iconsdir}/hicolor/*x*/status/gnome-abrt.png
104 %{_iconsdir}/hicolor/symbolic/apps/gnome-abrt-symbolic.svg
105 %{_mandir}/man1/gnome-abrt.1*
This page took 0.128707 seconds and 4 git commands to generate.