]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- added pylint patch, but still fails (looks like false positive)
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4 #
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        0.2.10
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  9cdb88de911163980add38fad1e3df72
14 Patch0:         %{name}-pylint.patch
15 URL:            https://fedorahosted.org/abrt/
16 BuildRequires:  asciidoc
17 BuildRequires:  gettext-devel >= 0.17
18 BuildRequires:  gtk+3-devel >= 3.0
19 BuildRequires:  intltool >= 0.35.0
20 BuildRequires:  libreport-gtk-devel >= 2.0.19
21 %{?with_tests:BuildRequires:    libreport-python}
22 BuildRequires:  pkgconfig
23 %{?with_tests:BuildRequires:    pylint}
24 BuildRequires:  python-devel >= 1:2.7
25 BuildRequires:  python-pygobject3 >= 3.0
26 BuildRequires:  rpmbuild(macros) >= 1.596
27 BuildRequires:  xmlto
28 Requires(post,postun):  gtk-update-icon-cache
29 Requires:       hicolor-icon-theme
30 Requires:       python-dbus
31 Requires:       python-inotify
32 Requires:       python-pygobject3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A GNOME application allows users to browse through detected problems
37 and provides them with convenient way for managing these problems.
38
39 %description -l pl.UTF-8
40 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
41 zapewniająca wygodny sposób zarządzania tymi problemami.
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %build
48 %configure \
49         %{!?with_tests:PYLINT=/bin/true} \
50         --disable-silent-rules
51
52 %{__make}
53
54 %{?with_tests:%{__make} check}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gnome_abrt/wrappers/*.la
62 %py_postclean
63
64 # just a copy of cs
65 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/cs_CZ
66
67 %find_lang %{name}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %update_icon_cache hicolor
74
75 %postun
76 %update_icon_cache hicolor
77
78 %files -f %{name}.lang
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_bindir}/gnome-abrt
81 %dir %{py_sitedir}/gnome_abrt
82 %{py_sitedir}/gnome_abrt/*.py[co]
83 %dir %{py_sitedir}/gnome_abrt/wrappers
84 %{py_sitedir}/gnome_abrt/wrappers/__init__.py[co]
85 %attr(755,root,root) %{py_sitedir}/gnome_abrt/wrappers/_wrappers.so
86 %{_datadir}/gnome-abrt
87 %{_desktopdir}/gnome-abrt.desktop
88 %{_iconsdir}/hicolor/*/apps/gnome-abrt.png
89 %{_iconsdir}/hicolor/*/status/gnome-abrt.png
90 %{_mandir}/man6/gnome-abrt.6*
This page took 0.063633 seconds and 4 git commands to generate.